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Digitizer Support Setup

Digitizer support is an additional feature in Sitework 4D, which must be purchased 

separately. This tutorial demonstrates how to install the tablet drivers and set up your 

tablet for use with Sitework 4D, as well as using the tablet enter a takeoff using a paper 

plansheet. Be sure to install the Sitework 4D software before installing tablet drivers. For 

information regarding Sitework 4D installation please refer to the “Installation” section of 

this manual, beginning on page 1-1.

Lesson 1 -  TabletWorks Driver  Installation

TabletWorks is the software driver used to control the digitizer. This program can be 

downloaded from the GTCO website at http://www.gtco.com/supportgtcocalcompsoft-

ware.htm.

1. Open you internet browser and go to http://www.gtco.com/supportgtcocalcompsoft-

ware.htm.

2. Click on the link to download the Tabletworks version 10.09 software and save it 

somewhere easy to find.

3. Double-click the saved installation file.

4. Click Next in the GTCO CalComp TabletWorks Install Wizard dialog box.
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5. Click yes to accept the license agreement.

6. Select Complete, and click Next.

7. Click Next in the Welcome to Found New Hardware Wizard dialog box.

8. Click Finish to continue.

Lesson 2 AGTEK  16-button Cursor Configuration

After Tabletworks has been installed, you must configure the AGTEK 16-button cursor.

1. Select Start>All Programs>Tablet Works>Tablet Works.

2. Click the 16 Btn tab. The button configuration dialog box is displayed.

3. Select Relative in Mouse Mode, and make sure the Enable Mapping box is checked.

4. Click on the buttons on the cursor image to set their function. The buttons on the 

screen correspond to the actual buttons on your cursor (the top right button is the 

“7” button). Set the buttons to the following:

 7 - None  8  - None  9  - None  Enter - Left Click

 4 - None  5  - None  6  - None  Period - Right Click

 1 - None  2  - None  3  - None  SP - None

 0 - None  Backspace  - None Blank  - Right Click Minus - None

5. Click OK to apply the changes.
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 Plansheet Takeoff Overview

Sitework 4D can be used for dirt takeoff purposes when there is no electronic data avail-

able using a traditional paper plansheet. In these situations Sitework 4D relies on digi-

tized input using a digitizer, and AGTEK 16-button Cursor.

The   Cursor

The AGTEK-formatted 16-button cursor is used to enter digitized data from plan sheets. 

Below is an example of the cursor and a brief explanation of the buttons.

     The   Enter key is used for selecting and entering   

     data. Holding down the Enter key allows tracing of   

     data lines with AGTEK’s intelligent stream mode.

     The  SP key is used to “snap” a point to the nearest   

    data point. Pressing the SP key twice on the same   

    point selects the entire line, and allows the user to   

    determine the distance desired with a third SP entry. 

     The  Period key is used to display the Right-Mouse   

    menu, for entering daylight points, and as a decimal   

    point. 

     The   Blank or End key is used to end a line or stop   

    data entry. It is also used to display the Right-Mouse   

    Menu when not in data entry mode.

     The   Backspace key is used to delete the last point   

    entered while digitizing.

     The Number keys are used to type in values in   

    designated text boxes.0 9to

Tablet Entry Guide

In the Guide menu, Sitework 4D contains guide for PDF, CAD, Tablet, and Haul Plan 

entry. This tutorial focuses on Tablet entry. The Tablet Entry Guide can be accessed 

by selecting Guide>Tablet, and later by pressing the G key. The Guide display a check 

mark in the corresponding box when an operation has been completed.
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   Scaling

Before any data can be digitized, the plan sheet must be scaled. Scaling aligns the plan 

sheet with the digitizer, creates a coordinate system for the job, and establishes the 

scale of the plan sheet. There are three methods of scaling and the one you choose 

should reflect the needs of the job.

 Right Angle

The simplest method is to draw a right angle on the plan. Place the right angle near the 

center of the plan sheet. Measure out about 10” along each axis with the appropriate 

plan scale (20’ = 1” in this case) and mark the coordinates based upon these measure-

ments (see the example below). You can use this method if you don’t need to align the 

takeoff to a CAD file, survey, or a matching sheet. It also does not adjust for any plan 

shrinkage from duplication.

 Known Distance

Another method is to find some known distances on the plan both horizontally and verti-

cally and use those to create the coordinate system. Property Line measurements and 

road stationing often provide known distances. The chief advantage of this method over 

the former is the adjustment for any plan shrinkage. 

 Northings and Eastings

The best method is to use Northings and Eastings marked on the plan sheet. There are 

two advantages to this method. First, alignment to CAD files, surveys, and other sheets 

is greatly simplified. Second, this method adjusts for plan shrinkage. 
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Data Entry Sequence

Below is the suggested data entry sequences for plansheet takeoff.

Enter Existing Ground

• Start a new Job

• Scale Drawing

• Enter Existing Perimeter

• Enter Existing Data Lines

• Enter Stripping Area

Enter Proposed Design

• Enter Design Data Lines

• Enter the Design Perimeter

• Enter Report/Sectional Areas

Calculate Volumes

• Visual Verification with the 3D Window

• Calculate Volumes

Print Reports
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Lesson 1 – Enter Existing Data Lines

Prior to beginning, tape the Pine Street grading plan to your digitizer. Be sure you have 

access to a right angle and an engineers scale. The following lesson demonstrates how 

to enter the existing ground.

 Start a  New Job (Job Setup)

1. Double-click on the Sitework 4D shortcut or select Start>Programs>AGTEK> 

Sitework 4D. The Open dialog box displays.

2. Click New to start a new job. The Job Information dialog box displays.

3. Enter a Job Name, Builder, Bid Date, and Operator. Select the units of measure (feet 

for this job) and click OK. Sitework 4D opens in Entry Mode with a blank screen 

ready for data entry.
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Enter the  Plan Scale

To scale the tablet to the Pine Street plan sheet, use the Northings and Eastings marked 

on the eastern property corners and on a monument in the center of Gregory Lane.

1. Select Guide>Tablet, then click Enable Tablet in the Tablet Entry Guide dialog box. 

The Tablet Scaling dialog box is displayed.

2. Type the monument coordinates for the first point, the southeastern property corner 

for the second point, and the northeastern property corner for the third point. Make 

sure the North Always Up box is checked, and click OK to accept these values. A 

dialog box prompts you to digitize the first point.

3. Place the 16-button cursor over the first point, and press the Enter button. Move to 

the second and third scaling points and press the Enter button over each point. A 

confirmation window displays the vertical and horizontal scales.

4. The scale for this job should be about a 1:20. Click OK to accept, or Rescale to re-

enter the scaling coordinates again. After you have accepted the scale, the program 

switches to Entry Mode, and defaults to the Existing Surface and Perimeter Layer.
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Enter the  Existing Perimeter

Once the job has been scaled to the plans, you can begin entering jobsite data, including 

the site boundary, original topo information, and stripping areas. 

A site boundary is supplied on the Pine Street plan sheet (the dashed box with one side 

running down the center of Gregory Lane).

1. Switch to the Entry mode and select Existing from the surface pulldown and Perim-

eters from the Layer pulldown, or select Guide>Tablet, and select Enter Existing 

Perimeter from the Tablet Entry Guide.

2. Place the 16-button cursor over one corner of the marked site boundary and press 

the Enter button. The crosshair is connected to the first point by “rubber band“ line.

3. Move the cursor to the next corner and press the Enter button. Continue entering the 

other corners of the perimeter. If you make a mistake, press the Backspace key to 

remove the last point entered. 

4. Press the Blank key to finish boundary entry.

The Existing 

Perimeter 

is used to 

define the 

limits of 3D 

calculations 

and speed 

3D rendering. 

Make sure 

necessary 

data is 

included in 

the Existing 

Perimeter.
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4. Click the Home button, or press the Home key on the keyboard to zoom out and 

view the boundary.

   Enter Existing Data

With the site boundary entered, the next step is enter the existing ground information. 

All of the topo information is entered into the Data Lines layer. This section demon-

strates how to enter a contour, spot elevation, closed areas, ridge, and swale lines, but 

does not cover entering all data from the plan sheet.

Enter Contours

Contours can be entered in any order but we’ll use the 253 contour in the upper middle 

part of the plan sheet. 

1. Select Existing from the Surface pulldown, and Data Lines from the Layer pulldown, 

or press the G key, and select Enter Existing Datalines from the Tablet Entry Guide.



Sitework 4D Digitizer Support Tutorial

7-10

2. Type in “253” on the 16-button cursor then move the cursor crosshairs over the 

beginning of the contour, and press the Enter button. The status bar at the bottom of 

the screen displays the entered elevation and coordinates. The program creates the 

first point and connects the cursor to the point by a rubber band line. 

3. Move the cursor along the contour, and press the Enter button at the end of each 

straight section.

4 Press the Enter button several times while moving the cursor around the radius of 

curves.

5. Press the Blank button to end the line at the end of the contour. Your screen should 

look similar to the illustration below.

The more 

points you 

enter while 

digitzing a 

curve, the 

smoother and 

more accurate 

the data will 

be.
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Enter  Closed Contours

Closed contours are entered differently than typical contours. We’ll use the 254 closed 

area inside the contour just digitized in this example.

1. Type in “254” on the 16-button cursor, and then move the crosshairs over the con-

tour and press the Enter button.

2. Digitize the contour, pressing the Enter button at the end of each straight section, 

and pressing the Enter button several times while moving the cursor around the ra-

dius of curves. Your screen should look similar to the illustration below.

3. Move the crosshair close to the starting point, and press the SP button to snap to 

that point and close the contour. 

4. Press the Blank button to end the line.

Auto Increment Elevation Entry

The auto increment function assists in entering elevations. As sequential elevations are 

entered, Sitework 4D anticipates the next elevation and fills it in automatically. As often 

as possible you should enter the contours sequentially by elevation to take advantage of 

this feature.

• Enter the 255 closed contour inside the 254 elevation using the auto increment func-

tion, and steps 2 through 4 above.
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Enter  Spot Elevations

There are several spot elevations in the existing ground. We’ll use one inside the 255 

contour just digitized in this example.

 1. Type in “255.48” on the cursor then move the cursor crosshairs over the elevation 

inside the contour and press the Enter button.

2. Press the Blank button to end the spot elevation entry. Your screen should look simi-

lar to the illustration below.

Enter Remaining Elevations

Use the previous techniques to enter the remaining existing elevations from the Pine 

Street plan sheet.
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   Enter Ridges and Swales

Ridges and swales can be entered to increase the accuracy of the ground model. This 

grading plan includes an existing street (Gregory Lane) represented as contours on the 

left side of the plan sheet. The chevron pattern of the contours do not model the curb 

line very well and leaves out the sharp edge of curb and crown slope. To optimize the 

3D model we should snap elevation lines at the crown and sides of the existing street. 

This improves the model of the original ground.

1. Switch to Entry mode, and place the 16-button cursor near the center crown tip of 

the 247 street contour, then press the SP button to snap to this point.

2. Move the crosshairs to the 248 street contour crown, and press the SP button again.

3. Continue up the street snapping to the other center-line points on the contours.

4. Press the Blank button to close the line.

5. Snap a few other lines along the curb on either side of the existing street. This 

should give it more definition for a better ground model.

6. Press the Blank button to display the Right Mouse menu, and select Edit Mode to 

end line entry. Your screen should look similar to the illustration below.
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Edit  Existing Ground

After you’ve entered the existing ground, you should take some time to edit the data to 

ensure it is as accurate as possible. Essentially, all of the existing ground is made up of 

lines or points. This section shows how to edit lines and points. Editing is typically done 

in Edit mode with the mouse instead of the 16-button cursor.

 Undo

If at any time you make a mistake, Sitework 4D has the added feature of Undo. To ac-

cess this command, press Ctrl+Z or select Edit>Undo. Up to the last 8 commands can 

be reversed. Undo works in both Edit and Entry mode.

 Editing a Line

The Line Editor is used to make changes that affect every point on the line. The Line Edi-

tor allows you to change the Elevation, Point Labels, and the Line Label for the selected 

line. A description of the fields is below.

• To open the Line Editor, double-click on a line, or select a line, right-click to display 

the Right-Mouse menu, and select Line Editor.

Elevation  Changes all points on the selected line to one constant elevation.

Point Label  Assigns all the points on the selected line the same point label.

Line   Assigns a label to the line. This label is independent of any point  

    labels already assigned.

Affect Adjacent  This causes any line attached to the currently selected line   

Points  to also be modified at the point where they connect.

     Deleting a Line

To delete a line, select it then select Edit>Delete or press the Delete key. Multiple lines 

can be deleted by selecting each line using Shift+click before deleting them.
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Breaking a Line

Sometimes only part of a line needs to be edited. To do this you first have to break the 

line, then edit the new line as needed. To break a line:

•  Click on a point on a line and press Ctrl+X or select Edit>Break Line.

or

• Place the cursor over the point at which you want to break the line and press the F5 

key. The line breaks at the location of the cursor and a point is inserted at the break 

points on each line segment.

 Editing a Point

Individual points are edited using the Point Editor. The Point Editor allows you to change 

the North, East, and Elevation of the point as well as the Point Label and Line Label for 

the selected point. Sitework 4D has five point types, color-coded by type. The point 

types are:

•  Interpolated points (light blue) derive their elevation from the slope between the 

Entered elevations that surround them. If the elevation of the points that are used for 

interpolation are edited, the interpolated point elevation is recalculated as well.

•  Daylight points (green) are assigned elevation from the Existing surface. 

•  Entered points (white) are points with user-assigned elevations, through editing or 

entry. These points do not change elevation unless the user specifically changes 

them.

•  Snapped points (red) are created when a point on a data line is snapped (F6 or F8) 

to another existing data line. These become Entered points after the job is saved and 

reopened.

•  Annotation points (brown) are not used by the program to create the 3D surface. 

The presence of an Annotation point on a line changes all points on the line to An-

notation. Lines transferred through the CAD transfer with an elevation of zero are 

automatically assigned as Annotation.

�
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To open the Point Editor:

• Select a point, then right-click and select Point Editor from the Right Mouse Menu. 

 North  The northing coordinate for the point.

 East  The Easting coordinate for the point.

 Elevation  Changes the selected point’s elevation.

 Point Label Assigns the point label to the selected point.

 Line  Assigns a label to the line the point is part of. This label is indepen- 

   dent of any point labels already assigned.

 Affect Adjacent This causes any line attached to the currently selected point to also  

Points   be modified at the point where they connect. 
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2D Overlay

3D Terrain

 Inspect the Existing Ground

Now that all the existing ground data has been digitized and edited, you can visually 

inspect the site in 3D. To view the existing ground in 3D:

• Press the V key, or click the 3D View button on the tool bar. If the 3D view does not 

appear, press T key to toggle the display of the terrain.

Cut or Fill  amount at 

the current location

Resets all settings to

the program defaults

Launches HELP

Point  label of 

selected point

Line label of 

selected point Elevation of 

selected point

Northing of 

selected point

Easting of 

selected point

Horizontal distance 

between selected 

point and current 

location

Slope between

selected point and 

current location

Vertical distance 

between selected point 

and current location

Drives forward 

and back

Turns the view 

left and right

Increases and

decreases the

elevation skew

Changes the

viewing angle

Increases/decreases

the viewing distance

 behind the vehicle

Toggles between ground 

and aerial views
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 Enter  Stripping Areas

 Stripping areas are used to remove a constant depth from the existing ground to reflect 

vegetation and topsoil removal. Stripping areas are entered in the Existing surface in 

the Stripping Areas layer. On this site we’ll strip .5 feet from the back of the existing 

sidewalk over the remainder of the site. Stripping areas are not cumulative, so putting a 

stripping area within an existing stripping area does not add the depths together. 

1.  Switch to Entry mode and select Existing from the Surface pulldown and Stripping 

Areas from the Layer pulldown, or Select Guide>Tablet and choose Enter Stripping 

Areas, and the Stripping Areas dialog box displays.

Fix Bad Elevations

Use the Arrow keys or the 3D Controls on the right side of the window to move the ve-

hicle around the site while looking for bad elevations. A bad elevation usually appears as 

a spike up or down on the 3D terrain. To fix a bad elevation:

1. Select the bad elevation in the 2D Overlay or move the vehicle to the location.

2. Switch to Edit Mode, and press the T key to turn on the terrain to see the bad eleva-

tion in 3D.

3. Select the bad elevation (if not selected). The elevation is highlighted in the Elevation 

list on the right side of the window.

4. Double-click the elevation in the list to open the Point Editor, and make necessary 

modifications. 

5. Switch back to 3D View mode to find and fix other bad elevations.

2. Enter “Stripping 1” for the Area Name and “.5” for the stripping depth. Click OK. 

3. Move you cursor to where the sidewalk for Gregory Lane intersects with the prop-

erty line behind Lot 1.

4. Move the cursor up to where the sidewalk for Gregory Lane intersects with the prop-

erty line behind Lot 4 and push the Enter button.

Having the 
terrain vis-
ible allows 
you to see 
how any 
changes 
affect the 
3D model 
instantly.
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5. Continue to the right and push the Enter button at the point labeled with a Northing 

and Easting at the top-right of the job.

6. Continue down to the next point labeled with a Northing and Easting, and push the 

Enter button.

6. Press the Blank key to end the entry and snap the Stripping Area closed.

 Editing  Stripping Areas
Editing the stripping area is just like editing any line or point on a line. To edit the entire 

area, use the Line Editor. To edit points on the stripping area, including moving the point 

to modify the shape of the area, use the Point Editor. See “Edit Existing Ground” on page 

7-14 and “Editing a Point” on page 7-15 for more information.
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Lesson 2 –  Enter The  Proposed Design

The next step is to enter the proposed design lines. All proposed design lines are entered 

in the Design surface. Like the previous sections, this section demonstrates how to enter 

lots, streets, retaining walls, and curbs, but does not cover entering all data from the 

plan sheet.

 Enter  Lots

There are four lots on Pine Street, but we’ll enter lot on the bottom left as a demonstra-

tion.

1. Switch to Entry Mode and select Design from the Surface pulldown and Data Lines 

from the Layer pulldown, or press the G key and select Enter Design Data Lines from 

the Tablet Entry Guide.

2. Type in “251.0” on the 16-button cursor, then move the crosshairs over the lower 

left corner of lot 1 and press the Enter button. The status bar at the bottom of the 

screen displays the entered elevation and coordinates. The program creates the first 

point and connects the cursor to the point by a rubber band line.

3. Move the cursor along the lot and press the Enter button at the end of each straight 

section.

4. Press the Enter button several times while moving the cursor around the radius of 

curves.

5. Press the SP button to snap to the first point and close the lot. Press the Blank but-

ton to end the line.

6. Enter the remaining lots to practice the technique.
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 Enter the Street

The street will be built to subgrade, and the street, curb/gutter, and sidewalk will be built 

using offset lines. To do that, we must digitize a reference line with elevations to use for 

offset line creation. The reference line we will use is the top of curb line.

1. Type in “246.9” on the 16 button cursor, then move the crosshairs to the left of Lot 

1 where the proposed street meets Gregory Lane, and press the Enter button.

2. Press the Enter button several times while moving the cursor around the radius of 

the curve until you reach the next assigned elevation. 

3. Type in “247.9” on the cursor then press the Enter button to enter that point.

4. Continue typing in elevations and pressing the Enter button along the length of the 

curb to enter points.

5. Press the Blank button to end the line.

6. Type in “247.8” on the cursor, then move the cursor crosshairs to the other side of 

the street at Gregory Lane, and press the Enter button.

7. Continue typing in elevations, and pressing the Enter button along the length of the 

curb to enter points.



Sitework 4D Digitizer Support Tutorial

7-22

 Create the Sidewalk using  Offset Lines

The sidewalk needs to be entered. The top of curb line will be used as the reference for 

creating this line using the Offset Line Editor.

 Offset Line Editor

The Offset Line Editor is a powerful tool for creating lines based on numeric distances 

from a reference line. The following page has explanations of the features of the Offset 

Line Editor.

8. Press the Blank button to end the line. Your screen should look similar to the illustra-

tion below.
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Line Controls

Offset The Offset button toggles the direction of the offset line compared to  

   the selected reference line. The point order on the line determines right  

   and left. An arrow displays on the overlay showing the offset direction.

Points Every This is a two part control. When the Points Every box is checked, the  

   program creates extra points on the offset line at the distance specified in  

   the text box. When the box is unchecked the program matches the points  

   on the reference line and only adds points to correctly model corners. 

Connectors This option creates lines between the reference point and its corre-  

   sponding offset point. It is most often used when sloping to Daylight.

Daylight The Daylight check box allows creation of lines at a specified slope to  

   daylight. Checking this option adds Cut and Fill slope text boxes to the  

   Start and End of line areas.  

Start/End of Line

The Start/End of Line text boxes control the placement of the offset line. Specifying any 

two values for the Start or End calculates the other value and displays it in red. Varying 

the Start and End values allows creation of offset lines not parallel to the reference line.

Offset   The distance from the reference line to the offset line.

Distance

Elevation   The change in elevation between the reference and offset lines.   

Difference     

Slope  The slope from the reference line to the offset line specified as a

   percentage.

Confirmation Controls

Apply  Creates an offset line based upon the specifications in the Offset   

   Editor. 

View  Displays changes made in the Offset Editor settings without actually   

   creating the line. 

Close  Closes the Offset Editor. 

Determining  Line Direction

The line direction is indicated by a diamond at the end of the line indicating the first 

point when the line was drawn. Imagine yourself standing on the first point of the line 

looking down the line. An offset line to the left and right would be the same as your left 

and right.

Other Offset Features

The Offset Editor can offset multiple selected lines. This relies on the line direction being 

constant between the lines. The  Utility>Swap Ends command changes line direction.
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Because we started the lines at Gregory Lane when we digitized the top of curb lines, 

both start on the left side of the job. For this example, we need to change the direction 

of one of the lines so that we can enter the offsets for both lines simultaneously.

1. Switch to Edit mode, and click on the top of curb reference line nearest Lot 4.

2. Click the Swap Ends button to change the direction of the line. The diamond should 

now be at the opposite end of the line.

3. Shift+click on the other top of curb reference line so that both lines are selected.

4. Press the T key to toggle on the terrain display. Your screen should look similar to 

the illustration below.
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5. Click the Offset Line button or select Utility>Offset Line to open the Offset Line Edi-

tor.

6. Set the offset to Right, type “5.5” as the Offset Distance and “2” as the Slope, then 

click the View button to see the line displayed. If it looks to be in the right place, 

click Apply to add the line. After applied, your screen should look like the illustration 

below.

7. Click the Close button to close the Offset Line Editor.
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3. Switch to Entry Mode.

4. Place the 16-button cursor over the 252 design contour behind Lot 2 where it con-

nects to the existing contour, and press the F6 key. This inserts a point on the exist-

ing contour, and snaps to that location. Move to the 253 existing contour and press 

F6 to insert a point, and snap to that contour.

5. Continue digitizing the contour, pressing the F6 key only to snap to a place on a line 

where there is no point. If there is a point on the line available, use the F8 key to 

snap to the existing point.

6. Enter the remaining design contours behind Lots 2 and 3 using the method above. 

When complete, your job site should look similar to the illustration on the next page.

Adding the  Design Contours and a Retaining Wall

The only proposed ground left to enter is the retaining wall and the design contours at the 

back of lots 2 and 3. Most of the contours tie into the existing ground so it is helpful to 

see the existing ground during design entry. 

1. Click the Layer Selection button. The Layer Selection window is displayed. In this 

case, we want to make the existing contour lines visible so we can tie the design con-

tours into them. 

2. Select the Existing box, and click OK. The existing contour lines now display with the 

design lines. 
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7. Zoom in to the location of the retaining wall. Type in “253.5” for the top of the wall, 

and enter points along the wall’s length. Make sure you zoom in far enough that you 

don’t overlap the retaining wall line with the design line for Lot 2.

 Editing Design Data Lines

Editing design lines is the same as editing the existing ground. See “Editing Existing 

Ground” on page 7-14 for additional information.

 For this example, we do not put in the bottom of the retaining wall, because the bot-

tom of the retaining wall is at the same elevation as the building pad. It is not neces-

sary to enter the bottom of the wall in this example. For future retaining walls, use an 

offset line set at 0.1 to the down-sloping side of the wall.

8. Press the Blank button to end data entry.
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 Enter the  Design Perimeter

The Design Perimeter controls the limits of excavation. Any data outside of the Design 

Perimeter area is not calculated and is not included as part of the total volume. Any area 

that does not have a Report Region assigned to it will be a part of the Perimeter Pro-

posed on the volumes report. The Design Perimeter is entered in the Design Perimeter 

layer.

The Design Perimeter has no elevation when entered but calculates the elevation of the 

Existing Ground along its length. The Design Perimeter conforms to the Existing Ground 

and adds a data line, known as a Drape Line, to the Proposed Design at daylight.

 Drape Lines

For most situations the Design Perimeter should be entered with a Drape Line. A Drape 

Line ties the edges of the job to daylight at the perimeter of the job. For example, you 

may not want a drape line if you are doing a takeoff from multiple sheets with perimeters 

around each sheet to calculate volumes but not needed to slope to daylight.

In the illustration above, you can see how the design data slopes differently when there 

is a drape line. With a drape line, the design slopes to daylight at the design perimeter. 

When there is no drape line, the design continues its current slope until it reaches the 

perimeter and then slopes straight to daylight.

Enter the Design Perimeter

1. Switch to Entry Mode and select Design from the Surface pulldown and Perimeters 

from the Layer pulldown, or press the G key and select Enter Design Perimeter from 

the Tablet Entry guide.

2. Place the 16-button cursor at the lower right corner of the plan sheet and press 

the SP button twice to snap to the Stripping Area that should be displayed on the 

screen. If it is not displayed, select View>Show All and make sure that Stripping 

Areas is checked in the Layer Selection dialog box.

3. Snap to the remaining corners of the Stripping Area. You may want to extend the 

perimeter beyond the street so that the associated daylight line does not cause the 

street to slope to daylight.

Design Surface

Existing Surface

Perimeter

Drape Line

Straight SlopeSloping to Daylight
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4. Press the Blank button to close the region. Press the Blank button again to end data 

entry. The Apply Drape Line dialog box is displayed.

5. Click Yes to apply a drape line.

 Entering a  Hole in the Design Perimeter

A hole in the Design Perimeter is entered as a perimeter within the Design Perimeter and 

is excluded from volume calculation. A hole in the design perimeter also places holes in 

the stripping areas, report regions and sectional areas. The opposite is true for a perim-

eter entered outside the Design Perimeter. This acts as an island and becomes a part of 

the volume calculation of the Design Perimeter. The undisturbed area behind Lot 2 will 

be entered as a hole in the Design Perimeter.

1. Make sure that the Design Surface and Perimeters Layer are selected from the 

pulldown menus, and zoom into the area behind Lot 2.

2. Press the Enter button at each of the corners of the hole to create the hole.

3. Press the Blank button twice to close the area, and end data entry. The Apply Drape 

Line dialog box is displayed.

4. Click Yes to apply a drape line. Your screen should look like the illustration below.
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1. Switch to Entry Mode.

2. Click the Add Report Regions button, or press the G key and select Enter Report/Sec-

tional Areas from the Tablet Entry Guide. The Report Regions dialog box is displayed.

3. Type “Lot 1” in the Region Name. Check the Report Region box and uncheck the 

Sectional Area box. Type “.5” as the Sectional Depth. Click OK.

4. Place the cursor over the top left corner of Lot 1, and press the F8 key twice then 

the Blank key to snap a report region around Lot 1.

5. Repeat step 4 for lots 2-4 to digitize a region around each lot.

Sitework 

4D auto-

increments 

Report Region 

names when 

the name is 

followed by a 

space and a 

number, i.e., 

“Lot 1”.

Create  Report Regions/Deduct  Sectional Areas

Sitework 4D uses Report Regions to break up areas for individual calculation on the 

volume report. These are created by entering a Report Region around the area. Sectional 

areas are regions that subtract their depth from the design grade elevations, as well as 

being broken up for individual calculation on the volume report.
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Entering the Street  Sectional Area

To drop the street to subgrade, we need to create a sectional depth.

1. Switch to Entry Mode.

2. Click the Add Report Regions button, or press the G key, and select Enter Report 

Regions/Sectional Areas from  the Tablet Entry Guide. The Report Regions dialog box 

is displayed.

3. Type “Street” in the Region Name. Check the Report Region box and the Sectional 

Area box. Enter “1.15” in the Fill Factor box and “1.33” in the Sectional Depth box. 

Click OK.

6. Press the Blank button again to end Report Region entry.
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4. Place the cursor over the beginning of the top of curb line near Lot 4.

5. Using the F8 key and line snap, digitize a region around the street. Use the other top 

of curb line for the other side of the street and connect the lines at the openings.

6. Press the Blank button to end the entry and close the Sectional.
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Entering the Sidewalk Sectional Areas

To drop the sidewalks to subgrade, we need to create a sectional similar to he street 

section created previously.

1. Click the Add Report Regions button, or press the G key, and select Enter Report 

Regions/Sectional Areas from the Tablet Entry Guide. The Report Regions dialog box 

is displayed

2. Type “Sidewalk 1” in the Region Name box. Check the Report Region box and the 

Sectional Area box. Enter “1.15” in the fill factor box and “0.330” in the Section 

Depth box.

3. Place the cursor over the beginning of the top back or walk line near Lot 4.

4. Using the F8 key and line snap, digitize a region around the left sidewalk between 

the back of walk line and the top of curb line.

5. Press the Blank button to end the entry and close the sectional.

6. Repeat the above process for the sidewalk on the other side of the street, using 

“Sidewalk 2” for the name.
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 Lesson 3 – Calculating Volumes

The creation of 3D surfaces allows comparison of the surfaces for volumes. This les-

son shows how to verify the job with the 3D view and specify the area to calculate and 

generate the volumes.

Visual Verification with the 3D View Window

Sitework 4D can display the 3D terrain as it is entered in the Edit window. The 3D View 

Window adds greater flexibility to viewing and verifying the 3D surfaces.

While we were editing, the 3D Terrain showed how the program interpreted the data 

lines to form the surfaces. The 3D Window is a much more flexible version of the 3D 

Terrain which allows greater control over the view.

Press the 3D View icon on the tool bar or choose Window>3D View. The 3D window 

calculates the cut/fill colors and surfaces before displaying.

Use the 3D controls to inspect the terrain for any errors and to see how the data we 

have entered displays on the job. Refer to “Inspect the Existing Ground” on page 7-17 

for a description of this window and the 3D Controls. Note that the Ref and Diff surfaces 

can be changed to compare different surfaces on the 3D View.

Driving

Driving the 3D View is the easiest way to double check your work and the surface qual-

ity. It also can display the Subgrade and Stripping surfaces and calculate volumes.

Be sure the 

finished 

surface (the 

surface you 

are calculating 

to) is on the 

left, and the 

begining 

surface (the 

one you are 

calculating 

from) is on 

the right.
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Use the Arrow keys on the keyboard to drive through the site. The Up and Down arrows 

move forward and back. The Right and Left arrows turn. For additional clarity you may 

want to turn the Overlay off by pressing the O key or by selecting Display>Overlay. The 

speed of the drive is based on the Arrow Rate setting which is located on the Edit menu. 

Each arrow key press has a distance that the Arrow Rate controls. The speed of your 

computer and video adaptor can also affect screen speed.

Try using the 3D controls to change the views and get a feel for what they do. Also try 

changing the Reference and Difference surfaces to see the different views and compari-

sons.
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 Calculate Volumes

1. Define the  Volume Area. Click the A button on the Utility Tool Bar to create a bound-

ing box around the entire job. This determines the limits of the volume calculation. 

2. Specify the Surfaces. Before calculating the volumes verify that the correct surfaces 

are selected. For our example, set the Reference surface to Design and the Differ-

ence surface to Stripped.

3. Calculate the Volume. The Volume Calculation is started by clicking the Calc Volume 

button on the tool bar or by selecting Utility>Calc Volume.

During the volume calculation the cross sections display at the bottom of the screen 

with blue representing the Reference and Green the Difference. A line displays on the 

overlay showing the corresponding location of the cross section. The calculation can be 

paused by pressing the Spacebar or aborted by pressing Esc. When paused, the I key on 

the keyboard will move across the site incrementally. Pressing the Spacebar again will 

resume the volume calculation.

Cross Section 

display

Cross Section 

location
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When the calculation finishes, the Volume Calculation Results are displayed. 

These numbers represent uncompacted cut and fill between the two surfaces. The 

Horizontal Area represents plan view areas with no slope adjustment and is broken down 

into Cut, Fill, and On-grade square footage. Slope Area represents a slope adjusted 

square footage. It is the total surface area, excluding vertical surfaces like the curb face. 

Press Done to close the dialog box. These volume numbers can be recalled by clicking 

the Volume Report button on the tool bar.
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Job: Pine Street PDF Tutorial
Units: Ft-CY

Mon Mar 07, 2011 09:16:47 Page 1

Volume Report
      Subgrade vs. Stripped      

               Area         Volume     Comp/Ratio  Compact  Export  Change   
                                              Total            Cut             Fill     OnGrade              Cut      Fill          Cut        Fill          Cut        Fill    -Import  Per .1 Ft   
Landscape   29,881     9,511     17,821  2,549     319  672     1.00   1.00   319  672  -353  111   

   
Lot 1   7,358     0     7,358  0     0  498     1.00   1.00   0  498  -498  27   
Lot 2   11,666     7,864     2,955  847     290  50     1.00   1.00   290  50  240  43   
Lot 3   8,645     7,103     1,120  422     251  17     1.00   1.00   251  17  234  32   
Lot 4   7,580     2,654     4,703  223     143  274     1.00   1.00   143  274  -131  28   

                                                                                                                                                                                                       

Lot Sub:  35,249     17,621     16,136  1,492     684  839           684  839  -155  130  
   

Sidewalk 1   2,038     1,946     0  92     105  0     1.00   1.00   105  0  105  8   
Sidewalk 2   1,441     1,391     0  50     47  0     1.00   1.00   47  0  47  5   

                                                                                                                                                                                                       

Sidewalk Sub:  3,479     3,337     0  142     152  0           152  0  152  13  
   

Street   14,113     14,113     0  0     1,254  0     1.00   1.00   1,254  0  1,254  52   
                                                                                                                                                                                                                                               

Regions Total   82,722     44,582     33,957  4,183     2,409  1,511           2,409  1,511  898  306  
   
   
   Plane     Slope  

Stripping Qtys                     Area          Area         Depth       Volume  
Stripping   81,992     82,195     0.500  1,522  

   
   
   Plane     Slope  

Sectional Qtys                    Area          Area         Depth       Volume  
Landscape   29,881     30,572     0.000  0  

   
Lot 1   7,358     7,388     0.500  137  
Lot 2   11,666     11,698     0.500  217  
Lot 3   8,645     8,674     0.500  161  
Lot 4   7,580     7,605     0.500  141  

                                                                         

Lot Sub:  35,249     35,365        656  
   

Sidewalk 1   2,038     2,057     0.330  25  
Sidewalk 2   1,441     1,455     0.330  18  

                                                                         

Sidewalk Sub:  3,479     3,512        43  
   

Street   14,113     14,118     1.330  695  
                                                                         

Sectional Total  82,722     83,567        1,394  

The  Volume Report

Select Window>Volume Report or click on the Volume Report button to switch to the 

Volume Report.

The Volume Report displays area, volume, and depth for stripping and sectional areas. The 

total area, cut/fill, strata, and on grade volume for each report region and sectional area 

are displayed, if created. The report also displays the Cut-Fill volumes, compaction ratios 

and their impact on the volumes, import/export data, and volume change per 0.1 foot of 

elevation change, which is useful for balancing the site. The data in the volume report 

should be similar to the illustration below.
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 Vector PDF Entry Overview

This tutorial illustrates how to digitize a job using the information found in a vector PDF. 

A vector PDF is one that contains line data from a CAD, or similar, file. A vector PDF can 

be identified by the color of the border when the image is imported into Sitework 4D; a 

green outline represents a vector PDF, while a red outline represents a standard raster 

PDF. Remember: green for go, red for no.
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Data Entry Sequence

The following is the suggested data entry sequence when entering a takeoff using a PDF 

file.

Import and Scale PDF File

• Start a New Job

• Import the PDF

• Scale the Image

Vectorizing and Transferring Data

• Vectorize PDF

• Transfer Existing Lines

• Transfer Design Lines

Verifying the Scale

• Select known distance

• Length/Area to verify scale

Assigning Elevations

• Line Editor

• Increment Snap

• Elevation Snap
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Lesson 1 - Importing and Scaling

This lesson covers the importing and scaling of a vector PDF. Training videos discussing 

vector PDFs can be found at http://www.agtek.com/trainingvideos.asp. It is recommend-

ed to watch the training videos before beginning the tutorial.

Start a New Job.

1. Double click the Sitework 4D shortcut on the desktop. The open dialog displays.

2. Select the “Montessori School Site.pdf” file and click Open.

3. The PDF is imported into the Data Transfer Mode with a green outline, signifying 

a vector PDF. A vector PDF contains the information necessary for the program to 

vectorize the data, and create line work similar to a CAD file. The information is 

divided into layers based on line color and thickness. A red outline signifies a raster 

PDF which can not be vectorized and must be entered manually.
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4. Rotate the image pressing the L key twice to rotate the image counter-clockwise into 

the proper alignment. The R key will rotate the image clock-wise. Your screen should 

appear similar to the illustration below.

Scaling the PDF

1. Zoom in to the lower-right section of the PDF and locate the scale bar. In this exam-

ple the scale is 1:20 feet.

2. Select Data Transfer>Image Scale and the Edit Image Scale dialog box is displayed.

Scale Bar

3. Enter “20” for the scale and click OK.

4. A dialog box is displayed advising you to verify the scale of a drawing by measuring 

a known distance. Click OK.
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Lesson 2 - Vectorizing and Transferring Data

When you  vectorize a file using AGTEK software, annotation lines are created and sepa-

rated into layers depending line weight and color of the original file i.e.; red, black, and 

blue lines would all be in different layers (Layer 1, Layer 2, etc...). 

1. Since this is a vector PDF, which has line data from a CAD file, we can vectorize the 

data by selecting Data Transfer>Vectorize.

2. When complete, vecotrized lines are laid over the image. To turn off the background 

image, select Display>Bitmap, or by pressing the T key. Your screen should appear 

similar to the illustration below.

3. Zoom into the drawing and select one of the gray Existing contour lines.

Existing Contour Line

This screen 

shot has been 

zoomed into 

the upper-left 

side of the 

job.

Some files 

vectorize 

better than 

others. You 

may want 

to transfer 

data that 

vectorizes 

well, and 

trace the data 

that doesn’t 

manually.

When existing 

contours 

are dashed, 

and can be 

separated 

into their 

own layer 

(same weight, 

color, etc...) 

Sitework 

4D will 

automatically 

join them, 

eliminating 

the gaps.
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4. Right-click and select Send to Existing. Since there are no elevations assigned, all 

lines are sent to the annotation layer.

5. Select a Design line. Right-click and select Send to Design. Continue sending data to 

the Design layer until all useful information is transferred.

Design Data Line

Lesson 3 - Verifying the Scale

1. Click the Edit Mode button to switch modes and press the Home key to zoom out 

and center the job. Your screen should appear similar to the illustration below.

This screen 

shot has been 

zoomed into 

the upper-left 

side of the 

job.
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2. Press the T key to turn the PDF back on.

3. Zoom in to the lower-right portion of the job and locate the scale bar.

4. Select a line that runs the length of the scale bar.

Select Here

5. Click the Length/Area button on the toolbar and the Length and Area dialog box dis-

plays. The Line Length should be approximately 60 feet, confirming that the scale is 

correct. Keep in mind PDF files are not as accurate as CAD files.

Lesson 4 -  Assigning Elevations

1. Turn off the PDF by pressing the T key. This will make the annotation lines easier to 

read.

2. Zoom into the top-left portion of the job and select the 500 contour line. Enter “500” 

using the keyboard and the Line Editor dialog will display. Click OK.

If the scale is 

incorrect, see 

page A-70 for 

directions on 

rescaling a 

PDF file.

Vectorized 

design lines 

are sometimes 

segmented. 

They can 

be joined 

to create a 

single line. For 

information on 

joining lines, 

see page 3-

13.
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3. Select the 505 contour and enter “505” using the keyboard and the Line Editor dia-

log will display. Click OK.

4. Press the ESC key to clear all selections.

5. Position your arrow over the “500” contour, BUT DO NOT CLICK. Press the F8 key. 

�

6. Position your arrow over the “505” contour, BUT DO NOT CLICK. Press the F8 key.  

This will enable Increment Snap. The current interval can be seen at the bottom left 

of the program window.

7. Continue using the Increment Snap to assign the rest of the elevations at the top of 

the slope. The increment, in this case 5 feet, and direction, up or down - this case 

up, is determined by the first two lines selected. In the case the first two lines se-

lected were 500 and 505, so following lines will be assigned ascending elevations in 

5 foot increments. 

 Increment 

snap 

increases/

decreases the 

elevation of 

the last line 

and assigns 

that elevation 

to the current 

line. It will 

continue until 

you press 

ESC or select 

something by 

clicking the 

mouse.
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8. When complete, select annotated portion of the 550 contour line on the right side 

of the job. Position your arrow over the blue portion of the “550” contour line (data 

line) BUT DO NOT CLICK. Press the F9 key. The elevation from the selected 550 

data line will be assigned to the indicated annotation line.

9. Continue using the same technique to assign the rest of the Design contour lines. 

The Existing contour lines can also be entered using the same techniques.

It is not uncommon for jobs to be spread across multiple PDFs. In this case, you will 

need to align PDFs to data that has already been entered. For information on aligning 

multiple PDFs please see page A-70 in the appendix.

For more information on completing the job; adding Sectional Areas/Report Regions, Pe-

rimeters, Stripping, etc., please see the CAD Tutorial beginning on page 3-1. There area 

also training videos available at http://www.agtek.com/trainingvideos.asp. It is advised 

that you watch the corresponding training videos before completing the tutorials.

�




