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Left Button

Wheel Button

Right Button

Materials Overview

With Materials you can create material takeoffs from PDF files, CAD files or from your 
Sitework takeoff. Materials generates detailed or summary reports sorted by structure or 
material.  

 Keyboard, and Mouse Interface

Materials relies on the standard center-roller-button mouse for entry, and the keyboard 
for alphanumeric entry and keyboard shortcuts.

  Keyboard

To effectively use Materials you will use the mouse, and the keyboard. Most Materials 
4D tasks are available on menus and the Materials toolbar at the top of the screen, but 
the tasks can also be accessed much faster through keyboard shortcuts. Keyboard short-
cuts are listed in the Reference Section of this manual and are mentioned in the Tutorial 
Section where appropriate.

  The Mouse

A two-button wheel mouse is used for non-digitized entry. Below is a description of the 
buttons and their function.

The Left button is used to select objects and choose menu items.

The Right button is used to display the Right Mouse Menu. This menu displays quick 
access to specific commands.

The Wheel Button allows the user to zoom in or out over the location of the cursor by 
rolling the wheel Up or Down respectively. Holding the button down and moving the 
mouse allows the user to pan the view on the screen.
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Tool Bars

Materials utilizes the tool bar function for many of its commands for easy and quick 
access. Click on the button to activate the command. Below is a list of the commands on 
the tool bars. Buttons that are gray are not accessible.

Mode Selection Buttons

The Mode Selection Tool Bar is used for switching between the different Modes.

Import Mode  Switches to Transfer/Import Mode.

Edit Mode  Switches to the Edit Mode.

Entry Mode  Switches to Entry Mode.

Print Preview Mode Displays the Print Page.

File Tool Bar Buttons

The Tool Bar is used for opening files, saving files, and printing report.

New   Starts a new job file. The same command as selecting New   
     from the File menu.

Open   Opens an ESW file. The same command as selecting Open from  
     the File menu.

Save   Saves the current job. The same command as selecting Save   
     from the File menu.

Print   Prints the data that is currently displayed on the screen. The   
     same command as selecting Print from the File menu.

Report View   Toggles the Report View On/Off.

Display Tool Bar Buttons

The Display Tool Bar is used to Show/Hide structures. These options are also under the 
Display menu.

Show Areas  Shows/Hides all Areas in the job.

Show Lengths  Shows/Hides all Lengths in the job.

Show Counts  Shows/Hides all Counts in the job.

Show Annotation Shows/Hides all Annotation lines in the job.

Materials Introduction
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Utility Tool Bar Buttons

The Utility Tool Bar displays different options depending on the Mode.

Home   Centers the overlay and sizes it to fill the screen.

Pan   Enables the Pan tool to move the overlay. Click the Pan button,  
     then click and hold the overlay to move it. Release to stop   
     moving the overlay.

Area Zoom  Defines the view by dragging a box around the information   
     desired. Click and drag the box to define the zoom area. 

Layer Selection  Displays the Background Layer Selection window.

Label Selection  Selects all lines with the same label within the same layer or   
     structure.

Add Benchmark  Adds a benchmark on the selected point. If no points are   
     selected, position the cross-hairs on the desired location to add a  
     benchmark.

Offset Line  Creates a line/area offset a specified amount from a selected
     line/area.

Join   Connects multiple lines together.

Swap Ends  Switches the start and end points of a selected line.

Trim Line  Breaks all lines that cross the selected trim line.

Phase Region  Used for phasing a takeoff after all structures have been entered.  
     Enter an area around the desired phase.

Send to   Sends the current screen image to the Print Page.
Print Page

Add Note  Used to add a note to the Documentation layer. Position the   
     cursor at the desired location of the note. Left click to enter the  
     point.  Add the desired text or image.

Report Tool Bar Buttons

Materials  Report displaying each individual material and structure. The   
     material is listed first.

  Structures  Report displaying each individual structure and material entry.  
     The structure is listed first.

Structure Measures Basic report displaying the area and length of the structures of  
     the job.

Export to Excel  Exports the selected report to an Excel XLS file.

Print Report  Sends the selected report directly to the printer.

Send to Print Page Sends the selected report to the Print Page.
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Adding a Material

Click the Add button, or scroll to the bottom of the list. Select the Type pulldown and 
select Area, Length or Count. Enter the material name. Enter the Multiplier. Multipliers are 
used to convert the unit of measure for Lengths, Areas, and Counts to the specified job 
unit or to units of purchase. Lengths and Areas typically use multipliers that are calculat-
ed based on the individual structure. The multiplier for Counts is typically 1. Multipliers 
will be covered in more detail in the next section.

Editing a Material

Double-click on the material name or multiplier to edit the material. When all materials 
have been modified, click OK.

Deleting a Material

Right click on the material name and select Delete Selected. To select multiple materials, 
hold the Shift key on the keyboard to select additional materials. Click the Clear button to 
delete all the materials from the list. When all desired materials have been deleted, click 
OK. 

Import Material List

Click the Import button to import a materials list exported from a previous job. Select the 
desired CSV file and click Import.  When all desired materials have been imported click 
OK.

Export Material List

Click the Export button to export the materials to a file. You may save the file as the 
default MaterialsF.csv (Feet) or MaterialsM.csv (Meters) for future projects.

Materials List

The materials list displays the available materials for the job. To view the list or to add, 
delete, or modify materials on the list, select Edit>Materials. When the command is se-
lected, the Materials dialog box is displayed.

Materials Introduction
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Structures List

Materials uses a list of structures composed of materials. Structures and their materials 
are listed for each job and can be edited as needed.

There are three types of above ground structures in Materials: Areas, Lengths, and 
Counts. Each structure uses a measurement, section, and multiplier to calculate  
materials.

  Length Length Measured X Section X Multiplier

  Area Area Measured X Section X Multiplier

  Count Points Entered X Section X Multiplier

  Sections and Multipliers

Sections are the thicknesses of the materials. Lengths and Areas typically have sections 
that are calculated based on the individual structure. Counts typically have a section of 
1. 

Multipliers are used to convert the unit of measure for Lengths, Areas, and Counts to the 
specified job unit or to units of purchase. Lengths and Areas typically use multipliers that 
are calculated based on the individual structure. The multiplier for Counts is typically 1. 

For example, the Curb Straight Length used in this tutorial has a multiplier to convert 
cubic feet into cubic yards, and the Paving HD has a multiplier to convert square feet into 
tons. Below are examples of how to calculate sections and multipliers for the Curb and 
Concrete Entrance used in this tutorial.
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3 in/12 in = 0.25 ft.

 150 LB/CF  
2000 LB/CF = 0.075 TN/CF

9 in/12 in = 0.75 ft.

To calculate the section for each material, you must calculate the depth in decimal feet. 
Divide the depth of each layer by 12 to convert to decimal feet (calculating decimal feet 
is done by dividing the measurement in inches by 12). The section for the AC is 0.25 ft. 
or 3 divided by 12. The AB Class II has a section of 0.75 ft. or 9 divided by 12.

For this example and tutorial, AC and AB Class II materials are purchased by the ton, so 
both must be converted using a multiplier. We need to calculate a multiplier to convert to 
tons per cubic foot. Assuming one cubic foot of AC weighs 150 pounds, the multiplier 
is 0.075. See the equation above for the calculation. For the AB Class !! we will assume 
one cubic foot of Base weighs 145 pounds, the multiplier is 0.0725.

Note: Contact your supplier for actual material weights to calculate an accurate   
      multiplier.

To calculate the section of a Length, you must calculate the end area. The curb measures 
6” X 14”, or 6/12 ft. X 14/12 ft. The end area, or Section, for the curb is
0.5 X 1.1667 = 0.5833 sq. ft. 

The multiplier for this Length is used to convert linear feet to cubic yards. A cubic yard is 
27 cubic feet (a cubic foot is 1/27th of a cubic yard). To calculate the Multiplier, 
divide 1 by 27. The result, 0.037037037, is the Multiplier.

      Calculating Area Sections and Multipliers

Material quantities for an Area structure are measured by Area x Section x Multiplier. In 
this example, the paving area consists of two materials, 3” of AC and 9” of AB Class II 
so a section and multiplier must be calculated for each material.

Curb Typical

      Calculating Length Sections and Multipliers

Material quantities for a Length structure are measured by Length x Section x Multiplier.

Materials Introduction
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It is 
imperative 
that the 
units are set 
correctly 
before you 
begin your 
takeoff

Material Takeoff from a Raster PDF File

Materials uses a variety of data sources including PDF plan sheets, CAD files, and 
Sitework 4D files for use in completing materials takeoffs. This tutorial uses the   
Montessori School Raster.pdf file.

Launch the Program

Double-click the Gradework 4D shortcut on the desktop and the Open dialog box   
displays.

1. Click New and the Job Information dialog box is displayed.

2. Enter “Montessori Materials” for the Job Name, set the Units to Feet. The Builder 
and Operator information are optional. Check Materials and click OK.

Import and Scale the PDF

1. Select File>Import and the Import dialog box is displayed. You may also use the  
 Guide. Select the Guide menu and select Entry PDF. Click Import PDF file.
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If necessary 
you can rotate 
the drawing 
by using the 
L and R keys 
to rotate 
the drawing 
counter-
clockwise and 
clockwise 
respectively

2. Select the Montessori School Raster.pdf file and click Import. The image opens in the 
Import mode.

3. Zoom in to the lower-right portion of the job and locate the scale bar. Notice the 
scale of this job is 1”= 20’.

4.  Select the Data Transfer menu and select Image Scale. You may also press the G key 
for the Guide. Select Scale Drawing.

5.  Enter 20 for the scale and click OK.
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6. You will be prompted to check the scale. Click Yes to check the scale.

7. To check the scale, we must enter two points with a known length.  You will see a 
run of storm pipe near the bottom of the site that should be 135 feet long.

8. You can see the measured length is 135.04 feet, confirming the scale is correct. 
Click OK. If the measured value was incorrect, you would enter the actual length. 
Click the Edit Mode button or right click and select Edit Mode.
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Entering a Length

1. Click the Entry Mode button or right click and select Entry Mode. 

3. Select “Curb Straight” from the structure list. We will calculate the length of the 
curb as well as the volume of concrete. The Section refers the end area of the Curb 
Straight. For this entry the curb is “.5” (six inches) wide, by 1 (one foot) deep so the 
section is “.5” (1’ X .5’ or L X W).

4. The Multiplier is used to convert cubic feet to cubic yards. The multiplier is 1 divid-
ed by 27 which equals .037037 (1/27 = .037037), the number of cubic yards in a 
cubic foot. 

5. Using your mouse, enter the Straight Curb along the entrance road leading to the 
parking area. Position your cursor over the end of the curb line at the entrance of the 
road. Click to begin entering the curb. You can pan across the PDF image, without 
interrupting entry, by pressing on the wheel of your mouse and dragging the image. 

2. Click the Add Structures button or press G for the Guide. Select Enter Structures.

New installations 
have a default 
structures list 
that contains the 
structures for this 
tutorial.
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6. Using your mouse, enter the Straight Curb along the entrance road leading to the 
parking area. Position your cursor over the end of the curb line at the entrance of 
the road. Left click to begin entering the curb. You can pan across the PDF image, 
without interrupting entry, by pressing on the wheel of your mouse and dragging the 
image. 

7. Move along the curb line, clicking as you go. The more points used on curves, the 
smoother and more accurate your entry will be. Straight sections only require two 
points.

8. Continue entry along the curb, until the curb and gutter begins (this will be a differ-
ent structure). Right-click to end the entry.
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9. Repeat the process until all straight curb is entered. When complete, your screen 
should resemble the illustration below.

10. Click the Structure pulldown and select Curb & Gutter from the list.

11. Enter the curb and gutter where required. When complete, right click and select Edit 

Mode or click the Edit Mode button. Your screen should resemble the illustration 
below. 
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Entering an Area

1. Click the Add Structure button to display the structures list.

2. Select Paving HD from the list. This structure contains more than one material: 3 
inches of Aggregate Coarse (AC), and 9 inches of Aggregate Base (AB).  The Section 
for AC is .25.  For the Multiplier we used (150/2000 = .075 tn / FT³). For the sec-
ond material, the section is .75 and the Multiplier is .0725  (145/2000 = .0725 tn. / 
FT³). Click OK.  Numbers for your materials will be different. Contact your materials 
supplier for the correct values.

3. Enter the Heavy Duty Paving area as required beginning with the entry driveway. You 
may use the F8 key to snap to the curb lines if desired. Right-click to end the area 
entries.  When complete your screen should resemble the illustration below.
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4. Click the Structure pulldown and select Paving LD from the list.

5. Enter the light duty paving where required. Again, you may snap to the curb or curb 
and gutter when possible. When complete, right click and select Edit Mode or click 
the Edit Mode button. Your screen should resemble the illustration below. 
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6. Continue entering the islands using the same procedure.

7. Right-click and select Edit Mode.

8. Click the Save button to save your file.

Removing Holes from an Area

1. Paving Areas include a number of unpaved islands, which must be deducted for an 
accurate measurement. 

2. Make sure that Paving LD is the selected area.

3. Right-click and select Entry Mode.

4. Place your cursor over a point of an island inside the Light Duty Paving Area. Line 
Snap (press F8 key twice in rapid succession) to snap to the island.

5. Right-click to end the entry. Notice the pattern for the Light Duty Paving is removed.
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Entering a Count

1. Click the Add Structure button to display the structures list.

2. Select Yard Lights from the structure list. Since we only need a count of the yard 
light the section and multiplier are 1.00. Click OK.

3. Click the Entry Mode button or right click and select Entry Mode.

4. Click to enter a point on each one of the yard lights and the symbol will display.

5. Continue entering all the yard lights. When complete, right-click and select Edit 

Mode.

6. Click the Save button to save your file.
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Reporting

1. Reports will be displayed on the left side of the screen. If the Report View is not dis-
played, click the Report View icon.  Click the Structure Measure button. The report 
will display. This report lists structure only, no material quantities are reported. Click 
Summary to view the totals only. Click Detail to view all individual entries.

2. Click the Export to Excel button to save to an Excel spreadsheet file (.XLS).

3 Click the Print Report button to send the report directly to the printer.

4 Click the Send to Print Page button to send the report to the Print Page.
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5. Click on the Structure Report button and the report is organized by structure name, 
along with materials quantities.  Click Summary to view the totals only. Click Detail 
to view all individual entries.

6. Click the Materials Report button and the report is organized by material name. Click 
Summary to view the totals only. Click Detail to view all individual entries.
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Apply Structures

1. If you are also going to complete a sitework takeoff on this same project, you may 
use the structures as sectional areas or stripping regions.  Select the Utility menu 
and select Apply Structures.

2. Select the desired layer (Sectional Areas or Stripping Areas). Check Select All to 
select all the structures.

3. Check the box for the desired structure to be used. Make sure the section depth is 
correct. Click OK.
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It is 
imperative 
that the 
units are set 
correctly 
before you 
begin your 
takeoff

Material Takeoff from a Vector PDF File

Materials uses a variety of data sources including PDF plan sheets, CAD files, and 
Sitework 4D files for use in completing materials takeoffs. This tutorial uses the   
Stonecrest Apartments Civil.pdf file.

Launch the Program

Double-click the Gradework 4D shortcut on the desktop and the Open dialog box dis-
plays.

1. Click New and the Job Information dialog box is displayed.

2. Enter “Stonecrest Materials” for the Job Name, set the Units to Feet. The Builder and 
Operator information are optional. Check Materials and click OK.

Import and Scale the PDF

1. Select File>Import and the Import dialog box is displayed. You may also use the  
 Guide. Select the Guide menu and select Vector PDF. Click Import PDF file.
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If necessary 
you can rotate 
the drawing 
by using the 
L and R keys 
to rotate 
the drawing 
counter-
clockwise and 
clockwise 
respectively

2. Select the Stonecrest Apartments Civil.pdf file and click Import. The image opens in 
the Multi-Page Preview Window.

3. Click Next or enter the sheet number. Enter 2 for the sheet number and press Tab 
on the keyboard to preview the sheet. You may position the arrow on the plan and 
press the space bar to zoom in to make sure this is the correct sheet. Click OK.
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6. You will be prompted to check the scale. Click Yes to check the scale.

4.  Select the Data Transfer menu and select Image Scale. You may also press the G key 
for the Guide. Select Scale Drawing.

5.  Enter 40 for the scale and click OK.
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8. You can see the measured length is 335.57 feet, confirming the scale is correct. 
Click OK. If the measured value was incorrect, you would enter the actual length. 

9. The sheet border is green, indicating the file is a vector PDF file. Select the Data 

Transfer menu and select Vectorize or press the G key for the key and select 
Vectorize Image.

7. To check the scale, we must enter two points with a known length.  You will see the 
property line shows a length of 335.54 feet. Enter the points on the property corners 
across the bottom of the site.

10. Lines will be generated from the image. Press the J key on the keyboard to turn off 
the display of the image to see the vector lines clearly.
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11. We are now ready to transfer the lines to the job file. Select the line (Layer 04) that 
goes around the stone entrance. Click the Join icon to join the lines. 

12. Click the blue Send To arrow to transfer the data to the job file.
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13. Multiple layers may be selected by holding the CTRL key.  Single lines may be select-
ed by holding the Shift key. Select the silt fence (Layer 10). Hold the CTRL key and 
select the baffles (Layer18). Hold the Shift key and select the property line (Layer 
05). Click the Send To arrow. 

14. Click the Edit Mode button or right click and select Edit Mode.

16. Click the Add button. Enter EC for the name. You may add the classes as you go, or 
you may enter all the desired classes. Click OK.

15. Before we enter a structure, we will first create a new class for the erosion control 
structures. Click the Edit menu and select Classes. Click the Add button. Enter EC 
for the name.
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Entering a Length

1. For this tutorial, we will need to create new structures. Click the Add Structures  
button.

3. Select the annotation lines representing the porous baffles in the detention pond. 
Hold the shift key to select multiple lines.

4. Click the blue Send To arrow to assign the lines to the structure.

2. Select EC for the Class.  Select Length for the Type. Enter Baffles for the name. 
Select a color. Select the Line Weight. For this example, we will only calculate the 
length of the baffles. Click OK.
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5. Click the Add Structures button.

6. Select EC for the Class.  Select Length for the Type. Enter Silt Fence for the name. 
Select a color. Select the Line Weight. For this example, we will only calculate the 
length of the silt fence. Click OK.

7. You can see the vector line for the silt fence are not continuous lines. We will need 
to enter the lines manually. Click the Entry Mode button or right click and select  
Entry Mode. 

8. You may snap to the ends of the Annotation lines representing the silt fence. Right 
click and make sure Snap Enabled is checked.  Right click to end the entry. Repeat 
the process until all silt fence has been entered.
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4. Click the blue Send To arrow to assign the lines to the structure.

Entering an Area

1. Click the Add Structure button to display the structures list.

2. Select EC for the Class.  Select Area for the Type. Enter Stone Entrance for the 
name. Select a color. Select the pattern. For this example, we will only calculate the 
area of the stone entrance in square feet. Click OK.

3. Select the annotation line around the stone construction entrance.
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5. Click the Add Structures button.

6. Select EC for the Class.  Select Area for the Type. Enter Rip Rap for the name. Se-
lect a color. Select the pattern. For this example, we will only calculate the area of 
the rip rap in square feet. Click OK.

7. Select the annotation line around the rip rap in the pond area.

8. Click the blue Send To arrow to assign the lines to the structure.
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Removing Holes from an Area

1. The Rip Rap in the pond has an area inside that must be removed. 

2. Make sure that Rip Rap is the selected area.

3. Select the annotation line inside the rip rap structure. Click the blue Send To arrow 
to assign the line to the structure. Notice the pattern for the Rip Rap is removed.

4. Continue assigning the Rip Rap on the job. When all structures have been entered, 
save the file. We are now ready to import the next sheet to takeoff the construction  
class structures. 
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2. The original PDF Stonecrest Apartments Civil.pdf should be selected by default. Click 
Import.

Import and Align Multiple Sheets

On some jobs, there may be multiple plan sheets for different classes of material struc-
ture. For example, the erosion control may be on one sheet and the construction grading 
and paving plans may be on separate sheets. The sheets must be aligned before they 
can be vectorized and used in the same job. 

1. Right click and select Import Image/File.
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4. Click Next to advance to the next sheet. You may also enter the sheet number. Click 
OK.

5. The sheet will automatically be scaled and inserted to the right of the first sheet. 

6. To align the sheet, we must find two common points on the first sheet. In this  
example, we will use the property line.

3. The image opens in the Multi-Page Preview Window.
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7. Right click and select Align Image.

8. On the new image, position the cursor over the property corner in the lower left 
corner of the site. Left click to enter the point. A yellow diamond will display on the 
point.

9. Position the cursor over the Annotation on the property corner on the first sheet. 
Press the F8 key to snap to the point or left click if Snap is enabled.

10. The image will move to the second point. You can see the image is aligned since the  
plan sheets are at the same orientation. Right click and select Cancel or press the 
Escape key on the keyboard to complete the alignment.
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11. Click the Import Mode button. Select the Data Transfer menu and select Vectorize. 
You may also press the G key for the Guide and select Vectorize Image. Press the J 
key to turn off the display of the image.

12. Select one of the building pad lines. Click the blue Send To arrow to transfer the 
data to the job file.

13. Transfer the curb lines, sidewalks and remaining silt fence layers. When complete, 
return to Edit mode.
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Entering a Length

1. We will need to create a new structure. Click the Add Structures button.

2. Select Concrete for the Class. Select Length for the Type.  Enter Curb & Gutter for 
the name. Select a Color and Line Weight. We will calculate the length of the curb as 
well as the volume of concrete. The Section refers the end area of the Curb & Gut-
ter. For this entry the curb is “.5” (six inches) wide, by 1 (one foot) deep. The gutter 
is 1 foot wide by 6 inches deep so the section is “1” (1’ X .5’ + .5’ X 1’).

3. The Multiplier is used to convert cubic feet to cubic yards. The multiplier is 1 divid-
ed by 27 which equals .037037 (1/27 = .037037), the number of cubic yards in a 
cubic foot. Click OK.

4. Select one of the Annotation lines for the curb and gutter. Hold the Shift key on the 
keyboard to select multiple lines.  Make sure the selected lines only represent the 
curb and gutter. Click the blue arrow to assign the lines to the structure.
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Entering an Area

1. We will need to create a new structure. Click the Add Structures button.

2. Select Concrete for the Class.  Select Area for the Type. Enter Pads for the name. 
Select a color. Select the pattern. For this example, we will only calculate the area 
of the rip rap in square feet.. This structure contains more than one material: 4 
inches of Concrete, and 4 inches of Aggregate Base (AB).  The Section for Concrete 
is .3333.  For the Multiplier we used (1/27 = .037037 CY / FT³). For the second 
material, the section is .3333 and the Multiplier is .0725  (145/2000 = .0725 tn. / 
FT³). Numbers for your materials will be different. Contact your materials supplier for 
the correct values. Click OK.

3. Select one of the Annotation lines for the pads. Hold the Shift key on the keyboard 
to select multiple lines.  Make sure the selected lines only represent the pads. Click 
the blue arrow to assign the lines to the structure.  
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4. On occasion, the vector data may be unusable or the lines may not vectorize at all.  
In this case, you may trace the line manually. Select the Entry Mode button or right 
click and select Entry Mode.  Make sure Pads is the current structure. 

5. Trace around the extents of the pad.  Right click to end. Return to Edit mode.
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6. We will need to create a new structure for the paving area. Click the Add Structures 
button.

7. Select 2D for the Class.  Select Area for the Type. Enter Paving 2” on 8” for the 
name. Select a color. Select the pattern. This structure contains more than one ma-
terial: 2 inches of Aggregate Coarse (AC), and 8 inches of Aggregate Base (AB).  The 
Section for AC is .1667.  For the Multiplier we used (150/2000 = .075 tn / FT³). 
For the second material, the section is .6667 and the Multiplier is .0725  (145/2000 
= .0725 tn. / FT³). Click OK.  Numbers for your materials will be different. Contact 
your materials supplier for the correct values.

8. To enter the paving area, you may use the F8 key to snap to the Annotation lines if 
desired. Position the cursor over the end of the line and press the F8 key two times 
to line snap. Follow to the end of the line and press F8 one time to pick up the line. 
Trace across the entrance. Line snap to the opposite side Annotation line.  Go the 
end of the line and press F8 one time to pick up the line.  Trace back to the starting 
point. Right-click to end the area entries. 
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Removing Holes from an Area

1. The Paving Area includes two unpaved islands, which must be deducted for an  
accurate measurement. 

2. Make sure that Paving 2” on 8” is the selected area.

3. Select the Annotation lines around the edge of pavement.

4. Click the blue Send To arrow to assign the lines to the structure. The pattern will be 
removed from the islands.

5. Click the Save button to save your file.
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Entering a Count

1. Click the Add Structure button to display the structures list.

2. Select 2D for the Class. Select Count for the Type. Enter Inlet Protection for the 
name. Since we only need a count of the inlets, the section and multiplier are 1.00. 
Click OK.

3. Click the Entry Mode button or right click and select Entry Mode. You may click the 
Show Area icon to hide the areas to see the plan clearly. 

4. Click to enter a point on each one of the inlets and the symbol will display.

5. Continue entering all the inlets. When complete, right-click and select Edit Mode.

6. Click the Save button to save your file.
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Reports

1. Reports will be displayed on the left side of the screen. If the Report View is not dis-
played, click the Report View icon.  Click the Structure Measure button. The report 
will display. This report lists structure only, no material quantities are reported. Click 
Summary to view the totals only. Click Detail to view all individual entries.

2. Click the Export to Excel button to save to an Excel spreadsheet file (.XLS).

3 Click the Print Report button to send the report directly to the printer.

4 Click the Send to Print Page button to send the report to the Print Page.
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5. Click on the Structure Report button and the report is organized by structure name, 
along with materials quantities.  Click Summary to view the totals only. Click Detail 
to view all individual entries.

6. Click the Materials Report button and the report is organized by material name. Click 
Summary to view the totals only. Click Detail to view all individual entries.



Materials Tutorial 2   

3-24

Apply Structures

1. If you are also going to complete a sitework takeoff on this same project, you may 
use the structures as sectional areas or stripping regions.  Select the Utility menu 
and select Apply Structures.

2. Select the desired layer (Sectional Areas or Stripping Areas). Check Select All to 
select all the structures.

3. Check the box for the desired structure to be used. Make sure the section depth is 
correct. Click OK.
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Using Earthwork Takeoff Data

Materials may use the linework from your earthwork takeoff. When entering an earth-
work takeoff that is also to be used for your material quantities, enter Design Data Lines 
to the finished elevations, and use Sectional Areas to account for the material depths 
necessary for total dirt calculations. It is also a best practice to use line labels when 
entering jobs, so that multiple areas may be selected at the same time using the Label 
Select tool. The linework may then be used in Materials to calculate total material quan-
tities.

Launch the Program

1. Double-click the Gradework 4D shortcut on the desktop and the Open dialog box 
displays.

2. Select the Montessori School Sitework.esw file and click Open. The file will open in 
Gradework. 
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Materials Mode

1. Position the cursor inside the sheet border and press the Insert key to insert the plan 
sheet.

2. Click the Materials button in the upper right corner of the screen. The program will 
switch to the Materials program.

3. Click the Layer Selection icon on toolbar or press Alt-B on the keyboard to display 
the Layer Selection window. Check only the layers needed to complete the materials 
takeoff. For this tutorial, uncheck all layers except Sectional Areas.
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2. Click the Add Structure button to display the structures list.

Assign Area Structures

1. To assign a sectional area to a structure, we will first need to add or select the struc-
ture from the structure list. 

3. Select Paving HD from the list. This structure contains more than one material: 3 
inches of Aggregate Coarse (AC), and 9 inches of Aggregate Base (AB).  The Section 
for AC is .25.  For the Multiplier we used (150/2000 = .075 tn / FT³). For the sec-
ond material, the section is .75 and the Multiplier is .0725  (145/2000 = .0725 tn. / 
FT³). Click OK.  Numbers for your materials will be different. Contact your materials 
supplier for the correct values).

New installations 
have a default 
structures list 
that contains the 
structures for this 
tutorial.
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4. Select the Paving HD sectional area. 

5. Click the blue Send To arrow to assign the selected sectional area to the Paving HD 
structure.  

6. The fill pattern will display for the Paving HD. The results will be displayed on the 
report on the left side of the screen.
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The image 
may be 
toggled on 
and off using 
the “J” key.

7. Click the Structure pulldown and select Paving LD from the list.

8. Select one of the Paving LD sectional areas.

9. Click the Label Select button and all Paving LD areas will be selected.

10. Click the blue Send To arrow to assign the selected sectional area to the Paving LD 
structure.

6. The fill pattern will display for the Paving LD. The results will be displayed on the 
report on the left side of the screen.
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3. Select one of the Island sectional areas.

4. Click the Label Select button and all Island areas will be selected.

5. Click the blue Send To arrow to assign the selected sectional area to the Paving LD 
structure.

Removing Holes from an Area

1. Paving LD includes a number of unpaved islands, which must be deducted for an 
accurate measurement. 

2. Make sure that Paving LD is the selected structure.

6. The fill pattern will be removed for the Paving LD. The areas will display as a   
negative value on the report.

7. Continue entering all area structures by assigning the sectional areas to the appropri-
ate structure.
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Assign Length Structures

1. After all area structures have been assigned, we will next enter a length structure. 
To enter the lengths, we will display the Data Lines only.

2. Click the Layer Selection icon on toolbar or press Alt-B on the keyboard to display 
the Layer Selection window. For the lengths, uncheck all layers except Design. Click 
OK.

3. Click the Show Areas icon to hide the area structures from the display to see the 
data lines clearly. 
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8. Select one of the top of curb lines. In this tutorial, line labels were used when enter-
ing the data lines. The straight curb lines were labeled TC.  Click the Label Selection 
icon to select all the lines labeled TC. Make sure only the desired lines are selected.

4. Click the Show Areas icon to hide the area structures from the display to see the 
data lines clearly. 

5. Click the Add Structures button.

6. Select “Curb Straight” from the structure list. We will calculate the length of the 
curb as well as the volume of concrete. The Section refers the end area of the Curb 
Straight. For this entry the curb is “.5” (six inches) wide, by 1 (one foot) deep so the 
section is “.5” (1’ X .5’ or L X W).

7. The Multiplier is used to convert cubic feet to cubic yards. The multiplier is 1 divid-
ed by 27 which equals .037037 (1/27 = .037037), the number of cubic yards in a 
cubic foot. 

The image 
may be 
toggled on 
and off using 
the “J” key.
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9. Click the blue Send To arrow to assign the selected sectional area to the Curb 

Straight structure.

8. Select one of the curb and gutter lines.  Click the Label Selection icon to select all 
the lines labeled CGRef. Make sure only the desired lines are selected.

9. Click the blue Send To arrow to assign the selected lines to the Curb & Gutter   
structure.



4-10

Materials Tutorial 3   

Entering a Count

1. Click the Add Structure button to display the structures list.

2. Select Yard Lights from the structure list. Since we only need a count of the yard 
light the section and multiplier are 1.00. Click OK.

3. Click the Entry Mode button or right click and select Entry Mode.

4. Click to enter a point on each one of the yard lights and the symbol will display.

5. Continue entering all the yard lights. When complete, right-click and select Edit 

Mode.

6. Click the Save button to save your file.
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2. Click the Export to Excel button to save to an Excel spreadsheet file (.XLS).

3 Click the Print Report button to send the report directly to the printer.

4 Click the Send to Print Page button to send the report to the Print Page.

Reporting

1. Reports will be displayed on the left side of the screen. If the Report View is not dis-
played, click the Report View icon.  Click the Structure Measure button. The report 
will display. This report lists structure only, no material quantities are reported. Click 
Summary to view the totals only. Click Detail to view all individual entries.
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5. Click on the Structure Report button and the report is organized by structure name, 
along with materials quantities.  Click Summary to view the totals only. Click Detail 
to view all individual entries.

6. Click the Materials Report button and the report is organized by material name. Click 
Summary to view the totals only. Click Detail to view all individual entries.
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It is 
imperative 
that the 
units are set 
correctly 
before you 
begin your 
takeoff

Material Takeoff from a CAD File

Materials uses a variety of data sources including PDF plan sheets, CAD files, and 
Sitework 4D files for use in completing materials takeoffs. This tutorial uses the   
Stonecrest Apt.dwg file.

Launch the Program

Double-click the Gradework 4D shortcut on the desktop and the Open dialog box dis-
plays.

1. Click New and the Job Information dialog box is displayed.

2. Enter “Stonecrest Materials CAD” for the Job Name, set the Units to Feet. The  
Builder and Operator information are optional. Check Materials and click OK.

Import the CAD File

1. Select File>Import and the Import dialog box is displayed. You may also use the  
 Guide. Select the Guide menu and select CAD. Click Import CAD file.
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2. Select the Stonecrest Apt.dwg. file and click Import.

3. When importing a CAD file, the Show Hidden Layers dialog window may display. 
Click Continue to display only layers that are not hidden or frozen from view by the 
engineer. Click Show All to display all layers in the file. Click Continue. The file will 
open in Import mode.

4. You will see some profile data on the right side of the screen. Drag the job data to 
the center of the screen and select Data Transfer > Crop Rectangle.
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5.  Using your mouse, draw a box around the job data, making sure to include all the 
data required for the material takeoff. 

6.  Click Yes to remove everything outside the bounding rectangle.

7. The CAD data will display the in the center of the screen.
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8. Zoom into the job data and select one of the building pads. The CAD layer name 
will be B-FP. The diamonds on the segments represent the starting point of the line. 
You can see the pad lines are broken into small segments. click the Join icon on the 
toolbar to join the lines.

9. The lines will be joined creating a single line around the building pad.

10. Click the blue arrow (Send To) to transfer the lines to the job file. 
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11. Select the curb lines, (Layer B_CONC). Click the Join icon to join the lines. 

12. Click the blue Send To arrow to transfer the data to the job file. Transfer the PL and 
Walks layer in the same manner. Return to Edit mode. 

13. The program will display the lines transferred to the job. We will next import and 
align the PDF file in the background.
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Import and Align the PDF

1. Select File>Import or right click and select Import File. Select the Stonecrest   

 Apartments Civil.pdf file and click Import.

2. The image opens in the Multi-Page Preview Window.

3. Click Next or enter the sheet number. Enter 3 for the sheet number and press Tab 
on the keyboard to preview the sheet. You may position the arrow on the plan and 
press the space bar to zoom in to make sure this is the correct sheet. Click OK.
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4.  Select the Data Transfer menu and select Image Scale. You may also press the G key 
for the Guide. Select Scale Drawing.

5.  Enter 40 for the scale and click OK. Return to Edit mode.

6.  You can see the image is not aligned to the CAD data. We will need to find two 
points on the PDF image that correspond to the CAD data.  In this example, we will 
use the property line.
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7.  Right click and select Align Image.

8.  Position the cursor over the first point on the PDF image.  Left click to enter the 
point. A yellow diamond will display on the point.
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9.  Position the cursor over the corresponding point in the CAD data.  Press the F8 key 
to snap to the point. The image will move to the second point. You can see, the 
image is not in the same orientation as the CAD data. We will need to select the 
second point.

10.  Position the cursor over the second point on the PDF image.  Left click to enter the 
point. A yellow diamond will display on the point.
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12. The corresponding points are displayed with a scale factor. If the scale factor is close 
to 1.00, keep Maintain Image Scale check and click OK.

13. The image will be aligned to the CAD data.

11.  Position the cursor over the corresponding point in the CAD data.  Press the F8 key 
to snap to the point. The Aligning Site dialog window will display.
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2. Select the Bldg structure from the pulldown list. Select one of the building pad lines. 
Click the Label Selection icon on the toolbar. All the building pad lines should be se-
lected. 

3. Click the blue Send To arrow to assign the lines to the structure.

Assign Structure by Label

1. The procedure for assign and entering structures is the same as using a Vector PDF  
 file, however when using a CAD file, you may use the label selection to select lines  
 in the same layer. Select Bldg from the Structure pulldown menu.
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Underground Overview

With Underground you can create material takeoffs from precise computer-generated 
CAD files, AGTEK ESW files, or printed plan sheets. When you enter data such as pipe-
lines, laterals, verticals and fittings. Trench details may be entered to calculate trench 
excavation and material quantities. 

  Document Conventions

This tutorial uses standard software documentation conventions to explain how the soft-
ware works. These conventions are described below.

Click/click on - Press the left mouse button (assuming the buttons are set to the default 
settings). 

Double-click - Press the left mouse button twice in rapid succession.

Right-click - Press the right mouse button.

Click and hold - Press and hold down the left mouse button.

Shift/Ctrl+click - Press and hold down the Shift/Ctrl key then press the left mouse but-
ton.

Click and drag - Press and hold the left mouse button, then move the mouse.

Ctrl+(Key) - Press the Ctrl key then press the keyboard key noted in the step.

Press - Press a specified key on the keyboard.

Select - Use the mouse to pick an item on the screen or menu command.

Menu Commands - When documenting a menu command, the command is described us-
ing the following format: Menu>Command. If there is more than one level to the menu, 
it appears as a Sub-menu. For example, Options>Sound Preference>Sound Card.

Data Entry/File Names - If a file is specified in a procedure, or if specific text needs to be 
entered into a field as part of a procedure, it will appear inside double quote marks.
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 Keyboard, and Mouse Interface

Underground relies on the standard center-roller-button mouse for entry, and the key-
board for alphanumeric entry and keyboard shortcuts.

  Keyboard

To effectively use Underground you will use the mouse, and the keyboard. Most Un-
derground tasks are available on menus and the Underground toolbar at the top of the 
screen, but the tasks can also be accessed much faster through keyboard shortcuts. 
Keyboard shortcuts are listed in the Reference Section of this manual and are mentioned 
in the Tutorial Section where appropriate.

The Left button is used to select objects and choose menu items.

The Right button is used to display the Right Mouse Menu. This menu displays quick ac-
cess to specific commands.

The Wheel Button allows the user to zoom in or out over the location of the cursor by 
rolling the wheel Up or Down respectively. Holding the button down and moving the 
mouse allows the user to pan the view on the screen.

  The Mouse

A two-button wheel mouse is used for non-digitized entry. Below is a description of the 
buttons and their function.

Left Button

Wheel Button

Right Button
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Lesson 1 - Importing and Scaling the PDF

Underground uses a variety of data sources including PDF plan sheets, CAD files, and 
Gradework files for use in completing materials takeoffs. This tutorial uses the Montes-
sor School PDF.pdf file.

Launch the Program

Double-click the Gradework shortcut on the desktop and the Open dialog box displays.

1. Click New and the Job Information dialog box is displayed.

2. Enter “Montessori Underground Takeoff” for the Job Name, set the Units to Feet, 
Check Materials. The Builder and Operator information are optional. Click OK.

Import and Scale the PDF

1. Select File>Import and the Import dialog box is displayed.

2. Select “Montessori School PDF.pdf” and click Open. The image opens in the Import 
mode.
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If necessary 
you can rotate 
the drawing 
by using the 
L and R keys 
to rotate 
the drawing 
counter-
clockwise and 
clockwise 
respectively

3. Select Data Transfer>Image Scale and the Edit Image Scale dialog box displays.

4. Enter “20” for the scale and click OK.

5. A dialog box displays advising you to check the scale of the drawing using a known 
distance. Click Yes.
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6. Enter two points at the ends of the 8 inch storm pipe on the north side of the site.  
The points should be 60 feet apart.  

7.  The Measured distance is very close.  Click OK. 

8. Click the Edit mode button or right click and select Edit Mode. 
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Lesson 2 - Entering Pipes, Laterals, Verticals, and Fittings

Underground uses a list of structures composed of materials. Structures and materials 
can be created for each job, or you can import a list from a previous job.  When starting 
a new job in Underground, separate phases are created for 4 classes: Storm, Sewer, 

Water and Other.

Structures

There are four types of structures in Underground: Pipes, Laterals, Verticals and Fittings.  
Each structure uses a measurement, section, and multiplier to calculate trench materials.

Pipe  Calculates length and average depth.

Lateral Calculates length and average depth.

Vertical Counts and calculates depth of vertical structures (Manholes, Inlets).

Fitting Counts the number of fittings.

  Sections and Multipliers

Sections are the thicknesses of the materials. Pipes and Laterals typically have sections 
that are calculated based on the trench definition. Verticals and Fittings typically have a 
section of 1. 

Multipliers are used to convert the unit of measure for Pipes, Laterals, Verticals and 
Fittings to the specified job unit or to units of purchase. Pipes and Laterals typically use 
multipliers that are calculated based on the individual structure. The multiplier for verti-
cals and fittings is typically 1. 
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The color can 
be change by 
clicking in the 
Color column 
and scrolling 
through 
available 
colors. You 
can double-
click the color 
to display the 
color palette, 
which will 
allow you to 
create custom 
colors.

Entering a Pipe (Rim - Invert)

Pipes may be entered using two different methods. You may enter Rim - Invert, or you 
may use the desired surface from your sitework takeoff. This section will demonstrate 
entering Rim - Invert.

1. Click Add Structure to create a new structure.

2. Select Storm for the Class.

3. Select Pipe for the Type.

4. Enter “SD 8-in” for the Structure Name. Use the inside diameter of the pipe in the 
name. This value will be used to calculate the default trench specifications, press 
Tab.  The Trench Description window displays.
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6. Enter the desired values for the following fields.

  •Bottom Width Width in inches of the trench.
 •Bedding Thickness Thickness in inches of material below the pipe.
 •Cover Thickness Thickness in inches of material to cover the pipe
 •Select Thickness Thickness in inches of select material above the pipe.
 •Bench Width  Width in feet of a bench.
 •Flare Point  Vertical distance in feet from the trench bottom to start the  
    Flare Slope.
 •Flare Slope  Slope in percent or V:H to daylight from Flare Point.
 •Pipe Wall  Thickness in inches of the pipe wall.  This value will default  
    to 10% of the pipe ID.
 •Outside Diameter Thickness in inches of the outside diameter of the pipe.
 •Inside Diameter Thickness in inches of the inside diameter of the pipe. This  
    value is derived from the pipe name.
 •Backfill Compaction Compaction factor for imported backfill.

7.  For this example, enter 6 inches for the Select Thickness. Click OK.

5. The trench diagram displays different fields to be calculated.  When a field is select-
ed, the diagram will highlight the corresponding line or area.
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9. Click the Entry mode button or right click and select Entry Mode.

 8 The materials from the trench detail will be calculated based on the trench   
parameters.  Click OK.

10. Zoom into the storm drain inlet on the north side of the job. Position the cursor on  
the inlet.  Enter 514.25 - 508.7 (Rim - Invert) and left click to enter the point.
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11. Move to the next inlet and enter 513.3 - 508.12 and left click to enter the point.

13. Continue entering all 8 inch storm pipe. If a run of pipe intersects a previous entry, 
you may use the F8 key or enable Snap to snap to the pipe.

14 When complete, right click and select Edit Mode.

15. Click the Save icon to save the file.

12. Continue to the next inlet and enter 503.6 - 498.32.  Left click to enter. You can see 
in the profile window the rim is tracking the design surface. Continue this procedure 
to the existing storm drain at  497.4 - 494.63. Right click to end the run. 
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Entering a Lateral

Laterals are a special type of pipeline.  Laterals connect to the main pipe entry, and end 
at a user defined depth or slope or elevation.

1. Click Add Structure to create a new structure.

5. Change the Bottom Width to 24 inches.  Click OK.

6. The trench materials sections will be updated.  Click OK.

2. Select Storm for the Class.

3. Select Lateral for the Type.

4. Enter “SD 4-in” for the Structure Name. Use the inside diameter of the pipe in the 
name. This value will be used to calculate the default trench specifications, press 
Tab.  The Trench Description window displays.
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7. Select the Options menu and select Lateral Depth to enter either an end depth or 
minimum slope percentage.

10 Continue entering all 4 inch storm laterals.

8. Position the cursor at the intersection of the 8” storm pipe and the 4” lateral. Press 
F6 on the keyboard to snap to the pipe. 

9 Move the cursor to the end of the lateral and left click to enter the point. The invert 
will be 4 feet below the pipe unless the slope is less than 1 percent. 
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Entering a Vertical

Verticals are used to count and calculate depth of vertical structures (Manholes, Inlets).

1. Click Add Structure to create a new structure.

2. Select Storm for the Class.

3. Select Vertical for the Type.

4. Enter “SD Inlet” for the Structure Name. 

6. Choose a desired color from the color palette.

6. To add a symbol, click in the Pattern and select the “Drop Inlet” symbol. Click OK.

7. Position the cursor over the SD 8-in pipe at the inlet. Press the F8 key to snap or 
enable Snap and left click to enter the inlet. 

8. If the inlet has a drop connection make sure to snap to the deepest invert. 

9. Continue entering all the SD Inlets.
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7. Position the cursor at the intersection of the 8” storm pipe and the 4” lateral. Left 
click to enter the fitting. 

8. Add all storm fittings using the same procedure.

2. Select Storm for the Class.

3. Select Fitting for the Type.

4. Enter 8 x 4 Wye for the structure name.  Press Tab.

5. Choose a desired color from the color palette.

6. You may add a symbol if desired. Click OK.

Entering a Fitting

1. Click Add Structure to create a new structure.

Fittings will 
only attach 
to structures 
of the same 
class.
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Entering Water Lines

 Water pipelines may not show rim and invert elevations. Waterlines may require a fi xed  

 depth.  To accommodate this, we must establish the desired depth with fi ctitious rim and  

 invert elevation.

1. Click Add Structure to create a new structure.

2. Select Water for the Class.

3. Select Pipe for the Type.

4. Enter “Water 1.5-in” for the Structure Name, press Tab. 

5. Default trench materials will automatically be added to the Materials.

6. For this example we will use the default trench specifications.  Click OK.

7. Zoom into the Waterline on the west side of the job. Position the cursor on   
the end of the Water Line.  Enter 500-496 (For a 4 foot deep trench) and left click to 
enter the point. Trace the entire water line. Right click to end.
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8. Water laterals and fittings are entered the same as before. The Fire line may also be 
entered in the Water class.

9. When all entries are complete, click the Save icon to save the file.
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Reporting

1. When all entries are complete, the report will display on the left side of the screen. 
The Materials Report will display by default.  You may view the Summary or Detail 
report. 

2. The Materials Report organizes the report by materials. The trench material volumes 
will be displayed for each structure.

3. Click the Export to Excel button to save to an Excel spreadsheet file (.XLS).

4 Click the Print Report button to send the report directly to the printer.

5 Click the Send to Print Page button to send the report to the Print Page.
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7. The Underground Report generates depth bracket for each structure. The length of 
pipe in each bracket is report.  The verticals are also reported by depth. 

8. The Trench Volume Report organizes the report by underground structures. The 
trench material volumes will be displayed for each structure. You may view the Sum-

mary or Detail report. 

6. The Underground Report organizes the report by underground structures. The trench 
material volumes will be displayed for each structure. You may view the Summary or 
Detail report. 

9. The Trench Volume Report displays the trench excavation, the trench materials and 
the Import/Export of the native backfill. 
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Lesson 2 - Entering Underground from a Sitework Takeoff

Underground may use the lines and surfaces created in Gradework to completer the un-
derground takeoff. 

Launch the Program

Double-click the Gradework shortcut on the desktop and the Open dialog window   
displays.

1. Select the Montessori School Sitework.esw file and click Open.

2. The file will open in Gradework mode. Click the Materials button in the upper right 
corner of the screen.
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1. Position the arrow inside the sheet border and press the Insert key to insert the plan  
sheet.

2. Before we begin entry, we can clear the data that will not be used from the screen 
to clear the view. 

2. Before we begin entry, we can clear the data that will not be used from the screen. 
To clear the view, click the Hide Annotation Layers button.
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2. Select Storm for the Class.

3. Select Pipe for the Type.

4. Enter “SD 8-in” for the Structure Name. Use the inside diameter of the pipe in the 
name. This value will be used to calculate the default trench specifications, press 
Tab.  The Trench Description window displays.

Entering a Pipe (Assign Rim Elevation)

Pipe may be entered using two different methods. You may enter Rim - Invert, or you 
may use the desired surface from your sitework takeoff. This section will demonstrate 
using the Assign Rim Elevation from the sitework takeoff surface.

1. Click Add Structure to create a new structure.
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6. Enter the desired values for the following fields.

  •Bottom Width Width in inches of the trench.
 •Bedding Thickness Thickness in inches of material below the pipe.
 •Cover Thickness Thickness in inches of material to cover the pipe
 •Select Thickness Thickness in inches of select material above the pipe.
 •Bench Width  Width in feet of a bench.
 •Flare Point  Vertical distance in feet from the trench bottom to start the  
    Flare Slope.
 •Flare Slope  Slope in percent or V:H to daylight from Flare Point.
 •Pipe Wall  Thickness in inches of the pipe wall.  This value will default  
    to 10% of the pipe ID.
 •Outside Diameter Thickness in inches of the outside diameter of the pipe.
 •Inside Diameter Thickness in inches of the inside diameter of the pipe. This  
    value is derived from the pipe name.
 •Backfill Compaction Compaction factor for imported backfill.

7.  For this example, enter 6 inches for the Select Thickness. Click OK.

5. The trench diagram displays different fields to be calculated.  When a field is select-
ed, the diagram will highlight the corresponding line or area.
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9. Click the Entry mode button or right click and select Entry Mode.

10. Click the Assign Rim Elevation button. The window displays.

 8 The materials from the trench detail will be calculated based on the trench   
parameters.  Click OK.

The color can 
be change by 
clicking in the 
Color column 
and scrolling 
through 
available 
colors. You 
can double-
click the color 
to display the 
color palette, 
which will 
allow you to 
create custom 
colors.

11. Select the desired surface to be used for the rim elevations. In this example we will 
use the Design.  Click OK.
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13. Move to the next inlet and enter 508.12 and left click to enter the point.

14. Continue to the next inlet and enter 498.32.  Left click to enter. You can see in the 
profile window the rim is tracking the design surface. Continue this procedure to the 
existing storm drain at  494.63. Right click to end the run. 

15. Continue entering all 8 inch storm pipe. If a run of pipe intersects a previous entry, 
you may use the F8 key or enable Snap to snap to the pipe.

16 When complete, right click and select Edit Mode.

17. Click the Save icon to save the file.

12. Zoom into the storm drain inlet on the north side of the job. Position the cursor on  
the inlet.  Enter 508.7 (Invert) and left click to enter the point.
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Entering a Lateral

Laterals are a special type of pipeline.  Laterals connect to the main pipe entry, and end 
at a user defined depth or slope or elevation.

1. Click Add Structure to create a new structure.

6. Change the Bottom Width to 24 inches.  Click OK.

7. The trench materials sections will be updated.  Click OK.

2. Select Storm for the Class.

3. Select Lateral for the Type.

4. Enter “SD 4-in” for the Structure Name. Use the inside diameter of the pipe in the 
name. This value will be used to calculate the default trench specifications, press 
Tab.  The Trench Description window displays.
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8. Position the cursor at the intersection of the 8” storm pipe and the 4” lateral. Press 
F6 on the keyboard to snap to the pipe.

9. Move the cursor to the end of the lateral.  Enter -4 feet for the depth to the invert. 
Press the F10 key on the keyboard to enter the point. Right click to end the entry.

10. Laterals may also be entered by slope. Snap to the main line as before. Trace the 
lateral to the end.  On the last point, enter the desired slope. In this example, enter 
1% and left click to enter the point. Right click to end.
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Entering a Vertical

Verticals are used to count and calculate depth of vertical structures (Manholes, Inlets).

1. Click Add Structure to create a new structure.

2. Select Storm for the Class.

3. Select Vertical for the Type.

4. Enter “SD Inlet” for the Structure Name. 

4. Choose a desired color from the color palette.

5. To add a symbol, click in the Pattern and select the “Drop Inlet” symbol. Click OK.

6. Position the cursor over the SD 8-in pipe at the inlet. Press the F8 key to snap or 
enable Snap and left click to enter the inlet. 

7. If the inlet has a drop connection make sure to snap to the deepest invert. 

8. Continue entering all the SD Inlets.
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Entering a Fitting

1. Click Add Structure to create a new structure.

2. Select Storm for the Class.

3. Select Fitting for the Type.

4. Enter 8 x 4 Wye for the structure name.  Press Tab.

5. Choose a desired color from the color palette.

6. You may add a symbol if desired. Click OK.

7. Position the cursor at the intersection of the 8” storm pipe and the 4” lateral. Left 
click to enter the fitting. 

8. Add all storm fittings using the same procedure.

Fittings will 
only attach 
to structures 
of the same 
class.
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Entering Water Lines

 Water pipelines may not show rim and invert elevations. Waterlines may require a fi xed  

 depth.  To accommodate this, we must establish the desired depth with fi ctitious rim and  

 invert elevation.

1. Click Add Structure to create a new structure.

2. Select Water for the Class.

3. Select Pipe for the Type.

4. Enter “Water 1.5-in” for the Structure Name, press Tab. 

5. Default trench materials will automatically be added to the Materials.

6. For this example we will use the default trench specifications.  Click OK.

7. Zoom into the Waterline on the west side of the job. Position the cursor on   
the end of the Water Line.  Enter -4 for the depth and press the F10 key to enter the 
points.  Trace the entire Water line using F10 on each point. Right click to end.
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8. Water laterals and fittings are entered the same as before. The Fire line may also be 
entered in the Water class.

9. When all entries are complete, click the Save icon to save the file.
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Reporting

1. When all entries are complete, the report will display on the left side of the screen. 
The Materials Report will display by default.  You may view the Summary or Detail 
report. 

2. The Materials Report organizes the report by materials. The trench material volumes 
will be displayed for each structure.

3. Click the Export to Excel button to save to an Excel spreadsheet file (.XLS).

4 Click the Print Report button to send the report directly to the printer.

5 Click the Send to Print Page button to send the report to the Print Page.



Underground Tutorial 2

7-14

7. The Underground Report generates depth bracket for each structure. The length of 
pipe in each bracket is report.  The verticals are also reported by depth. 

8. The Trench Volume Report organizes the report by underground structures. The 
trench material volumes will be displayed for each structure. You may view the Sum-

mary or Detail report. 

6. The Underground Report organizes the report by underground structures. The trench 
material volumes will be displayed for each structure. You may view the Summary or 
Detail report. 

9. The Trench Volume Report displays the trench excavation, the trench materials and 
the Import/Export of the native backfill. 
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   Menus

The Menu bar lists the available menus and commands. Many of the menus and com-
mands are common, though some modes have specific menus and specific commands 
different from the other modes. Below is a description of all of the available commands 
from each menu, with special menus and commands noted.

Note: The illustration below shows all Menus.

File Menu

The File Menu is used to start new jobs, open jobs, save jobs, import/export jobs, set 
printer preferences, and exit the program. Below is a list of commands in the File Menu 
in all modes.

New

Starts a new job. When the command is selected, the Job Information dialog box is dis-
played.

Enter the Job Name, Builder, Operator, and Units. The Bid Date and Operator are auto-
matically entered based on the current data. Click OK to start the new job.

Open

Opens an existing job. When the command is selected, the Open dialog box is displayed.

Select the file from the list in the window and click Open to open the file.
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Recent Files

Displays the most recent files that were opened. Select the file to open.

  Import

Used to import data from an ESW, DXF, DWG or PDF file. When the command is select-
ed, the Import dialog box is displayed.

Select the file from the list in the window. The name then displays in the File Name text 
box. Click Import to get the file. Files are opened in Import Mode.

Merge

Used to merge data from one Materials file to another. When the command is selected, 
the Merge dialog box is displayed.

Select the file from the list in the window. The name then displays in the File Name text 
box. Click Merge to get the file.
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Recover Data

Import/Export recover data from GPS alignments.

Save

(Not Available in Import Mode)

Saves the job with the current job name to the working directory.

Save As

(Not Available in Import Mode)

Saves the current job with a different name. When the command is selected, the Save 
As dialog box is displayed.

Type the new name of the file in the text box and click Save to save the file.

Export

(Not Available in Import Mode)

Used to export data into a specific format. The Export sub-menu contains six commands.

AGTEK Mobile (.ADF)

 Used only for Gradework Data

AGTEK Data Transfer (.AGT)

 Used only for Gradework Data

AutoCAD Drawing (.DWG/.DXF)

 Used only for Gradework Data
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KMZ Export (.KMZ)

 When the command is selected, the Save As dialog box is displayed.

 Type the new name of the file in the text box and click Save to save the file. The  
 KMZ File Export window is displayed.

 Select the desired data to be exported to the KMZ file.  Click Export.  
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Materials Report (.XLS)

 When the command is selected, the Save As dialog box is displayed.

 Type the name of the file in the text box and click Save to save the file.

Ground Control Points (.CSV)

 Used to export Ground Control Points to various Drone Processing software.

Page Setup

(Not Available in Import Mode)

Displays the Page Setup dialog box to change printer properties. When the command is 
selected, the Page Setup dialog box is displayed.

Change the printer properties. Click OK accept changes.
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Print

(Not Available in Import Mode)

When the command is selected in Edit mode, the Print dialog box is displayed. When the 
command is selected in Print Preview Mode, the currently displayed data is printed.

Send to Print Page

Select the printer, change the printer properties, and select the print range. Click Apply 
to accept the settings.

(Not Available in CAD Transfer Mode)

Sends the current view to the Print Page. 

Email.

(Not Available in CAD Transfer Mode)

Launches your default Email application to share job files. 

Exit

Exits Materials. If changes have been made, a dialog box is displayed asking to save the 
file before quitting.

Click Yes to save, No to exit without saving or Cancel to abort saving and continue 
working.
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Edit Menu

The Edit Menu is used to undo commands, as well as select and edit structures and ma-
terials and edit phases and classes. Below is a list of the commands available from the 
Edit Menu in all modes.

Undo

(Not Available in Print Preview Mode)

Undoes the last command.

Redo

(Not Available in Print Preview Mode)

Restores the last Undo command.

Copy

(Edit Mode Only)

Copies the currently selected data and stores it in temporary memory.

Paste

(Edit Mode Only)

Inserts the currently stored data from the Copy command into the job file.

Delete

Deletes the currently selected data. Deleting annotation data removes it from the entire 
job. Deleting data in Import Mode does not modify the original CAD file.

Phases

(Not Available in Import Mode)

Edits or adds phases to a job and specifies which phase is currently active for data entry 
or editing. When the command is selected, the Phases dialog box is displayed.

Click Add to add a new phase. Enter the name. Check current for the phase to be en-
tered.  When all phases have been added or modified, click OK.
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Classes

(Not Available in Import Mode)

Edits or adds classes to a job and specifies which class is currently active for data entry 
or editing. When the command is selected, the Classes dialog box is displayed.

Click Add to add a new class. Enter the name. Check current for the class to be entered.  
When all phases have been added or modified, click OK.

Structures

(Not Available in Import Mode)

Adds, creates, imports, edits, and saves structures. When the command is selected, the 
Edit Structures dialog box is displayed.

Click Add to add a new structure. Enter the Class, Type, Name and Materials. When all 
structures have been added or modified, click OK. 
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Materials

(Not Available in Import Mode)

Adds, creates, imports, edits, and saves Materials. When the command is selected, the 
Edit Materials dialog box is displayed.

Click Add to add a new material. Enter the Type, Name and Multiplier and Unit. When all 
materials have been added or modified, click OK. 

Symbols

(Not Available in Import Mode)

Used to delete symbols from the current job and save symbols for use in other jobs. 
When the command is selected, the Edit Symbols dialog box is displayed.

Check the Master box for the symbols you want to use for every job. When all symbols 
have been selected, click OK. 



8-10

Materials Reference   

View Menu

The View Menu is used to adjust the display of visible data on the screen. The View 
Menu is not available in Report View Mode. Below is a list of the commands available 
from the View Menu in all other modes.

Hide

Hides the currently selected data line(s).

Hide All But

Hides everything but the currently selected data line(s).

Show All

Displays all hidden data.

Gray Hidden Lines

Displays hidden Annotation lines in Gray.

Plan View Scale

Displays the Edit Plan View Scale dialog window.

Enter the desire scale factor and click OK.

Elevation Scale

Not used in Materials. 
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Layer Selection

Used to select layers to be displayed during data entry. When the command is selected, 
the Layer Selection window is displayed.

Check only the layers required for completing the materials takeoff. When all layers have 
been selected, click OK.
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Display Menu

The Display Menu is used to adjust how data is displayed on the screen. A check next to 
a command indicates that it is enabled.  Below is a list of the commands available from 
the Display Menu in all other modes.

Overlay

Not used in Materials.

Terrain

Toggles the 3D view if Sitework data is in the file.

Image

Toggles the display of the image.

Darken Image

Displays the image in low resolution when checked. 

Show Annotation

Toggles on or off the display of annotation data.

Show Areas

Toggles on or off the display of Area structures.

Show Lengths

Toggles on or off the display of Length structures.

Show Counts

Toggles on or off the display of Count structures.

Plus Marks

Toggles on or off the display of plus marks over points on lines in the selected layer only.

Plus All

Toggles on or off the display of plus marks over points on all data lines.

Line Labels

Toggles on or off the display of line labels.

Point Labels

Toggles on or off the display of point labels.
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Utility Menu

The Utility Menu is used to change the job coordinates or scale, crop data, reassign 
phases and classes and manage the image cache. The Utility Menu is available in Edit 
and Entry Modes only. The Utility Menu also contain commands on the toolbar. Below is 
a list of the commands available from the Utility Menu.

Transform Job

Translate North/East 

    Used to change the North/East coordinates of the job. This is useful when moving  
    a job file into field or CAD file coordinates. When the command is selected, the      
    Transformation Selection dialog box is displayed.

     Check Whole Job if you are moving the entire project to a new coordinate system.   
     Click OK.

     Select a point with a known North/East coordinate. The Translate North/East dialog  
     box will display.

 Enter the correct North/East coordinates in the To fields. Do not change the elevation  
 or the job elevations will be changed. Click OK. The Translating site dialog box will  
 display.

  The distance the job has been moved will be displayed.  Click OK. The job is now in  
 the new coordinate system, however you must check to see if the alignment is  
 correct by checking a second known point. If the alignment is not correct, you will  
 need to use the Align Matching Edge command under the Transform Job menu.
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Align Matching Edges

    Used to change the North/East alignment of coordinates of the job. This is useful  
    when moving a job file into field or CAD file coordinates. You will need two points  
    with a known North/East coordinates. If the Translate North/East command was  
    used, you may enter a Benchmark at the second known coordinate. When the    ` 
    command is selected, the Transformation Selection dialog box is displayed.

     Check Whole Job if you are aligning the entire project to a new coordinate system.   
     Click OK.

     First, select the point that will be moved to the new location. If the Translate North/ 
 East command was used, select the point used for the translation.. The Alignment  
 Point 1 of 4 dialog box will display. Click OK.

 Second, select a point with a known North/East coordinate.  If the Translate North/ 
 East command was used, select the same point used for Alignment Point 1. The  
 Alignment Point 2 of 4 dialog box will display. Click OK.
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 Third, select the second point that will be moved to the new location. The Alignment  
 Point 3 of 4 dialog box will display. Click OK.

 Fourth, select the point with the correct North/East coordinate. This point may be  
 a benchmark added at the correct location. The Alignment Point 4 of 4 dialog box  
 will display. Click OK.

 The Aligning Site dialog box will display. Click OK.

 The Alignment is complete.
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Stretch Site

    Used to change the scale of the job file. When the command is selected, the   
    Transformation Selection dialog box is displayed.

     Check Whole Job if you are stretching the entire project. Click OK.

     Select any point in the job file. The Stretch Point 1 of 3 dialog box will display.      
 Keep the check int he box to Enter Scale Values Directly Click OK.

     The Rescale Job dialog box will display .Enter the incorrect scale in the Old Scale  
 field and enter the correct scale in the New Scale field. Click OK.

     The Stretching Site dialog box will display showing the scale factor. Click OK.

     The job will now be at the correct scale.
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Check Job Scale

    Used to change the scale of the job file. When the command is selected, you will get  
    a cross-hairs. Enter two points with a known distance. The Override Entered Value  
    dialog box will display.

     If the Measured distance is incorrect, enter the correct distance in the Actual field.   
 Click OK. The job will now be at the correct scale. 

State Plane Lookup

    Used to move a job file to State Plane Coordinates. You must first enter two   
    benchmarks with Latitude and Longitude. This information may be found on the plans  
    or may provided by the engineer.
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     Select one of the Benchmarks containing Latitude and Longitude information before  
 selecting the State Plane Lookup command. The State Plane Lookup dialog box will  
 display.

     Click the Lookup button.  The State Plane Coordinate Zone and Northing and Easting  
 coordinates will display. Click Move to move the job to state plane coordinates.

     Click Yes to move the job to state plane coordinates.

Map Projection Settings

    Used to geo-reference files that are in state plane coordinates.  When the command  
    is selected the Map Projection Settings dialog box is displayed.

     Select the State Plane Coordinate Zone from the pulldown list.  Click Set. Two  
 Benchmarks will be added to the file with Latitude/Longitude.
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Crop Rectangle

Used to remove unwanted data by drawing a frame around the desired data and then 
cropping the data outside the frame. 

Click Yes to remove all Annotation data outside the bounding rectangle. This will only 
remove Annotation.

Enter Phase Region

Enters a Phase Region on the job. When the command is selected, the Enter Phase  
Region dialog box displays.

Click Add to add a new phase or select the phase from the list.  Click OK.
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Enter a line around the desired area to be phased. All structures inside this area will be in 
the new phase. Right click to end.

A message dialog box will display.

Click Yes to continue transferring the data to the new phase.

To view the structures in the new phase only, double-click on the phase from the list at 
the bottom of the screen.
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Reassign Class

Used to reassign a structure to a new or existing class. Select the structure or structures 
you want to reassign. When the command is selected, the Assign to Different Class 
dialog box displays.

Click Add to add a new class or select the desired class from the list. Click OK.

Reassign Phase

Used to reassign a structure to a new or existing phase. Select the structure or struc-
tures you want to reassign. When the command is selected, the Assign to Different 
Phase dialog box displays.

Click Add to add a new phase or select the desired phase from the list. Click OK.
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Manage Image Cache

Used to manage the temporary image cache.  When the command is selected, the Tem-
porary Image Cache dialog box displays.

Enter the number of days before deleting the temporary files or enter the maximum 
cache size. Click Clear to clear all temporary images. Click OK.

Offset Line

Used to set the offset for selected Areas and Lines. When the command is selected, the 
Offset Line Editor dialog box is displayed.

Select the desired side for the offset line. Enter the desired offset distance.  Labels may 
be added to the offset line. Click OK.
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Bridge Gap (Join)

Used to connect annotation line segments as one line. Select the segments to join, then 
select the Join command. When the command is selected, the Edit Bridge Gap Distance  
dialog box is displayed.

Keep the Horizontal distance .1 and the Vertical 0. Click OK.

Swap Ends

Used to reverse the direction of the selected lines. 

Trim Line

Used to break lengths and areas on the selected line. 

Apply Structures

Used to apply area structure to your sitework takeoff Sectional Areas or Stripping   
Regions.

Select the desired structures to be used. Verify the section depth is correct. Click OK.
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Options Menu

The Options Menu is used to set certain preferences, such as sound, graphics, snap, and 
undo levels. Changes remain in effect for future sessions. Below is a list of commands 
available from the Options Menu in all Modes.

AutoSave

Allows the user to enable/disable the AutoSave function and change the interval be-
tween saves. When selected, the AutoSave dialog box is displayed.

Enable Sound

Allows the user to choose sound preference. A check next to the option indicates sound 
is enabled.

Max Undo Levels

Allows the user to set the number of undo levels. The maximum number of levels is 10.

Snap Size

Allows the user to edit the snap size. This option may vary depending on screen resolu-
tion.  Check the box to Draw Snap Circle to see the circle when Snap is enabled.



 Materials Reference 

8-25

Bridge Gap Distance

Allows the user to edit the Bridge Gap Distance used when using the Join Command. 
The Horizontal is the distance between the points. The Vertical is the elevation   
difference.

Sticky Zoom

When checked, the program will zoom into the selected point.

Auto Plus Marks

When checked, the program will display the Plus Marks when zooming in.

Classes/Phases as Strings

When checked, the Classes and Phases will display the name of the class and phase 
on the reports.  When unchecked, the class and phase number will be displayed on the 
reports.

Rotated Text

When checked, the text from a CAD file will be displayed in its original orientation from 
the CAD file.

Window Menu

The Window Menu is used to set some window view preferences. The Window Menu 
may also be used to switch between mode. Below is a list of commands available from 
the Window Menu.

High/Low Contrast

Allows the user to edit the contrast of the screen background. When High contrast 
is displayed, the screen has a dark background. When Low Contrast is displayed, the 
screen has a white background. This is typically used for viewing the data outdoors. 

Area Zoom

Allows the user to draw a window around a specific area to increase the zoom levels. 
Press the Home key on the keyboard or on the toolbar to reset the area zoom.
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Show Report View

When checked, the Reports will be displayed on the left side of the screen. 

Float/Dock Report View

When Float is selected, you may move the Report view to a different location. When 
Dock is selected, the Report view will be docked to the side of the screen.

1 Import Mode

When selected, switches the program to Import Mode. 

2 Material Edit Mode

When selected, switches the program to Materials Edit Mode. 

3 Material Entry Mode

When selected, switches the program to Materials Entry Mode. 

4 Print Preview

When selected, switches the program to the Print Preview. 

Help Menu

The Help Menu displays job and software version information. Below is a list of com-
mands available from the Help Menu.

Gradework 4D Help

Launches the Gradework/Materials Help system.

Hot Key Help

Launches the Hot Key Help options. You may print a list of the hot keys from this menu.

Job Info

Displays the Job Information window.
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File Info

Displays information about the job file, including the job min/max coordinates, number of 

lines and points.

OpenGL Info

Displays Graphic card and OpenGL information about your computer.

Visit AGTEK Online

Launches your internet browser and goes to www.agtek.com. 

About Gradework 4D

Displays the current version and date of the software.

Check for Update

Checks the AGTEK website for updates. 

Revision History

Displays the revision history of all the updates to the software.
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Guide Menu

The Guide Menu displays the user entry guides for using CAD files, vector PDF and  
raster PDF files.

CAD Guide

Displays the CAD Guide to step you through the takeoff process when using a CAD file.

Vector PDF Guide

Displays the Vector PDF Guide to step you through the takeoff process when using a 
Vector PDF file.

Entry PDF Guide

Displays the Entry PDF Guide to step you through the takeoff process when using a  
raster PDF file.
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Material Classes

Material structures may be entered by various classes of construction. When creating a 
new structure, you may select the class. On new installations, all structures are in the 
default 2D class. This class may be used for all area, length and count structures. User 
defined classes may be added.

Add Classes

1. To add a new class select Edit>Classes.

2. Click the Add button.

3. Enter the name of the new class. Repeat this process until all classes have been  
added. Click OK.

4. When adding a new structure select the Class pulldown and select the desired class. 
You may enter the structures by class, or you may assign the class after the takeoff 
has been completed. 
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Reassign Class

1. To assign classes after the takeoff has been completed, you may add the classes as 
described in the previous section, or you may add the class when reassigning the 
structures.

2. Select the desired structures. You may select the structure from the plan view or the 
report. 

3. Select Utility>Reassign Class. Click Add to add a new class or check the desired 
class from the list.  Click OK.

4. The structure will be assigned to the new class.
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2.  To view the report for a specific class, select the Class pulldown and check the  
desired class. The report will show structures for the selected class or classes.

Reports by Class

1. After the takeoff is complete, you may view the reports by class.  To view all   
classes, select the Class pulldown at the bottom of the screen and make sure All 

Classes is checked.
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Material Phases

Material structures may be entered by phase of construction. Phases may represent 
different stages of the project, or they may be used to break a complete material takeoff 
into multiple phases for bidding purposes.

Add Phases

1. To add a new phase select Edit>Phases.

2. Click the Add button.

3. Enter the name of the new class. Repeat this process until all phases have been  
added. Click OK.

4. You may enter the structures by phase, or you may assign the phase after the take-
off has been completed. To enter the structure by phase, select the phase pulldown 
and double-click on the desired phase. This will be the current phase. All new entries 
will be in this phase.
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Reassign Phase

1. To assign phases after the takeoff has been completed, you may add the phases as 
described in the previous section, or you may add the phase when reassigning the 
structures.

2. Select the desired structures. You may select the structure from the plan view or the 
report. 

3. Select Utility>Reassign Phase. Click Add to add a new class or check the desired 
phase from the list.  Click OK.

4. The structure will be assigned to the new phase.
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2.  To view the report for a specific class, select the Phase pulldown and check the  
desired phase. The report will show structures for the selected phase or phases.

Reports by Phase

1. After the takeoff is complete, you may view the reports by phase.  To view all  
phases, select the Phase pulldown at the bottom of the screen and make sure All 

Phases is checked.
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Phase Region

The Phase Region command may be used to break a complete material takeoff into   
multiple phases for bidding purposes.  

1. Before you use the Phase Region command, it is recommended to save the complete  
takeoff as a different name before you enter the phase region to preserve the original  
data.

2. Select Utility>Enter Phase Region. Click Add to add a new class or check the de-
sired phase from the list.  Click OK.
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3. Enter a line around the desired area.  All structures inside the phase region line will 
be in the new phase. Right click to end the phase region.

4. Click Yes to continue the data transfer to the new phase.

5.  To view the report for the new phase only, select the Phase pulldown and dou-
ble-click on the new phase.


