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Sitework 4D Field Use Tutorial

Field Use Overview
RTK GPS support is an additional feature in Sitework 4D, which must be purchased separately. In addition to creating takeoffs from grading plans, Sitework 4D can be used to
capture field data using GPS to manage, update, and correct the 3D model in the office.

Data Collection Tutorials
Sitework 4D is used for GPS data entry/collection on a job site. The following are the
tasks and applications for using Sitework 4D in the field.

Instrument Setup
•
•

GPS Base Setup
Aligning the Site/Rover Setup

Checking Existing Ground
Progress Topoing

Lesson Examples
This part of the tutorial uses lesson files located in the C:\AGTEK\Data directory.
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Lesson 1 – Instrument Setup
Before you begin collecting GPS data on a job site, you must perform GPS Base Setup to
localize the Base on the job site. In addition, each time you use Sitework 4D to collect
GPS data at a job site, you must align to the site using the Rover, or recover the alignment.

GPS Base Setup
Once the Bluetooth connections are established between the computer and the Base,
you must setup the Base to verify it is receiving GPS data and localize it to the job site.
Make sure the job site location for the Base has the following:
•

A clear view of the horizon

•

No nearby obstructions (buildings, trees, etc.)

•

A secure and protected location

•

Within 1000 feet of benchmark #1

•

Within radio range of benchmark #2

•

Away from sources of radio interference (cell, microwave towers, etc.)

To setup the Base:
1. Position the Base on the job site location.
2. Double-click the GPS Base Setup Icon on your desktop or select Start>All
Programs>AGTEK>GPS Base Setup. The AGTEK GPS Base Initialization dialog box
is displayed.

3. Select the type of GPS receiver you are using (Topcon, Trimble) from the pulldown
menu.
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4. Click the Port Settings button to verify that the Port is set to the COM port you selected for the Base during Bluetooth setup (typically COM8).
5. Click the SETUP BASE from GPS button. The Base takes shots for 5 minutes to ensure an accurate reading.
To use the
position file in
the future, the
Base must be
in the same
location with
the same
rod height as
when the file
was saved.

6. Save the position file for future use on the job site.
7. Click Done to complete Base setup.

Aligning to the Site/Rover Setup
The Rover is the GPS receiver that moves around the job site. Rovers can be pole, backpack, or vehicle mounted. Before you can collect data for the job site, you must align to
the site using the Rover.
1. Double-click the Sitework 4D icon or select Start>Programs>AGTEK>
Sitework 4D. The Open dialog box is displays.

2. Select the model file, and click Open. The job site is opened in Edit Mode.
3. Switch to 3D View Mode, then select Instrument>GPS>Enable. Your screen should
appear similar to the following illustration.

Bullseye Button

North Arrow Button
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If you have
already
aligned to
the job site,
you can click
the Recovery
button to use
the previous
alignment
data.

4. Select the benchmark on the screen you plan on shooting first, move to the point,
level the Rover over the point, then click the Bullseye button. Benchmark 1 is shot.
5. Select the benchmark on the screen you plan on shooting second, move to the point,
level the Rover over the point, then click the North Arrow button. Benchmark 2 is
shot and the RTK Deviation Confirmation displays the deviation between the theoretical distance of the Benchmarks and the actual measured distance.

6. Click Accept to complete the alignment, or Retry to reshoot the second benchmark.
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Lesson 2 – Checking Job Site Data
Once you have run a GPS Base Setup and aligned to the site, you can use Sitework 4D
to manage your 3D model with actual job site data, including checking and correcting
existing ground, progress topoing, and grade checking.
Although Sitework 4D can be used to gather job site data, most of the functions associated with data capture (topoing, staking, grading, area/stockpile measurement, etc.) are
performed using a GradePilot RTK unit. Refer to your GradePilot manual for information
about using the GradePilot RTK unit.

Checking Existing Ground (Simulation)
In this example the grades on the site begin to deviate substantially from the ground
model and there appears to be a mound on the surface near the base of the slope. These
deviations must be shot and recorded in order to update our current surface.
1. Double-click the Sitework 4D icon or select Start>Programs>AGTEK>
Sitework 4D. The Open dialog box is displayed.

2. Select the “Stanley Court Demo.esw” file, and click Open.
3. Switch to 3D Mode, then select Instrument>GPS>Configure. The GPS Configuration dialog box is displayed.

4. Select Simulator from the GPS Type pulldown menu, and click the Change File button. The Open dialog box is displayed.
5. Select the “sim_checkOG.agt” file, click OK, clear the repeat checkbox, then click
OK in the GPS Configuration dialog box
6. Click the Enable GPS button, or select Instrument>GPS>Enable. In the field, once
you select the Enable command you must align the model to the site with the Rover
to begin receiving actual GPS data from the Rover. In simulate mode Alignment is
not necessary.
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7. Select “Existing” from the Ref pulldown menu to check actual topo data against the
data currently in the model. Your screen should look similar to the illustration below.

In the field
you would
move the
Rover to an
area outside
the deviations
before clicking
the Record
Off button
instead
of using
simulated
shots.

8. Click the Record Off button so that it reads Record On, then click the Start button
to begin checking the topo. Notice that the shots detailing the area go out until they
closely match the Ref surface. This makes sure that survey data ties into the existing
topo and reflects any volume on the edges.
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Notice that the 3D Controls window reports the cut/fill value between the actual
(survey) and theoretical (reference) as shots are being taken. The Elev box displays
the elevation or the Reference (Ref) surface at the Rover position. The Northing and
Easting boxes show the Northing and Easting coordinates for the location using GPS
data. Also notice that the survey elevation is displayed as the “Z” value at the bottom
of the screen.
9. After all of the shots are taken, click the Stop button. When the simulation stops, the
check is complete and we can view and quantify the difference between the shots
and the existing topo. Your screen should look similar to the following illustration.
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Correcting the Topo
Once you’ve collected the new survey data, you can use it to update the model so it
contains accurate data based on job site data.
1. Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.

2. Select Stage, then click OK. The Current Layers Background dialog box is displayed.

3. Select Existing, and click OK to create the Current Surface with the survey data
staged into the Existing Surface. The survey data is shown on the screen.
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4. Right-click, then select Survey Boundary to draw a boundary around the survey data.
The Current Surface is displayed with the existing ground and survey data and the
Apply Survey Data dialog box is displayed.

5. Click the Stage Data button. The Current surface now contains the Existing surface
data plus the new survey data.
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Calculating the Survey Volume
Once you’ve created the Current surface, you can compare it to the Existing surface to
calculate the survey volume difference.
1. Click the Survey Volume Calc button. The survey data is shown on the screen.

2. Right-click, then select Finished to use the existing survey boundary. After calculation, the Volume Calculation Results dialog box is displayed.

3. Click the Done button and the Survey Volume Report is displayed.
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Typically you would save the file at this point. Since this is a sample file that will be
used in other examples, do not save the file.

Progress Topoing
In this example, the street and top two pads will be surveyed to check the work progress in those areas.
1. Double-click the Sitework 4D icon or select Start>Programs>AGTEK>
Sitework 4D. The Open dialog box is displayed.

2. Select the “Stanley Court Demo.esw” file, and click Open.
3. Select File>Save As. The Save As dialog box displays. Add today’s date to the file
name (i.e. “Stanley Court DemoJune062010.esw”), and click the Save button.
4. Switch to 3D Mode, then select Instrument>GPS>Configure. The GPS Configuration Dialog box is displayed.

5. Select Simulator from the GPS Type pulldown menu, and click the Change File button. The Open dialog box is displayed.
6. Select the “sim_progtopo.agt” file, click OK, clear the repeat box, then click OK in
the GPS Configuration dialog box.
7. Click the Enable GPS button or select Instrument>GPS>Enable. In the field, once
you select the Enable command you must align the model to the site with the Rover
to begin receiving actual GPS data from the Rover. In simulate mode Alignment is
not necessary.
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8. Select Existing from the Ref pulldown menu to check actual topo data against the
data currently in the model. Your screen should look similar to the illustration below.

In the field
you would
move the
Rover to the
area to topo
before clicking
the Record
Off button.
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9. Click the Record Off buttons so that it reads Record On, then click the Start button
to begin the progress check. Notice that the cut/fill differences are small at the edge
of the work area and get larger as the simulation reaches the street and the pads.
10. After all of the shots are taken, click the Stop button. When the simulation stops,
the check is complete and we can view and quantify the difference between the
survey and the existing topo. Your screen should look similar to the following illustration.
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Saving the Progress Topo Data
Once you’ve collected the new survey data, you can save it for comparison to the master file for the job site.
Because this is an irregular shaped survey and you want to get an accurate volume calculation, you need to snap a boundary around data rather than using the Survey Boundary command.
1.

Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.

2. Select Stage, then click OK. The Current Layers background dialog box is displayed.

3. Select Existing, and click OK to create the Current Surface with the Existing Surface
as the background and the survey data staged into it. The survey data is shown on
the screen.
4. Make sure Snap is enabled (press the S key to turn snap on if it is not already), then
zoom in, and double-click the first point of the survey near the street on the left side
of the job.
5. Move to the right end of the survey data, and click the point at the top of the curve.
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6. Double-click the end point of the next curve above. Your screen should look similar
to the illustration below.

7. Click on the corner point at the top left of the street.
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8. Continue clicking and double-clicking until the outside edge of the survey has been
selected. Your screen should look similar to the illustration below.

9. Right-click, and select Finished. The survey data is shown with the Apply Survey
Data dialog box.
10. Click the Stage Data button. The Current surface now contains the Existing surface
data plus the new survey data. Click the Home button to see the entire job site.
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Calculating the Survey Volume
Once you’ve created the Current surface, you can compare it to the Existing surface to
calculate the survey volume difference.
1. Click the Survey Volume Calc button. The survey data is shown on the screen.

2. Right-click, then select Finished to use the existing survey boundary. After calculation, the Volume Calculation Results dialog box displays.

3. Click the Done button and the Survey Volume Report is displays.
4. Save the file.
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Lesson 3 – Field Supervision
If you use Sitework 4D in the field to collect data, you can export it from the field file,
then import the survey data in to the master file.

Collect the Data
1. Open the job file that contains the reference surface or start a new file.
2. Switch to 3D View mode and collect data in the field.
3. Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.
4. Select Replace (Copy) and click OK. The Current surface is created with the survey
data.
5. Select File>Save As, and save the file as an AGT file.
6. (Optional) Save the file as an ESW file for reference. Make sure to change the name
of the file so the original file is not overwritten.

Apply the Survey Data
1. Open the master file in Sitework 4D.
2. Select File>Import. The Import dialog box is displayed.
3. Select the AGT file that was created with the survey data in it, and click Open. The
Survey data is opened in CAD Transfer mode.
4. Select the survey data, select “Current” from the Surface pulldown, “Survey Data”
from the Layer pulldown, then click the Send To button. The data is transferred to
the Current surface.
5. Switch to 3D Mode and select Edit>Apply Survey. The Survey Into Current dialog
box is displayed
If the topo
data is
symmetrical,
right-click and
select Survey
Boundary to
auto-create
the boundary,
then rightclick and
select
Finished.

6. Select Stage (Edit), then click OK. The Current Layers Background dialog box is displayed.
7. Select Existing and click OK to create the Current Surface with the Existing Surface
as the ground and the survey data staged into it. The survey data is shown on the
screen.
8. Enter a survey boundary around the updated topo data. Right-click at the start of the
boundary, then select Finished to complete the boundary.
9. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer
now contains the Existing layer data plus the new topo data.
10. Select Current from the Ref pulldown and Existing from the Diff pulldown. This compares the Existing surface with the Current surface to calculate the volume difference between the two surface.
11. Click the Survey Volume Calc button. After calculation, the Volume Calculation Results dialog box is displayed.
12. Click the Done button, and the Volume Report displays.
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Applying Survey Data Collected in GradePilot RTK
If you use a GradePilot RTK unit in the field to collect data, you can import the survey
data directly from the unit to the master file.

Apply the Survey Data
1. Open the master file in Sitework 4D.
2. Connect the GradePilot to the computer via a USB port, then select File>PlanPilot
Import. The Open dialog box is displayed.
3. Select the file that was used to collect the data, and click Open. The Survey data is
opened in CAD Transfer mode.
4. Click the Send To button. The data is transferred to the Current surface.
5. Switch to 3D Mode, and select Utility>Apply Survey. The Survey Into Current dialog
box is displayed

If the topo
data is
symmetrical,
right-click and
select Survey
Boundary to
auto-create
the boundary,
then rightclick and
select
Finished.

6. Select Stage (Edit), then click OK. The Current Layers Background dialog box is displayed.
7. Select Existing, and click OK to create the Current Surface with the Existing Surface
as the ground and the survey data staged into it. The survey data is shown on the
screen.
8. Enter a survey boundary around the updated topo data. Right-click at the start of the
boundary, then select Finished to complete the boundary.
9. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer
now contains the Existing layer data plus the new topo data.
10. Select Current from the Ref pulldown and Existing from the Diff pulldown. This compares the Current surface with the Existing surface to calculate the volume difference between the two surfaces.
11. Click the Survey Volume Calc button. After calculation, the Volume Calculation
Results dialog box is displayed.
12. Click the Done button, and the Volume Report is displayed.
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Stake Checking
Make sure you have setup Bluetooth connections and run GPS Base Setup before stake
checking. Refer to “GPS Base Setup” in “Lesson 1 - Instrument Setup” on page 6-2 for
information.
1. Open the model file that contains the stake data to check.
2. Align to the site using the Rover. Refer to “Aligning to the Site/Rover Setup” on page
6-3 for information.
3. Select a stake point to check in the job file.
4. Move the Rover to the point on the site and level the Rover. The Offset tab of the 3D
Controls window displays the horizontal and vertical difference and the slope from the
picked point to the Rover

5. Verify the information displayed in Sitework 4D matches the cut/fill and elevation
data on the stake at the job site.
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