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AGTEK Software License Agreement
PLEASE READ CAREFULLY. BY USING THIS PRODUCT, YOU ARE CONSENTING TO BE
BOUND BY THIS AGREEMENT.
Copyright

The AGTEK software package, on CD or in electronic form, together with associated
documentation, is protected under copyright. The buyer may make copies for the buyer’s
internal use only. The buyer agrees not to reverse engineer or otherwise seek to discover
the source code, or to modify or create derivative works from this software.

Single License

AGTEK grants to the buyer a non-exclusive, single license to load and use the AGTEK
software on one or more computers operated by the buyer, provided that use by the
buyer shall not be on more than one computer at a time. The buyer agrees not to rent,
loan or otherwise temporarily transfer this software for use on computers not operated by
the buyer.

Access Key

Access key. The AGTEK software is enabled by means of an access key that must be
present on the computer when the software is running. The access key may be a key
code checked-out from the Internet or a physical device that plugs into a computer port.

Export

AGTEK software includes cryptography that is not user-accessible, specifically designed
to allow execution of copy-protected software. Accordingly, this software is controlled
under ECCN EAR99 of the Export Administration Regulations (NLR, no export license
required). The buyer agrees to comply with all applicable regulations and prohibitions with
regard to export or re-export to sanctioned countries or individuals.

Limitations of
Warranty and
Liability

Limitations of warranty and liability. AGTEK software is licensed “as is” and with all
faults. AGTEK Development Company, Inc. and its Representatives make no warranties,
either expressed or implied, with respect to AGTEK software, its quality, performance,
merchantability, or fitness for any particular use. In no event will AGTEK Development
Company, Inc. or its Representatives be liable for direct, indirect, incidental or consequential damages resulting from any defect in AGTEK software, even if AGTEK Development
Company, Inc. has been advised of the possibilities of such damages.
Copyright© 2011 AGTEK Development Company, Inc.

Trademark
Credits

Windows XP® , Windows Vista® and Windows® 7 are registered trademarks of
Microsoft Corp. Google Earth™ is a trademark of Google. AutoCAD®, CAiCE™, DWG™,
DXF™ are trademarks of Autodesk, Inc. GEOPAK, MicroStation, GPK and DGN are trademarks of Bentley Systems, Inc
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Materials 4D Installation

There are two parts to installing Materials 4D; the program software installation, setting
up the digitizer, and software protection key installation. Installation must be performed
in the following order to ensure proper functioning of the software:
1. Materials 4D Software Installation
2. USB/Internet Key Installation

Materials 4D Software Installation
1. Launch your internet browser, most likely Internet Explorer, and go to www.agtek.
com/software.asp.
2. Click the link on the left hand side of the screen for Materials 4D.
3. Enter your AGTEK UserID/Login and Password, then click Login.
4. Click the Download link, and choose Save.
5. Save the download somewhere easy to find, such as your desktop.
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Software Installation Sequence

Materials 4D Installation

Installation from an Internet Download
1. Find the downloaded installation file and double-click the icon.
2. Click Next in the Welcome Dialog.
3. Click Next in the Choose Destination Location dialog box.

4. Select the Allow Internet Key check box, then click Next and the Setup Complete
box is displayed.
5. Click Finish to complete the installation.

Internet Key Setup - Users
An Internet Key allows multiple users access to a common Materials 4D license. Users
are added by the Internet Key’s administrator. To use Materials 4D with an Internet Key,
you must be entered as a user by the key administrator. To check out an Internet Key,
you need the email address and password associated with your user name. The first time
you open the software, you will be asked to enter a password and then confirm it. This
will become your permanent password.

Using an Internet Key
•

Obtain and Install the Current Version of the Materials 4D software

•

Launch the Software Using an Internet Key

Launching the Program
For instructions on obtaining and installing a current version of the software, see page
1-1.
1. Double-click the Materials 4D icon on your desktop.
2. If no USB key is found in the system, the Internet Key box is displayed. Click Yes.
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3. Enter you E-mail address and password..If this is your first time using the software,
Create a password that can be easlly remembered, and click OK.

4. The first time you use the software, you will also be asked to confirm your password. Enter your password again and click OK.

5. Choose an available Internet Key from the list and click OK. If no Internet Key is
available you will be unable to use the program until one becomes available.

6. When closing Materials 4D, the Internet Key dialog box displays and asks if you want
to release the Internet Key. If you choose not to release the Internet Key, it automatically releases after the time period set by your key administrator has expired.
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Internet Key Administration
An Internet Key allows multiple users access to a common Earthwork 4D software
license. Users are created by the Internet Key’s administrator. As an Internet Key administrator you have the ability to add and/or delete users, assign different users to
each key, and set the number of days an Internet Key can remain checked out. As the
administrator, a user name is created for you when your software order is processed
by AGTEK. You need the email address associated with your user name to launch the
AGTEK Software, and to manage users. The password used to login for the first time is
your permanent password.

Using a Internet Key
•

Launch Software Using an Internet Key

•

Manage user accounts

Launch Software Using an Internet Key
1. Double-click the Earthwork 4D Software icon on your desktop.
2. If no USB key is found in the system, the Internet Key box is displayed. Click Yes

3. Enter the email address and password associated with your user name, and click
OK.
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As Internet Key administrator you have the ability to create, modify, delete users and
set the offline check-out period. To create a user you need the following information for
each user: first and last name, email address and phone number. You also have the ability to allow administrator access for other users.

Creating a User
1. Follow steps 1 through 3 in the Launching Software section and the Internet Key
Selection dialog box is displayed.
2. Select the User Admin tab and click the Add User button.

3. The Add User dialog box displays.

4. Enter the requested information. If the user is to be an Internet Key administrator,
select the Internet Key Administrator check box.
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Manage Users

Materials 4D Installation

5. Click OK and the list of all company keys will display

6. Select the programs you wish to assign to the new user. They may be assigned to
multiple keys.
7. When the new user logs into the program for the first time they will set their own
password.

Deleting a User
1. Follow steps 1 through 3 in the Launching Software section and the Internet Key
Selection dialog box is displayed.
2. Select the User Admin tab and select the user you wish to remove.
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3. Click Delete User and then Yes to permanently remove the user, or No to cancel the
operation.

Right-click Menus
Under the User Admin tab of the Internet Key Selection dialog box you can perform the
following operations by right-clicking on a user: Allow or Remove Admin, Reset Password, Cancel.
Allow or Remove Admin:

Changes the Administrator status of a user.

Reset Password:

Allows the user’s password to be reset by a Internet Key
administraton.

Cancel

Cancels the operation.
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Assigning Users to a Key
As an Admistrator, you may assign different users to each key purchased by your company. There are two ways to assign users to a key
1. Follow steps 1 through 3 in the Launching Software section and the Internet Key
Selection dialog box is displayed.
2. Select the key you wish to assign to the user.
3. Click the Users button at the bottom.

4. Click in the Assigned field to toggle the user on and off. There may be up to 10 users per key.
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5. You may also assign users from the User Admin window.
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6. Select the user from the list and click the Keys button at the bottom.

7. Click the Assigned field for the keys you wish to assign to this user.
8. Click OK.
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Setting Offline Check-out Period
The Offline Check-out Period defines the number of days a user can keep a key checked
out. Once this time period has expired, the key is be checked in automatically. The
default check-out period is three days. There are two ways to set the offline Check-out
period.
1. Follow steps 1 through 3 in the Launching Software section and the Internet Key
Selection dialog box is displayed.
2. Select the desired key and click the Users button.

3. Enter the number of days you wish to allow a user to check out a key.
4. Click OK.
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5. You may also set the Offline Check-out time from the Internet Key Admin window.

6. Select the desired key from the list.
7. Click the Users button.

8. Enter the number of days you wish to allow a user to check out a key.
9. Click OK.
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USB Protection Key Installation
Materials 4D uses either an Internet Key or a USB protection key and will not run if a key
is not available. If using a USB key, install Materials 4D first, then use the diagram below
to install the USB key before starting AGTEK software .
Do not force the key into a port. If it does not fit, make sure it is right side up and try
again. Only one USB key should be installed on a computer.

USB Port

USB Protection key
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Materials 4D Overview
With Materials 4D you can create material takeoffs from precise computer-generated
CAD files, AGTEK ESW files, or printed plan sheets. When you enter data such as areas,
lengths, and counts, Materials 4D can generate reports detailing such information for the
placement of materials, structures, and quantities on a job.

Document Conventions
This tutorial uses standard software documentation conventions to explain how the software works. These conventions are described below.
Click/click on - Press the left mouse button (assuming the buttons are set to the default
settings).



Double-click - Press the left mouse button twice in rapid succession.
Right-click - Press the right mouse button.
Click and hold - Press and hold down the left mouse button.
Shift/Ctrl+click - Press and hold down the Shift/Ctrl key then press the left mouse button.
Click and drag - Press and hold the left mouse button, then move the mouse.
Ctrl+(Key) - Press the Ctrl key then press the keyboard key noted in the step.
Press - Press a specified key on the keyboard.
Select - Use the mouse to pick an item on the screen or menu command.
Menu Commands - When documenting a menu command, the command is described using the following format: Menu>Command. If there is more than one level to the menu,
it appears as a Submenu. For example, Options>Sound Preference>Sound Card.
Data Entry/File Names - If a file is specified in a procedure, or if specific text needs to be
entered into a field as part of a procedure, it will appear inside double quote marks.
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Keyboard, and Mouse Interface
Materials 4D relies on the standard center-roller-button mouse for entry, and the keyboard
for alphanumeric entry and keyboard shortcuts.

Keyboard
To effectively use Materials 4D you will use the mouse, and the keyboard. Most Materials
4D tasks are available on menus and the Materials 4D toolbar at the top of the screen, but
the tasks can also be accessed much faster through keyboard shortcuts. Keyboard shortcuts are listed in the Reference Section of this manual and are mentioned in the Tutorial
Section where appropriate.

The Mouse
A two-button wheel mouse is used for non-digitized entry. Below is a description of the
buttons and their function.
Wheel Button
Left Button
Right Button

The Left button is used to select objects and choose menu items.
The Right button is used to display the Right Mouse Menu. This menu displays quick access to specific commands.
The Wheel Button allows the user to zoom in or out over the location of the cursor by
rolling the wheel Up or Down respectively. Holding the button down and moving the
mouse allows the user to pan the view on the screen.
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Data Entry Sequence
Below is the suggested data entry sequence for Materials 4D.

Scale the Plan Sheet
•
•

Start a New Job
Enable the Tablet and Scale the Sheet

Create Above Ground Structures and Materials
•
•
•

Create Lengths
Create Areas
Create Counts



Generate and Print Materials Reports
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Lesson 1 - Importing and Scaling the PDF
Materials 4D uses a variety of data sources including PDF plan sheets, CAD files, and
Sitework 4D files for use in completing materials takeoffs. This tutorial uses the Montessor School PDF.pdf file.

Launch the Program
Double-click the Materials 4D shortcut on the desktop and the Open dialog box displays.

1. Click New and the Job Information dialog box is displayed.

It is
imperative
that the
units are set
correctly
before you
begin your
takeoff

2. Enter “Montessori Materials” for the Job Name, set the Units to Feet, and click OK.
The Builder and Operator information are optional.

Import and Scale the PDF
1. Select File>Import and the Import dialog box is displayed.
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If necessary
you can rotate
the drawing
by using the
L and R keys
to rotate
the drawing
counterclockwise and
clockwise
respectively

2. Select “Montessori School PDF.pdf” and click Open. The image opens in the Data
Transfer mode.

3. Zoom in to the lower-right portion of the job and locate the scale bar. Notice the
scale of this job is 1:20. Press the Home key to zoom out and center the job.
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4. Select Data Transfer>Image Scale and the Edit Image Scale dialog box displays.

5. Enter “20” for the scale and click OK. A dialog box displays advising you to check
the scale of the drawing using a known distance. Click OK.
6. Click the Planview button to exit the CAD Transfer window.
7. Zoom into the scale bar on the lower right-right portion of the job.
8. Select Enter>Annotation.
9. Draw an annotation line across the width of the scale bar by positioning your cursor on the left side of the scale bar and click to enter a point. Drag the cursor to the
right side of the scale bar and click to enter a point. You Screen should appear similar to the illustration below.

10. In the status bar at the bottom of the screen you can see the distance is approximately 60 feet, which verifies the accuracy of the scale.
11. Right-click to end the entry. Right-click again and select Edit Mode.
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12. Press the Home key to zoom out and center the job. Your job should resemble the
illustration below.
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Lesson 2 - Entering Takeoff Data: Areas, Lengths and Counts
Materials 4D uses a list of structures composed of materials. Structures and materials
can be created for each job, or you can import a list from a previous job.

Structures
There are three types of above ground structures in Materials 4D: Areas, Lengths, and
Counts. Each structure uses a measurement, section, and multiplier to calculate materials.
Length

Length Measured X Section X Multiplier

Area

Area Measured X Section X Multiplier

Count

Points Entered X Section X Multiplier

Sections and Multipliers
Sections are the thicknesses of the materials. Lengths and Areas typically have sections
that are calculated based on the individual structure. Counts typically have a section of
1.
Multipliers are used to convert the unit of measure for Lengths, Areas, and Counts to the
specified job unit or to units of purchase. Lengths and Areas typically use multipliers that
are calculated based on the individual structure. The multiplier for Counts is typically 1.
For example, the Curb Length used in this tutorial has a multiplier to convert cubic feet
into cubic yards, and the Concrete Entrance Area has a multiplier to convert inches into
decimal feet. Below are examples of how to calculate sections and multipliers for the
Curb and Concrete Entrance used in this tutorial.

Calculating Length Sections and Multipliers
Material quantities for a Length structure are measured by Length x Section x Multiplier.

Curb Typical

To calculate the section of a Length, you must calculate the end area. The curb measures 6” X 14”, or 6/12 ft. X 14/12 ft. The end area, or Section, for the curb is
0.5 X 1.1667 = 0.5833 sq. ft.
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The multiplier for this Length is used to convert linear feet to cubic yards. A cubic yard is
27 cubic feet (a cubic foot is 1/27th of a cubic yard). To calculate the Multiplier,
divide 1 by 27. The result, 0.0370, is the Multiplier.

Calculating Area Sections and Multipliers

8 in/12 in = 0.67 ft.

8”

Concrete

4 in/12 in = 0.33 ft.

4”

AB Class II



Material quantities for an Area structure are measured by Area x Section x Multiplier. In
this example, the Concrete Entrance Area consists of two materials, 8” of Concrete and
4” of AB Class II so a section and multiplier must be calculated for each material.

To calculate the section for each material, you must calculate the depth in decimal feet.
Divide the depth of each layer by 12 to convert to decimal feet (calculating decimal feet
is done by dividing the measurement in inches by 12). The section for the concrete is
0.6667 ft. or 8 divided by 12. The AB Class II has a section of 0.33 ft. or 4 divided by
12.
For this example and tutorial, concrete is measured by the cubic yard, and AB Class II
materials are purchased by the ton, so both must be converted using a multiplier. We
have already calculated the multiplier for cubic yards (0.0370) for the concrete in the
previous example, but we need to calculate a multiplier to convert to tons per cubic foot.
Assuming one cubic foot of rock weighs 150 pounds, the multiplier is 0.075. See the
equation below for the calculation.
Note: Contact your supplier for actual material weights to calculate an actual multiplier.
150 LB/CF
2000 LB/CF = 0.075 TN/CF
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Entering a Length
1. Select Enter>Lengths and the Structures List dialog box is displayed.
The color can
be change by
clicking in the
Color column
and scrolling
through
available
colors. You
can doubleclick the color
to display the
color palette,
which will
allow you to
create custom
colors.

New
installations
have an
empty
structure list.
An existing
Structure
List can be
imported by
selecting
File>Import
Structure List,
selecting a list
and clicking
Open.
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2. Enter “Curb Straight” for the Structure Name, press Tab to skip to the Material section of the dialog box.
3. Enter “Concrete” for the Material name and press Tab to skip to the Section.
4. The Section area refers the end area of the Length, in this case Curb Straight. For
this entry we will assume the curb is “.5” (six inches) wide, by 1 (one foot) deep.
Enter “.5” (1’ X .5’ or L X W) for the Section and press Tab.
5. In this case the Multiplier is used to convert cubic feet to cubic yards. To find our
multiplier we divide 1 by 27 which equals .037037 (1/27 = .037037), the number
of cubic yards in a cubic foot. Enter “.037037” for the Multiplier.
6. Enter “CY” (Cubic Yards) for the Units. The entry is for labeling purposes and has no
bearing on the material quantities. Click OK.

Materials 4D Tutorial 1



7. Using your mouse, enter the Straight Curb along the entrance road leading to the
parking area. Position your cursor over the end of the curb line at the entrance of the
road. Click to begin entering the curb.You can pan across the PDF image, without
interrupting entry, by pressing on the wheel of your mouse and dragging the image.

8. Move along the curb line, clicking as you go, to enter the curb. The more points used
on curves, the smoother and more accurate your entry will be. Straight sections only
require two points.
9. Continue entry along the curb, until you come to where the curb and gutter begins
(this will be a different structure.) Right-click to end the entry.
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10. Repeat the process until all straight curb is entered. When complete, your screen
should resemble the entry below.

11. Right-click and select New Length.
12. Enter “Curb & Gutter” for Structure Name, “1.25” for the Section, change the color
to green , and click OK.
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13. Enter the curb and gutter where required. When completed, your screen should resemble the illustration below.

14. Right-click and select Edit Mode.
15. Click the Save button to save your file.
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Entering an Area
1. Select Enter>Area and the Structures dialog box is displayed.

2. Enter “Paving HD” for the name.
3. This structure contains more than one material: 3 inches of Aggregate Coarse, and 9
inches of Aggregate Base. Enter “AC” for the Material, “.25” for the Section, “.075”
for Multiplier, and “TN” for tons. (For this example we are assuming a cubic foot of
asphalt weighs 150 pounds. To find the Multiplier we used (150/2000 = 150 lbs. /
FT³) Numbers for your materials will be different. Contact your materials supplier for
the correct values.).
4. For the second material, choose “Area” for the Type “AB” for the Material, “.75” for
Multiplier, and “TN” for Units, and click OK.
5. Enter the Heavy Duty Paving area as required beginning with the entry driveway.
Right-click to end the area entries. When complete your screen should resemble the
illustration below.
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6. Light Duty Paving can be entered in a similar manner. Right-click and select New
Structure>New Area and the Structures dialog box is displayed.



7. Enter “Paving LD” for the name.
8. This structure contains more than one material: 3 inches of Aggregate Coarse, and 7
inches of Aggregate Base. Enter “AC” for the Material, “.25” for the Section, “.075”
for Multiplier, and “TN” for tons.
9. For the second material, choose “Area” for the Type “AB” for the Material, “.5833”
for Multiplier, and “TN” for Units (the multiplier will remain the same), and click OK.
10. Enter the Light Duty paving areas in the same manner as the Heavy Duty Paving. Notice that the Light Duty When complete your screen should resemble the illustration
below.
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11. Paving Areas include a number of unpaved islands, which must be deducted for an
accurate measurement.

Removing Holes from an Area
12. Make sure that Paving LD is the selected area.

13. Right-click and select Entry Mode.
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14. Place you cursor over the point of and island or planter inside a Light Duty Paving
Area. Line Snap (press F8 key twice in rapid succession) to snap to the island.



15. Right-click to end the entry. Notice the pattern for the Light Duty Paving is removed.
Continue this process until all islands and planters have been entered. Your screen
should resemble the illustration below.

16. Click the Save button on the toolbar.
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Entering a Count
1. Select Enter>Count and the Structures dialog box is displayed.

2. Enter “Yard Light” for the structure name. You can use the same name for the material name. Since we only need a count of the yard light no Sections or Multipliers are
needed.
3. To add a symbol, click in the Pattern box and select the “Light Pole” symbol. Click
OK.
Your own
symbols may
be created
by selecting
Enter>Symbol

4. Click OK again.
5. Click to enter a point on each one of the yard lights and the symbol will appear.
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6. When complete, right-click and select Edit Mode.

7. Click the Save button to save your file.
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Reporting
1. When all entries are complete, the report can be generated by clicking on the Report
View button on the tool bar. The Structure Measure report will display.

2. The report lists structure totals only, no material quantities are reported.
3. Click on the Structure Report button and the report is organized by structure name,
along with materials quantities.
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4. The Details button toggles between summary and detail reports.



5. Click the Materials Report button and the report is organized by material name.

6. Again, the Details button toggles between summary and detail reports.
7. The reports can be sent to the printer by clicking the Print button on the toolbar, or
sent to the print page.
8. The Planview, along with the PDF image can also be sent to the Print Page.
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Lesson 1 - Importing ESW File
When entering a Sitework 4D job that is meant for Materials 4D, be sure to enter Design
Data lines to the finished elevations, and use Sectional Areas to account for the material depths necessary for total dirt calculations. It is also a best practice to use line labels
when entering jobs, so that multiple areas may be selected at the same time using the
Label Select tool. The job may then be opened in Materials 4D to calculate total material
quantities. For information on entering job in Sitework 4D (including the use of Sectional
Areas), please see the Sitework 4D manual which available for download here.

Launch the Program
1. Double-click the Materials 4D shortcut on the desktop and the Open dialog box displays.



2. Select “Montessori School Materials 4D.esw” and click Open. The file will open in
the import window.
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Transfer Sitework 4D Layers
1. The Sectional Areas layer is selected by default as seen in the layer selection dropdown menu. Click the Transfer button to transfer the Sectional Areas layer to the
job.

2. In the layer selection dropdown, select Design Annotation.
3. Right-click and select Transfer.
4. In the layer selection dropdown, select Design Lines.
5. Right-click and select Transfer.
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6. Click the Planview button to switch to the Planview Mode. All transferred data will
be displayed as design annotation. Your screen should appear similar to the illustration below.

Import Structures List



1. For this lesson, we will use a structures list from a previous job. Select File>Import
Structure List and the Open dialog box is displayed.
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2. Select “Materials4DStructures.mks” and click Open. The Structure List editor will
display.

Materials may
also be added
in the window
or deleted by
right-clicking
and selecting
“Delete
Material”.

3. By clicking on an entered structure, you can see the materials used to create them.
The material thickness and/or multiplier may need to be edited for a specific job or
materials provider. Click OK.

Assign Structures
1. To display the PDF image behind your job, select the bounding rectangle around the
job.
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2. Right-click and select Import. The PDF will display in the background.
The image
may be
toggled on
and off using
the “T” key.



3. Select Sectional Areas from the Layer pulldown. All Sectional Areas will be highlighted.
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4. Select View>Hide All But. Only the Sectional Areas will be displayed.
5. Select the “Heavy Duty Paving Area”.

6. Select the Paving HD from the structure pulldown.
7. Click the Transfer Annotation to Structure arrow to assign the structure.
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8. Select one of the “Light Duty Paving Areas”.
9. Click the Label Select button to and all “Light Duty Paving” areas will be selected.

10. Select the Paving LD from the structure pulldown.



11. Click the Transfer Annotation to Structure arrow to assign the structure.
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12. There are several islands in the Light Duty Paving area. Select one of these islands
and click the Label Select button. Verify only the desired lines are selected.

13. Keep the Structure Pulldown on Paving LD and click the Transfer Annotation to
Structure arrow to remove the islands from the Light Duty Paving area.
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14. Continue the process until all areas are assigned.
15. Select Design Lines from the Layer pulldown menu.
16. Select View>Hide All But and only the Design Lines layer will be displayed.

17. Select one of the Top of Curb “TC” lines.



18. Click the Label Select button to select of Top of Curb lines.
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19. Change the Structure pulldown to “Curb Straight”.
20. Click the Transfer Annotation to Structure arrow to assign the structure.

21. Sometimes lines entered in Sitework 4D may not represent the line you want use to
measure your structure. Select the Curb and Gutter line illustrated below.
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22. Click the Offset Line button and the Offset Selected Area dialog box is displayed.



23. Enter “.75” for the offset and click Apply. This ads a line down the center of the
Curb and Gutter area. Click OK.
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24. Select the offset line you just created.

25. Select “Curb & Gutter” from Structures dropdown.
26. Click the Transfer Annotation to Structure arrow to assign the structure.
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27. Count items still need to be entered manually. Select “Yard Lights” from the
28. Click the Entry Mode button.
29. Click in the appropriate locations to add Yard Lights.



30. When the takeoff is complete, reports can be generate as seen in the previous lesson.
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The Mouse
Materials 4D makes extensive use of the mouse throughout the program. A roller-style
center button mouse is highly recommended. The Mouse can be substituted for the cursor for non-digitized entry like editing.
Right Button
Left Button

Center-roller-button

The Left button is used to select objects and choose menu items.
The Right button is used to display the Right Mouse Menu. This menu displays quick access to specific commands in each job surface.
The Wheel Button allows the user to zoom in or out over the location of the arrow by
rolling the wheel Up or Down respectively. Holding the button down and moving the
mouse allows the user to pan the view on the screen.

Pull Down Menus
Menu commands can be selected from pulldown menus by clicking on the menu then
clicking the command. A submenu is noted by an arrow pointing to the right after the
command name. Click on the command with the submenu to view the available commands and click on the command in the submenu to select it. Menus and commands
displayed in grey are not available. Keyboard equivalent commands are also listed in the
menu, if available.

Buttons

Check Boxes and Radio Buttons
Check Boxes and Radio Buttons are used to display whether an option is enabled or disabled. When filled, the option is on.

Checks
Checks indicate that a certain command option is enabled. These appear in menus and
submenus in Materials 4D.
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A button is selected by placing the cursor over the button and clicking it.
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The Arrow Cursor
The arrow cursor is used for selecting items only.

The Crosshair Cursor
The crosshair cursor means the program is in data entry mode and structures and materials can be entered.

Selecting
Selecting is done by placing the arrow over the object and clicking it (mouse) . Multiple
items can be selected by pressing and holding the Shift key while selecting the items.

Text Boxes
Text Boxes are used to input values. Select the Text box to add or modify the data. The
text cursor can be moved with the TAB key or by selecting a new text box.
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Screen Modes
Materials 4D operates in several Modes, each with a different purpose and a different set
of menus and commands to perform specific tasks associated with that Mode. Below is
a description of each of the Modes.

CAD Transfer Mode
CAD Transfer Mode is used to transfer structures from ESW, DWG, or DXF files to the
Materials 4D job file.

Plan View Mode
Plan View Mode displays the materials and structures of the job on the screen, and
functions both in Edit Mode and an Entry Mode. Plan View Mode can also be split with
Report and Profile Modes. See below for more information.

Report View Mode
Report View Mode displays the structure and materials entered on the job and previews
the printed report. Report Mode has a split screen mode called Plan w/Report View
Mode. See below for more information.

Plan w/ Report View Mode
Plan w/ Report View Mode displays the materials and structures report and the materials
and structures of the job on the screen. Also, If a specific structure/material is selected
in the Plan View, it is highlighted in the Report View. Functions both in Edit Mode and an
Entry Mode.

Print Preview Mode
The Print Preview Mode displays the Print Page and allows the user to arrange items on
the page. Titles, images and additional text can also be added.

Edit Mode
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Edit Mode is used to edit existing materials and structures.

Entry Mode
Entry Mode is used to enter new materials and structures.
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Keyboard Equivalents
Materials 4D contains many commands that can be accessed by both the menus and by
keyboard shortcuts. Below is a list of these commands, their shortcut and a brief description of the command along with the mode in which the command is used.

Changing Modes
Toggles between Edit and Entry Modes. Switches to Edit Mode from any other
mode.

e
p
a
f

Switches to Print Preview Mode from any mode.
Switches to CAD Transfer Mode from any mode (if CAD data has been imported).
Switches to Profile View Mode from any mode.

All Modes

§n
§o
§s
§p

Starts a new Job.
Opens a Job File.
Saves the current job.
Sends the current view to the Print Page.

CAD Transfer Mode

²
£¢
¥¤
Spacebar

³ ´
µ
¦h
¦s
§z
and
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Zooms out to the extents of the job and restores the default viewing parameters.
Moves the view in the direction of the arrow selected.

Zooms In or Out to the cursor location.
Zoom In and Zoom Out.
Deletes the currently selected object(s).
Hides the currently selected object(s).
Displays all hidden data.
Undo the last edit up to the last eight stored.

Materials 4D Reference

Edit and Entry (Plan View) Mode

²
£¢
¥¤

Zooms out to the extents of the job and restores the default viewing parameters.

0- 9
and
.

The Number and Period keys are used to enter numerical values, such as
multipliers and sections.

Moves the view in the direction of the arrow selected.

Zooms In or Out over cursor location.

Spacebar

³
µ

and

´

Zoom In and Zoom Out.
Deletes the currently selected data/structure (Edit Mode only).

çBackspace

Removes the last point entered on a line (Entry Mode only).



In Edit Mode, snaps a point on the selected line closest to the crosshair.
In Entry Mode, snaps a count item to an existing line of the same class.



Snaps to the point closest to the crosshair (Entry Mode only).

Report Mode

³ and ´
£ ¢
§p
and

Scrolls the report Up/Down a full page.
Scrolls the report Up/Down one line at a time.
Prints the report.

Split Screen Modes
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Split screen Modes simply show multiple Modes on the screen and use the keyboard
shortcuts from these Modes. The screen in which you want to use keyboard shortcut
must be made active for the shortcut to function.
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Tool Bars
Materials 4D utilizes the tool bar function for many of its commands for easy and quick
access. There are two types of tool bars: Selection and Utility. Click on the button to
activate the command. Below is a list of the commands on the tool bars. Buttons that
are grey are not accessible.

Selection Tool Bar Buttons
The Selection Tool Bar is used for opening files, saving files, and printing as well as
switching between the different Modes.
New

Starts a new job file. The same command as selecting New from
the File menu.

Open

Opens an MK3 file. The same command as selecting Open from the
File menu.

Save

Saves the current job. The same command as selecting Save from
the File menu.

Print

Prints the data that is currently displayed on the screen. The same
command as selecting Print from the File menu.

CAD Transfer Mode Switches to CAD Transfer Mode.
Plan View Mode

Switches to Plan View Mode.

Report View Mode

Switches to Report View Mode.

Plan w/Report View Switches to a split screen Plan View with Report View Mode.
Mode
Print Preview Mode Displays the Print Page.
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Edit Mode

Switches to the Edit Mode.

Entry Mode

Switches to Entry Mode.
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Home

Centers the overlay and sizes it to fill the screen.

Pan

Enables the Pan tool to move the overlay. Click the Pan button,
then click and hold the overlay to move it. Release to stop moving
the overlay.

Area Zoom

Defines the view by dragging a box around the information desired.
Click and drag the box to define the zoom area. Click again to zoom
in.

Send to
Print Page

Sends the current screen image to the Print Page.

Show Areas

Shows/grays all Areas in the job.

Show Lengths
and Counts

Shows/grays all Lengths and Counts in the job.

Show Annotation

Highlights/grays all Annotation lines in the job.

Utility Tool Bar Buttons
The Utility Tool Bar displays different options depending on the Mode.

Plan View Entry/Edit Mode
Join

Connects multiple lines together.

Close Line

Connects the end points of a line to create a closed area.

Trim Line

Breaks all lines that cross the selected trim line.

Label Selection

Selects all lines with the same label within the same layer or struc
ture.

Offset Line

Creates a line/area offset a specified amount from a selected line/
area.

Swap Ends

Switches the start and end points of a selected line.

Report View Mode

Structures

Report displaying each individual structure and material entry. The
structure is listed first.

Materials

Report displaying each individual material and structure. The
material is listed first.

Detail/Summary

Toggles between showing report data in detail or in summary
items.
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Structure Measures Basic report displaying the area and length of the structures of the
job.
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Menus
The Menu bar lists the available menus and commands. Many of the menus and commands are common, though some modes have specific menus and specific commands
different from the other modes. Below is a description of all of the available commands
from each menu, with special menus and commands noted.
Note: The illustration below shows all Menus, though not all menus will appear on the
screen, depending on the mode.

File Menu
The File Menu is used to start new jobs, open jobs, save jobs, import/export jobs, set
printer preferences, and exit the program. Below is a list of commands in the File Menu
in all modes.

New
Starts a new job. When the command is selected, the Job Information dialog box is displayed.
Enter the Job Name, Builder, Operator, and Units. The Bid Date and Date are automatically entered based on the current data. Click OK to start the new job.
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Open
Opens an existing job. When the command is selected, the Open dialog box is displayed.

Select the file from the list in the window and click Open to get the file.

Close
(Not Available in CAD Transfer Mode)
Closes the currently open job. If there have been any changes to the job since it was last
saved, a dialog box is displayed asking if you want to save the job.

Click Yes to save the job, No to close without saving.

Save
(Not Available in CAD Transfer Mode)
Saves the job with the current job name to the working directory. If no file exists, it is
saved using the Job Name from the Job Information dialog box as the name of the file.

Save As
(Not Available in CAD Transfer Mode)
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Saves the current job with a different name. When the command is selected, the Save
As dialog box is displayed.

Type the new name of the file in the text box and click Save to save the file.
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Close Import
(CAD Transfer Mode Only)
Closes the open import file, ends CAD Transfer Mode, and switches to Edit Mode.

Import
(Not Available in CAD Transfer Mode)
Used to import data from an ESW, DXF, or DWG file. When the command is selected,
the Import dialog box is displayed.

Select the file from the list in the window. The name then displays in the File Name text
box. Click Open to get the file. Files are opened in CAD Transfer Mode.

Export
(Not Available in CAD Transfer Mode)
Used to export data into a specific format. The Export submenu contains two commands, described below.

To AGT File
Exports the data line information to an AGT file. When the command is selected, the
Save As dialog box is displayed.

Change to the desired directory, type the new name of the file in the text box, and click
Save to save the file.
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Report To Excel Text
Exports the contents of the report as a text file, which can then be imported into a
spread sheet program, such as Microsoft Excel©. When the command is selected, the
Save As dialog box is displayed.

Change to the desired directory, type the new name of the file in the text box, and click
Save to save the file.

Print
(Report View and Print Preview Mode Only)
When the command is selected in Print Preview Mode, the currently displayed data is
printed. In Report View Mode, the Print dialog box is displayed.

2EFERENCE

Select the printer, change the printer properties, and select the print range. Click OK to
print the report.
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Page Setup
(Not Available in CAD Transfer Mode)
Displays the Print Setup dialog box to set and change printer properties. When the command is selected, the Print Setup dialog box is displayed.

Choose the printer, change printer properties and print settings. Click OK accept changes.

Send to Print Page
(Not Available in CAD Transfer Mode)
Sends the current view to the Print Page.
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Exit
Quits Materials 4D. If changes have been made, a dialog box is displayed asking to save
the file before quitting.

Click Yes to save, No to exit without saving or Cancel to abort saving and continue
working.

Edit Menu
The Edit Menu is used to undo commands, as well as select and edit structures and
materials and change job file information and settings. Below is a list of the commands
available from the Edit Menu in all modes.

Undo
(Not Available in Print Preview Mode)
Undoes the last command.

Copy
(Edit Mode Only)
Copies the currently selected data and stores it in temporary memory.

Paste
(Edit Mode Only)
Inserts the currently stored data from the Copy command into the job file.

Delete
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Deletes the currently selected data. Deleting annotation data removes it from the entire
job. Deleting data in CAD Transfer Mode does not modify the original CAD file.
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Drawing Scale
(Print Preview Mode Only)
Sets the scale of the Plan view on the Print Page. When the command is selected, the
Edit Scale dialog box is displayed.

Enter the desired scale in the Scale box and click OK.

Add Text
(Print Preview Mode Only)
Used to add additional text to the screen. When selected, the Enter Text dialog box is
displayed.

Choose the font type, style, size and color. Type in the text to display on the screen in
the box at the bottom of the window. Click OK to add the text to the screen.
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Phases
(Not Available in CAD Transfer Mode)
Adds phases to a job and specifies which phase is currently active for data entry or editing. When the command is selected, the Phases dialog box is displayed.

Adding a Phase

Type in the name of the new phase in the Phase Name box,
add any comments in the Notes box, and click the Add but
ton.

Selecting a Phase

Select the phase from the pulldown menu. Check the Current
(Default) box to make this the active phase. Click OK.

Sheets
(Edit Mode and Report View Modes Only)

Add

Adds a new sheet with the default name Sheet 1, 2, 3, and so on,
and uses the name typed in the Sheet Name box (if any).

Translate N/E

Used to move the coordinate system for the job. Refer to the
Transform Job command in the Utility menu for more information.
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Adds sheets, specifies which sheet is the currently active sheet, transforms the North/
East Coordinates, aligns the matching edges, and scales the tablet. When the command
is selected, the Sheets dialog box is displayed.
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Match Edges

Displays the Align Edges dialog box.

Select common To and From points on the sheets, then click
on the points on the first sheet then the second
sheet.
Tablet

Used to rescale the plansheet. Refer to the Tablet Scale command
in the Edit menu for more information.

Copy Scale
sheet.

Used to select an existing sheet to copy its scale to the current

Delete

Select a sheet from the pulldown, then click Delete to delete it.

Structures
(Not Available in CAD Transfer Mode)
Adds, creates, imports, edits, and saves structures. When the command is selected, the
Structures dialog box is displayed.

To add a structure, scroll to the end of the Structure list, and enter the Type, Name,
Color, and Pattern. In the Materials list, add the material details. Click Apply to add the
structure.
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Apply

Applies any changes or additions made to structures on the list.

Copy

Creates a copy of the currently selected structure.

Import

Opens a Structure File (MKS) file from another job, and imports it
into the current job.

Export

Saves a Structure File (MKS) from the current job for use in other
jobs.

Clear

Deletes all Job Materials and Structures from the current job. When
the command is selected, a confirmation dialog box is displayed.

Click Yes to delete the Structures and Materials lists, No to delete
all Job Structures but leaves the Materials List, or Cancel to return
to the Structures dialog box without deleting anything.
OK

Applies all changes to the Structure List and closes the window.

Cancel

Cancels any changes that have not been applied and closes the
window.

Materials
(Not Available in CAD Transfer Mode)

To make any changes to a material, double-click the appropriate box and make any
changes to the information. Click OK to apply the changes, Cancel to abort, or Save As
Default to save it to your master list. To add a material, scroll to the end of the Materials
list, and enter the Type, Name, Multiplier, and Units, then click OK.
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Adds, deletes, or modifies Materials. When the command is selected, the Materials dialog box is displayed.
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Symbols
(Not Available in CAD Transfer Mode)
Used to delete symbols from the current job and save symbols for use in other jobs.
When the command is selected, the Edit Symbols dialog box is displayed.

To delete a symbol, select it from the list and click Delete. To save the symbol list, click
OK, then name the list and click the Save button in the Save As dialog box.

Tablet Scale
(Edit/Entry Modes Only)
Used to scale the tablet to the plansheet scale. When selected, the Tablet Scaling dialog
box is displayed.

Select three points and enter the horizontal and vertical coordinates in the corresponding
text boxes. Click OK and then digitize each point in the order you entered the coordinates.
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View Menu
The View Menu is used to adjust the display of visible data on the screen. The View
Menu is not available in Report View Mode. Below is a list of the commands available
from the View Menu in all other modes.

Hide
Hides the currently selected data line(s).

Hide All But
Hides everything but the currently selected data line(s).

Show All
Displays all hidden data.

Selected Materials
(Not Available in CAD Transfer Mode)
Displays the Selected Materials dialog box, which lists materials for any selected structure.

2EFERENCE

.

4-19

Materials 4D Reference

Undo List
(Not Available in CAD Transfer Mode)
Displays the Undo List dialog box, which shows all the changes you have made to the
current job file during your active session. The list continues to record your job changes
until you close and save the job.

To undo any changes on the list, select the item on the list, then click Undo. To close
this window, click on the Close button.

Display Menu
The Display Menu is used to adjust how data is displayed on the screen. A check next
to a command indicates that it is enabled. The Display Menu is not available in Report
View Mode. Below is a list of the commands available from the Display Menu in all other
modes.

Show Annotation
(Not Available in CAD Transfer Mode)
Toggles on or off the display of annotation data.

Show Lengths/Counts
(Not Available in CAD Transfer Mode)
Toggles on or off the display of Length and Count structures.

Show Areas
(Not Available in CAD Transfer Mode)
Toggles on or off the display of Area structures.

Auto Plus Marks
(Not Available in CAD Transfer Mode)
Automatically displays plus marks over points on data lines when zooming in.
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Plus Marks
(Not Available in CAD Transfer Mode)
Toggles on or off the display of plus marks over points on data lines.

Show Line Labels
Toggles on or off the display of line labels.

Show Point Labels
Toggles on or off the display of point labels.

Compass
Toggles on or off the display of the compass.

Frame
(Print Preview Mode Only)
Adds a thick border around the edge of the paper.

Title Block
(Print Preview Mode Only)
Adds a Title Block across the bottom of the page. A Title Block can only be added if a
Frame has been added first.

Title Block Logo
(Print Preview Mode Only)
Inserts a logo to display in the Title Block across the bottom of the page. Only files with
the “.wmf” extension can be inserted in this manner. When the command is selected,
the Open dialog box is displayed.
Change the data path to the location of the .wmf image file. Select it from the window
and click Open to insert the image.

Add Row
(Print Preview Mode Only)
Adds a row of page(s) below the original print page(s) to the Print page.

Add Column
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(Print Preview Mode Only)
Adds a column of page(s) to the right of the original page(s) to the Print page.

Delete Row
(Print Preview Mode Only)
Deletes a row of pages from the bottom of the Print page.

Delete Column
(Print Preview Mode Only)
Deletes a row of pages from the right of the Print page.
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Enter Menu
The Enter Menu is used to select the type of data to enter. The Enter Menu is available
in Entry and Edit Modes only. Below is a list of the commands available from the Edit
Menu.

Areas
Enters an Area. When the command is selected, the Structures dialog box is displayed to
select an Area to enter.

Select an Area to enter and Click OK. The screen switches to Entry Mode.

Lengths
Enters a Length. When the command is selected, the Structures dialog box is displayed
to select a Length to enter.

Select a Length to enter and Click OK. The screen switches to Entry Mode.
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Counts
Enters a Count. When the command is selected, the Structures dialog box is displayed to
select a Count to enter.

Annotation
Enters annotation data. The screen switches to Entry Mode for adding annotation lines.

Scaling Points
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Used for entering benchmark points when scaling to a plan sheet. The screen switches
to Entry Mode with the cursor changing to the Scaling Points cursor. Select the three
benchmark points with the cursor to enter the benchmarks.
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Symbol
Used to enter symbols to represent a Count structure. When the command is selected
the Add Symbols dialog box is displayed.

Enter a name in the Symbol Name box and use the drawing tools at the bottom of the
dialog box to create the symbol or select lines from the job that represent the symbol.
Click the Save Symbol button to save, and OK to close the dialog box.

Phase Regions
Enters a Phase Region on the job. If the current phase is not empty when the command
is selected, a dialog box displays, asking if you want to create a new phase.

Click OK to open the Phases dialog box and create a new phase. Once the phase is created, you can enter the phase region on the job.
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Utility Menu
The Utility Menu is used to assign structures, change the job coordinates, transfer lines
and symbols, set the transfer units, join and close lines, and crop data. The Utility Menu
is available in CAD Transfer, Enter, and Edit Modes only. Below is a list of the commands
available from the Utility Menu.

Assign to Structure
(Not Available in CAD Transfer Mode)
Used to assign selected annotation data to the active structure.

Assign to Current* Sheet
(Not Available in CAD Transfer Mode)
Sends the selected structure to the active Sheet.

Assign to Current* Phase
(Not Available in CAD Transfer Mode)
Sends the selected structure to the active Phase.

Move to Annotation
(Not Available in CAD Transfer Mode)
Moves the currently selected structure to the annotation layer.

Transform Job
(Not Available in CAD Transfer Mode)

The From coordinates are the current coordinates of a point from the data in the job file.
The To coordinates are from the same point, but in the new coordinate system. The bottom two boxes display the difference between the coordinates. Click Apply to translate
the coordinates.
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Contains the Translate North/East command, which is used to change the North/East
coordinates of the job. This is useful when moving a job file into field or CAD file coordinates. When the command is selected, the Translate North/East dialog box is displayed.
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Offset Lines/Areas
(Not Available in CAD Transfer Mode)
Used to set the offset for selected Areas and Lines. When the command is selected, the
Offset Selected Area(s) dialog box is displayed.

Enter the desired offset in the Offset box. Check the Inside box to have the line offset
inside the current line. If the line is not a closed area, click the Opposite Side button to
change the side the offset is created. Click Apply to set the line.

Join
(Not Available in CAD Transfer Mode)
Used to connect annotation line segments as one line. Select the segments to join, then
select the Join command.

Close
(Not Available in CAD Transfer Mode)
Used to connect the first and last point of an annotation line or length structure. Select
the line to close, then, select the Close command.

Trim Annotation
(Not Available in CAD Transfer Mode)
Breaks annotation lines that cross a selected line. Select a trim line (annotation or
length), then select the Trim Annotation command.

Trim Structures
(Not Available in CAD Transfer Mode)
Breaks lengths that cross a selected line. Select a trim line (annotation or length), then
select the Trim Structures command.

Break Line
(Not Available in CAD Transfer Mode)
Breaks a line at the selected point. One part of the line remains selected after breaking.

Crop Rectangle
Used to remove unwanted data by drawing a frame around the desired data and then
cropping the data outside the frame.
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Transfer
(CAD Transfer Mode Only)
Sends the selected CAD data to the job. Transferred data lines are automatically joined
so they do not transfer as line segments common in many CAD files.

Transfer Symbols
(CAD Transfer Mode Only)
Transfers lines that make up a symbol, such as a yardlight or storm drain, to the job.

CAD Transfer Units
(CAD Transfer Mode Only)
Used to set the units of measure for the transferred data. When the command is selected, the Import Transfer Units dialog box is displayed.

To change the units of measure, select the desired Import File Units and click OK.

Enter Symbol
(CAD Transfer Mode Only)
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Used to enter symbols to represent a Count structure in CAD Transfer Mode. Refer to
the Symbol command in the Enter menu for additional information.
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Options Menu
The Options Menu is used to set certain preferences, such as sound, graphics, snap, and
tablet options. Changes remain in effect for future sessions. The Options Menu is not
available in Report View Mode. Below is a list of commands available from the Options
Menu in all other Modes.

AutoSave
(Edit/Entry Modes Only)
Allows the user to enable/disable the Auto Save function and change the interval between saves. When selected, the Auto Save dialog box is displayed.

Enter a number in the Minutes box. Select On/Off to enable/disable the AutoSave function. Click OK to save changes. The file that is created when Auto Save is enabled is
called “Autosave.MK3” and is located in the your current working directory.

Sound Preferences
(Not Available in Print Preview Mode)
Allows the user to choose sound options. A check next to the option indicates which
one is active.
Sound Card

Allow the use of external speakers.

PC Speaker

Uses the internal PC speaker.

No Sound

Disables all sounds.

Fill Areas
(Edit/Entry Modes Only)
Displays a submenu with three options for displaying fill areas.
All
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Highlights all fill areas on the plan view.

Selected

Highlights all selected fill areas on the plan view.

None

Deselects any highlighted fill areas on the plan view.
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Advanced Graphics
(Not Available in Print Preview Mode)
Enables/disables the display of advanced graphics. This setting is enabled by default.
Disabling when in Split Screen Modes to assist in graphic display.

Snap
(Edit/Entry Modes Only)
Enables/disables the Snap feature. When enabled, Snap causes a point to be “snapped”
to the nearest point on an existing line during data entry.

Tablet Enable
(Edit/Entry Modes Only)
Enables/disables the use of the digitizer tablet.

Select Title Block Logo
(Print Preview Mode Only)
Inserts a logo to display in the Title Block across the bottom of the page. Only files with
the “.wmf” extension can be inserted in this manner. When the command is selected,
the Open dialog box is displayed.
Change the data path to the location of the .wmf image file. Select it from the window
and click Open to insert the image.

Report Menu
The Report Menu is used to change report display options. The Report Menu is available
only in Report Mode. Below is a list of commands available from the Report Menu.

Structure Measures
Displays a basic report displaying the area and length of the structures of the job.

Structures
Full report displaying each individual structure and material entry. The structure is listed
first.

Full report displaying each individual material and structure. The material is listed first.

Report Details
Toggles between showing report data in detail or in summary items.

Report Graphic
Displays the full Plan View, which can be printed directly to the printer.
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Font (Custom)
Changes the type, style, and size of the font used for text blocks on the report. When
the command is selected, the Font dialog box is displayed.

Select the Font, Style, Size, and Effects then click OK.

Font (Default)
Changes the Font characteristics back to the default type, style, and size.
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Window Menu
The Window Menu is used to switch between open job files and set some window view
preferences. Below is a list of commands available from the Window Menu.

Tile Horizontal
Displays the open job files stacked one above the other on the screen.

Tile Vertically
Displays the open job files side by side on the screen.

Open File List
Below the Tile Vertically command is a list of currently open job files. The job file with
the check next to it is the currently active file.

Help Menu
The Help Menu displays job and software version information. Below is a list of commands available from the Help Menu.

Job Info
Displays the Job Information dialog box.

2EFERENCE

This is the same window that displays when a new job is started. Make any changes and
click OK.
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Graphics Info...
Displays Graphic card and OpenGL information about your computer.

About Materials…
Displays the current software version installed on your computer.
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Snap Techniques
Snap is a powerful feature in Materials 4D. It allows for fast data entry with greater precision than possible with free-hand data entry. When used with CAD or ESW files, Snap
can be used to quickly enter a structure using the annotation lines. Each snap technique
is described below.

Snap Mode

s

With Snap Mode you can enter data by snapping to the nearest point of existing data.
Enable Snap Mode by pressing the S key on the keyboard or by displaying the RightMouse menu and selecting Snap. At the lower right side of the status bar at the bottom
of the screen, Snap displays as black when enabled and as gray when disabled. Simply
click to snap when in Snap mode.

Snapping in Edit Mode
Structure Snap



Structure Snap is used to quickly assign structure information to annotation data from
previously entered structures. Select the annotation data to assign, then place the arrow
over the existing entered structure on the job and press the F9 key.

Snapping in Entry Mode
Snap



Snap is done by pressing F8 on the keyboard . Snap enters a point at the existing point
closest to the crosshair.

Line Snap



Line Snap is a quick way to snap to multiple points on a line. Place the crosshair over the
line and press the F8 key (SP button) twice. The entire line highlights with the crosshair
connected by a rubber-band line. Move the crosshair to the point on the highlighted line
where you want to end and press the F8 key again to snap to just that portion of the
line.



Snapping to an enclosed area is a variation of Line Snap. Place the crosshair over the line
bounding the area and press the F8 key (SP button) twice. The entire boundary highlights with the crosshair connected by a rubber-band line. Right-click or press the Blank
key again to close the boundary and apply the structure.

Point Snap



When entering data, Point Snap adds a count item to a line of the same class only. This
allows you to attach a structure to a line where there is no entered point to snap to.
Place the crosshair over the desired point on the line and press the F6 key.
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Creating a New Structure
A new structure is one that has not yet been entered on the current job. It can be composed of existing or new materials. To create a new structure:
1. Switch to Edit Mode.
2. Select Edit>Structures. The Structures dialog box is displayed.
3. Scroll to the bottom of the Structures list, then select the Class and Type of structure.
Note: You can also copy an existing structure by selecting it and clicking Copy, then
edit the information to create a new Structure.
4. Enter a Structure Name, select a color, and a pattern (Areas and Counts only).

5. Select the Material(s) for the Structure in the Material list.
6. Click Apply to create the new Structure, then OK to close the dialog box.
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Entering a Structure
Structures are entered in Entry Mode, but you can begin Structure entry from Edit or
Entry Modes using the Right-Mouse menu. To enter a structure from Edit or Entry Mode:
1. Right-click to display the Right Mouse menu, select New Structure, then select the
type of structure to enter. The appropriate Structure dialog box is displayed, showing
all structures of that type (Length, Area, Count).

2. Select the desired structure or create a new structure and click OK. The program
switches to Entry Mode and the cursor changes to a cross hair.
3. Click or press the Enter button to enter points and create the structure at the desired
location on the job.

2EFERENCE

4. Right-click or press the Blank button to finish structure entry.
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Entering a Hole
A hole is an area within a structure to be excluded from the structure totals, like parking islands. Holes are entered by entering a structure of the same type within the parent
structure. Below is an example of properly entered holes. Refer to Entering Holes in the
Tutorial for information about entering a hole.
Hole
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