Rev. 05/25/12

AGTEK Software License Agreement
PLEASE READ CAREFULLY. BY USING THIS PRODUCT, YOU ARE CONSENTING TO BE
BOUND BY THIS AGREEMENT.
Copyright

The AGTEK software package, on CD or in electronic form, together with associated
documentation, is protected under copyright. The buyer may make copies for the buyer’s
internal use only. The buyer agrees not to reverse engineer or otherwise seek to discover
the source code, or to modify or create derivative works from this software.

Single License

AGTEK grants to the buyer a non-exclusive, single license to load and use the AGTEK
software on one or more computers operated by the buyer, provided that use by the
buyer shall not be on more than one computer at a time. The buyer agrees not to rent,
loan or otherwise temporarily transfer this software for use on computers not operated by
the buyer.

Access Key

Access key. The AGTEK software is enabled by means of an access key that must be
present on the computer when the software is running. The access key may be a key
code checked-out from the Internet or a physical device that plugs into a computer port.

Export

AGTEK software includes cryptography that is not user-accessible, specifically designed
to allow execution of copy-protected software. Accordingly, this software is controlled
under ECCN EAR99 of the Export Administration Regulations (NLR, no export license
required). The buyer agrees to comply with all applicable regulations and prohibitions with
regard to export or re-export to sanctioned countries or individuals.

Limitations of
Warranty and
Liability

Limitations of warranty and liability. AGTEK software is licensed “as is” and with all
faults. AGTEK Development Company, Inc. and its Representatives make no warranties,
either expressed or implied, with respect to AGTEK software, its quality, performance,
merchantability, or fitness for any particular use. In no event will AGTEK Development
Company, Inc. or its Representatives be liable for direct, indirect, incidental or consequential damages resulting from any defect in AGTEK software, even if AGTEK Development
Company, Inc. has been advised of the possibilities of such damages.
Copyright© 2011 AGTEK Development Company, Inc.

Trademark
Credits

Windows XP® , Windows Vista® and Windows® 7 are registered trademarks of
Microsoft Corp. Google Earth™ is a trademark of Google. AutoCAD®, CAiCE™, DWG™,
DXF™ are trademarks of Autodesk, Inc. GEOPAK, MicroStation, GPK and DGN are trademarks of Bentley Systems, Inc

iii

Table of Contents

TUTORIAL
UNDERGROUND 4D OVERVIEW ....................................................................................... 1-1
DOCUMENT CONVENTIONS ............................................................................................
Keyboard and Mouse Interface
Keyboard
The Mouse
Scaling
Known Distance
Data Entry Sequence
Scale the Plan Sheet
Create Underground Structures and Materials
Generate and Print Underground Reports
Lesson Examples
LESSON 1 – SCALING TO THE PLAN SHEET
Start a New Job (Job Setup)

FOR

1-1
1-1
1-1
1-2
1-3
1-3
1-5
1-5
1-5
1-5
1-5

TAKEOFF ........................................................ 1-3
1-3

LESSON 2 – ENTERING UNDERGROUND STRUCTURES .............................................................. 1-7
Underground Structure Classes
1-7
Underground Structure Types
1-8
Creating Underground Structures
1-8
Specify Pipe Depth
1-9
Entering Pipe Depth using Rim and Invert Values
1-9
Enter Laterals for the Pipe
1-11
Specify Lateral Depth
1-11
Enter Verticals for the Pipe
1-13
Enter Fittings for the Pipe
1-15
Reporting
1-18
Saving a Default Structure List
1-21

LESSON 3 – ENTERING PIPE LINES IN SITWORK 4D .............................................................
Label Pipe Lines
Enter Pipe LInes with invert elevations
Enter Laterals

1-22
1-22
1-23
1-24

LESSON 4 – CALCULATING TRENCH EXCAVATION ............................................................... 1-25
Apply Template
1-25
Calculate Trench Volumes
1-27

Table of Contents

LESSON 5 – IMPORTING ESW FILES TO UNDERGROUND 4D ...................................................
Opening an ESW file
Transfer Layers to Underground 4D
Import Structure List
Assign Annotation to Structures

iv

1-29
1-29
1-29
1-30
1-31

REFERENCE
USER INTERFACE .......................................................................................................
The Keyboard
The Mouse
Pull Down Menus
Buttons
Check Boxes and Radio Buttons
Checks
The Arrow
The Crosshair
Selecting
Text Boxes

2-1
2-1
2-1
2-2
2-2
2-2
2-2
2-2
2-2
2-2
2-2

SCREEN MODES .......................................................................................................
Transfer (Import) Mode
Plan View Mode
Report View Mode
Plan w/ Report View Mode
Plan w/ Profile View Mode
Print Preview Mode
Edit Mode
Entry Mode

2-3
2-3
2-3
2-3
2-3
2-3
2-3
2-3
2-3

KEYBOARD EQUIVALENTS .............................................................................................
Changing Modes
All Modes
Transfer (Import) Mode
Edit and Entry (Plan View) Mode
Report Mode
Split Screen Modes

2-4
2-4
2-4
2-4
2-5
2-5
2-5

TOOL BARS ............................................................................................................
Selection Tool Bar Buttons
Utility Tool Bar Buttons
Plan View Entry/Edit Mode
Report View Mode

2-6
2-6
2-7
2-7
2-7

MENUS ................................................................................................................. 2-8
File Menu
2-8

v

Table of Contents

New
Open
Close
Save
Save As
Close Import
Import
Export
Print
Print Setup
Send to Print Page
Exit
Edit Menu
Undo
Copy
Paste
Delete
Drawing Scale
Add Text
Phases
Sheets
Structures
Materials
Symbols
View Menu
Hide
Hide All But
Show All
Selected Materials
Point Info
Undo List
Display Menu
Show Annotation
Show Lengths/Counts
Show Areas
Auto Plus Marks
Plus Marks
Show Line Labels
Show Point Labels
Compass
Frame
Title Block
Title Block Logo
Add Row
Add Column
Delete Row
Delete Column
Enter Menu

2-8
2-9
2-9
2-9
2-9
2-10
2-10
2-10
2-11
2-11
2-11
2-12
2-13
2-13
2-13
2-13
2-13
2-14
2-14
2-15
2-15
2-16
2-17
2-18
2-19
2-19
2-19
2-19
2-20
2-20
2-20
2-20
2-20
2-20
2-20
2-21
2-21
2-21
2-21
2-21
2-21
2-21
2-21
2-21
2-21
2-21
2-21
2-22

Table of Contents

Storm
Sewer
Water
Other
Annotation
Symbol
Phase Regions
Utility Menu
Assign to Structure
Assign to Current* Sheet
Assign to Current* Phase
Move to Annotation
Transform Job
Translate North/East
Align Matching Edges
Stretch Site
Offset Lines/Areas
Join
Close
Trim Annotation
Trim Structures
Break Line
Crop Rectangle
Transfer
Transfer Symbols
CAD Transfer Units
Enter Symbol
Options Menu
AutoSave
Sound Preferences
Lateral Depth
Sectional Default
Advanced Graphics
Snap
Select Title Block Logo
Report Menu
Structure Measures
Structures
Materials
Underground
Report Details
Report Graphic
Font (Custom)
Font (Default)
Depth Brackets
Window Menu
Tile Horizontal
Tile Vertically

vi

2-22
2-22
2-23
2-23
2-24
2-24
2-24
2-25
2-25
2-25
2-25
2-25
2-25
2-26
2-26
2-27
2-28
2-28
2-28
2-28
2-28
2-28
2-28
2-29
2-29
2-29
2-29
2-30
2-30
2-30
2-30
2-31
2-31
2-31
2-32
2-32
2-32
2-32
2-32
2-32
2-32
2-33
2-33
2-33
2-33
2-34
2-34
2-34

vii

Table of Contents

Open File List
Help Menu
Job Info
Graphics Info...
About Materials…
SNAP TECHNIQUES ..................................................................................................
Snap Mode
Snapping in Edit Mode
Structure Snap
Snapping in Entry Mode
Snap
Line Snap
Area Snap
Point Snap

2-34
2-34
2-34
2-35
2-35
2-36
2-36
2-36
2-36
2-36
2-36
2-36
2-36
2-36

CREATING

A

NEW STRUCTURE ..................................................................................... 2-37

ENTERING

A

STRUCTURE ............................................................................................ 2-38

POINT INFO LIST .....................................................................................................
Editing a Point using the Point Info List
Entering Sectional Depths
Editing Underground Structure Lengths

TABLE

OF

CONTENTS

2-39
2-40
2-40
2-40

REFERENCE

Section 1

Tutorial

2-7

REFERENCE

2-8

Underground 4D Tutorial

Underground 4D Overview
With Underground 4D you can create material takeoffs from precise computer-generated
CAD files, AGTEK ESW files, or printed plan sheets. When you enter data such as pipelines, laterals, verticals and fittings.
In addition, Trench details may be entered to calculate trench material quanties. The Underground functions are only available if you have purchased the full version of Materials
4D/UG.

Document Conventions
This tutorial uses standard software documentation conventions to explain how the software works. These conventions are described below.
Click/click on - Press the left mouse button (assuming the buttons are set to the default
settings).
Double-click - Press the left mouse button twice in rapid succession.
Right-click - Press the right mouse button.
Click and hold - Press and hold down the left mouse button.
Shift/Ctrl+click - Press and hold down the Shift/Ctrl key then press the left mouse button.
Click and drag - Press and hold the left mouse button, then move the mouse.
Ctrl+(Key) - Press the Ctrl key then press the keyboard key noted in the step.
Press - Press a specified key on the keyboard.
Select - Use the mouse to pick an item on the screen or menu command.
Menu Commands - When documenting a menu command, the command is described using the following format: Menu>Command. If there is more than one level to the menu,
it appears as a Submenu. For example, Options>Sound Preference>Sound Card.
Data Entry/File Names - If a file is specified in a procedure, or if specific text needs to be
entered into a field as part of a procedure, it will appear inside double quote marks.
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Keyboard, and Mouse Interface
Underground 4D relies on the standard center-roller-button mouse for entry, and the keyboard for alphanumeric entry and keyboard shortcuts.

Keyboard
To effectively use Underground 4D you will use the mouse, and the keyboard. Most Underground 4D tasks are available on menus and the Underground 4D toolbar at the top of
the screen, but the tasks can also be accessed much faster through keyboard shortcuts.
Keyboard shortcuts are listed in the Reference Section of this manual and are mentioned
in the Tutorial Section where appropriate.

The Mouse
A two-button wheel mouse is used for non-digitized entry. Below is a description of the
buttons and their function.
Wheel Button
Left Button
Right Button

The Left button is used to select objects and choose menu items.
The Right button is used to display the Right Mouse Menu. This menu displays quick access to specific commands.
The Wheel Button allows the user to zoom in or out over the location of the cursor by
rolling the wheel Up or Down respectively. Holding the button down and moving the
mouse allows the user to pan the view on the screen.
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Lesson 1 - Importing and Scaling the PDF
Underground 4D uses a variety of data sources including PDF plan sheets, CAD files, and
Sitework 4D files for use in completing materials takeoffs. This tutorial uses the Montessor School PDF.pdf file.

Launch the Program
Double-click the Underground 4D shortcut on the desktop and the Open dialog box displays.

1. Click New and the Job Information dialog box is displayed.

It is
imperative
that the
units are set
correctly
before you
begin your
takeoff

2. Enter “Montessori School Underground” for the Job Name, set the Units to Feet, and
click OK. The Builder and Operator information are optional.

Import and Scale the PDF
1. Select File>Import and the Import dialog box is displayed.
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If necessary
you can rotate
the drawing
by using the
L and R keys
to rotate
the drawing
counterclockwise and
clockwise
respectively

2. Select “Montessori School PDF.pdf” and click Open. The image opens in the Data
Transfer mode.

3. Zoom in to the lower-right portion of the job and locate the scale bar. Notice the
scale of this job is 1:20. Press the Home key to zoom out and center the job.
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4. Select Data Transfer>Image Scale and the Edit Image Scale dialog box displays.

5. Enter “20” for the scale and click OK. A dialog box displays advising you to check
the scale of the drawing using a known distance. Click OK.
6. Click the Planview button to exit the CAD Transfer window.
7. Zoom into the scale bar on the lower right-right portion of the job.
8. Select Enter>Annotation.
9. Draw an annotation line across the width of the scale bar by positioning your cursor on the left side of the scale bar and click to enter a point. Drag the cursor to the
right side of the scale bar and click to enter a point. You Screen should appear similar to the illustration below.

10. In the status bar at the bottom of the screen you can see the distance is approximately 60 feet, which verifies the accuracy of the scale.
11. Right-click to end the entry. Right-click again and select Edit Mode.
12. Press the Home key to zoom out and center the job. Your job should resemble the
illustration below.
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13. Press the Home key to zoom out and center the job. Your job should resemble the
illustration below.

14. Press the Plan w/Profile icon to display the profile at the bottom. Your job should
resemble the illustration below.
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Lesson 2 - Entering Pipes, Laterals, Verticals, and Fittings
Underground 4D uses a list of structures composed of materials. Structures and materials can be created for each job, or you can import a list from a previous job. When
starting a new job in Underground 4D, separate phases are created for 4 classes: Storm,
Sewer, Water and Other.

Structures
There are four types of structures in Underground 4D: Pipes, Laterals, Verticals and Fittings. Each structure uses a measurement, section, and multiplier to calculate trench
materials.
Pipe

Calculates length and average depth.

Lateral

Calculates length and average depth.

Vertical

Counts and calculates depth of vertical structures (Manholes, Inlets).

Fitting

Counts the number of fittings.

Sections and Multipliers
Sections are the thicknesses of the materials. Pipes and Laterals typically have sections
that are calculated based on the trench definition. Verticals and Fittings typically have a
section of 1.
Multipliers are used to convert the unit of measure for Pipes, Laterals, Verticals and Fittings to the specified job unit or to units of purchase. Pipes and Laterals typically use
multipliers that are calculated based on the individual structure. The multiplier for verticals and fittings is typically 1.
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Entering a Pipe
1. Select Enter>Storm and the Structures List dialog box is displayed.
The color can
be change by
clicking in the
Color column
and scrolling
through
available
colors. You
can doubleclick the color
to display the
color palette,
which will
allow you to
create custom
colors.
New
installations
have an
empty
structure list.
An existing
Structure
List can be
imported by
selecting
File>Import
Structure List,
selecting a list
and clicking
Open.

2. Select Pipe for the Type.
3. Enter “8-in SD” for the Structure Name. Use the inside diameter of the pipe in the
name. This value will be used to calculate the default trench specifications, press
Tab.
4. Default trench materials will automatically be added to the Material
5. Click the Trench Pattern to display the Trench Description.

6. The trench diagram displays different fields to be calculated. When a field is selected, the diagram will highlight the corresponding line or area.
7. Enter the desired values for the following fields.
•Bedding Thickness
•Cover Thickness
•Select Thickness
•Flare Point
•Flare Slope
•Pipe Wall
•Outside Diameter
•Inside Diameter
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Thickness in inches of material below the pipe.
Thickness in inches of material to cover the pipe.
Thickness in inches of select material above the pipe.
Vertical distance in feet from the trench bottom to start the
Flare Slope.
Slope in percent or V:H to daylight from Flare Point.
Thickness in inches of the pipe wall. This value will default
to 10% of the pipe ID.
Thickness in inches of the outside diameter of the pipe.
Thickness in inches of the inside diameter of the pipe. This
value is derived from the pipe name.
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8. For this example, keep all the default values except for the Select Cover. Enter 6
inches for the Select Thickness. Click OK

9. The modified values will display in orange in the materials list. Click OK.

10. Zoom into the storm drain inlet on the north side of the job. Position the cursor on
the inlet. Enter 514.25 - 508.7 (Rim-Invert) and left click to enter the point.
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11. Move to the next inlet and enter 513.3 - 508.12 and left click to enter the point.
12. Continue to the next inlet and enter 503.6 - 494.75. Left click to enter. Right click
to end the run. You may combine multiple runs into one entry, or enter each pipe
segment separately.

13. Continue entering all 8 inch storm pipe. You may use the F8 key to snap to the ends
of the pipe whenever possible.
14. When complete, right click and select Edit Mode.
15. Click the Save icon to save the file.
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Entering a Lateral
Laterals are a special type of pipeline. Laterals connect to the main pipe entry, and end
at a user defined depth or slope.
1. Select Enter>Storm and the Structures dialog box is displayed.

2. Select Lateral for the Type.
3. Enter “4-in SD” for the Structure Name. Again, use the inside diameter of the pipe in
the name, press Tab.
4. Default trench materials will automatically be added to the Materials.
5. Click the Trench Pattern to display the Trench Description.

6. Change the Bottom Width to 24 inches. Click OK.
7. The trench materials sections will be updated. Click OK.
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8. Position the cursor at the intersection of the 8” storm pipe and the 4” lateral. Press
F6 on the keyboard to snap to the pipe.

9. Move the cursor to the end of the lateral. Enter 4 feet for the depth to the invert.
Left click to enter the point. Right click to end the entry.

10. Continue to the next lateral. The end depth will remain the same until changed.
11. You may also select the Options menu and select Lateral Depth to enter either an end
depth or minimum slope percentage.
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12. You may also select the Options menu and select Lateral Depth to enter either an
end depth or minimum slope percentage.

13 Continue entering all 4 inch storm laterals.
14. When complete, right click and select Edit Mode.
15. Click the Save icon to save the file.
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Entering a Vertical
1. Select Enter>Storm and the Structures dialog box is displayed.

2. Select Vertical for the Type.
3. Enter SD Inlet for the structure name. Press Tab.
4. Choose a desired color from the color palette.
5. To add a symbol, click in the Pattern box and select the “SD DI” symbol. Click OK.

6. Click OK again to enter the verticals.
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7. Position the cursor over the end of the 8 inch storm pipe. Press F8 on the keyboard
to snap to the pipe. The rim and invert elevations will be derived from the Pipe.

8. If verticals are entered before the pipe, you may enter Rim-Invert before entering the
point.
9. Continue to the next inlet. Press F8 to snap to the pipe.

10. When all inlets have been entered, right click and select Edit Mode.
11. Click the Save icon to save the file.
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Entering a Fitting
1. Select Enter>Storm and the Structures dialog box is displayed.

2. Select Fitting for the Type.
3. Enter 8 x 4 Wye for the structure name. Press Tab.
4. Choose a desired color from the color palette.
5. You may add a symbol if desired. Click OK.
6. Position the cursor at the intersection of the 8” storm pipe and the 4” lateral. Press
F8 on the keyboard to snap to the intersection.

Fittings will
only attach
to structures
of the same
class.

7. Right click and select Edit Mode. Click the Save icon to save the file.
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Entering Sewer and Water
Sewer Class structures are entered using the same procedure as the Storm Class. Water
pipelines may not show rim and invert elevations. Waterlines may require a fixed
depth. To accommodate this, we must establish the desired depth with fictitious rim and
invert elevations.
1. Select Enter>Water and the Structures dialog box is displayed.

2. Select Pipe for the Type.
3. Enter “Water 1.5-in” for the Structure Name, press Tab.
4. Default trench materials will automatically be added to the Materials.
5. For this example we will use the default trench specifications. Click OK.
6. Zoom into the Waterline on the west side of the job. Position the cursor on
the end of the Water Line. Enter 500-496 (For a 4 foot deep trench) and left click to
enter the point.
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7. Continue tracing the waterline to the end. Right click to end the entry.
8. Water laterals and fittings are entered the same as before.
9. When all entries are complete, click the Save icon to save the file.
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Reporting
1. When all entries are complete, the report can be generated by clicking on the Report
View button on the tool bar. The Structure Measure report will display.

2. The report lists structure totals only, no material quantities are reported.
3. Click on the Underground Report button and the report is organized by structure
name. Pipes, Laterals and Verticals are reported by depth brackets.
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4. The Details button toggles between summary and detail reports.

5. Click the Materials Report button to view the trench material volumes.

6. The reports can be sent to the printer by clicking the Print button on the toolbar, or
sent to the print page.
7. The Planview, along with the PDF image can also be sent to the Print Page.
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Creating a Default Structures List
1. When all entries are complete, you may export the Structure List in this file as a
default for future jobs. You may also choose to save the list to a file to be used in
future Underground jobs only. To Export the structure list, select the Edit menu and
select Structures.

2. Click the Export button.
3. To save the Structure List as the default for future jobs. locate the DefaultStuctures.
mks file in the C:\AGTEK\Materials 4D folder. Select the filename and click Save.

3. Click Yes to overwrite the existing default list.
4. To save the Structure List for future jobs, but not make it the default, enter a desired
filename and click Save.
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Lesson 3 - Entering Pipe Lines in Sitework 4D
Underground 4D will read Pipe Line data entered in Sitework 4D. Both rim and invert
elevations will be transferred directly from the Sitework 4D ESW file. Before entering the
Pipe Line data, you must first complete your earthwork takeoff.

Launch the Program
1. Double-click the Earthwork 4D shortcut on the desktop.

2. Select the Montessori School Underground 1.esw file and click Open.
3. Select the Annotation line from the PDF Border.
4. Right-click and select Import File. The background image will display.

5. Select the Entry mode icon on the toolbar.
6. Change the Layer to Pipe Lines.
7. We will begin by entering the Storm Pipelines. It is recommended you use line labels
when entering the pipe. Press the L key on the keyboard to label the line. Enter SD
8-in for the Line Label. Click OK.
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8. You may use the Layer Selection icon, or right click and select Display and uncheck
the Design Layer to improve the visibility of the image.
9. Position the cursor over the storm inlet north of the building. Enter the invert elevation 508.7 and left click to enter the point
The rim
elevations are
derived from
the surface you
have selected.
In this example,
we are using
the Design as
our reference.

10. Continue to the next inlet. Enter elevation 508.12 and left click to enter.
11. Continue to the line to the end of the 8 inch storm pipe. Right Click to end.

12. Continue entering all 8 inch Storm pipe.
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13. When the Storm main is complete, we can now enter the Laterals.
14. Press the L key to label the line. Enter SD 4-in for the Line Label. Click OK
15. Position the cursor at the intersection of the 4 inch lateral and the 8 inch main. Press
the F6 key on the keyboard to snap to the line.

16. Move the cursor to the end of the lateral. To enter the elevation for the invert at the
end of the lateral, you may either enter a depth or a slope percentage. To enter by
depth, type the depth as a negative number. For this example enter -4. Press the
F10 key on the keyboard. Right Click to end.
To enter the invert
elevation by slope
percentage, enter
the desired slope
followed by the
percent sign. For
example, enter 1%
for a one percent
fall from the end
of the lateral to the
main.
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Lesson 4 - Calculating Trench Excavation
When all Storm Pipelines and Laterals are entered, we will now apply a template to generate the trenches to calculate the total trench excavation.
1. Select one of the 8 inch Storm pipes.
2. Click the Layer Selection icon on the toolbar to select all the 8 inch pipe.

3. Click the Apply Template icon on the toolbar.
4. Select the 3fttrench.typ file and click Open.
5. Change the Daylight surface to Subgrade and the Output surface to New Surface
and click Apply.
The trench in this
example is 3 feet
wide by 4 feet
vertical, with a
1:1 slope if the
trench is deeper
than 4 feet. There
is also an offset
for .5 feet below
the invert for
bedding.
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6. The template will sweep down the selected lines. When complete, enter the name
Storm for the new surface. Change the color if desired.

The color can
be change
by clicking
in the Color
pulldown and
selecting the
desired color.

7. When the 8 inch pipe trenches are complete, we can now generate the 4 inch lateral
trenches. Change the layer back to Pipe Lines.
8. Select one of the 4 inch Laterals.
9. Click the Layer Selection icon on the toolbar to select all the 4 inch laterals.
10. Click the Apply Template icon on the toolbar.
11. Select the 3fttrench.typ file and click Open.
12. Change the bottom width to 1 on each side for a 2 foot wide trench.
13. Daylight to Subgrade and Output to Storm should still be selected. Click Apply.
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14. You will be prompted to save the new template. Click No.
15. The template will sweep down the selected lines. When complete, we can now calculate the volumes of trench excavation for all Storm Pipe.
16. Click the 3D View icon on the toolbar to inspect the 3D surface.
17. Change the Reference to Storm and the Difference to Subgrade.

18. Click the Volume Calculation icon to compute the trench volumes.

19. The Cut volume represents the total excavation. The Fill volume is ignored. Click
Done to view the Volume Report. Click the Save icon to save the file.
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Sewer, Water and Other pipelines may be entered in the same manner. When entering
the Water pipelines, you may use the F10 key on every point to maintain a constant
depth to the invert. When all entries are complete, you will have a separate surface
for each class of Pipe. You may use the Profile Mode to view all classes of pipe.

This file may be imported directly into Underground 4D.
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Lesson 5 - Importing ESW files to Underground 4D
Underground 4D will read Pipe Line data entered in Sitework 4D. Both rim and invert elevations will be transferred directly from the Sitework ESW file. Before entering the Pipe
Line data, you must first complete your earthwork takeoff.

Launch the Program
1. Double-click the Underground 4D shortcut on the desktop.

2. Select the Montessori School Underground.esw file and click Open.
3. The file will open in the Import Window. Sectional Areas will be selected by default.
In this example, we are only interested in the Underground entries. Select the Layer
pulldown and select Pipe Lines.

All data
transferred
will go to the
Annotation
layer.

4. Click the Transfer arrow, or right click and select Transfer.
5. Select the Design Annotation and click the Transfer arrow.
6. Right click and select Edit Mode.
7. To import the background image, select the bounding rectangle around the job.
8. Right click and select Import. The image will display in the background.
9. In this example, we will import the Structure List from a file. Select the File menu
and select Import Structure List.
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10. Select the Struct_UG4D.mks file in the C:\AGTEK\Materials 4D folder and click Open.

11. The Structure List will open in the Structures Editor window. Click OK.
12. We may now assign the Pipe Lines to the correct structure. We will first assign the
8 inch Storm pipe. Select SD 8-in from the structure pulldown menu.

13. Select one of the 8 inch storm pipe lines.
14. Click the Label Selection icon to select all the SD 8 inch lines.
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15. Click the Assign Annotation to Structure arrow. The lines will be transferred to the
SD 8-in structure. Select one of the SD 8-in lines to view the profile.

16. Change the structure to SD 4-in.
17. Click the Label Selection icon.
18. Click the Assign Annotation to Structure arrow.
19. To enter the storm inlets, select SD Inlets from the structure pulldown.
20. Click the Entry Mode icon on the toolbar.
21. Position the cursor over the inlet and press the F8 key on the keyboard.
You may also use
the Left Click to
enter the inlets if
Snap is enabled.
Right click and
make sure Snap
is checked to use
this option.

22. Continue entering all SD Inlets in the same manner.
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23. Fittings would be entered in the same manner as the inlets. Snap to the Pipe or Lateral to enter the Fitting.
24. To enter the Sewer, you may choose to hide the Storm entries. Click the Phase
pulldown at the bottom of the screen and double click on Sewer.

25. Enter the Sewer structures using the same procedure as the Storm.
26. When the Sewer entries are complete, enter the Water and Other classes in the same
manner.

27. When all entries are complete, you may now generate the reports which is covered
in Lesson 2.
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User Interface
Underground 4D relies on the mouse for entry, and the keyboard for alphanumeric entry
and keyboard shortcuts.

The Keyboard
Optimal usage of Underground 4D combines the mouse and keyboard. Use the QWERTY
keys and numeric keypad for alphanumeric entry, as well as keyboard equivalent commands. Most keyboard commands are also available on menus but can be accessed much
faster through the keyboard.

The Mouse
Underground 4D makes extensive use of the mouse throughout the program. A roller-style
center button mouse is highly recommended. The Mouse can be substituted for the cursor
for non-digitized entry like editing.
The Left button is used to select objects and choose menu items.
The Right button is used to display the Right Mouse Menu. This menu displays quick access to specific commands in each job surface.
The Wheel Button allows the user to zoom in or out over the location of the arrow by rolling the wheel Up or Down respectively. Holding the button down and moving the mouse
allows the user to pan the view on the screen.

Right Button
Left Button

Center-roller-button
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Pull Down Menus
Menu commands can be selected from pulldown menus by clicking on the menu then
clicking the command. A submenu is noted by an arrow pointing to the right after the
command name. Click on the command with the submenu to view the available commands and click on the command in the submenu to select it. Menus and commands
displayed in grey are not available. Keyboard equivalent commands are also listed in the
menu, if available.

Buttons
A button is selected by placing the cursor over the button and clicking it.

Check Boxes and Radio Buttons
Check Boxes and Radio Buttons are used to display whether an option is enabled or disabled. When filled, the option is on.

Checks
Checks indicate that a certain command option is enabled. These appear in menus and
submenus in Underground 4D.

The Arrow Cursor
The arrow cursor is used for selecting items only.

The Crosshair Cursor
The crosshair cursor means the program is in data entry mode and structures and materials can be entered.

Selecting
Selecting is done by placing the arrow over the object and clicking it (mouse) or pressing
the Enter button. Multiple items can be selected by pressing and holding the Shift key
while selecting the items.

Text Boxes
Text Boxes are used to input values. Select the Text box to add or modify the data. The
text cursor can be moved with the TAB key or by selecting a new text box.
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Screen Modes
Underground 4D operates in several Modes, each with a different purpose and a different
set of menus and commands to perform specific tasks associated with that Mode. Below
is a description of each of the Modes.

Transfer (Import) Mode
CAD Transfer Mode is used to transfer structures from ESW, DWG, or DXF files to the
Underground 4D job file.

Plan View Mode
Plan View Mode displays the materials and structures of the job on the screen, and functions both in Edit Mode and an Entry Mode. Plan View Mode can also be split with Report
and Profile Modes. See below for more information.

Report View Mode
Report View Mode displays the structure and materials entered on the job and previews
the printed report. Report Mode has a split screen mode called Plan w/Report View Mode.
See below for more information.

Plan w/ Report View Mode
Plan w/ Report View Mode displays the materials and structures report and the materials
and structures of the job on the screen. Also, If a specific structure/material is selected
in the Plan View, it is highlighted in the Report View. Functions both in Edit Mode and an
Entry Mode.

Plan w/ Profile View Mode
Plan w/ Profile View Mode displays the materials and structures of the job and a profile
view of the job to show underground structures. Functions both in Edit Mode and an
Entry Mode.

Print Preview Mode
The Print Preview Mode displays the Print Page and allows the user to arrange items on
the page. Titles, images and additional text can also be added.

Edit Mode
Edit Mode is used to edit existing materials and structures.

Entry Mode
Entry Mode is used to enter new materials and structures.
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Keyboard Equivalents
Underground 4D contains many commands that can be accessed by both the menus and
by keyboard shortcuts. Below is a list of these commands, their shortcut and a brief description of the command along with the mode in which the command is used.

Changing Modes
Toggles between Edit and Entry Modes. Switches to Edit Mode from any other
mode.

e
p
a
f

Switches to Print Preview Mode from any mode.
Switches to CAD Transfer Mode from any mode (if CAD data has been imported).
Switches to Profile View Mode from any mode.

All Modes

§n
§o
§s
§p

Starts a new Job.
Opens a Job File.
Saves the current job.
Sends the current view to the Print Page.

Transfer (Import) Mode

²
£¢
¥¤
Spacebar

³ ´
µ
¦h
¦s
§z

Zooms out to the extents of the job and restores the default viewing parameters.
Moves the view in the direction of the arrow selected.

Zooms In or Out to the cursor location.
Zoom In and Zoom Out.
Deletes the currently selected object(s).
Hides the currently selected object(s).
Displays all hidden data.
Undo the last edit up to the last eight stored.
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Edit and Entry (Plan View) Mode

²
£¢
¥¤

Zooms out to the extents of the job and restores the default viewing parameters.
Moves the view in the direction of the arrow selected.

09
.

The Number and Period keys are used to enter numerical values, such as multipliers
and sections.

Zooms In or Out over cursor location.

Spacebar

³
µ

´

Zoom In and Zoom Out.
Deletes the currently selected data/structure (Edit Mode only).

çBackspace

Removes the last point entered on a line (Entry Mode only).



In Edit Mode, snaps a point on the selected line closest to the crosshair.
In Entry Mode, snaps a fitting or vertical item to an existing line of the same class.



Snaps to the point closest to the crosshair (Entry Mode only).

Report Mode

³ ´
£ ¢
§p

Scrolls the report Up/Down a full page.
Scrolls the report Up/Down one line at a time.
Prints the report.

Split Screen Modes
Split screen Modes simply show multiple Modes on the screen and use the keyboard
shortcuts from these Modes. The screen in which you want to use keyboard shortcut
must be made active for the shortcut to function.
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Tool Bars
Underground 4D utilizes the tool bar function for many of its commands for easy and
quick access. There are two types of tool bars: Selection and Utility. Click on the button
to activate the command. Below is a list of the commands on the tool bars. Buttons that
are grey are not accessible.

Selection Tool Bar Buttons
The Selection Tool Bar is used for opening files, saving files, and printing as well as
switching between the different Modes.
New

Starts a new job file. The same command as selecting New from
the File menu.

Open

Opens an MK3 file. The same command as selecting Open from the
File menu.

Save

Saves the current job. The same command as selecting Save from
the File menu.

Print

Prints the data that is currently displayed on the screen. The same
command as selecting Print from the File menu.

CAD Transfer Mode Switches to CAD Transfer Mode.
Plan View Mode

Switches to Plan View Mode.

Report View Mode Switches to Report View Mode.
Plan w/Report View Switches to a split screen Plan View with Report View Mode.
Mode
Plan w/Profile View Switches to a split screen Plan View with Profile View Mode to
Mode
show underground structures.
Print Preview Mode Displays the Print Page.
Edit Mode

Switches to the Edit Mode.

Entry Mode

Switches to Entry Mode.

Attach Profile

Assigns elevations to an Underground data line from profile data.

Home

Centers the overlay and sizes it to fill the screen.

Pan

Enables the Pan tool to move the overlay. Click the Pan button, then
click and hold the overlay to move it. Release to stop moving the
overlay.

Area Zoom

Defines the view by dragging a box around the information desired.
Click and drag the box to define the zoom area. Click
again to zoom in.
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Send to
Print Page

Sends the current screen image to the Print Page.

Show Areas

Shows/grays all Areas in the job.

Show Lengths
and Counts

Shows/grays all Lengths and Counts in the job.

Show Annotation

Highlights/grays all Annotation lines in the job.

Utility Tool Bar Buttons
The Utility Tool Bar displays different options depending on the Mode.

Plan View Entry/Edit Mode
Join

Connects multiple lines together.

Close Line

Connects the end points of a line to create a closed area.

Trim Line

Breaks all lines that cross the selected trim line.

Label Selection

Selects all lines with the same label within the same layer or struc
ture.

Offset Line

Creates a line/area offset a specified amount from a selected line/
area.

Swap Ends

Switches the start and end points of a selected line.

Report View Mode
Structure Measures Basic report displaying the area and length of the structures of the
job.
Structures

Report displaying each individual structure and material entry. The
structure is listed first.

Materials

Report displaying each individual material and structure. The material
is listed first.

Depth Brackets

Report displaying each underground structure entry with the struc
ture listed first.

Detail/Summary

Toggles between showing report data in detail or in summary items.
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Menus
The Menu bar lists the available menus and commands. Many of the menus and commands are common, though some modes have specific menus and specific commands
different from the other modes. Below is a description of all of the available commands
from each menu, with special menus and commands noted.
Note: The illustration below shows all Menus, though not all menus will appear on the
screen, depending on the mode.

File Menu
The File Menu is used to start new jobs, open jobs, save jobs, import/export jobs, set
printer preferences, and exit the program. Below is a list of commands in the File Menu in
all modes.

New
Starts a new job. When the command is selected, the Job Information dialog box is
displayed. Enter the Job Name, Builder, Operator, and Units. The Bid Date and Date are
automatically entered based on the current data. Click OK to start the new job.

Open
Opens an existing job. When the command is selected, the Open dialog box is displayed.

Select the file from the list in the window and click Open to get the file.
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Close
(Not Available in CAD Transfer Mode)
Closes the currently open job. If there have been any changes to the job since it was last
saved, a dialog box is displayed asking if you want to save the job.

Click Yes to save the job, No to close without saving, or Cancel to continue working.

Save
(Not Available in CAD Transfer Mode)
Saves the job with the current job name to the working directory. If no file exists, it is
saved using the Job Name from the Job Information dialog box as the name of the file.

Save As
(Not Available in CAD Transfer Mode)
Saves the current job with a different name. When the command is selected, the Save As
dialog box is displayed.

Type the new name of the file in the text box and click Save to save the file.
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Close Import
(CAD Transfer Mode Only)
Closes the open import file, ends CAD Transfer Mode, and switches to Edit Mode.

Import
(Not Available in CAD Transfer Mode)
Used to import data from an ESW, DXF, or DWG file. When the command is selected, the
Import dialog box is displayed.

Select the file from the list in the window. The name then displays in the File Name text
box. Click Open to get the file. Files are opened in CAD Transfer Mode.

Export
(Not Available in CAD Transfer Mode)
Used to export data into a specific format. The Export submenu contains two commands,
described below.

To AGT File
Exports the data line information to an AGT file. When the command is selected, the
Save As dialog box is displayed.

Change to the desired directory, type the new name of the file in the text box, and click
Save to save the file.
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Report To Excel Text
Exports the contents of the report as a text file, which can then be imported into a spread
sheet program, such as Microsoft Excel©. When the command is selected, the Save As
dialog box is displayed.

Change to the desired directory, type the new name of the file in the text box, and click
Save to save the file.

Print
(Report View and Print Preview Mode Only)
When the command is selected in Print Preview Mode, the currently displayed data is
printed. In Report View Mode, the Print dialog box is displayed.
Select the printer, change the printer properties, and select the print range. Click OK to
print the report.

Print Setup
(Not Available in CAD Transfer Mode)
Displays the Print Setup dialog box to set and change printer properties. When the command is selected, the Print Setup dialog box is displayed.

Choose the printer, change printer properties and print settings. Click OK accept changes.

Underground 4D Reference

2-12

Send to Print Page
(Not Available in CAD Transfer Mode)
Sends the current view to the Print Page.

Exit
Quits Underground 4D. If changes have been made, a dialog box is displayed asking to
save the file before quitting.

Click Yes to save, No to exit without saving or Cancel to abort saving and continue working.
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Edit Menu
The Edit Menu is used to undo commands, as well as select and edit structures and materials and change job file information and settings. Below is a list of the commands available from the Edit Menu in all modes.

Undo
(Not Available in Print Preview Mode)
Undoes the last command.

Copy
(Edit Mode Only)
Copies the currently selected data and stores it in temporary memory.

Paste
(Edit Mode Only)
Inserts the currently stored data from the Copy command into the job file.

Delete
Deletes the currently selected data. Deleting annotation data removes it from the entire
job. Deleting data in CAD Transfer Mode does not modify the original CAD file.
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Drawing Scale
(Print Preview Mode Only)
Sets the scale of the Plan view on the Print Page. When the command is selected, the
Edit Scale dialog box is displayed.

Enter the desired scale in the Scale box and click OK.

Add Text
(Print Preview Mode Only)
Used to add additional text to the screen. When selected, the Enter Text dialog box is
displayed.

Choose the font type, style, size and color. Type in the text to display on the screen in
the box at the bottom of the window. Click OK to add the text to the screen.
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Phases
(Not Available in CAD Transfer Mode)
Adds phases to a job and specifies which phase is currently active for data entry or editing. When the command is selected, the Phases dialog box is displayed.

Adding a Phase

Type in the name of the new phase in the Phase Name box, add any
comments in the Notes box, and click the Add button.

Selecting a Phase Select the phase from the pulldown menu. Check the Current
(Default) box to make this the active phase. Click OK.

Sheets
(Edit Mode and Report View Modes Only)
Adds sheets, specifies which sheet is the currently active sheet, transforms the North/
East Coordinates, aligns the matching edges, and scales the tablet. When the command
is selected, the Sheets dialog box is displayed.

Add

Adds a new sheet with the default name Sheet 1, 2, 3, and so on,
and uses the name typed in the Sheet Name box (if any).

Translate N/E

Used to move the coordinate system for the job. Refer to the
Transform Job command in the Utility menu for more information.
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Displays the Align Edges dialog box.

Enter coordinates or select common To and From points on the
sheets, then click on the points on the first sheet then the second
sheet.
Tablet

Used to rescale the plansheet. Refer to the Tablet Scale command
in the Edit menu for more information.

Copy Scale

Used to select an existing sheet to copy its scale to the current
sheet.

Delete

Select a sheet from the pulldown, then click Delete to delete it.

Structures
(Not Available in CAD Transfer Mode)
Adds, creates, imports, edits, and saves structures. When the command is selected, the
Structures dialog box is displayed.
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To add a structure, scroll to the end of the Structure list, and enter the Type, Name,
Color, and Pattern. In the Materials list, add the material details. Click Apply to add the
structure.
Apply

Applies any changes or additions made to structures on the list.

Copy

Creates a copy of the currently selected structure.

Import

Opens a Structure File (MKS) file from another job, and imports it
into the current job.

Export
jobs.

Saves a Structure File (MKS) from the current job for use in other

Clear

Deletes all Job Materials and Structures from the current job. When
the command is selected, a confirmation dialog box is displayed.
Click Yes to delete the Structures and Materials lists, No to delete
all Job Structures but leaves the Materials List, or Cancel to return
to the Structures dialog box without deleting anything.

OK

Applies all changes to the Structure List and closes the window.

Cancel

Cancels any changes that have not been applied and closes the
window.

Materials
(Not Available in CAD Transfer Mode)
Adds, deletes, or modifies Materials. When the command is selected, the Materials dialog
box is displayed.
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To make any changes to a material, double-click the appropriate box and make any
changes to the information. Click OK to apply the changes, Cancel to abort, or Save As
Default to save it to your master list. To add a material, scroll to the end of the Materials
list, and enter the Type, Name, Multiplier, and Units, then click OK.

Symbols
(Not Available in CAD Transfer Mode)
Used to delete symbols from the current job and save symbols for use in other jobs.
When the command is selected, the Edit Symbols dialog box is displayed.
To delete a symbol, select it from the list and click Delete. To save the symbol list, click
OK, then name the list and click the Save button in the Save As dialog box.
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View Menu
The View Menu is used to adjust the display of visible data on the screen. The View
Menu is not available in Report View Mode. Below is a list of the commands available
from the View Menu in all other modes.

Hide
Hides the currently selected data line(s).

Hide All But
Hides everything but the currently selected data line(s).

Show All
Displays all hidden data.

Selected Materials
(Not Available in CAD Transfer Mode)
Displays the Selected Materials dialog box, which lists materials for any selected structure.
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Point Info
Displays the Point Info list on the right hand side of the screen, which shows horizontal
and elevation data (if an underground structure) of each point on a selected data line and
allows you to edit point information, such as the Rim, Invert, and Sectional depths. Refer
to “Point Info List” on page 2-41 for information about using the Point Info list.

Undo List
(Not Available in CAD Transfer Mode)
Displays the Undo List dialog box, which shows all the changes you have made to the
current job file during your active session. The list continues to record your job changes
until you close and save the job.

Display Menu
The Display Menu is used to adjust how data is displayed on the screen. A check next
to a command indicates that it is enabled. The Display Menu is not available in Report
View Mode. Below is a list of the commands available from the Display Menu in all other
modes.

Show Annotation
(Not Available in CAD Transfer Mode
Toggles on or off the display of annotation data.

Show Lengths/Counts
(Not Available in CAD Transfer Mode)
Toggles on or off the display of Length and Count structures.

Show Areas
(Not Available in CAD Transfer Mode)
Toggles on or off the display of Area structures.
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Auto Plus Marks
(Not Available in CAD Transfer Mode)
Automatically displays plus marks over points on data lines when zooming in.

Plus Marks
(Not Available in CAD Transfer Mode)
Toggles on or off the display of plus marks over points on data lines.

Show Line Labels
Toggles on or off the display of line labels.

Show Point Labels
Toggles on or off the display of point labels.

Compass
Toggles on or off the display of the compass.

Frame
(Print Preview Mode Only)
Adds a thick border around the edge of the paper.

Title Block
(Print Preview Mode Only)
Adds a Title Block across the bottom of the page. A Title Block can only be added if a
Frame has been added first.

Title Block Logo
(Print Preview Mode Only)
Inserts a logo to display in the Title Block across the bottom of the page. Only files with
the “.wmf” extension can be inserted in this manner. When the comma nd is selected,
the Open dialog box is displayed.
Change the data path to the location of the .wmf image file. Select it from the window
and click Open to insert the image.

Add Row
(Print Preview Mode Only)
Adds a row of page(s) below the original print page(s) to the Print page.

Add Column
(Print Preview Mode Only)
Adds a column of page(s) to the right of the original page(s) to the Print page.

Delete Row
(Print Preview Mode Only)
Deletes a row of pages from the bottom of the Print page.
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Enter Menu
The Enter Menu is used to select the type of data to enter. The Enter Menu is available in
Entry and Edit Modes only. Below is a list of the commands available from the Edit Menu.

Storm
Enters a Storm structure. When the command is selected, the Structures dialog box is
displayed to select a Storm structure to enter.

Select a Storm structure to enter and Click OK. The screen switches to Entry Mode.

Sewer
Enters a Sewer structure. When the command is selected, the Structures dialog box is
displayed to select a Sewer structure to enter.

Select a Sewer to enter and Click OK. The screen switches to Entry Mode.
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Water
Enters a Water structure. When the command is selected, the Structures dialog box is
displayed to select a Water structure to enter.

Select a Water structure to enter and Click OK. The screen switches to Entry Mode.

Other
Enters a user specified structure. When the command is selected, the Structures dialog
box is displayed to select an structure to enter.

Select a structure to enter and Click OK. The screen switches to Entry Mode.
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Annotation
Enters annotation data. The screen switches to Entry Mode for adding annotation lines.

Symbol
Used to enter symbols to represent a Count, Vertical, or Fitting structure. When the
command is selected the Add Symbols dialog box is displayed.

Enter a name in the Symbol Name box and use the drawing tools at the bottom of the
dialog box to create the symbol or select lines from the job that represent the symbol.
Click the Save Symbol button to save, and OK to close the dialog box.

Phase Regions
Enters a Phase Region on the job. If the current phase is not empty when the command is
selected, a dialog box displays, asking if you want to create a new phase.

Click OK to open the Phases dialog box and create a new phase. Once the phase is created, you can enter the phase region on the job.
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Utility Menu
The Utility Menu is used to assign structures, change the job coordinates, transfer lines
and symbols, set the transfer units, join and close lines, and crop data. The Utility Menu
is available in CAD Transfer, Enter, and Edit Modes only. Below is a list of the commands
available from the Utility Menu.

Assign to Structure
(Not Available in CAD Transfer Mode)
Used to assign selected annotation data to the active structure.

Assign to Current* Sheet
(Not Available in CAD Transfer Mode)
Sends the selected structure to the active Sheet.

Assign to Current* Phase
(Not Available in CAD Transfer Mode)
Sends the selected structure to the active Phase.

Move to Annotation
(Not Available in CAD Transfer Mode)
Moves the currently selected structure to the annotation layer.

Transform Job
(Not Available in CAD Transfer Mode)
Contains three commands Translate North/East, Align Matching Edges, and Stretch Site.
comman
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Translate North/East
(Not Available in CAD Transfer Mode)
Contains the Translate North/East command, which is used to change the North/East
coordinates of the job. This is useful when moving a job file into field or CAD file coordinates. When the command is selected, the Translate North/East dialog box is displayed.

The From coordinates are the current coordinates of a point from the data in the job file.
The To coordinates are from the same point, but in the new coordinate system. The bottom two boxes display the difference between the coordinates. Click Apply to translate
the coordinates.

Align Matching Edges
(Not Available in CAD Transfer Mode)
Contains the Align Matching Edges command, which is used to align multiple PDF files
or job data to a common coordinate system. When the command is selected, if an image
is in the background, the dialog box is displayed.

Select Image Only if you are aligning a PDF file to a previous sheet. The align matching
edges window will display.

Select common From and To points on the sheets, then click the Apply button to move
the data.
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Stretch Site
(Not Available in CAD Transfer Mode)
The Stretch Site command is used to change the scale of data that has been previous
entered. When the command is selected, if an image is in the background, the dialog box
is displayed.

Select Whole Job if you changing the scale of the data. The Stretch Site dialog will display.

Click a point on the drawing anywhere to display the Direct Entry tab.

Enter the original scale or incorrect measurement of a known distance in the Old Scale
box and the correct scale or distance in the New Scale box. Click Apply, then OK.
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Offset Lines/Areas
(Not Available in CAD Transfer Mode)
Used to set the offset for selected Areas and Lines. When the command is selected, the
Offset Selected Area(s) dialog box is displayed.

Enter the desired offset in the Offset box. Check the Inside box to have the line offset
inside the current line. If the line is not a closed area, click the Opposite Side button to
change the side the offset is created. Click Apply to set the line.

Join
(Not Available in CAD Transfer Mode)
Used to connect annotation line segments as one line. Select the segments to join, then
select the Join command.

Close
(Not Available in CAD Transfer Mode)
Used to connect the first and last point of an annotation line or length structure. Select
the line to close, then, select the Close command.

Trim Annotation
(Not Available in CAD Transfer Mode)
Breaks annotation lines that cross a selected line. Select a trim line (annotation or length),
then select the Trim Annotation command.

Trim Structures
(Not Available in CAD Transfer Mode)
Breaks lengths that cross a selected line. Select a trim line (annotation or length), then
select the Trim Structures command.

Break Line
(Not Available in CAD Transfer Mode)
Breaks a line at the selected point. One part of the line remains selected after breaking.

Crop Rectangle
Used to remove unwanted data by drawing a frame around the desired data and then
cropping the data outside the frame.
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Transfer
(CAD Transfer Mode Only)
Sends the selected CAD data to the job. Transferred data lines are automatically joined so
they do not transfer as line segments common in many CAD files.

Transfer Symbols
(CAD Transfer Mode Only)
Transfers lines that make up a symbol, such as a yardlight or storm drain, to the job.

CAD Transfer Units
(CAD Transfer Mode Only)
Used to set the units of measure for the transferred data. When the command is selected, the Import Transfer Units dialog box is displayed.

To change the units of measure, select the desired Import File Units and click OK.

Enter Symbol
(CAD Transfer Mode Only)
Used to enter symbols to represent a Vertical or Fitting structure in CAD Transfer Mode.
Refer to the Symbol command in the Enter menu for additional information.
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Options Menu
The Options Menu is used to set certain preferences, such as sound, graphics, snap, and
tablet options. Changes remain in effect for future sessions. The Options Menu is not
available in Report View Mode. Below is a list of commands available from the Options
Menu in all other Modes.

AutoSave
(Edit/Entry Modes Only)
Allows the user to enable/disable the Auto Save function and change the interval between saves. When selected, the Auto Save dialog box is displayed.

Enter a number in the Minutes box. Select On/Off to enable/disable the AutoSave function. Click OK to save changes. The file that is created when Auto Save is enabled is
called “Autosave.MK3” and is located in the your current working directory.

Sound Preferences
(Not Available in Print Preview Mode)
Allows the user to choose sound options. A check next to the option indicates which one
is active.
Sound Card

Allow the use of external speakers.

PC Speaker

Uses the internal PC speaker.

No Sound

Disables all sounds.

Lateral Depth
Sets the default lateral depth and slope of underground structures. When the command is
selected, the Edit Lateral Depth dialog box is displayed.
Set the End Depth (measured in feet) and Min Slope % and click OK.
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Sectional Default
(Edit/Entry Modes Only)
Sets the default sectional depth. When the command is selected, the Edit Default Sectional Depth dialog box is displayed.

Set the Depth (measured in feet) and click OK. Changing the depth only affects underground structures entered after the default is changed.

Advanced Graphics
(Not Available in Print Preview Mode)
Enables/disables the display of advanced graphics. This setting is enabled by default. Disabling when in Split Screen Modes to assist in graphic display.

Snap
(Edit/Entry Modes Only)
Enables/disables the Snap feature. When enabled, Snap causes a point to be “snapped”
to the nearest point on an existing line during data entry.

Tablet Enable
(Edit/Entry Modes Only)
Enables/disables the use of the digitizer tablet.
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Select Title Block Logo
(Print Preview Mode Only)
Inserts a logo to display in the Title Block across the bottom of the page. Only files with
the “.wmf” extension can be inserted in this manner. When the command is selected, the
Open dialog box is displayed.
Change the data path to the location of the .wmf image file. Select it from the window
and click Open to insert the image.

Report Menu
The Report Menu is used to change report display options. The Report Menu is available
only in Report Mode. Below is a list of commands available from the Report Menu.

Structure Measures
Displays a basic report displaying the area and length of the structures of the job.

Structures
Full report displaying each individual structure and material entry. The structure is listed
first.

Materials
Full report displaying each individual material and structure. The material is listed first.

Underground
Full report displaying each individual underground structure and material entry, including
the average depth and depth brackets for the structure. The structure is listed first.

Report Details
Toggles between showing report data in detail or in summary items.
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Report Graphic
Displays the full Plan View, which can be printed directly to the printer.

Font (Custom)
Changes the type, style, and size of the font used for text blocks on the report. When the
command is selected, the Font dialog box is displayed.
Select the Font, Style, Size, and Effects then click OK.

Font (Default)
Changes the Font characteristics back to the default type, style, and size.

Depth Brackets
Breaks up the quantity of underground structures by a specified depth and increment.
This command is only available when the Underground report is displayed. When the
command is selected, the Depth Bracket Settings dialog box is displayed.
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Window Menu
The Window Menu is used to switch between open job files and set some window view
preferences. Below is a list of commands available from the Window Menu.

Tile Horizontal
Displays the open job files stacked one above the other on the screen.

Tile Vertically
Displays the open job files side by side on the screen.

Open File List
Below the Tile Vertically command is a list of currently open job files. The job file with
the check next to it is the currently active file.

Help Menu
The Help Menu displays job and software version information. Below is a list of commands available from the Help Menu.

Job Info
Displays the Job Information dialog box.

This is the same window that displays when a new job is started. Make any changes and
click OK.
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Graphics Info...
Displays Graphic card and OpenGL information about your computer.

About Materials 4D…
Displays the current software version installed on your computer.
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Snap Techniques
Snap is a powerful feature in Underground 4D. It allows for fast data entry with greater
precision than possible with free-hand data entry. When used with CAD or ESW files,
Snap can be used to quickly enter a structure using the annotation lines. Each snap technique is described below.

Snap Mode

s

With Snap Mode you can enter data by snapping to the nearest point of existing data. Enable Snap Mode by pressing the S key on the keyboard or by displaying the Right-Mouse
menu and selecting Snap. At the lower right side of the status bar at the bottom of the
screen, Snap displays as black when enabled and as gray when disabled. Simply click to
snap when in Snap mode.

Snapping in Edit Mode
Structure Snap



Structure Snap is used to quickly assign structure information to annotation data from
previously entered structures. Select the annotation data to assign, then place the arrow
over the existing entered structure on the job and press the F9 key.

Snapping in Entry Mode
Snap



Snap is done by pressing F8 on the keyboard. Snap enters a point at the existing point
closest to the crosshair.

Line Snap



Line Snap is a quick way to snap to multiple points on a line. Place the crosshair over the
line and press the F8 key twice. The entire line highlights with the crosshair connected
by a rubber-band line. Move the crosshair to the point on the highlighted line where you
want to end and press the F8 key again to snap to just that portion of the line.

Area Snap



Snapping to an enclosed area is a variation of Line Snap. Place the crosshair over the
line bounding the area and press the F8 key twice. The entire boundary highlights with
the crosshair connected by a rubber-band line. Right-click or press the Blank key again to
close the boundary and apply the structure.

Point Snap



When entering data, Point Snap adds a fitting item to a line of the same class only. This
allows you to attach a structure to a line where there is no entered point to snap to.
Place the crosshair over the desired point on the line and press the F6 key.
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Creating a New Structure
A new structure is one that has not yet been entered on the current job. It can be composed of existing or new materials. To create a new structure:
1. Switch to Edit Mode.
2. Select Edit>Structures. The Structures dialog box is displayed.
3. Scroll to the bottom of the Structures list, then select the Class and Type of structure.
Note: You can also copy an existing structure by selecting it and clicking Copy, then
edit the information to create a new Structure.
4. Enter a Structure Name, select a color, and a pattern.
5. Select the Material(s) for the Structure in the Material list.

6. Click Apply to create the new Structure, then OK to close the dialog box.
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Entering a Structure
Structures are entered in Entry Mode, but you can begin Structure entry from Edit or Entry Modes using the Right-Mouse menu. To enter a structure from Edit or Entry Mode:
1. Right-click to display the Right Mouse menu, select New Structure, then select the
type of structure to enter. The appropriate Structure dialog box is displayed, showing
all structures of that Class (Storm, Sewer, Water, Other).

2. Select the desired structure or create a new structure and click OK. The program
switches to Entry Mode and the cursor changes to a cross hair.
3. Click or press the Enter button to enter points and create the structure at the desired
location on the job.
4. Right-click to finish structure entry.
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Point Info List
The Point Info list displays horizontal and elevation data (if an underground structure is
selected) for a line. The Point list can be used to review and edit information about points
on the line, including modifying the Rim (Finish) and Invert values of an underground
structure. To view the Point Info list, select Edit>Point Info. When displayed, the Point
Info List appears on the right side of the screen.
In addition, the Point Info list can be used to enter Sectional depths. A Sectional depth
is an area on an underground structure that is below design grade. This is typically the
subgrade elevation for a job.
Point Info List

Finish (Rim) Depth

Sect (Sectional) Depth

Invert Depth

Point Depth

Rim/Invert Box

Horizontal Tab
The Horizontal Tab displays the point number for the selected point.
Elevation Tab
Finish

Displays the Rim, or Finish, depth of the selected point.

Sect

Displays the Sectional depth of the selected point.

Depth

Displays the depth difference between the Rim and Invert of the
selected point.

Invert

Displays the Invert depth of the selected point.
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Editing a Point using the Point Info List
If you need to modify Rim (Finish) or Invert values of an underground structure after you
have digitized them, you can use the Point Info list to make changes. To edit a point:
1. Select the point in the Elevation tab.
2. Enter the new Rim/Invert elevation(s) in the Rim/Invert Box at the bottom of the list.

3. Press Enter or select another point to make the changes.

Entering Sectional Depths
If you digitize the profile of an underground structure at design grade, but need to reflect
subgrade, you can enter a Sectional depth to account for the difference using the Point
Info list.
1. Select the point(s) in the Elevation tab to which you want to assign a Sectional
depth. Multiple points can be selected by clicking a point then Shift+clicking additional points. To select all points, right-click in the list and select Select All from the
Right-Mouse menu.
2. Right-click again and select Sectional Depths from the Right-Mouse menu. The Edit
Sectional Depth dialog box is displayed.

3. Enter the Sectional depth and click OK. The Depth is measured in the same units that
the job has been set to.

Editing Underground Structure Lengths
1. If you digitize an underground structure, but it doesn’t equal the value specified on
the plansheet, you can use the Override button to specify the new length.
2. Select the underground structure.
3. Click the Override button (located at the bottom of the screen). The Override Measured Value dialog box is displayed.
4. Enter the new length for the structure and click OK.
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