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Highway 4D Tutorial

Highway 4D Overview
Highway 4D is a complete highway estimating and modeling tool that adds highwayspecific entry techniques and reporting to the Earthwork 4D Suite of products. Highway
4D allows entry of cross sections from PDF or TIF files, survey notes, or electronic file
formats as well as supporting coordinate geometry (COGO) entry. On-screen volume
reporting and an interactive mass diagram combine to allow quick analysis.
By combining different data types from a variety of sources, you can use Highway 4D
to create basic highway volumes and reports, surfaces for Earthwork 4D, and when accurate data types such as COGO and electronic sections are available for surfaces, field
layout and modeling.

Document Conventions
This tutorial uses standard software documentation conventions to explain how the software works. These conventions are described below.
Click/Click on - Press the left button on the mouse (assuming the mouse buttons are set
to the default setting).
Double-click - Press the left button on the mouse twice in rapid succession.
Right-click - Press the right button on the mouse.
Shift+Click - Press the Shift key then press the left button on the mouse.
Ctrl+(Key) - Press the Ctrl key then press the keyboard key noted in the step.
Press - Press a key on the keyboard.
Select - Use the mouse to pick an item on the screen or a menu command.
Menu Commands - Menu commands are described using the following format:
Menu>Command. If there is more than one level to the menu, it appears as a Submenu,
Menu>Submenu>Command. For example, Options>Sound Preference>Sound Card.
Data Entry/File Names - If a file is specified in a procedure, or if specific text needs to be
entered into a field as part of a procedure, it will appear inside double quotation marks.

Keyboard and Mouse Interface
Highway 4D relies on the mouse for input and the keyboard for alphanumeric entry and
keyboard shortcuts.

Keyboard
To effectively use Highway 4D you will use the mouse and the keyboard. Most tasks
are available on menus and the toolbar at the top of the screen, but the tasks can also
be accessed much faster through keyboard shortcuts. Keyboard shortcuts are listed in
the Reference Section of this manual and are mentioned in the Tutorial Section where
appropriate.
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The Mouse
A two-button wheel mouse is used for non-digitized entry. Below is a description of the
buttons and their function.
Wheel Button
Left Button
Right Button

The Left button is used to select objects and choose menu items.
The Right button is used to display the Right Mouse Menu. This menu displays quick access to specific commands in each job surface.
The Wheel Button allows the user to zoom in or out over the location of the arrow (or a
segment if selected) by rolling the wheel Up or Down respectively. Holding the button
down and moving the mouse allows the user to pan the view on the screen.

Data Entry Sequence
Highway 4D is used for the entry of cross sections from PDF or TIF files. You may also
enter Horizontal and Vertical COGO data. Below are the suggested data entry sequences.

Cross Sections
•
•
•
•
•
•
•
•

Start a New Job.
Import the PDF or TIF file.
Enter the Plan Scale
Enter the Reference Point
Enter Existing Points
Enter Design Points
Enter Stripping and Sectional Depths
View Volumes Report

Horizontal and Vertical COGO
•
•
•
•
•

Start a New Job/Name Highway
Enter Station Equations
Enter Horizontal COGO
Enter Vertical COGO
Enter Offset Points

Reports and Calculating Volumes
•
•
•
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Mass Diagram and Haul Report
Volumes Report
Calculate Volumes in 4D Mode
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Lesson 1 — Digitizing Cross Sections
Start a New Job
1. Double click the Earthwork 4D shortcut or select Start>Programs>AGTEK>
Earthwork 4D. The Open dialog box is displayed.

2. Click the New button. The Job Information dialog box is displayed.
3. Name the job, make sure Meters is selected as the Units and the Highway box is
checked, then click OK. The Enter Alignment Name dialog box is displayed.
4. Name the alignment and click OK. Highway 4D opens in Cross Section Mode.Import
the Cross Section Data

Import the Cross Section Data
1. Select File>Import then select the “Xsect Napa 121.pdf” file in the Import dialog
box and click Open. The PDF Page dialog box is displayed.
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2. Select the page of the PDF to open (the first page in our example) and click OK. The
PDF opens in CAD Transfer Mode. Your screen should look similar to the illustration
below.

Note: Files that only contain bitmap data and cannot be vectorized are imported with
a red bounding box. Files with at least some vector data are imported with a green
bounding box. Our example has a green bounding box and has vector data, but will
be digitized instead of vectorized.

Scale the Electronic Data
Cross sections are typically drawn using the same scale for a job. If so, you will only
need scale the cross sections one time. However, AGTEK recommends checking each
cross section to make sure the scale is the same. If the scale is not the same you would
perform the following steps each time the scale changes.
1. Switch to Entry Mode, then select Utility>Trace Cross Section. The Cross Section
Scaling dialog box is displayed.
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2. Type “75” in the Point 1 Vertical text box, then “-35” in the Horizontal box.
3. Enter “55” in the Point 2 Vertical text box, then “-35” in the Horizontal box
4. Enter “55” in the Point 3 Vertical text box, then “35” in the Horizontal box and click
OK.
5. Zoom into the left part of the cross section, place the crosshairs over point 1
(75, -35) and click. Make sure you are as accurate as possible when clicking on the
point.

6. Zoom into the bottom left part of the cross section, place the crosshairs over point 2
55, -35) and click.
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7. Zoom into the bottom right part of the cross section, place the crosshairs over point
3
(55, 35) and click.

8. Make sure the correct alignment is selected (the name you gave it if you created a
new job or “A Line” if you opened the COGO file) in the Alignment Selection dialog
box, the and click OK.
9. Enter “10+070” in the Station box at the bottom of the screen. This is the first station of the cross sections.

1-6

Highway 4D Tutorial

10. Select a reference point for the cross section and enter the offset in the Ref Offset
box and the elevation in the Ref Elev box, (use 0, 60) then click on that point in the
cross section. The reference point is entered and the cursor changes to a Crosshair.
Note: Like the scaling points, the reference point should be common to all cross sections you are going to digitize to facilitate data entry.

Digitize Cross Sections
Cross Sections are entered as existing ground, design, and daylight points. Daylight
points are special design points that are automatically connected to the existing ground
from the current horizontal position when entered.

Enter Cross Section 1 Existing Ground
1. Move the cursor to the beginning of the existing ground from left to right and click to
create the first point.
2. Move the crosshair to the next point you want to enter, typically a grade break and
click to create a line connecting the points.
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3. Continue moving the cursor and entering points by clicking at the grade breaks until
you reach the end of the cross section.

Note: If you make a mistake during entry, the error can be removed by pressing the
Backspace key.
4. Right-click to end the existing ground entry. The Layer selection changes to Design
and the on-screen crosshair is no longer connected to the existing.
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Enter Cross Section 1 Design Points
1. Move the cursor to the beginning of the design where it connects to existing ground.
2. Press the Period (.) key then click on the first design point as a daylight point.
Note: Because the first design point starts at existing ground, you should enter it as
a daylight point. Pressing the Period key before clicking creates a daylight point.
3. Move the crosshair to the next point you want to enter, typically a grade break and
click to create a line connecting the points.
Note: The second point is not a daylight point, so you do not need to press the Period key before clicking.

4. Continue moving the cursor and entering points by clicking at all of the grade breaks
until you reach the end of the design. If the design crosses existing ground, you
should enter the point as a daylight point by pressing the Period key before clicking.
Note: If you make a mistake during entry, the error can be removed by pressing the
Backspace key.

1-9

Highway 4D Tutorial

5. Right-click to end the design entry. Highway 4D automatically enters a new station
number in the Station box.

6. Click the Next Page button.
Note: Make sure to digitize all cross sections from a page before moving onto the
next page.

Enter Cross Section 2 Existing Ground
Highway 4D has features to facilitate electronic data entry. To demonstrate those features, we will enter another cross section As mentioned, scaling is page-specific when
digitizing from electronic data. However, if you chose scaling points that are common for
all of the pages you are digitizing you do not need to re-scale each page. In this example,
the page does not need to be re-scaled. In addition, because we selected a reference
point that was common, we do not need to pick a new reference point, simply click on
the point we chose earlier.
1. Enter “10+080” in the Station box at the bottom of the screen.
Note: Once you have entered two stations, Highway 4D automatically enters stations based on that interval.
2. Zoom into the reference point (0, 60) and click on it. The reference point is entered
and the cursor changes to a Crosshair.
3. Move the cursor to the beginning of the existing ground from left to right and click
on the first point.
4. Move the crosshair to the next point you want to enter, typically a grade break and
click to create a line connecting the points.
5. Continue moving the cursor and entering points by clicking at the grade breaks until
you reach the end of the cross section.
Note: If you make a mistake during entry, the error can be removed by pressing the
Backspace key.
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6. Right-click to end the existing ground entry. The Layer selection changes to Design
and the on-screen crosshair is no longer connected to the existing.

Enter Cross Section 2 Design Points
Notice how the existing and design lines overlap for part of this cross section. Highway
4D can “daylight snap” to the existing ground to ensure accurate cross sections.
1. Move the cursor to the beginning of the design where it connects to existing ground.
2. Press the Period key then click on the first design point as a daylight point.
3. Move the crosshair to the next point you want to enter, typically a grade break and
click to create a line connecting the points.
Note: The second point is not a daylight point, so do not press the Period key before
clicking.
4. Continue entering points until you notice the design line overlapping the existing
ground. Press the Period key then click on the point where they overlap.
5. Move the cursor to the right until the design line and existing ground do not overlap,
press the period key twice and click at that point. The design line will follow exactly
the existing ground to that point.

Note: If you make a mistake during entry, the error can be removed by pressing the
Backspace key.
6. Right-click to end the design entry. Highway 4D automatically enters a new station
number in the Station box.
7. Click the Next Page button.
Once the cross section has been digitized, you would continue the process of clicking
the Next Sheet button, entering the Station number, selecting a reference point, then
digitizing the data until all cross sections have been digitized.
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Entering Stripping and Sectional Depths
When entering cross sections, you may enter stripping on the existing and sectional
depth for the design.
Enter Stripping
1. When tracing the existing ground line, enter the depth you want to strip before entering the point. The value will display in the Stripping column.You may change the
depth as you go.
2. Stripping will be added to the cross section in Highway Mode. Separate volumes will
be calculated for stripping.
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Entering Stripping and Sectional Depths
When entering cross sections, you may enter stripping on the existing and sectional
depth for the design.
Enter Sectional Depths
1. When tracing the design ground line, enter the depth you want to deduct for
subgrade before entering the point. The value will display in the Sectional column.
Continue tracing the finished grade line. You may change the depth as you go.
2. The sectional depth will be deducted from the design elevations in Highway Mode.
There are no volumes generated for the sectional areas.

1-13

Highway 4D Tutorial

Lesson 2 — Entering COGO
Coordinate Geometry (COGO) entry uses numeric values to specify road information both
horizontally and vertically. For this example, you will enter a portion of the horizontal
and vertical COGO for Vasco Road. Digital plans are not available, so all required entries
have been added to the worksheets.

Start a New Job (Job Setup)
1. Double click the Earthwork 4D shortcut or select Start>Programs>AGTEK>
Earthwork 4D. the Open dialog box is displayed.
2. Click the New button. The Job Information dialog box is displayed.

3. Type Vasco COGO for the Job Name, select the Highway checkbox, and click OK.

The Enter Alignment Name dialog box is displayed.
4. Type B-Line and click OK. Highway 4D supports multiple COGO lines (alignments)
and the Alignment Name is used to distinguish between alignments.
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Enter Station Equations
When entering a highway, the first task is to enter any station equations that may exist.
This job has a station equation 285 feet from the beginning of the highway where station 1010+00 becomes station 0+00.
Note: Before entering Station Equations and COGO, go through the plans and write
down all the information you’ll need to enter. Worksheets are provided in the back of
this manual and the Vasco COGO worksheet is on the next page.
1. Select Edit >Station Equations. The Alignment Starting Station dialog box is displayed.
2. Type “100715” and click OK. The Edit Station Equations window is displayed showing the Starting Station as the first equation and leaves room in the cells below for
other equations

3. Click in the Old Station cell of the second row and type “101000” to represent the
original station location where it transitions to the new stationing

4. Press the Tab button to go to the New Station cell of the second row.
5. Type “0” to finish the first station equation. The equation as entered tells Highway
4D that at station 1010+00 you want to renumber the stationing to start at 0+00.
Additional Station Equations may be entered by the same method.
6. Click OK to continue.
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Horizontal COGO Worksheet
Station Equations 1010+00

0+00

PC-BC/PT-EC

Length

Bearing/Delta

1007+15
0+83.54
5+79.53
12+55.72
26+31.87
34+79.71
86+05.27

368.54

N 7 13 4.0 W
27 3 53.6 R
N 19 50 49.6 E
65 42 22.6 R
N 85 33 12.2 E
44 30 37 L
N 41 2 34.9 E

* Bold denotes user entered values
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=

676.19
847.84
3882.59

Radius

1050
1200
1600
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Enter Horizontal COGO
1. Change to the Horizontal COGO view by either selecting Edit >Horizontal COGO or
by pressing the Horizontal COGO (H) button in the upper right corner of the window.
2. Click the Edit COGO button or select Edit>Horizontal COGO. The Horizontal COGO
window displays the specifications for the first line segment, and in the Station List
at the right, the starting Station specified earlier is highlighted.
3. Press the Tab button to accept this value and the cursor moves to the Northing cell.
4. The Northing and Easting for this first segment are N: 2101976.638 and E:
6204262.317. Enter these numbers into their respective cells and press Tab to move
to the Length of Straight cell.
Note: The default Northing and Easting of the first segment is 0,0. If the Northing
and Easting are known on a later segment, these values can be typed in later and all
Northings and Eastings will be recalculatd.
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5. On the L-1 plan sheet the first straight is 368.54 long. Enter this for the Length and
press the Tab key. The cursor moves to the Bearing cell and displays the calculated
Station End.
Note: The Station equation entered earlier is reflected in the Station End and the calculated values display in red.
6. The bearing for the first straight is N 7 13 4.0 W. Type in “N <space> 7 <space>
13 <space> 4 <space> W” and press the Tab key. The Northing and Easting for
the Station End calculate and the segment displays graphically on the screen above.
Note: Straight bearings are entered in a specific format using spaces as separators
between the elements. The elements are:
N or S

North or South is specified at the beginning of the Bearing

Degrees, Minutes Each separated by a space.
Seconds
E or W

East or West is entered at the end of the Beari

7. Click Next to define the next segment.
Note: By default, the COGO entry alternates between straights and curves but can
be overridden by pressing the desired tab at the top of the window. The Curve window defaults to entry of the Angle first.
The Edit COGO window defaults to using the data from the lesson job but is flexible
on what it can use to define the segments. Other data cells for each segment can
have data entered as an alternative entry method.
8. By looking at the table at the top of sheet L-1 you can see that the curve angle
is 27°03’53.6” with a turn to the right. Type “27 <space> 3 <space> 53.6
<space> R” and press the Tab key. The cursor moves to the radius cell.
Note: Similar to straight bearings, curve angles use a specific format for entry. The
format is Degrees, Minutes, Seconds and Right or Left for the curve direction. All
values are separated by a space during entry.
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9. Type “1050” as the radius and click Apply to see the results. Your screen should
look like the illustration below.
The window shows the two COGO segments with the current segment highlighted
and the arc controls visible. The Arc Controls and Arc Coordinates display is controlled by respective settings on the Display meu.

10. Click Next to specify the next segment. The cursor is in the Length of Straight text
box. Type “676.19” as the length and click Next.
Note: Bearing is already calculated and should match the plans.
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11. The rest of the COGO data follows a similar pattern. Enter the remainder of the
COGO up to station 86+05.2628 from the plans. Listed below are the entries required for the remaining four segments (bold denotes the entry values).
Station
Angle
Radius

12+55.71999
65 42 22.6 R
1200

Station
Length
Bearing

26+31.86906
847.84
N 85 33 12.2 E

Station
Angle
Radius

34+79.70906
44 30 37.3 L
1600

12. Click OK to complete the entry. Your screen should look like the illustration below.
There are no cross sections attached yet, so the section of the window below the
horizontal COGO is blank.
The curves display in magenta and the straights in blue. A segment can be selected
by clicking on it or by selecting the starting station of the segment in the station list.
The specifications for a segment can be viewed or edited by double-clicking the segment.
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Vertical COGO Worksheet

BVC/EVC

Length

Slope

1007+15
1007+50
1+00
4+90
6+90
7+40
9+40
16+25
31+25
49+10
67+10
86+05.26

35
350
390
200
50
200
685
1500
1785
1800
1895.26

1.72%
-5.715%
-6.32%
-5.925%
6.704%

Elevation
959.99
953.00
930.71
918.68
915.52
903.25
862.70
868.55
988.23

-1.06%

* Bold denotes user entered values
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Enter Vertical COGO
The horizontal COGO just entered has no elevation. One way to assign elevation is to
enter the vertical COGO. Vertical COGO entry is similar to the horizontal COGO just completed.
1. Select Edit>Vertical COGO. The Vertical COGO entry/edit window is displayed and
the starting station defaults to 100715.

2. Press the Tab key to move to the slope cell and type “1.72” as shown on the plans.
3. Press Tab to bypass the Elevation box and go the Station End since you don’t have
an elevation for the beginning of the job.
4. Enter “1007+50” as the Station End and press the Tab key. The next curve begins
there so it can be used as the Station End.
5. Enter “959.99” in the Elevation text box. The program back-calculates the starting
elevaton.

6. Click Next to finish this segment and move to the Curve.
Note: Similar to the Horizontal COGO, by default the vertical COGO alternates between Slope and Curve segments, although you can override this. The ending station
is automatically highlighted and the starting station is derived from the previous segment.
7. Enter “100” as the Station End and press the Tab key to go to the slope field. The
next slope begins there so it can be used as the Station End.
8. Enter “-5.714” in the Slope text box, as reflected on the plans. Your screen should
look like the illustration on the next page.
9. Click Next to finish the segment and continue. As you enter segments, the amount
of information that must be typed in for each segment is limited to the beginning and
end of the vertical curves along with the slope for the curve segment.
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10. You can use the information provided below to enter the remaining vertical COGO
(entered values are in bold).
Station
Length

4+90
390

Station
Length
Slope

6+90
200
-6.32

Station
Length

7+40
50

Station
Length
Slope

9+40
200
-5.924

Station
Length

16+25
685

Station
Length
Slope

31+25
1500
6.704

Station
Length

49+10
1785

Station
Length
Slope

67+10
1800
-1.06

Station
Length

86+05.26
1985.26
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11. When finished, click OK to close the vertical COGO entry window. The screen should
look similar to that shown below.

Horizontal and Verical COGO are not required for calulating volumes in Highway 4D.
COGO is only required when creating a surface in Eathwork 4D. This excercise will
be covered in Lesson 4 in this turorial.
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Editing COGO
COGO segments are interdependent—changing one segment affects the others. This is
true of both horizontal and vertical COGO. In either view, the segment can be edited by
double-clicking on the screen representation or on the Station List. Choosing the appropriate COGO type from the Edit menu also displays the selected segment.
The segment edit window is identical to the entry window. Values in white text cells can
be edited by clicking in the cell and typing new numbers. Clicking Next or Prev moves
forward or backward through the segments. Clicking Apply saves the changes to the
values, but leaves the window open. Clicking OK saves the changes and closes the edit
window. Clicking Cancel saves no changes made after Apply was used.

Deleting Segments
Because COGO segments are interdependent, only the last segment of a COGO line may
be deleted. To delete the last segment, select it on the cross-section or on the Station
List. Pressing the Delete key displays a confirm dialog box. Click Yes to complete the
deletion or No to cancel.

On the Station List, you can also select the ending station and right-click to display a
menu, then select Delete Stations. This is the same as pressing the Delete key.
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Lesson 3 — Reports and Calculating Volumes
Highway 4D provides three report types—Mass Diagram, Haul Report, and Volume Report. All are based on the simple average end-area calculation.
This lesson uses a finished job file located in the “AGTEK\Data” directory named
“Highway49Example.esw”. Start Highway 4D and select “Highway49Example.esw”
from the Open dialog box. The primary alignment is named CA_49. Make sure that this
alignment is selected on the toolbar.

Mass Diagram
The Mass Diagram is a graphical report of the hauls for a specific alignment such as
CA_49. Click the Volumes (V) button on the left side to display the Mass Diagram. The
Highway Volume Calculation dialog box is displayed

The Volume Calculation dialog box controls what is included in the calculation. Choices
include the entire alignment or split both lengthwise or across. The default Station range
is all stations but can be limited by entering the starting and ending stations.
Volumes can be limited to a portion of each station by entering extent limits. Extent
limits are measured from the reference point (0 horizontal) on the cross sections and are
specified as negative for the left extent and positive for the right. For example, if you
wanted the volumes for only the right side you could enter “0” for the left extent and a
positive number for the right.
In this example, keep All Stations and Total Width checked and click OK. The Mass Diagram window is displayed.
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The Mass Diagram Window
The different parts of the Mass Diagram window are described below.
u

The Mass diagram itself shows the net cumulative volumes along the alignment by
station. The blue represents a net fill and the red represents a net cut. Where the line
crosses or is on the center 0 line indicates where the alignment balances.

v

The Selected Haul displays on the Mass Diagram and the Haul Report below as a
gray band. Roll the mouse roller-button to move between the haul intervals.

w

The selected station location displays as a blinking square on the Mass Diagram and
is highlighted on the Station List. Stations may be selected by clicking on the Mass
Diagram or the Station List.

x

Haul Intervals are numbered on the Mass Diagram to correspond to the Haul report.

y

The In Station Haul volumes are graphed on the left side of the Mass Diagram. A
separate legend of the volumes is shown at the top of report. In Station hauls are the
amount of dirt being moved across the alignment instead of down.

z

The Haul Report shows the numbers that the Mass Diagram Graphic represents. The
details of each Haul Interval Station numbered above display in this report.

{

Any user-entered borrow or spoil displays to the right of the Mass Diagram. Numbers
in parentheses indicate a spoil.
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Mass Diagram Window Controls
Mass Diagram screen controls differ from those on the other Highway 4D windows and
are summarized below.
Left Button

Clicking on the Mass Diagram selects the station nearest to the
arrow. Clicking on the station list selects the station number nearest the arrow. Clicking on the Haul Report selects the haul interval
nearest the arrow.

Wheel-button

The wheel-button scrolls through the Haul Intervals if the Mass Diagram or Haul Report is selected. If the Station List is selected, the
wheel-button scrolls through the stations.

PageUp/PageDown Zoom in and Zoom out respectively on the Mass Diagram.

Interpreting the Mass Diagram
Select Interval 3 on the Haul Report. It should look like the illustration shown below.
From left to right, the Interval 3 fields are described below:
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Balance Interval

The 3rd haul on the alignment. This identifies the haul. An (S) or (B)
indicates a haul with excess volumes.

Net Cut Station

The range of stations where the cut volumes are coming from. In
this case, from station 3+650 to 3+860.

Net Fill Station

The range of stations where the cut volumes will be used to fill.
Station 3+860 to 3+970 in this example.

Source Cut

The volume in cubic meters (or yards) being moved for this interval.

Source Borrow

Any volumes introduced through borrow pits specified by the user.

Use Fill

The volume in cubic meters (or yards) used as fill.

Use Spoil

Any volumes introduced through spoils removal specified by the
user.

Balance Total

The yards moved for the haul interval. This number will always be
equal to either the Source totals or the Use totals.

In Station

The portion of the Balance Total quantities that is used across the
alignment instead of being moved to the next station.

Alignment Haul

Quantities to be moved down the alignment, or the difference
between the Balance Total and the In Station volumes.

Alignment Haul

Haul brackets are user specified distances that allocate the Alignment

Brackets

Haul quantities in amounts per distance. These can be edited for
different equipment spreads by selecting Edit>Haul Brackets.

Average Haul
Distance

The average measurement in meters or feet of the haul interval.
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Printing the Mass Diagram
The Mass Diagram can be sent directly to the printer or sent to the print page for layout.
Note: The Haul Report displays with the Mass Diagram but is printed separately. Refer
to “Printing the Haul Report” later in this tutorial for information about printing the Haul
Report.
Configuring the Printer
The default printer settings determine the size of the direct printed output and the size of
the Print Page. To change the printer and its setup, select File>Print Setup. Verify that
the correct printer is selected, the Orientation is set to Portrait, and click OK

Printing Direct
Mass Diagrams sent directly to the printer are always sized to fit the paper width and
automatically print to the next page if they require more than a single sheet. Selecting
File>Print or clicking the Print button sends the Mass Diagram to the printer.
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Sending to the Print Page
The Print Page allows for visual layout of different reports and views. Like direct printing,
the Print Page relies on the selected printer for its size. For best results, verify that the
correct printer, page orientation, and paper size are selected before sending information
to the print page.
Unlike direct printing, Print Page does not size the Mass Diagram to fit the width of the
page and it does not send the entire Mass Diagram. Instead, it prints only the Mass Diagram view as displayed on the screen.
PageUp and PageDown can be used to control the zoom level and pressing. Holding the
mouse roller-button while moving the mouse controls panning.
Use the screen controls mentioned above to get the desired view. Select File>Send to
Print Page or click the Send to Print Page button. The Print Page displays with the selected Mass Diagram positioned on it as shown in the following illustration.

Resizing Graphics on Print Page
The size and position of the graphic may be smaller than desired and not positioned
where you want it. To resize the graphic, move the arrow over the lower right selection
block, then press and hold the left mouse button. The arrow changes to a double-headed
arrow. By moving the cursor away from the graphic, you can resize it. Resize the Mass
Diagram to the desired page width.
Moving Graphics on Print Page
The Mass Diagram is now bigger, but may not be positioned correctly on the page. To
move the diagram, click and hold the diagram, then move it to the desired position on
the print page.
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When satisfied with the size and positioning, select File>Print or click the Print button
on the toolbar. The Print Page can display multiple reports and views, so you can add
more items to it before printing.

Printing the Haul Report
The Haul Report has been explained in the prior pages describing the Mass Diagram, as it
shows the numbers that the Mass Diagram represents. It does not, however, print from
the Mass Diagram screen. To display a separate Haul Report, click the Haul Report (H)
button on the toolbar.
Like the Mass Diagram, the Haul Report can be printed directly or sent to the print page.
However, the entire Haul Report is always sent to the Print Page instead of only what is
currently displayed. Once on the Print Page, the report can be sized or moved as desired.

The Volumes Report
The Volumes Report breaks the volumes down by station and shows the accumulating
volumes as you move down the alignment.
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Display the Volumes Report by pressing the Volumes Report (white V) button after a
Mass Diagram is calculatd.

The volume report lists the surface areas, the numbers used to calculate the volumes
and the net results along the selected alignment. For example, Stations 2+360 to
2+369.34 are shown and explained in the following figure.

Unseen report data . . .

Unseen report data . . .
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Station Number

Location for the values on the job. The volumes and areas represent
the calculation between this station and the prior station.

Surface Area

Plan view area calculated between the station and the prior station.
Totals, Cut, and Fill are self-explanatory. On Grade areas are those
areas that have less than 0.1 feet (or the metric equivalent) of Cut/
Fill.

End Area

Square meters or feet of cut and fill for the station. These numbers
are also shown on the cross section. This area is used to calculate
the cut/fill volumes.

Highway 4D Tutorial

Raw Volume

The volumes calculated before applying a compaction factor. The
end area explanation above shows how this is calculated.

Compaction Ratio

Ratios entered by the user to adjust for compaction or expansion
of Fill or Cut. Compaction is edited by right-clicking on the Station
List.

Compacted
Volumes

Volumes after any compaction ratios are applied. These volumes
are used to calculate the Net Volume and Cumulative Volumes.

Net Volume

Difference between the compacted Cut/Fill volumes.

Cumulative
Volumes

Volume that accumulates along the Alignment. The amount shown
is the cumulative volume left over after the Net Volume is applied.

Printing the Volumes Report
Like the Mass Diagram and Haul Report, the Volumes Report can be printed directly or
sent to the print page. The technique is the same as printing a Mass Diagram. However,
unlike the Mass Diagram, the entire Volumes Report is always sent to the Print Page
instead of only what is displayed on the screen. Once on the Print Page, the report can
be sized or moved as desired.
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Other Volumes-Related Features
Although not directly related to the Report views, the following features affect the volumes.

Compaction
Compaction ratios enable the program to compensate for shrink and swell. Compaction
can be assigned for all stations or a range of stations.
1. Selecting a Compaction Range
2. Click the Highway Mode button to change to Highway Mode.
3. Select a station from the Station list.
4. Right-click to display the menu and select Compaction. The Cross Section Range
Selection dialog box is displayed and the selected station is automatically put in both
the starting station and ending staion.

5. Select the All Stations checkbox. The Stations change to the first (Starting Station)
and last (Ending Station). Click OK. The Edit Highway Compaction dialog box is displyed.

6. Type “1.15” for the Fill Factor and click OK to apply the change. A 1.15 fill ratio
increases the amount of fill required by 15% and the Mass Diagram changes to reflect that. Compactions ratios are multiplied with raw volumes to produce compacted
volmes.

1-34

Highway 4D Tutorial

Entering Borrow/Spoil Locations
The default Mass Diagram and Haul Reports don’t always reflect how the dirt has to
move. Unbuilt bridges, haul roads, and sites for borrow and spoil can complicate choices
on how the dirt moves. To accommodate these variables, Highway 4D allows Borrow
and Spoil volumes to be inserted on stations. The reports then recalculate to reflect the
change.
The first step identifies if there is too much dirt or not enough. At the end of the Haul
Report, the spoil volume indicates that there is an excess of 156,108 cubic meters. This
reflects a 1.15 fill compaction ratio.
The next step is to figure out where this dirt can be removed from the job. For this
example, assume that the nearest location from which you can remove the dirt is at the
Tonzi Road intersection at station 6+560. Entering a borrow/spoil location first requires
picking the location on the Station List.
1. Select station 6+560 on the Station List.
2. Right-click to display the menu and select Borrow/Spoil. The Compacted Borrow/
Spoil dialog box is dispayed.

3. Type “-156108” and click OK. Spoils are entered as negative numbers. The mass
diagram automatically recalculates to reflect the change and the Borrow/Spoil station
on the station list changes color as an identifier and the spoil amount displays on the
right side of the mass diagram as shown in the illustration on the next page.

Note: Highway 4D supports multiple borrow/spoil locations, but for this example, we
want to remove all of the spoils of th job.
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Stopping and Starting Volumes
Another common situation in highway jobs is station ranges where no volumes should be
calculated. Highway 4D allows you to specify Starts and Stops through the Station List.
In this example, an existing bridge is widened from station 4+435 to 4+620 and you
don’t want volumes to be calculated for that area.
1. Scroll through the Station List to display stations 4+435 to 4+620.
Note: Notice that both the stations are color coded red for stop and green for start to
show that the stops and starts are entered. The program also duplicates the station
when a start or stop is created.
2. Select station 4+435 on the Station List.
3. Right-click to display the menu and select Stop/Start. The Insert Station Attribute
dialog box is displayed for the selected tation.
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4. Leave the Stop Highway checkbox checked and click OK to continue.
Note: The dialog box opens with the Stop Highway checkbox checked to signify
that volumes will stop being calculated from that station forward. The Stop can be
removed by clicking the checkbox off.
The Start Station, 4+620 is green to show its status. If you selected it, the above
window would show the Station Number with the Start Highway checkbox hecked.
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Lesson 4 — Advanced Topics - Creating Surface Models
The previous lessons covered three basic tasks performed in Highway 4D to create a
model and generate volume reports for your highway job. This lesson covers advanced
topics for using existing CAD or Earthwork 4D data to create models, create typicals for
fast highway entry, and generate 3D models of a Highway job. The following are covered in this lesson:
•
•
•
•

Creating 3D Models with Imported COGO and Cross Sections
Surfacing Multiple Alignments with Starts/Stops
Perfecting Models from Digitized Cross Sections
Creating a Highway Job from Earthwork 4D

Creating 3D Models with Imported COGO and Cross Sections
Using existing COGO and Cross Section data, you can create a 3D model of your highway job by importing COGO and Cross Section information, then generating the model.

Import COGO
•

Open the “Vasco.CGO” file. The imported COGO is displayed in the main window.

The COGO includes the station equation entered in the previous tutorial and is the
entire Vasco Road example.
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Import Cross Sections
Highway 4D can import a variety of electronic cross-section files. In this example, you
will use the ROG/RDS format.
1. Click the Cross Sections (C) button to change to the Cross Sections mode.
2. Select File>Import then select “Vasco.ROG” and click Open to import the existing
ground sections. The Cross Sections window displays only the Existing Ground lines.
Note: The Import window automatically displays all files to avoid missing readable
data. If the extension is not recognized by the program, you’ll be prompted to pick a
type and layer destination.

3. Select File>Import again and select “Vasco.RDS” and click Open to import the
Design. The Design section lines display and the station end areas calculate. Your
screen should look like the illustration on the next page.
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With what you have here, you can calculate volumes and create a model.
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Create the Model
Highway surfacing takes the COGO and attaches the cross sections perpendicular to the
COGO. Highway data surfaced into Earthwork 4D is no different than any other Earthwork 4D data. It may be edited, added to, or deleted as required.
1. Click the Surface Creation (S) button over the Station List to start creating your
model. The Highway Surface Modeling dialog box is displayed.
Moving left to right on the options, both the Design and Existing surfaces must be
created from the cross sections. There is only one alignment present, so the Render
Last is always on. The Use Vertical COGO option just means that the cross sections are moved, when required, to match the vertical COGO. Vertical COGO Offset
is used when the cross sections are at subgrade and you must compensate for the
difference from the finish grade COGO. Grade Point Offset is used only when the
Vertical COGO is specified as an offset location from the Horizontal COGO.
2. Click OK to start the surface creation

Your screen should look similar to the illustration below.
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3. Select a point on the highway surface and zoom in to get a closer look. Your screen
should look like the illustration below.

The given cross sections display as heavier light-blue lines while the intermediate interpolated sections are displayed as thinner lines. The thicker lines also have a line label that
represents the station location. Highway 4D automatically generates a Design perimeter
for the boundaries of the design sections and an existing perimeter to the limits of the
existing sections.
To see the three-dimensional terrain, press the T key or select Display>Terrain. Selecting any point on the plan view overlay moves the view to that point. The view may be
rotated by pressing the R or L keys.
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Visual Verification with the 3D Window
The Edit mode terrain view works for examining and editing but the 3D View is preferred
for verification. Click the 3D View button to display the job in 3D and visually verify the
model.
The 3D View displays a view similar to the Edit window with Terrain on. The difference
is that the 3D window allows you to drive over the site with the arrow keys and more
readily manipulate the view

When Highway data is present in the 3D view mode, you do not need to enter a drive
path. An automatic drive-through feature, using the center line as the drive path, is automatically created from the COGO data.
•

Click the Play button and the program begins driving down the highway. Underneath
the view controls, the current station displays as the vehicle passes over it.

•

Click the Pause button to stop the drive without later having to restart at the begin
ning.

•

Click Pause again to restart the drive.

•

Click Stop to reset the drive to the beginning.

•

The speed of the drive can be changed by selecting Edit>Vehicle Arrow Rate and
increasing or decreasing the number to change the speed.

1-43

Highway 4D Tutorial

Surfacing Multiple Alignments with Starts/Stops
The CA_49 tutorial file contains multiple alignments and starts and stops. Highway 4D
allows you to create a job with multiple starts and stops so you can generate accurate
volume reports and create a 3D model of the job.
1. Click the Surface Creation (S) above the Station List to start the surfacing process.
The Highway Surface Modeling dialog box is displayed. Note the following:
• This job has five alignments and CA_49 has Render Last selected. CA_49 is the
primary alignment and the others are crossing roads. When you select Render
Last for this alignment, Highway 4D surfaces the crossings first. In doing this,
the CA_49 surface takes precedence over the cross roads where they overlap.
• Vertical COGO offset is not zero. The cross sections in this file are taken off
at subgrade, but the vertical COGO is specified at finished grade. Entering the
elevation difference between finished grade and subgrade allows Highway 4D to
correct the cross-section centerline elevations without moving them too high to
finished grade.
2. Leave the settings of the Surface modeling window unchanged and click OK to create the surface. The program calculates the surface and changes to edit mode. Your
screen display should look similar to the illustration on the next pae.

1-44

Highway 4D Tutorial

Notice that there some areas where the highway stops and then begins again. When the
Starts and Stops are specified in the Station list, the program will not create the surface
for the specified station ranges. Pick something near the upper gap in the highway and
zoom n.

While the COGO line continues through the gap, the program inserts Design Perimeters
to surround only the used cross sections. This prevents volumes from being calculated
outside the perimeters and from showing any Design in those areas in the Terrain view
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Inspect the Job
When multiple alignments are surfaced, duplicates of design perimeters can cause
holes to display in the 3D Surface. To remove these holes:
1. Select the Design Surface and Perimeters Layer.

2. Zoom in to the planview and select the innermost design perimeter line.
3. Press the Delete key on the keyboard or select Edit>Delete.
4. Select Options>Stage Design to view how the design ties in with the existing
ground data.
5. Click the 3D View button to switch to 3D View mode.
6. Click the Play button on the Utility Toolbar to play a recorded path down the centerline of the road to inspect the job.
7. Mistakes or design anomalies can be corrected by entering or editing the cross sections.
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Perfecting Models from Digitized Cross Sections
There are two phases to highway jobs: bidding and building. While digitized cross sections are sufficient for estimating, building the job demands more precision from the
model and requires COGO and precise sections for the best results. The process described below details a technique used to take the already entered COGO and cross
sections to build an accurate model of the job, including and replacing the travelway
portions of the roadway with precise typical-based sections.
Travelway Transitions are used to accurately calculate width and slope transitions when
creating a highway model, such as lane widenings or superelevations. Generally there are
typical cross sections that define the parameters of the roadway. Width transitions can
be found on the plan sheets, while slope transitions are typically shown on the profile
sheets. Horizontal and vertical COGO, as well as cross section data, are required to enter
travelway transitions. This lesson uses the “Vasco Road HW4D.esw” file, which already
has cross section and COGO information entered.

Enter Travelway Transitions
1. Open the Vasco Road HW4D.esw” file. The job opens in the Cross Section window.
2. Select Edit>Copy Alignment and enter a name for the new alignment.
3. Select Edit>Travelway Transitions and enter the number of segments to the left and
right side of the reference point, which is normally centerline of the travelway, then
click OK to continue. For this example, there are two segments on each side of centerline.
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Typical Sections Worksheet
Name

Begin Step

End Step

Station

1007+15

2

1007+58

4

1007+69

-2%

12
-5%

12

-2%

12
-2%

Segment 4
Width Slope

2

-2%

-5%

12

4

1009+80

8

12

12

8

1+54

6%
8

5+10

6%
12

6%
8

8+95

12

24
-5%

8

-6%

6%

8

12

24

-6%

-6%

-2%

-5%

4

12

9+40

-6%
8

-2%

-5%
8

12.62

Begin Step

9+68.5

-5%

-2%

-2%

-5%

End Step

13+06

4%

4%

-4%

-5%

15+13.4

8

24

24

8

23+08.06

8

24

24

8

25+75

8

12

24

8

Begin Step

25+82

4%

4%

-4%

-5%

End Step

29+19.5

-5%

-2%

-2%

-5%

Begin Step

31+65

-5%

-2%

-2%

-5%

33+07

8

12

24

8

33+32

8

12

24

6

35+50

-6%

-6%

6%

6%

56+53

-6%

-6%

6%

6%

50+38

-5%

-2%

-2%

-5%

54+00

8

12

24

6

60+00

6

24

24

6

82+17.5
86+05
1-48

12

Segment 3
Width Slope

4

8+13.37
End Step

-5%

Segment 2
Width Slope

1008+55

2+13.67
Begin Step

Segment 1
Width Slope

-5%
6

-5%

-2%
24

-2%

-2%
24

-2%

-5%
6

-5%
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4. Press the Tab key to enter the first Travelway Transition then enter a width of “2”
for segment 1, “12” for segment 2, “12” for segment 3, and “2” for segment 4.
The default values for slope are already correct. The numbers in black are fixed
values, while the red numbers are interpolated. This is very important to remember
when both width and slope transitions are occurring at the same tme.

5. Click Next and type “100758” to define the next travelway transition Station.
6. Enter a width of “4” for segment 1 and “4” for segment 4. Click on segments 2 and
3 to keep them fixed at 12. The slope does not change, so the values can be left
interpolated.
Note: When you click on the number it changes from red (interpolated) to black (entered).
7. Click Next and type “100769” to define the next travelway transition Station.
8. Check the Begin Step box, then click on each of the slope fields to set the fix the
values, leaving the width values interpolated.
Note: This station begins a Step Transition. When transitioning from a full crown
section to a full superelevation section, the outermost segment will change until it
matches the slope of the next segment. This continues until all segments are at the
desired slope.
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9. Click Next and type “100855” to define the next travelway transition Station.
10. Click on the width for each segment, making them fixed at their current values, leaving the slopes interpolated.
11. Click Next and type “100980” to define the next travelway transition Station.
12. Enter a width of “8” for segment 1 and 4, then click on the width for segments 2
and 3 to set them fixed at 12. Leave the slopes interpolated since we are still in a
transition.
13. Click Next type “154” to define the next travelway transition Station.
14. Check the End Step box, then enter “6” for the slope of segment 1, “6” for segment
2, “-6” for segment 3 and “-6” for segment 4. The widths remain interpolated.
Note: This station represents the full superelevation, which will end the step transition.
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15. Click Next and continue entering Travelway Transitions from the Typical Sections
worksheet. Your screen should look similar to the illustration beow.

Surface the Job
1. Click the Surface button to start the creation of the 3D Surface model. The Highway
Surface Modeling dialog box is displayed.
2. Select the renamed alignment to Render Last and click OK to create the 3D Surface.
By selecting the travelway precise section to render last, you can substitute your
precise roadway for that portion of the digitized sections.
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Creating a Highway Job from Earthwork 4D
In some situations you may want to create Highway Data from an Earthwork 4D file. In
the following example, you will enter a profile and then generate Horizontal COGO and
Cross Sections that create the highway data.
1. Double click the Earthwork 4D shortcut or select Start>Programs>AGTEK>
Earthwork 4D. In the Open dialog box select the “Vasco Earthwork 4D.esw” file and
click OK.
2. Choose the line you want to use for the reference line. The line may be a data line or
an annotation. This line will be used to create the profile to generate cross sections
and the horizontal COGO.You may also enter the horizontal cogo as described in Lesson 2.
3. Click the Profile View button on the Selection Toolbar to switch to Profile Mode.
4. Zoom in to the start of the chosen line in the direction of travel. You may want to
select Display>Plus Marks to turn on plus marks if they do not display.
5. Click the Profile Entry button on the Utility Toolbar.
6. The profile line must be entered in the direction of travel for proper stationing. Place
the cursor over the start of the line and press the F8 key to snap to this first point.
7. Use F8 to snap to points along this line, or Line Snap (F8 twice) over the same point
to capture the entire length. Make sure the line is heading in the right direction. Select Utility>Swap Ends to change the line direction.
8. Press the Blank button twice to stop the line and end data entry. The entered profile
line displays the change in elevation along the line in the panel below the planiew.
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9. Click the Station Generator button. The Cross Section Generation dialog box is displayed.
10. Enter a name for the alignment.
11. Enter the station Interval and the Left and Right Offset distance. These are used to
determine how far the cross section is drawn from the center line. In the example, a
300 foot cross section (200 meters left and 100 meters right of the centerline) will
be drawn at stations every 20 meters. Check the Send to Highway checkbox and
click OK to continue. The Enter Highway Name dialog box is displayed.

12. Choose the desired approximation method. For best results, choose Straights only.

12. Enter the Starting Station value, or use the default “0+000”. Click OK to start generating the cross sections.
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the cross sections draw along the profile line and then the screen switches to the Horizontal COGO screen in Highway Mode.

13. Select one of the cross sections. Below the planview the existing and design profile
of the cross section diplays.
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Importing Other Cross Section Data Files
In addition to standard RGS and ROG cross section files, Highway 4D can import other
formats, including AGTEK, CAiCE, GeoPak, InRoads, and MX Roads to create cross sections. This cross section data may need editing after it is imported. This section demonstrates how to import and edit the data.

Import the Cross Section
1. Double click the Highway 4D shortcut or select Start>Programs>AGTEK>Highway
4D. The Open dialog box is displayed.
2. Click the New button to create a new highway file. The Job Information dialog box is
displayed.
3. Enter a Job Name, check the Highway checkbox, select the Units, and click OK to
continue. The Enter Alignment Name window displays.
4. Select File>Import. The Import dialog box is displayed.
5. Find the file to import and click Open. The Highway Import Format dialog box is displayed.
Note: For some imported formats, you cannot determine whether the data is design
or existing, so make sure you are importing the correct file. The name of the file can
often be used to determine if the data is design or existing data.
6. Select the type of the imported file and click OK to continue. In this case, the file
originated from a GEOPAK program. The Highway Layer dialog box is displayed.

7. Select Existing or Design as the destination for the imported data and click OK. If the
imported data was sent to the wrong layer, select Edit>Undo.
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The program switches to the Cross Sections screen of Highway Mode and displays the
imported data. In the example below, only the design data has been imported.
Notice how there are two lines represented in the cross section view. The thin blue line
represents the original imported data. The bold blue line is the actual imported data after
the data has been processed. The original data has points which switch back on themselves. Highway 4D uses this information and creates verticals based on the original
data.
Review the cross sections to ensure that the imported data was interpreted correctly.
Discrepancies typically occur in the design data.

Edit the Cross Section
If you find a cross section that appears incorrect, you can edit the cross section.
1. Double-click the cross section to edit.
2. Click No when prompted to enable the digitizer.
3. Select the Layer to edit and use the Arrow keys to move through the points on the
line. Make any changes and click Apply to apply the change and OK to close the window.
4. Repeat this process for the existing data for any other incorrect cross sections.

1-56

REFERENCE

Section 2

Reference

2-57

REFERENCE

2-58

2-1

Highway 4D Reference

User Interface
To effectively use Highway 4D you will use the 16-button cursor for digitized input, the
mouse for non-digitized entry, and the keyboard for alphanumeric entry and keyboard
shortcuts.

Keyboard
Most tasks are available on menus and the toolbar at the top of the screen, but the tasks
can also be accessed through keyboard shortcuts shown next to the command in the
menus.

The Mouse
Highway 4D uses the mouse throughout the program. A roller-style center button mouse
is recommended. The mouse can be substituted for the cursor for non-digitized entry.
The Left button is used to select objects and choose menu items.
The Right button is used to display the Right Mouse Menu. This menu displays quick access to specific commands in each job surface.
The Wheel Button allows the user to zoom in or out over the location of the arrow (or a
segment if selected) by rolling the wheel Up or Down respectively. Clicking and holding
and moving the mouse allows the user to pan the view on the screen.

Pull Down Menus
Menu commands are selected from pulldown menus by clicking on the menu then clicking on the command. A submenu is noted by an arrow to the right of the command name.
Click on the command with the submenu to view available commands then click on the
command in the submenu to select it. Menus and commands displayed in grey are not
available.

Buttons
A button is selected by placing the cursor over the button and clicking it.

Check Boxes and Radio Buttons
Check Boxes and Radio Buttons are used to display whether an option is enabled or disabled. When filled, the option is on.

Checks
Checks indicate that a certain command option is enabled. These appear in menus and
submenus in Highway 4D.

The Arrow
The Arrow is used for selecting items only.
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The Crosshair
The Crosshair means the program is in data entry mode.

Selecting
Selecting is done by placing the arrow over the object and clicking the mouse. Multiple
items can be selected by pressing and holding the Shift key while selecting the items.

Text Boxes
Text Boxes are used to input values. Select the Text box to add or modify the data. The
text cursor can be moved with the TAB key or by selecting a new textbox.
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Screen Modes
Highway 4D is a companion product to Earthwork 4D and operates in several modes,
each with a different purporse and set of menus and commands to perform specific tasks
associated with that mode. Only Modes specific to Highway 4D are documented in this
manual. For information about other Modes, refer to your Earthwork 4D manual.

Horizontal and Vertical COGO Modes
The Horizontal and Vertical COGO Modes aree usede to enter COGO data from a plan into
Highway 4D. COGO use the coordinate geometry on the plans to describe the line (generally the centerline) from beginning to end. Horizontal COGO describes the X and Y values
of the line. The Z value (elevation) are described by Vertical COGO. The Horizontal/Vertical GOGO modes are used to enter this COGO information.

Cross Sections Mode
The Cross Sections Mode is used to enter cross sections from a plan into Highway 4D.
The Cross-Section Window displays three sections at a time. The Station List on the right
lists all of the stations.
• Click on the upper displayed section to scroll up through the stations.
• Click on the lower section to scroll down through the stations.
• Double-click on the center section or click the Edit/Enter button to edit that station.
• Click in the Station List and use the roller wheel on the mouse to scroll through the
list. The keyboard arrows may also be used to move up and down through the list.

Haul Report Mode
The Haul Report Mode displays the mass haul diagram and the haul report on a split
screen. In this mode, you can change the borrow/spoil for a station, determine the extent
of the volume calculations, and edit the haul brackets.

Other Modes
When the Surface Button is pressed, Highway 4D switches to Edit Mode in Earthwork 4D.
All functionality for Edit, Enter, Profile View, Plan View, 3D View, Volume Report, and
Print Preview Modes is described in your Earthwork 4D manual.
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The Station List Interface
The Station list has its own interface and menu commands. From this menu you can edit,
create gaps in station volumes, adjust the compaction, insert borrow or spoil volumes,
delete stations, and move/copy cross sections. Select a station and right-click the mouse
to display the Station List menu.

Right-Mouse Menu
The following commands are available when you right-click over the Station List

Edit Selected

Opens the Highway Sections dialog box to edit the selected cross sections.

Stop/Start

Enters a stop or start point along the length of hte highway for volume cal
culations.

Compaction

Used to enter a compaction ratio for a range of cross sections to compensate for shrink or swell.

Borrow/Spoil

Used to enter borrow and spoil volumes on stations. Once entered, the Mss
Diagram and Haul reports recalculate for these variables.

Delete Stations

Deletes the selected cross sections.

Move Section

Moves the selected cross section to a designated station.
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Keyboard Shortcuts
Highway 4D contains many commands that can be accessed by both the menus and by
keyboard shortcuts. The keyboard shortcuts of Earthwork 4D also function in Highway
4D. Below is a list of the commands and their shortcuts commonly used with a highway
job. Refer to your Earthwork 4D manual for a description of the other commands.

Changing Modes

e
v
p
h
w
f

Switches to Edit Mode from any other mode. Toggles between Edit and Entry Modes.
Switches to 3D View Mode from any other mode.
Switches to Print Preview Mode from any other mode.
Switches to Highway Mode. Toggles between Highway Mode and Haul Report Mode.
Switches to Plan View Mode from any other mode.
Switches to Profile View Mode from any other mode.

Horizontal/Vertical COGO Modes

µ
²
£¢
¥¤

Deletes the currently selected segment or highlighted text from a textbox.

09
.
³ ´

Used to enter values for COGO. When the cursor is over the Station List, the number
keys jump to the station that starts with that number.

Zooms out to the extents of the job and centers the data on the screen.
Moves the view in the direction of the key press. When the cursor is placed over the
Station List, the arrows move up and down the list highlighting the segment on the
screen and on the list.

Zooms in or Out over the location of the cursor or selected data (Sticky Zoom).

çBackspace

Deletes one character at a time in a selected textbox.

z
¦ p
§ z
§ y

“Sticky Zoom” toggle. Allows zooming over a selected segment.
Sends the currently selected view to the Print Preview Page.
Undo the last edit.
Redo previously undone edit.
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Cross Sections Mode

²
£¢
¥¤
09
.
³ ´
µ
çBackspace

¦ p
§ z
§ y

Zooms out to the extents of the job and centers the data on the screen.
When the cursor is placed over the Station List, the arrows move up and down the
list highlighting the segment on the screen and on the list.
The Number and Period keys are used to enter values for Cross Section. When the
cursor is over the Station List, the number keys jump to the station that starts with
that number.
Scrolls Up and Down the Station List three at a time.
Deletes the currently selected cross section or highlighted text from a textbox.
Deletes one character at a time in a selected textbox.
Sends the currently selected cross section to the Print Preview Page.
Undo the last edit.
Redo previously undone edit.

Haul Report Mode

²

Resets the mass haul diagram vertical scale.

£¢
¥¤

When the cursor is placed over the Station List, the arrows move up and down the list
highlighting the segment on both the mass haul diagram and the list. Place the cursor
over the diagram and pressing the Up/Down Arrows causes the different interval to
highlight on both the report and the mass haul diagram.

³
¦
§
§

´
p
z
y

Increases/decreases the vertical scale of the mass haul diagram.
Sends the currently selected view to the Print Preview Page.
Undo the last edit.
Redo previously undone edit.

Volume Report Mode

¦ p

Sends the currently selected view to the Print Preview Page.
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Tool Bars
Highway 4D utilizes the tool bar function for many of its commands for easy and quick
access. There are two tool bars: Selection and Utility. Click on the button to activate the
command. Below is a list of the commands availalable in Highway 4D. Buttons that are
grey are not accessible. Refer to the Earthwork 4D manual for a description of the other
tool bar commands.

Selection Tool Bar
The Selection Tool Bar is used for opening files, saving files, and printing as well as
switching between the different Modes.
Highway Mode

Switches to Highway Mode.

Haul Diagarm Mode Switches to Haul Diagram Mode.

Utility Tool Bar
The Utility Tool Bar displays different options depending on which window is open. Below
is a list of commands which may display in this tool bar.
Calc Volume

Calculates the volume and displays the Mass Haul Diagram and
Volume Report.

Edit Cogo/
Cross Sections

Enters vertical and horizontal COGO or cross sections, depending on
the current view.

Station North/East

Displays the northing and easting coordinates of a station and to
enter offset points and labels.

Insert/Delete
Borrow/Spoil

Adjusts the volume at a given station.

Insert Stop/Start

Inserts a point to stop or start the highway for calculating the
volume.
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Menus
Highway 4D is a companion product to Earthwork 4D program and has menu commands
not described in the Earthwork 4D manual. In addition, some of the menu commands
function differently in Highway 4D than in Earthwork 4D. Only commands that function
differently or are specific to Highway 4D are documented in this manual. For information
about other commands, refer to your Earthwork 4D manual.

File Menu
The File Menu is used to access files, import files, save job files, setup the printer and
exit the program. Below is a description of the different/additional commands for the
Highway 4D File Menu.

New
Used at the start a new job. When the command is selected, the Job Information dia
log box is displayed

Highway 4D adds the Highway checkbox to specify that this is a new highway job.
in addition to entering the other job data, make sure to check the box to create a
highway job.

Open
Used to open an existing job. When the command is selected, the Open dialog box is
displayed.

Select the file from the list in the window. The name then displays in the File Name text
box. Highway 4D adds the ability to open AGTEK Highway Files (*.esw,*.cgo, *.rds,
*.rog). Click Open to get the file.
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Import
Used to import CGO, RDS and ROG files. When the command is selected, the Import dialog box is displayd.

From the Files of type pulldown, select AGTEK Highway Files to display only highway
files, then select the file from the list in the window. The name displays in the File Name
text box. Click Open to get the file.

Edit Menu
The Edit Menu is used to undo/redo commands, change station equations, edit horizontal/
vertical cogo, add/delete highways and change the elevation of the vertical cogo. Below is
a description of the different/additional commands for the Highway 4D Edit Menu.

Station Equations
Station Equations are used where a project switches to a different stationing system part
way through the job. The Station Equation should be entered before entering any stations.
When the command is selected, the Alignment Starting Station dialog box is displayed

Enter the starting station for the job. A plus mark (+) does not need to be used. For
example, if the starting station is 1007+15, you would enter “100715” and Higway 3D
auomatically inserts the “+”.
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After the starting station is entered, the Edit Station Equations dialog box is displayed

Line 1 represents the starting station alignment. Line 2 is where the first station equation
is entered. A second station equation would be entered on Line 3, and so on. In this case,
the station equation meets at 1010+00 and 0+00. These stations are at the same location on the job. To enter the location where the two station equations meet, click in OLD
STATION on Line 2. Type a value of “101000”. Press the Tab button, or click in NEW
STATION on Line 2 and enter “0”. Entering station equations tells the program where the
two stationing systems meet on the job to maintain proper positioning to one another.

Horizontal Cogo
Used to enter and edit Horzontal COGO data. Much of the information in the dialog box
is calculated and filled in automatically, such as northings and eastings. The line is drawn
relative to the other segments based off the bearings, lengths, and radii. Clicking the Next
button after entering a COGO switches tabs in the following order:
Straight - Curve - Straight - Curve
To enter a segment different from this pattern, use the tabs at the top of the screen to
specify the next segment type.
When the command is selected, the Horizontal Cogo dialog box is displayed. There are
three tabs for entering different types of Horizontal COGO data: Straight, Curve, and Spiral.
Straight
Enter the Station Start, Northing, Easting, Length and Bearing. The Ending station and
coordinates are filled in automaticaly.
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Curve
When entered after a Straight, much of the information in the window is already filled.
The only thing needing to be filled in is the Angle and Radu.

Spiral
A Spiral is a special type of horizonal COGO. It is a type of curve and can be used as
a transition between straight and curved segments. When entered after a straight, the
Length, Angle, Radius, Degree and Curvature must be filled. When entered after a curve,
only the Length and Curvature need to be speciied.

The buttons along the bottom of the dialog box are the same in each tab and are explained below.
Previous

Steps back to the previously entered COGO.

Next

Advanced to the next COGO entered, or to enter a new COGO.

Apply

Applies any changes to the COGO without closing the window.

OK

Applies changes to the COGO and closes the window.

Cancel

Aborts any changes made, unless Apply was clicked first.
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Vertical Cogo
Used to enter elevation change along the length of the roadway. Like the Horizontal Cogo
dialog box, much of the information is calculated and filled in automatically after the first
segment is entered. Clicking the Next button after entering a COGO switches tabs in the
following pattern:
Straight - Curve - Straight
To enter the next segment different from this pattern, use the tabs at the top of the
screen to specify the next segment type.
When the command is selected, the Vertical Cogo dialog box is displayed. There are two
tabs for entering different types of Vertical COGO data: Slope and Curve.
Slope
The Station Start from Horizontal COGO is used. If there is no Horizontal COGO entered,
the default is 0+00. Enter the Slope, Elevation and Slope Length. The Ending Station and
Elevation fill in automatially.

Curve
Enter the Curve Length, Slope and Elevation. Many of the entries fill automatially.

The buttons along the bottom of the dialog box are the same in both tabs and are explained below.
Previous

Steps back to the previously entered COGO.

Next

Advanced to the next COGO entered, or to enter a new COGO.

Apply

Applies any changes to the COGO without closing the window.

OK

Applies changes to the COGO and closes the window.

Cancel

Aborts any changes made, unless Apply was clicked first.
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Cross Sections
Used to enter digitized cross sections from a plan sheet. When the command is selected,
a dialog box is displayed asking to enable the ablet.

Click No to not scale the digitizer or Yes to scale the digitizer. If Yes is clicked, the Tablet
Profile Scaling dialog box is dislayed.

Enter the Vertical and Horizontal coordinates for three points that form a right angle on
one of the cross sections plan sheet. Click OK, then digitize each point in the order you
entered them. Once all three points have been digitized, the Tablet Scale dialog box is
dislayed.

Click OK to accept or Rescale to repeat scaling. If OK is clicked, the Highway Sections
dialog box is dislayed.

Edit/enter your cross sections using the Highway Sections dialog box.
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Travelway Transitions
Used to accurately calculate width and slope transitions when creating a highway model,
such as lane widenings or superelevations. Generally there are typical cross sections that
define the parameters of the roadway. When the command is selected, the Enter Number
of Segments dialog box is dislayed.

Enter the number of segments to the left and right of the reference point, typically the
centerline of the travelway, then click OK. The Travelway Transitions dialog box is dislayed.

Enter your travelway transition Station number, select whether it is a Begin or End Step
transition, and enter the Width, Height, and/or slope of the transitions. Click OK to enter
the transition and start a new transition or Apply to enter the transition and close the
dialog box.

Add Alignment
Used to add a highway to the current job. When selected, the Enter Alignment Name dialog box is diplayed.

Type in the name of the new highway and click OK to add the highway.

Copy Alignment
Copies the current alignment and opens the Enter Alignment Name dialog box to name it.

Rename Alignment
Opens the Enter Alignment Name dialog box to enter a new name for the current alignment.

2-15

Highway 4D Reference

Delete Alignment
Used to remove all COGO and Cross Sections for the current alignment. The current alignment is displayed in the Alignment pulldwn menu.

Select the alignment to delete from the Alignment pulldown menu and select Edit>Delete
Highway. A confirmation dialog box is dsplayed.

Click Yes to delete all COGO and Cross Sections.

Raise/Lower
Used to change the elevation of the Vertical COGO. If there is no Vertical COGO, this
command is not available. When selected, the Raise/Lower Elevation dialog box is
dsplayed.

Type a value in either the Raise or Lower Elevation box. Once a value is entered, the other
box become unavailable. Click OK to adjust the elevation.

Haul Brackets
Used to set the Alignment Haul Brackets on the Volume Report. When the command is
selected the Edit Haul Brackets dialog box is dsplayed.

The Mass Haul Diagram report displays three columns for the Haul Brackets.
0-(Minimum)

(Minimum)-(Maximum)

(Maximum)+

Changing the Minimum or Maximum changes the report by moving quantities to different
ranges accordingly. Type in the desired changes and click OK to change the values.

Highway 4D Reference

2-16

Display Menu
The Display Menu is used to adjust how screen data is displayed. A check next to the
command indicates that it is enabled. Below is a description of the different/additional
commands for the Highway 4D Display Menu.

Arc Controls
Displays arc control points and lines in Horizontal and Vertical COGO Modes.

Station Numbers
Displays the station labels in Horizontal and Vertical COGO Modes.

Arc Coordinates
Displays the arc coordinates in Horizontal COGO Mode if Arc Controls is also selected.

Utility Menu
The Utility Menu is used to display specialized commands used to modify the entered
data. Below is a description of the different/additional commands for the Highway 4D Utility Menu.

Calc Volume
Used to compute the volumes for the current alignment. When the command is selected,
the Highway Volume Calculation dialog box is displayed

Enter the Starting and Ending stations and Left and Right Extent, or check the All Stations
and Total Width boxes. Click OK to start volume calculation.

Calc Accum Volume
Used to generate a Volume Report with a column showing the total cut/fill volumes accumulated from station to station.

Delete Model(s)
Used to delete all previous 3D Models rendered for the job in Highway 4D.
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Break Alignment
Used to break a highway at the end of the currently selected segment. When the command selected, the Enter Alignment Name dialog box is displaye.

The default name appends an incremental value after the current highway name. Change
the name as desired and click OK to break the highway.

Station North/East
Used to display the northing and easting of the selected station, enter labels, and offset
points. When selected, the Station Northing and Easting dialog box is displayed.

To create an offset point, enter a distance with a “-” for Left or “+” for Right. Check the
Label Point box to add a label. Click Apply to enter the changes or OK to enter the changes and close the window.
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Translate Stations
Used to move specified stations into a different station numbering sequence. When selected, the Cross Section Range Selection dialog box is displaed.

Enter the specified stations or check the All Stations box and click OK. All the stations in
the specified range highlight on the right side of the screen and the Translate Station(s)
dialog box is displaced.

Enter the new value for the station numbering and click OK to apply the change.

Insert Curve
Used to insert a curve segment between two straight segments with a user defined radius. When the command is selected, the Edit Curve Radius dialog box is displaed.

Enter the desired radius of the curve and click OK.
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Borrow/Spoil
Used to set a borrow or spoil amount from a selected station. When the command is selected, the Compacted Borrow/Spoil dialog box is displyed.

Enter a Borrow/Spoil amount in the box below the currently selected Station. A Borrow
value is entered as a positive number and a Spoil value is entered as a negative (-) value.

Stop/Start
Used to enter a stop or start point along the length of highway for use in volume calculation. A stop point tells the program to stop calculating at the selected station. A start
point tells the program to resume, or start, calculating at the selected station. When the
command is selected, the Insert Station Attribute dialog box is dispayed.

Enter the Station where the start/stop should be and check Stop Highway or Start Highway to specify if it is a stop or start. Click OK to apply the attribute.
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Surfacing
Surfacing creates a 3D surface by using the COGO and Cross Section data to generate 3D
data lines for the existing and design surfaces and a displays a 3D model of the job. When

the Surface button is clicked, the Highway Surface Modeling dialog box is displayed.
Layer Replacement

Choose Design and/or Existing to replace any existing layers
created by previous surfacing. If you wish to only send one layer,
check the appropriate layer to replace.

Station Interval

Determines the distance between each data line that is created
during rendering. Stations are automatically rendered, regardless of
distance.

Alignment

This is the list of all the alignments (highways) for the job.

Render Last

This option allows you to choose the order in which multiple alignments are rendered to create the 3D Model. Selecting an alignment
to render last uses all other alignments first then layers the selected
alignment over the others.

Use Vertical Cogo

When checked, this option use the elevations from the Vertical
COGO to correct the cross section elevations to match.

Vertical Cogo Offset Changes the Vertical COGO offset if it is based on a location other
than the 0 horizontal location (centerline). For example, to use a
vertical COGO that is offset 7 feet to the left of the centerline, you
would enter “-7”. A negative number offsets to the left and a
positive number offsets to the right.
Grade Point Offset

Changes the vertical COGO offset if the cross sections are at
subgrade, but the vertical COGO is at finished grade. Enter the
depth of the section at the centerline to create a section at
subgrade for the alignment.

Enable Rendering

When checked, this option renders the specified alignment and
over-writes any previous rendering of that alignment with the new
options. If unchecked, the alignment is not rendered and any previous rendering of the alignment remains in the 3D model.
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