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Software Installation Sequence

There are two parts to installing Materials 4D; the program software installation, setting 
up the digitizer, and software protection key installation. Installation must be performed 
in the following order to ensure proper functioning of the software:

1. Materials 4D Software Installation

2. USB/Internet Key Installation

Materials 4D Software Installation

1. Launch your internet browser, most likely Internet Explorer, and go to www.agtek.
com/software.asp.

2. Click the link on the left hand side of the screen for Materials 4D.

3. Enter your AGTEK UserID/Login and Password, then click Login. 

4. Click the Download link, and choose Save.

5. Save the download somewhere easy to find, such as your desktop.
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Installation from an Internet Download

1. Find the downloaded installation file and double-click the icon. 

2. Click Next in the Welcome Dialog.

3. Click Next in the Choose Destination Location dialog box.

4. Select the Allow Internet Key check box, then click Next and the Setup Complete 
box is displayed.

5. Click Finish to complete the installation.

Internet Key Setup - Users

An Internet Key allows multiple users access to a common Materials 4D license. Users 
are added by the Internet Key’s administrator. To use Materials 4D with an Internet Key, 
you must be entered as a user by the key administrator. To check out an Internet Key, 
you need the email address and password associated with your user name. The first time 
you open the software, you will be asked to enter a password and then confirm it. This 
will become your permanent password.

Using an Internet Key

• Obtain and Install the Current Version of the Materials 4D software

• Launch the Software Using an Internet Key

Launching the Program

For instructions on obtaining and installing a current version of the software, see page 
1-1.

1. Double-click the Materials 4D icon on your desktop.

2. If no USB key is found in the system, the Internet Key box is displayed. Click Yes.
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3. Enter you E-mail address and password..If this is your first time using the software, 
Create a password that can be easlly remembered, and click OK.

4. The first time you use the software, you will also be asked to confirm your pass-
word. Enter your password again and click OK.

5. Choose an available Internet Key from the list and click OK. If no Internet Key is 
available you will be unable to use the program until one becomes available. 

6. When closing Materials 4D, the Internet Key dialog box displays and asks if you want 
to release the Internet Key. If you choose not to release the Internet Key, it automati-
cally releases after the time period set by your key administrator has expired.
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 Internet Key  Administration

An Internet Key allows multiple users access to a common Earthwork 4D software 
license. Users are created by the Internet Key’s administrator. As an Internet Key ad-
ministrator you have the ability to add and/or delete users, assign different users to 
each key, and set the number of days an Internet Key can remain checked out. As the 
administrator, a user name is created for you when your software order is processed 
by AGTEK. You need the email address associated with your user name to launch the 
AGTEK Software, and to manage users. The password used to login for the first time is 
your permanent password.

Using a Internet Key

• Launch Software Using an Internet Key

• Manage user accounts

Launch Software Using an Internet Key

1. Double-click the Earthwork 4D Software icon on your desktop.

2. If no USB key is found in the system, the Internet Key box is displayed. Click Yes

3. Enter the email address and password associated with your user name, and click  
OK. 
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 Manage Users

As Internet Key administrator you have the ability to create, modify, delete users and 
set the offline check-out period. To create a user you need the following information for 
each user: first and last name, email address and phone number. You also have the abil-
ity to allow administrator access for other users.

Creating a User

1. Follow steps 1 through 3 in the Launching Software section and the Internet Key 
Selection dialog box is displayed.

2. Select the User Admin tab and click the Add User button. 

3. The Add User dialog box displays.

4. Enter the requested information. If the user is to be an Internet Key administrator, 
select the Internet Key Administrator check box. 
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5. Click OK and the list of all company keys will display

6. Select the programs you wish to assign to the new user.  They may be assigned to 
multiple keys.

7. When the new user logs into the program for the first time they will set their own 
password.

 Deleting a User

1. Follow steps 1 through 3 in the Launching Software section and the Internet Key 
Selection dialog box is displayed.

2. Select the User Admin tab and select the user you wish to remove.
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3. Click Delete User and then Yes to permanently remove the user, or No to cancel the  

operation.

 Right-click Menus

Under the User Admin tab of the Internet Key Selection dialog box you can perform the 
following operations by right-clicking on a user: Allow or Remove Admin, Reset Pass-
word, Cancel.

Allow or Remove Admin: Changes the Administrator status of a user.

Reset Password:  Allows the user’s password to be reset by a Internet Key  
     administraton.

Cancel   Cancels the operation.
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Assigning Users to a Key

As an Admistrator, you may assign different users to each key purchased by your com-
pany. There are two ways to assign users to a key 

1. Follow steps 1 through 3 in the Launching Software section and the Internet Key 
Selection dialog box is displayed.

2. Select the key you wish to assign to the user.

3. Click the Users button at the bottom.

4. Click in the Assigned field to toggle the user on and off.  There may be up to 10 us-
ers per key.
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5. You may also assign users from the User Admin window.

6. Select the user from the list and click the Keys button at the bottom.

7. Click the Assigned field for the keys you wish to assign to this user.

8. Click OK.
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Setting Offline  Check-out Period

The Offline Check-out Period defines the number of days a user can keep a key checked 
out. Once this time period has expired, the key is be checked in automatically. The 
default check-out period is three days.  There are two ways to set the offline Check-out 
period.

1. Follow steps 1 through 3 in the Launching Software section and the Internet Key 
Selection dialog box is displayed.

2. Select the desired key and click the Users button.

3. Enter the number of days you wish to allow a user to check out a key.

4. Click OK.
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5. You may also set the Offline Check-out time from the Internet Key Admin window.

6. Select the desired key from the list.

7. Click the Users button.

8. Enter the number of days you wish to allow a user to check out a key.

9. Click OK.
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USB Port

USB Protection key

USB Protection Key  Installation

Materials 4D uses either an Internet Key or a USB protection key and will not run if a key 
is not available. If using a USB key, install Materials 4D first, then use the diagram below 
to install the USB key before starting AGTEK software .

Do not force the key into a port. If it does not fit, make sure it is right side up and try 
again. Only one USB key should be installed on a computer.
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 Document Conventions

This tutorial uses standard software documentation conventions to explain how the soft-
ware works. These conventions are described below.

Click/click on - Press the left mouse button (assuming the buttons are set to the default 
settings). 

Double-click - Press the left mouse button twice in rapid succession.

Right-click - Press the right mouse button.

Click and hold - Press and hold down the left mouse button.

Shift/Ctrl+click - Press and hold down the Shift/Ctrl key, then press the left mouse but-
ton.

Click and drag - Press and hold the left mouse button, then move the mouse.

Ctrl+(Key) - Press the Ctrl key, then press the keyboard key noted in the step.

Press - Press a specified button a key on the keyboard.

Select - Use the mouse to pick an item on the screen or menu command.

Menu Commands - When documenting a menu command, the command is described us-
ing the following format: Menu>Command. If there is more than one level to the menu, 
it appears as a Submenu. For example, Options>Sound Preference>Sound Card.

Data Entry/File Names - If a file is specified in a procedure, or if specific text needs to be 
entered into a field as part of a procedure, it will appear inside double quote marks.

Zoom In/Out - Use the Page Up/Page Down Keys to increase/decrease the area of the job 
in view. If your system is equipped with a roller-wheel mouse, you can use the roller-
wheel to zoom in/out.

Pan - Select the Pan tool, then click and drag to change the view of the job. If your sys-
tem is equipped with a roller-wheel mouse, you can push down on the roller wheel and 
drag to pan.

Lesson  Examples

Samples files for all tutorials are found in the C:\AGTEK\Data directory.
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 Saving Your Work

You should save your work often to avoid losing data in the event of an accidental clo-
sure or system crash. To Save your work:

• Select File>Save, name your job (if you are saving for the first time), then click the 
Save button.

 AutoSave

AutoSave is a function of Sitework 4D that automatically backs-up your work in prog-
ress at a user-specified interval. With AutoSave enabled, Sitework 4D automatically asks 
you if you wish to open the most recent backup of the last open job file in the event of 
accidental closure or the computer crashes. An AutoSave will not occur unless at least 
one manual save has been completed. Even though the AutoSave function automati-
cally saves the job, it is good practice to frequently save the job manually. To edit the 
AutoSave interval:

• Select Options>AutoSave, then set the interval in the Edit Autosave Minutes dialog 
box. A check next to the command on the menu indicates that it is enabled.

AutoSave allows you to set the interval between saves from 5 and 60 minutes. By 
default, the program sets the save interval to 5 minutes. It is recommended that this 
feature not be disabled. However, if you wish to turn off the Auto Save function, select 
the Disable check box, and click OK.

The  Autosave.esw File

Autosave automatically saves to a file named Autosave.esw. The Autosave.esw file is 
located in the current working directory. This file is only created when the amount of 
time passed is greater than both the AutoSave interval and the amount of time since the 
last Save command was executed. If Earthwork 3D is closed using the Exit command 
from the file menu, any autosave file is deleted. If an autosave file is opened, be sure 
to save the file and either change the name of the file or choose the previous version of 
that file and overwrite it.
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PDF  Entry Overview

Sitework 4D can be used for dirt takeoff purposes when there is no CAD file available. 
This tutorial illustrates how to digitize a job using the images found in PDF, and TIF files, 
as a virtual plansheet. TIF files are treated the same as PDF files that contain no vector 
information.

PDF   Guide

In the Guide menu, Sitework 4D contains guides for PDF, CAD, Tablet, and Haul Plan 
entry. This tutorial focuses on PDF entry. The PDF Guide can be accessed by selecting 
Guide>PDF or by pressing the G key. When a procedure is selected from the Guide, 
Sitework 4D will change to the proper mode, surface, and layer necessary for that proce-
dure. The Guide displays a check mark in the corresponding box when an operation has 
been completed.
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Data Entry Sequence

The following is the suggested data entry sequence when entering a takeoff using a PDF 
file.

Import and Scale PDF File

• Start a New Job
• Import the PDF
• Scale the Image and Verify Accuracy

Enter Existing Data

• Enter Existing Perimeter
• Enter Existing Data Lines
• Enter Stripping Areas

Enter Design Data

• Enter Design Data Lines
• Create Offset Lines
• Enter Design Perimeter
• Enter Report/Sectional Areas

Review Graphics

• Confirm Accuracy with 3D Mode

Compute Volumes

• A and V buttons
• Understanding the Report

Print Reports

• Send Report to Print Page
• Printing PDF
• Send Other Views to Print Page
• Send Images to Print Page
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Lesson 1 -  Importing and Scaling PDF File

This lesson will demonstrate how to import the Pine Street.pdf file, scale the file and re-
view the accuracy of that scale. Training videos discussing PDF takeoffs can be found at 
http://www.agtek.com/trainingvideos.asp. It is recomended to watch the training videos 
before begining the tutorial.

Start a  New Job

1. Double-click the Sitework 4D shortcut on the desktop or select Start>All 

Programs>AGTEK>Sitework 4D, and the Open dialog box is displayed.

2. Click New to start a new job and the Job Information dialog box is displayed.

3. Enter a Job Name, Builder, Bid Date and Operator. Set the Units to Feet and click 
OK. Sitework 4D opens in the Entry Mode with a black screen.

 Import the PDF

1. Select File>Import, or press the G key and select Import PDF File from the PDF Entry 
Guide, and the Import dialog box is displayed.

2. Select “Pine Street.pdf” from the C:/AGTEK directory, and click Open. The PDF im-
age is displayed in the CAD Transfer Mode.

When opening an 

existing file, the PDF 

used to create the file 

may be re-imported 

by positioning the 

arrow inside the sheet 

annotation border and 

pressing the Insert key 

on the keybboard or by 

selecting the annotation 

sheet border, right-

clicking, and selecting 

Import File.
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3. The L key rotates the image counter-clockwise while the R key rotates the image 
clockwise. Press the L key twice to properly align the drawing on the screen. It 
should appear similar to the illustration below.

(Optional)  Vectorize Image

When a PDF is imported it has either a green or red border. A red border indicates the 
file is a raster PDF and has no line work data available. A green border indicates a vector 
PDF and contains the information necessary to vectorize the file and create line work. 
That line work can then be transferred and turned into 3D data as though it were a CAD 
file. For information on transferring data and converting it to 3D, please see page 3-2 for 
the Modeling Tutorial

 Scale the Image and Verify Accuracy

1. Most PDF’s contain the scale of the image. Zoom into the lower-right side of this job 
and you can see that we are using a 20 scale.

2. Select Data Transfer>Image Scale, or press the G key and select Scale Drawing 
from the PDF Entry Guide, and the Edit Image Scale box displays.

IMAGE SCALE
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3. Enter “20”, and click OK.

4. A dialog box displays advising you to verify the scale of the drawing using a known 
distance. Click Yes to check the scale

5.  From the typical section, we can see the width of the road from back of curb to back 
of curb should be 40 feet.  Enter two points on the plan on the back of curb lines on 
both sides of the street.

Lesson 2 - Enter Existing Data

This lesson demonstrates entering the existing conditions of the job site, as well as the 
site limits and stripping areas.

Enter  Existing Perimeter

The existing perimeter represents the limits of the job site. It also gives the computer a 
place to stop calculating, which will speed up volume calculations.

1. Press the E key to switch to Entry Mode and set the Surface to Existing and the 
Layer to Perimeter, or press the G key to open the Guide, and select Enter Existing 

Perimeter from PDF Entry Guide.

2. Zoom in to the lower, left portion of the job site.

3. Find the dashed line that surrounds the entire job site. Click on the lower-left corner 
of the dash line.

4. Pan to the right and click on the lower-right corner of the dashed line.

5. Click on the remaining two corners of the same dashed line.

6. Right-click to end the entry. Sitework 4D will automatically snap the Existing Perim-
eter closed. 
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7. Press the Home key on the keyboard to Zoom out and center the job. Right-click to 
get your arrow back.

8. The screen should like like the illustration below.

Enter  Existing Data Lines

Existing data lines create a 3D representation of the ground prior to work being done.

 Contour Lines

1. Confirm the Surface is set to Existing and change the Layer to Data Lines, or press 
the G key to open the Guide, and select Enter Existing Data Lines from the PDF Entry 
Guide.

2. Zoom into the lower left-hand portion of the job site and locate the contour with a 
247 elevation. Enter the “247” using the keyboard.

3. Begin the 247 contour by clicking at the end of the contour line.

4. Move along the contour line, clicking your mouse to enter points as you go, and 
right-click when the contour is completed. 

If you make 
a mistake 
entering a 
contour, press 
Backspace to 
delete the last 
point entered.

247 CONTOUR
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5. Repeat steps 3 and 4 to enter the remaining contour lines. For now, leave the closed 
contours in the middle of the job alone. After the entering the second consecutive 
contour, the program will enter Auto-icrement mode and jump to the next elevation 
for automatically i.e.: 248 will auto-icrement to 249. Right-click to get your arrow 
back, then press the T key and your screen should look similar to the illustration be-
low.

6. Press the T key twice to bring the PDF back.

7. Click the Save button to save your work.

 Closed Contours

1. Begin with the closed, 254 contour in the top-left portion of the job.

2. Enter “254” on the keyboard. Click along the line to enter points.

3. When nearing the start point of the data line, move the cursor over the starting point 
of the line and press the F8 key to snap the contour closed. 

4. A red 254 appears in the point list on the right if you have snapped the line closed 
correctly.

5. Right-click to end the entry.

Placing 
points only 
at the sharp 
angles of the 
M shaped 
contours 
results in 
straighter 
lines.

254 Contour
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6. Repeat the above process for the remaining closed contours. Right-click to get your 
arrow back, then press the T key and your screen should look similar to the illustra-
tion below.

7. Press the T key twice to bring the PDF back.

 Spot Elevations

1. Locate the 246.5 spot elevation in the lower-left portion of the job site.

2. Enter “246.5” on the keyboard.

3. Click on the 246.5 spot elevation.

4. Right-click to end the entry.

246.5 Spot Elevation
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5. Repeat this process to enter the remaining spot elevations. Right-click to get your 
arrow back, press the Home key, then press the T key and your screen should look 
similar to the illustration below.

7. Press the T key twice to bring the PDF back.

6. Click the Save button to save your work.

Enter  Stripping Areas

The stripping area removes a uniform depth from the existing ground surface.

1. Verify that Surface is still set to Existing and change the Layer to Stripping Areas. 
Click the Add Regions button, or press the G key to open the Guide and select Enter 

Stripping Areas on the PDF Entry Guide. The Stripping Areas dialog box displays.

2. Enter “Stripping 1” for the Area Name and “.5” for the Stripping Depth.

3. Click where the side walk for Gregory Lane intersects with the property line behind 
Lot 1.

Begin Stripping 
Area Here

4. Pan up to, and click, where the same sidewalk intersects with the property line be-
hind Lot 4.

5. Pan to the right, and click on the point labeled with a Northing/Easting at the far right 
of the job.

6. Continue down, and click on the point labeled with a Northing/Easting at the bottom-
right of the job.
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7. Right-click to end the entry. Sitework 4D will snap the Stripping Area closed for you. 
Right-click to get your arrow back, press the Home key, then press the T key and 
your screen should look similar to the illustration below.

8. Press the T key twice to bring the PDF back.

9. Click the Save button to save your work.

Lesson 3 - Enter Design Data

This lesson demonstrates entering data for the intended design including subgrade and 
the limits of construction.

Enter Design Data Lines

Enter  Building Pads

1. Change the Surface to Design and the Layer to Data Lines, or press the G key and 
select Enter Design Data Lines from the PDF Entry Guide.

2. Find Lot 1 in the lower-left portion of the job and enter the “251” elevation using the 
keyboard.

3. Click on the bottom-left corner of Lot 1.

4. Continue tracing the line for Lot 1, clicking on the corners and using multiple points 
to create the curve on the top right. Before completing the lot, put the cursor over 
the start point of the lot line and press F8 to snap the line closed.

5. Right-click to end the entry.

6. Repeat the above process for the remaining lots. The more points you use tracing the 
curves, the smoother your curves will be. Be sure to snap all pads closed using the 
F8 key.
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8. Press the T key twice to bring the PDF back.

9. Click the Save button to save your work.

Enter Retaining Wall

1. Zoom in to the retaining wall behind Lot 2.

2. Enter the top of wall elevation of “253.5”.

3. Beginning at the top, click on the corners of the retaining wall. Be sure that you do 
not cross the data line representing Lot 2.

7. When finished, press the Home key to zoom out and center the job. Right-click to 
get your arrow back, then press the T key and your screen should look similar to the 
illustration below.



Sitework 4D PDF Tutorial

2-14

4. Right-click to end the entry.

Enter Curb Lines

This exercise enters data lines with varying elevations.

1. Zoom into the left, center portion of the job and locate the top of curb line labeled 
246.9.

2. Enter “246.9” using the keyboard and click on the beginning of the curb line.

3. Continue to follow the curb line, clicking to enter points as you go.

4. When you come to the first elevation change, enter “247.9” using the keyboard.

5. Move the cursor to the next elevation change, enter “248.7” on the keyboard 
and click on the elevation change. This keeps the line between the two elevations 
straight.

6. Continue the same process, entering elevation changes as you come to them, until 
you reach the 252.6 elevation at the top of the job.

7. After entering the 252.6 elevation, right-click to end the entry and move directly 
across the street.

Retaining Wall
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8. Beginning with the 252.6 elevation, enter the second top of curb line using the 
process outlined above. When finished, right-click to get your arrow back, press the 
Home key, then press the T key and your screen should look similar to the illustration 
below.

9. Press the T key twice to bring the PDF back.

10. Click the Save button to save your work.
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 Offset Line Editor

This exercise uses the Offset Line Editor to create the street by offsetting the top of 
curb line. Offset lines are created by choosing distance and elevation or slope differences 
from a chosen reference line. The features of the Offset Line Editor are explained below. 
For more information regarding offset lines, see page 8-92.

Creating Offset Lines

1. Press the E key to switch to the Edit Mode, and click on the top of curb line nearest  
Lot 4.

2. Shift+Click the remaining top of curb line.

3. Click the Offset Line Editor button, and the Offset Line Editor box, as seen on previ-
ous page, displays.

4. To create the back of sidewalk lines set the Offset Direction to Right.

5. Be sure Connectors, Points Every, and Daylight are unchecked.

6. Enter “5.5” for the Offset Distance and “2” for the slope.
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7. Click the View button for a preview of the offset lines.

8. Click Apply, and then Close to enter the offset lines and close the Offset Line Editor 
box. When finished, press the T key and your screen should look similar to the illus-
tration below.

9. Press the T key twice to bring the PDF back.

Enter Design Contour Lines

1. Press the E key, or click the Entry Mode button, to switch to Entry Mode.

2. Zoom into the bottom-right portion of the job and locate the 252 design contour.

3 Enter “252” using the keyboard.

5. Enter the design contour lines by tracing the line with the mouse, clicking as you go.

6. Right-click to end the entry.
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7. Repeat the above process for the four remaining contour lines. When finished, Right-
click to get your arrow back.

8. Switch to the Edit Mode and press the T key. Your screen should look similar to the 
illustration below.

9. Press the T key twice to bring the PDF back.

10. Click the Save button to save your work.

Enter  Design Perimeter

The Design Perimeter represents the limits of construction of your job. The Design Perim-
eter also tells the computer where to limit it’s volume calculations. The Design Perimeter 
overrides all regions, sections, and areas, i.e. all dirt within the Design Perimeter will be 
counted, while all dirt outside of the Design Perimeter will be excluded from calculations. 
When the Design Perimeter is entered, you are asked to drape a Daylight line, at existing 
elevations, under the Design Perimeter. This will provide a smooth transition from the 
design to the surrounding conditions of the job site.

1. Press the E key to switch to the Entry Mode and set the Surface to Design and Layer 
to Perimeters, or press the G key, select Enter Design Perimeter from the PDF Entry 
Guide.

2. Right-click anywhere on the job and select Display>Stripping Areas.

3. Snap to the lower left corner of the Stripping Area using the F8 key. 

4. Continue to the right and then up, snapping to the corners of the Stripping Area as 
you encounter them.
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5. Continue to left, across the top of the Stripping Area. When you come to the street, 
extend the perimeter beyond the street. Use the F6 key to snap to the stripping line.

6. Continue to the left, and click on the top-left corner of the Stripping Area.

7. Continue down, extending the perimeter beyond the street.

8. Before returning to the starting point of the Design Perimeter, right-click to snap the 
perimeter closed. 

9. Zoom in on the area behind the retaining wall at Lot 2 labeled “No Grading within 
Drip Line.”

10. Enter a second Perimeter around the area behind the retaining wall by clicking at 
each of the corners. Be sure the Design Perimeter does not intersect with any design 
data lines.

11. Right-click to close the second perimeter and create a  hole in the job. The contents 
of this hole will be removed from the calculations.

Entering a 

perimeter 

withing a 

perimeter 

creates a hole 

in the job. Dirt 

quantities are 

not calculated 

withing 

this second 

perimeter.

Design Perimeter

Design Perimeter
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12. Right-click a second time and the Apply Drape Line dialog box is displayed. Click 
Yes. Right-click to get your arrow back, then press the T key, and your screen 
should look similar to the illustration below.

13. Press the T key twice to bring the PDF back.

Enter  Report/Sectional Areas

Report Regions are used to break a job up into individual areas for calculation on the vol-
ume reports. Sectional Areas are used to modify the design surface by subtracting their 
depth from the design surface and then listing the area individually on the volume report.

Break Out the Building Pad Areas

1. Switch to the Entry Mode. Click the Add Regions button, or press the G key, and se-
lect Enter Report/Sectional Areas from the PDF Entry Guide, and the Report Regions 
dialog box is displayed.

2. Enter “Lot 1” for the Region Name and “.5” (six inches) for the sectional depth (On 
a metric job .5 equals half a meter, or 500mm).  You may also enter a Fill Factor to 
account for compaction. Enter 1.15 for 15 percent compaction. Click OK.

3. Move the cursor over the corner of Lot 1 and Line Snap (press the F8 key twice in 
rapid succession) to the entire building pad.

4. Right-click to end the entry.

5. Repeat step 3 for the remaining building pads. Sitework 4D auto-increments the pad 
names (Lot 1, Lot 2, Lot 3...). Right-click to get your arrow back.

For the auto-

increment 

to function, 

the region 

name must 

be entered 

with a space 

between the 

name and the  

number as in 

the example.

HOLE
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Enter Street Area

1. Click the Add Regions button, or press the G key and select Enter Report/Sectional 

Areas from the PDF Entry Guide, and the Report Regions dialog box displays.

2. Enter “Street” for the Name and “1.33” for Sectional Depth.

3. Zoom into where the street meets Gregory Lane. Move your cursor over the South-
ern TOC line and Line Snap (press F8 twice in rapid succession on the same point) to 
the top of curb line.

4. Move the cursor to the top of the job, above the selected top of curb line, and press 
the F8 key once. The snapped line will attach itself to the cursor.

5. Move directly across the street and Line Snap (press F8 twice in rapid succession) to 
the other top of curb line.

6. Move back to where the street meets Gregory Lane, move the cursor above the end 
of the top of curb line and press F8 once.

7. Right-click to snap the region closed, and end the Entry. Right-click again to get your 
arrow back.

Enter A Final Report/Sectional Area

Entering a final Report/Sectional Area will make sure that all dirt is included in a Report 
Region. Any dirt left outside of a Report Region will be listed as Unspecified on the re-
port.

1. Click the Add Regions button, or press the G key and select Enter Report/Sectional 

Areas from the PDF Guide, and the Report Regions dialog box will display.

2. Enter “Landscape” for the Name and “0” for Sectional Depth and click OK.

3. Move the cursor over a corner of the Design Perimeter, and Line Snap (press F8 
twice in rapid succession on the same point) to snap to the Design Perimeter.

4. Right-click to end the entry. Right-click to get your arrow back, then press the T key 
and your screen should look similar to the illustration below.

“Landscape” 

is used for 

this example 

because it 

will primarily 

in clude the 

landscape/

grass areas 

around the 

building pads.

You may 

enter the 

Sidewalks 

in a similar 

manner using 

a sectional 

depth of .33
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5. Press the T key twice to bring the PDF back.

6. Click the Save button to save your work.

Lesson 4 - Review Graphics

The creation of 3D surfaces allows comparison of the surfaces for volumes. This lesson 
demonstrates how to verify the accuracy of the job with the 3D view, and specify the 
area to calculate and generate the volumes. The  3D Mode in Sitework 4D can be used to 
verify the accuracy of the job data. Using 3D controls to inspect the 3D surface and look 
for any errors which may have occurred during the data entry.

1. Switch to the 3D Mode, or select press the G key, and select Review Graphics from 
the PDF Guide. Make sure the Ref is set to Subgrade and the Dif is set to Stripped.

2. Use the controls described below to inspect the 3D surface for mistakes.

Toolbar  Use the Toolbar to change the reference (Ref) and difference (Diff)  
   surface to compare different surfaces in 3D View.

Overlay  The Overlay is the two-dimensional plan view of the job. Clicking  
   on the Overlay moves the view to that position.

Terrain  The Terrain is the three-dimensional representation of the job. Use  
   the Arrow keys to move around the Terrain View.

3D Controls  Use the 3D controls to inspect the terrain for any errors and to see  
   how all of the data you have entered displays on the job. 

Be sure the 

finished 

surface (the 

surface you 

are calculating 

to) is on the 

left, and the 

begining 

surface (the 

one you are 

calculating 

from) is on 

the right.

3D Controls
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 Driving

Driving the 3D View is the easiest way to double check your work and the surface qual-
ity. It also can display the Subgrade and Stripping surfaces and calculate volumes.

Use the Arrow keys on the keyboard to drive through the site. The Up and Down arrows 
move forward and back. The Right and Left arrows turn. For additional clarity, you may 
want to turn the Overlay off by pressing the O key or by selecting Display>Overlay. 
The speed of the drive is based on the Arrow Rate setting, which is located on the Edit 

menu. Each arrow key press has a distance that the Arrow Rate controls. The speed of 
your computer and video adaptor can also affect screen speed.

Try using the 3D controls to change the views and get a feel for what they do. Also try 
changing the Reference and Difference surfaces to see the different views and compari-
sons.

Cut or Fill amount at 
the current location

Line Label of 
selected point

Northing of 
selected point

Easting of 
selected point

Horizontal distance 
between selected point 

and current location

Slope between 
selected point and 

current location

Point Label of 
selected point

Elevation of 
selected point

Vertical distance 
between selected 
point and current 
location

Launches Help

Changes the 
viewing angle

Increases/decreases 
the viewing distance 

behind the vehicle

Drives forward 
and back

Turns the view 
left and right

Increases and 
decreases the 
elevation skew

Toggles between 
ground and aerial view
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Lesson 5 -  Calculating Volumes

Once the model has been verified, and any changes have been made, you can calculate 
volumes and compare surfaces.

1. While still in 3D Mode, specify the Surfaces to be used. For our example, set the 
Reference surface to Subgrade and the Difference surface to Stripped.

2. Define the  Volume Area. Click the A button on the Utility Tool Bar to create a bound-
ing box (using the Design Perimeter) around the entire job. This determines the limits 
of the volume calculation. 

3. Calculate the Volume. Click the V button on the Utility Tool Bar, or select 
Utility>Calc Volume, to begin volume calculations

During the volume calculation, cross sections display at the bottom of the screen with 
blue representing the Subgrade and green the Stripped surface. A line displays on the 
overlay showing the corresponding location of the cross section. The calculation can be 
paused by pressing the Spacebar or aborted by pressing Esc. When paused, the I key on 
the keyboard will move across the site incrementally. Pressing the Spacebar again will 
resume the volume calculation. When the calculation finishes, the Volume Calculation 
Results are displayed.

Cross Section 
Display

Be sure the 

finished 

surface (the 

surface you 

are calculating 

to) is on the 

left, and the 

begining 

surface (the 

one you are 

calculating 

from) is on 

the right.

Cross Section 
location
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These numbers represent uncompacted cut and fill between the two surfaces. The 
Horizontal Area represents plan view areas with no slope adjustment and is broken down 
into Cut, Fill, and On-grade square footage. Slope Area represents a slope adjusted 
square footage. It is the total surface area, excluding vertical surfaces like curb faces. 
Press Done to close the dialog box. These volume numbers can be recalled by clicking 
the Volume Report button on the tool bar.
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The  Volume Report 

Once you click Done in the Volume Calculations Results dialog box, the Volume Report is 
displayed. You can also access the report after volumes have been calculated by select-
ing Window>Volume Report, or by clicking the Volume Report button.

The Volume Report displays area, volume, and depth for stripping and sectional areas. 
The total area, cut/fill, strata, and on grade area for each report region and sectional area 
are displayed, if created. The report also displays the Cut-Fill volumes, compaction ratios 
and their impact on the volumes, import/export data, and volume change per 0.1 foot of 
elevation change, which is useful for balancing the site. The data in the volume report 
should be similar to the illustration below.
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Lesson 6 –  Printing Reports

Sitework 4D can print the Overlay and Terrain graphics along with Volumes and Profiles. 
The Print Preview Window allows the user to import graphics and resize, move, and add 
text.

 Set up the Printer

Before printing, the printer should be configured. Sitework 4D uses the printer specified 
to size the screen and margins.

1. Select File>Open, and choose Pine Street.esw. Click Open.

2. Select  File>Print to configure the printer.

3. Verify your printer and its settings and click Apply.

Send Graphics to the   Print Page

Selecting File>Send to Print Page sends the current screen view to the Print Page.

1. Click the 3D View button on the tool bar. The job is shown in 3D View mode.

2. Use the keyboard arrows and the 3D Controls to show a Terrain view you want to 
print, then select File>Send to Print Page, or click the Send to Print Page button.

3. If both the Overlay and Terrain are visible, the program asks which you want send. 
Select Send Terrain, and click OK.

To configure 

a printer 

when using 

Windows 

XP, select 

File>Print, 

and click the 

Printer button
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The Print Page Window

The Print Page displays a representation of the page with the Terrain as an object on 
the page. The white area is the printable area on the page. The gray area represents the 
printer’s margins.

  Selecting Objects

The Terrain object can be picked by clicking on it. A picked object displays four blocks 
around the object. In case of multiple overlapping objects, Shift+click cycles between 
objects.

  Moving and  Sizing Objects

To move an object, click and hold the object then drag it to the desired location.

To resize an object, click on an item, then click and hold the lower right selection block. 
The arrow changes to a double-headed arrow. By moving the cursor away from, or 
closer to, the object, you can resize it.

• Select the Terrain object, drag it to the right side of the page, and increase the size 
to similar to the illustration below.
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Adding Other Objects

The Print Preview window supports multiple objects. Next we’ll add the Volumes Report 
to the page.

1. Click the Volumes Report button or select Window>Volumes Report. The Volumes 
Report shows the volumes and areas calculated earlier.

2. Select File>Send to Print Page and the report transfers to the Print Preview window.

The Volumes Report can be moved and resized using the same methods as the Terrain 
object. Move and size the report until the page looks similar to the illustration below.

3. To add text to the report, select the Edit menu and select Add Text.

4. Enter the desired text and drag the object to the desired location.
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 Printing the PDF

The PDF can also be sent to the print page, as it appears on screen.

1. Switch to the Planview Mode.

2. Press the T key twice to display the PDF behind the planview of the job.

3. Click the Send to Print Page button and the Print Page displays.

4. The image can now be positioned and sized as desired on the Print Page.

5. To scale the plan, select the Edit menu and select Drawing Scale.  



Sitework 4D PDF Tutorial

2-31

Print The Report

1. When you are satisfied with the results, click the Print button from the Selection 
Tool Bar or choose File>Print.
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3D Modeling Overview

Sitework 4D can be used to convert CAD files into takeoffs and accurate 3D models. 
This tutorial covers the steps to perform the conversion and creating the model.

 CAD Entry  Guide

In the Guide menu, Sitework 4D contains guides for PDF, CAD, Tablet and Haul Plan 
entry. These guides aid the entry of a complete job. This tutorial focuses on CAD entry. 
The CAD Entry Guide can be accessed by selecting Guide>CAD or by pressing the G 
key. When a procedure is selected from the Guide, Sitework 4D will change to the prop-
er mode, surface, and layer necessary for that procedure. The Guide displays a check 
mark in the corresponding box when an operation has been completed.
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Data Entry Sequence

Sitework 4D is used for data entry and editing to create 3D models from CAD data. Be-
low is the suggested data entry sequence for the 3D modeling.

CAD Data Transfer

• Start a New Job
• Transfer CAD Data

Existing Ground Data

• Enter Existing Perimeter

• Edit Existing Ground
• Enter Stripping Areas

Design Ground

• Edit Design Data Lines
• Enter Design Perimeter
• Enter Sectional Areas

Calculate Volumes

• Visual Verification with the 3D Window
• Calculate Volumes
• Print Reports
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This Open 
dialog box 
defaults to 
display three 
file types: 
ESW, DXF, 
and DWG. 
ESW is 
the native 
file type of 
Sitework 4D.

Lesson 1 -  CAD  Data Transfer

Sitework 4D is a tool for creating takeoffs from PDF files, digitized plan sheets, and CAD 
files. Both DWG and DXF files are read and can be quickly transformed into a precise 3D 
model suitable for use in the field.When a DXF or DWG file is selected, the data from 
that file is opened in CAD Transfer Mode displaying all layers in the file including frozen, 
or locked, layers. Training videos discussing CAD modeling are available at http://www.
agtek.com/trainingvideos.asp. It recomended that you watch the training videos first.

Start a  New Job (Job Setup)

1. Double-click on the Sitework 4D shortcut, or select Start>Programs>AGTEK> 
Sitework 4D. The Open Dialog box is displays.

2.  Select the “4D Lesson1.dwg” file, and click Open.

3. Select Data Transfer>Crop Rectangle to remove unnecessary data. 

4. Click and draw a box around the relevant data, then click again to end.

5. Click Yes when asked to remove everything outside the rectangle.

6. Select Data Transfer>Import Transfer Units, and make sure Feet is selected as the 
units of measure, then click OK.

Import Transfer Units: The Import Transfer Units designate what unit of measurement 
the job is created in. It must be set to the same units as the CAD file being transfered: 
feet, metric, or architectural. User defined is used when the CAD file is created using a 
unique unit of measurement.

Transfer Existing Ground Data

When a line is selected in Import Mode, all lines in the same CAD layer are highlighted. 
The tool bar shows the name of selected layer along with the controls used to send that 
layer to a Sitework 4D surface. Transfer mode can also be found by pressing the G key, 
and choosing Transfer Data. 

Current Sitework 4D 
target surface

Send To button transfers 
selected CAD layer to 
target surface

Sitework 4D target layer Selected CAD Layer list
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1. Change to the Existing Surface and Data Line Layer, then click the “CONT-MNR” 
layer, or use the toolbar to select it in the CAD pulldown, then click the Send To but-
ton to transfer the layer to the Existing surface.

2. Select the “CONT-MJR” layer with the mouse or by using the layer pulldown menu 
and send it to the Existing Surface and Data Lines Layer.
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3. Change to the Design Surface and Data Line Layer, then select the “P-BLD” (building 
pad) layer and click the Send To button.

Other CAD Transfer Methods

In addition to the previous example, there are other methods of transferring CAD data.

Right-Click

Right-clicking a layer displays the Right-Mouse menu, which allows you to select the 
target surface.

• Select the “DSN-CNTR” layer, right-click, then select Send to Design to transfer the 
layer.

  Transferring Multiple Layers

CAD Transfer also supports the transfer of multiple layers simultaneously.

1. Click on the top of curb “Des-TC” near the upper-left corner of the site.

2. Ctrl+click on the storm drain detail “1-SD”.

3. Ctrl+click on the grade text “TXT”.

4. Ctrl+click on the retaining wall “1-WALL”.
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5. Right-click, then select Send to Design to move the layers to the Design surface.

Complete CAD Data Transfer

A few layers are left to transfer at this point. Use any of the transfer techniques to send 
the layers listed below to the Design surface.

• “Walk”

• “TEXT-GRADES”

• “1-DES-CURB”

When finished, click the Edit Mode button on the toolbar to leave CAD Transfer Mode.

6. Select File>Save, or click the Save button.

Other CAD Transfer Features

The CAD Transfer window has additional features that are not needed in this tutorial but 
are useful for future files.

Hide, Show All, and Delete

In some CAD files the amount of data displayed makes it difficult to identify the desired 
layers. The Hide command removes the selected data from the screen. It can be activat-
ed from the right-click menu, the Edit menu, or by pressing Alt+H. 

Selecting 
File>Save will 
give you the 
opportunity 
to save a 
copy of 
your current 
file using 
a different 
name, 
leaving the 
original file 
unchanged.
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The reverse of Hide is the Show All command. Show All is selected from the right-click 
menu or the View menu.

The Delete command removes the selected data from the screen permanently. Delete 
is activated by pressing the Delete key or through the Edit menu. It does not affect the 
original CAD file.

Undo and Redo

Sitework 4D supports up to eight levels of undo for those occasional mistakes that 
you wish you could start over. The Undo command is activated by pressing CTRL-Z or 
through the Edit menu. The Redo command is usually used when Undo was used one 
too many times. It also supports eight levels and is activated by pressing CTRL-Y or 
through the Edit menu.

Lesson 2 - Existing Ground

The Existing Ground represents the current conditions of the job site. In addition to the 
existing conditions, we add the Existing Perimeter and Stripping Areas so the existing 
surface can be used in volume calculations.

Enter the  Existing Perimeter

The Existing Perimeter defines the job limits of your existing ground and is used to speed 
3D rendering by ignoring information outside of the boundary. Use the following steps to 
enter the Existing Perimeter.

1. Select File>Open and open “4D Lesson2.esw”.

2. Switch to Entry mode, then select Existing from the Surface pulldown and Perimeter 
from the Layer pulldown, or press the G key, and choose Enter Existing Perimeter 
from the CAD Entry Guide.

3. Using the mouse, draw a perimeter around your site boundary. Right-click to close 
and end the site boundary entry. Right-click again to get your arrow back.
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Edit Existing Data Lines

The 3D surface is created by converting the two-dimensional CAD data into a three-
dimensional surface. Much of this work consists of cleaning up the data that has been 
transferred, including assigning elevations to points and contours, and joining lines. 
In this example all existing lines transfer with elevations already assigned to them. All 
techniques used to edit design data lines found in Lesson 3 of this tutorial can be used 
to edit existing data lines as well. To see what information is assigned to an individual 
existing data line:

1. Switch to the Edit mode by clicking the Edit Mode button and select Data Lines in 
the Layer drop down, or press the G key, and select Edit Existing Data Lines from the 
CAD Entry Guide.

2. Click on an existing data line to select it.

3. Right-click and choose Line Editor from the right-click menu. The Line Editor box is 
displays.

4. Click Cancel to close the Line Editor box.

Enter  Stripping Areas

The depth specified for Stripping Areas is deducted from the Existing surface to create 
a Stripped surface. Stripping Areas are not additive, you may exclude areas from being 
stripped by entering a stripping area with a depth of “0”.

In this sample we also display the design data lines and design annotation behind the 
existing data lines. This aids in the Stripping Area entry.

1. Switch to Entry mode, and select Existing from the Surface pulldown and Stripping 
Areas from the Layer pulldown, or press the G key and select Enter Stripping Area 
from the CAD Entry Guide.

2. If the Stripping Areas box is not displayed, click the Add Regions button.

3. Enter “Stripping 1” for the Area Name, “0.5” for the Stripping Depth, and click OK.
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4.  Right-click on the existing ground and select Display>Design Layer.

5. Right-click on the existing ground and select Display>Design Annotation.

6. Using your mouse, enter the Stripping Area around the area you plan to strip.

7. Right-click to close the Stripping area and end the entry. Be sure to keep the Strip-
ping Area within the Existing Perimeter.

8. Right-click twice on the existing ground and select Display>Design Layer to turn the 
layer off.

9. Right-click on the existing ground and select Display>Design Annotation to turn the 
layer off.

10. Select File>Save, or click the Save button.
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Lesson 3 - Design Data

The Design Ground contains the design information for your job. In this lesson we will 
clean up the data transferred from a CAD file by joining lines, and assigning elevations, 
as well as creating offset lines, entering the Design Perimeter, grade breaks, Sectional 
Areas and control points.

 Edit Design Lines

While editing Design lines we will clean up the transferred data by assigning elevations 
and joining lines. We will further refine the data by adding Sectional Areas, benchmarks, 
grade breaks, and a Design Perimeter.

The  Edit Window 

The initial view of the design data after transfer looks similar to the illustration below. 
Some lines transferred from the CAD file may have an elevation assigned to them al-
ready, while others may not. Lines with elevations are displayed in light blue. Lines with-
out elevation are sent to the Annotation layer and are displayed in Brown.
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 Elevation List

  The Elevation List shows information on the selected line (see the illustration below). 
Points listed in the elevation window are color-coded by type. Sitework 4D has five point 
types: Interpolated, Daylight, Entered, Snapped and Annotation.

•  Interpolated points (light blue) derive their elevation from the slope between the 
Entered elevations that surround them. If the elevation of the points that are used for 
interpolation change, the interpolated point elevation is recalculated as well.

•  Daylight points (green) are assigned elevation from the Existing surface. 

•  Entered points (white) are points where the user has assigned an elevation to by 
editing or entry. These points do not change elevation unless the user specifically 
changes them.

•  Snapped points (red) are created when a point on a data line is snapped (F6 or F8) 
to another existing data line. These become Entered points after the job is saved and 
reopened.

•  Annotation points (brown) are not used by the program to create the 3D surface. 
The presence of an Annotation point on a line changes all points on the line to An-
notation. Lines transferred through the CAD transfer with an elevation of zero are 
automatically assigned as Annotation.

 Point Label of the 
selected point

Northing and Easting of 
the selected point

Line label

List of e levations for points 
on the selected line

Point type buttons 
(Interpolated, Daylight, Entered, Annotation)

The selected point
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  Assign Elevations

Annotation lines are lines with no elevation. Assigning elevations to annotation lines es-
sentially converts them to data lines. Elevations can be assigned to these lines by using 
the Snap techniques described in this tutorial. We’ll go over several different snap tech-
niques in the exercises that follow.

Before you begin, switch to the Design Surface in Edit mode. Notice how the contour 
lines on the upper right side on the screen are blue, while the ones on the left are brown. 
The blue contours have elevations assigned. We need to assign the remaining elevations 
to the brown (annotation) contours.

It may be 
sesired to 
import and 
align the 
grading plan 
to enter the 
design data. 
The image 
may be 
toggled on 
and off by 
pressing the 
T key on the 
keyboard.
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 Join Lines/ Assign Spot Elevations using Elevation Snap

CAD file lines are often “broken” and should be joined to ease elevation assignment. 
Before you can join lines, you should make sure to set your Bridge Gap Distance to the 
appropriate amount.

The Bridge Gap Distance indicates how far apart lines can be and still be joined. The 
space between the endpoints must be less than the Bridge Gap Distance for the lines to 
be joined.

 Joining Lines

1. Select File>Open and open “4D Lesson3.esw”. Make the Surface is set to Design 
and the Layer is set to Data Lines, or select Guide>CAD and select Edit Design Data 

Lines from the CAD Entry Guide

2. Select one of the pad lines at the base of the slope.

3. Click the Label Select button. All the pad lines are selected.

4. Select Options>Bridge Gap Distance, and enter the desired distance in the Edit 
Bridge Gap Distance dialog box. The distance is measured in feet. For this example, 
use the default distance of “0.1”.

5. Click Join button to join the lines. After the line is joined, it is selected.
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Assign Elevations using  Elevation Snap

Once the lines for the pad are joined, you can use Elevation Snap to assign an elevation 
to the line from a label.

1. Select the pad again and verify that it is now a single line.

2. Move the cursor over the text in the center (FF=103.5) and press F9 to assign that 
elevation to the pad.

3. Continue using this technique to assign elevations to the remaining pads.



Sitework 4D CAD Tutorial

3-15

Elevation Snap (F9) grabs the elevation data from a label, or data line, and assigns it to a 
selected line.

4. Select File>Open and open “4D Lesson3.esw”.

5. Zoom in to the contours at the top of the screen, and click on the first brown (anno-
tation) contour on the left. Notice the elevation is 0.000 in the Elevation list.

All of the snap 
techniques 
shown can 
be used 
for existing 
ground data 
as well as 
design data.

3. Place the cursor over the light blue line to the right, and press the F9 key. The eleva-
tion assigned to the line is displayed in the Elevation list.

4. Repeat this process for the next contour to practice the technique. Use the Elevation 
list to verify that an elevation has been assigned.
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 Assigning Elevation Using Increment Snap

Increment Snap creates an elevation increment and direction, then applies it to lines. 

1. Press the Esc key to deselect any selected lines.

2. Place the cursor over the light blue contour with an elevation of 131, and press F8. 

3. Move to the next contour below (130), and press F8 again. The triple-beep indicates 
that the program is now in Increment Snap Mode.

4. Move to the next brown contour below, and press F8 again. It automatically assigns 
the next incremental elevation, 127, to the line.

5. Repeat this process until you reach the bottom of the slope to practice the tech-
nique.
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Assigning Varied Elevations to a Line

Up to this point we have snapped a single elevation to entire lines. However, you can 
also snap multiple elevations to a line. We will next assign elevations to the curb lines, 
which have varying elevations.  It is recommended to Join the curb line using the same 
procedure as joining the Pads.  Select one of the curb lines and click the Label Selection 
icon to select all the curb lines, then click the Join icon.

1. Click on the top of curb line on the top, right side of the job. Notice that the first 
point on the line is marked with a diamond. 

2. Click on the diamond or select the first point in the Elevation list to Select the first 
point.

3. Move the cursor to the 98.0TC label, and press F9 to assign that elevation to the 
curb.
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4. Select the next point (corner point) on the line, and use F9 to snap to the 97.5TC 
elevation label.

5. Continue selecting points at the leaders along the curb and assigning the elevations 
using F9.

6. Move the cursor to the intersection of the 103.4 leader line, and press  F6 to add a 
point on the curb line. The new point is automatically selected. Use F9 to assign the 
103.4 elevation. 
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7. Continue to the end of the curb line assigning grades as needed. Repeat the process 
for the remaining curb lines.

Assigning Elevations Using the   Line Editor

The Line Editor can also be used to assign elevations to annotation lines or change exist-
ing elevations. To use the Line Editor:

1. Click on a data line, then right-click to display the Right-Mouse menu and select Line 

Editor. The Line Editor dialog box is displayed.

2. Type in an elevation or label and click OK. The changes are displayed in the Elevation 
list.

For extra practice, you can continue to the assign elevations to the remaining annotation 
lines using the techniques previously discussed.
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Creating Offset Lines

The job now has all of the top of curb, pad, and contour elevations assigned. To refine it 
further we need to create the bottom of curb lines.

In this example, to reach light duty pavement subgrade the new line needs to be offset 
down 1.25 feet (.5 for curb height, .75 paving materials). We’ll use an offset distance of 
.1 because you should never create two lines exactly on top of each other with differing 
elevations.

1. Select File>Open and open the “4D Lesson4.esw” file.

2. Switch to Edit Mode, then select Design from the Surface pulldown and Data Lines 
from the Layer pulldown, or select Guide>CAD, and select Edit Design Data Lines 
from the CAD Entry Guide.

 Offset Line Editor

Offset Lines are a powerful method of creating lines based upon numeric distances and 
elevations from a specified reference line (such as creating the bottom of curb from the 
top of curb line). This tutorial uses the “4D Lesson 4.esw” file, with all of the CAD data 
converted. For more information regarding offset lines, see page 8-92.
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3. Press the T key to turn on the Terrain View.

4. Click on the top of curb line to which elevations were first assigned in the previous 
lesson (below the 103.5 pad), then select Utility>Offset Line. The Offset Line Editor 
is displayed.

5. Enter “CURB SUB” in the Label box. AGTEK recommends that you label lines when-
ever possible. Labels are helpful for making changes to the model later if needed; 
such as raising the elevation of all lines with a common label.

6. Type “.1” in the Start of Line Offset Distance box, and “-1.25” in the Elevation Dif-
ference box. The Slope calculates automatically. Make sure the Offset button shows 
“Left” (click the button to change it if necessary).

 Click Apply and notice that the bottom of curb line is showing and the curb face has 
been created using the two lines. Click Close.

At this point you can select and offset the remaining top of curb lines on the job. The 
Offset Line Editor remembers the last settings used so the only changes you should need 
to make is changing the direction of the offset using the Swap Ends button.
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Add  Grade Breaks

Grade breaks are another method to refine the model for accurate takeoffs and volume 
calculations. This section uses the “4D Lesson5.esw” file, which has all of the bottom of 
curb (BC) lines offset.

The parking areas include grade breaks and rim elevations for drainage. To refine it 
further we’ll enter the grade breaks including the drains for the parking lot on the right 
(between the 103 pads).

1. Select File>Open and open the “4D Lesson5.esw” file.

2. Switch to Entry Mode, select Design from the Surface pulldown and Data Lines from 
the Layer pulldown, then zoom in to the parking lot on the right side of the job.

3. Move the cursor to the bottom left curb at grade break and press F8. The first point 
is entered at the curb and a tether line connects it to the cursor.

4. Move the cursor near the drain point in the center of the lot (101.4RIM), and press 
F9 to grab the elevation. Postion the cursor at the end of the leader line and press F8 

to snap.

5. Continue diagonally to opposite corner, and press F8 to snap to the bottom of curb.

6. Right-click to end the line, and move the crosshair across to the opposite corner.
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7. Press F8 to snap the top left corner, snap again to the point you previously entered 
near the drain rim, and finish the line in the opposite corner.

8. Enter the remaining grade breaks on the job.



Sitework 4D CAD Tutorial

3-24

Enter  Sectional Areas

Sectional Areas are closed areas that modify the Design Surface by their specified depth. 
When we used the Offset Editor to create the bottom of the curb, we subtracted both 
the curb height and the light duty pavement section. This means that the only area need-
ing a section is the heavy duty paving and the pads. The first sectional we’ll enter is the 
heavy duty paving area. This section starts with all data lines entered and uses “4D Les-
son6.esw”.

1. Select File>Open and open the “4D Lesson6.esw” file.

2. Switch to Entry Mode, select Design from the Surface pulldown and Sectional Areas 
from the Layer pulldown, or Press the G key and select Report/Sectional Areas. 
Then, zoom to the driveway in the lower-left of the design.

3. Enter “HD Paving” as the Region Name, “.42” (5 inches) as the Sectional Depth (this 
is the difference between the heavy duty and light duty section). Clear the Report 
Region checkbox and click Enter. 

Once a 
Sectional 
Area has been 
entered, it 
can also be 
used as a 
report region 
by selecting 
the area in 
Edit Mode, 
selecting 
Edit>Report 

Region, and 
naming the 
region.

On a metric 
job the same 
“.42” would 
represent 
.42m , or 
420mm.
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4. Move the cross hair down to the lower-left edge of the driveway, and press F8 to 
snap to the bottom of the curb line.

5. Move the crosshair to the next point up the driveway and press F8 twice (Line 
Snap). The entire line is selected and changes the cursor to the line snap cursor.

6. Press the Spacebar to display the entire job. The selected line goes all the way to the 
retaining wall at the top of the parking lot. We want to follow only the portion of the 
line that borders the heavy duty paving area.

7. Move the cursor to the top of the driveway where the parking stalls start and press 
the Spacebar again to toggle back to the zoomed view, then press F8 to limit the 
amount of line entered to just that section.

8. Move the cursor across the end of parking stalls, and press F8 twice to snap to the 
end of the peninsula and then line snap around the tip.

9. Continue down the end of the parking stalls to the retaining wall using snap and line 
snap as necessary. 

10. Trace around the outer edges of the parking while avoiding the light duty areas until 
you reach the starting point (see the illustration below).

It may be 
sesired to 
import and 
align the 
paving plan 
to enter the 
sectional 
areas.
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11. At the starting point (marked with a diamond) right-click to end and close the area.

 Sectional Areas within Sectional Areas

The sectional area entered would drop the entire area within it by .42 feet. Since we 
want this to affect the heavy duty parking lot only, new sectional areas need to be en-
tered within the first to represent different depths. Sectional Areas within other sections 
are not additive. We can specify a 0 depth and remove the portions from the surrounding 
section. 

1. Switch to Entry Mode, select Design from the Surface pulldown and Sectional Areas 

from the Layer pulldown.

2. Type “0” to set the new depth to no sectional.

3. Move the crosshair to the center pad and surrounding curb (shown in the illustration 
below).

4. Use the F8 key to snap and line snap around the CURB SUB line, and light parking 
areas (see the illustration below).

5. Right-click to finish and close the area.

The pad in the center of the 0 section has a .67 section. We need to add another sec-
tional area to represent this.

1. Type “.67” for the section and move the crosshair over one of the pad corners, then 
press F8 twice to change to line snap mode. The entire pad line highlights.
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2. Right-click to snap to the entire area. This is a variation of Line Snap, called Area 
Snap, which assigns the elevation to the entire enclosed area.

3. Continue the process to enter the rest of the sectional areas.



Sitework 4D CAD Tutorial

3-28

Enter  Design Perimeter

Design Perimeters define where the Design stops and the Existing surface begins. They 
are also useful as a ready-made boundary when defining the volume calculation area.

Our goal with the perimeter is to trace around the edges of the design where it meets 
the existing ground. The Design Perimeter does not need any elevations to be entered 
because it automatically daylights to the Existing surface after exiting Entry mode. 

1. Switch to Entry Mode and select Design from the Surface pulldown and Perimeters 
from the Layer pulldown, or select Guide>PDF and then select Enter Design Perim-

eter from the CAD Entry Guide.

2. Right-click, select Display>Stripping Areas.

3. Position the cursor over the Stripping Areas line and press the F8 twice to line snap 
to the Stripping Areas line.

4. Right-click to end then entry. Right-click again and the Apply Drape Line dialog box 
displays. Click Yes.

5. Right-click to return to an arrow. Return to Edit Mode.

The program calculates the daylight elevations of the perimeter and creates a data line 
in the Design surface. If the 3D Terrain is turned on and the Options>Staged Design is 
checked, you’ll see the Existing Ground shown outside of the Perimeter.
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Toolbar

Lesson 4 – Verify the  3D Model

The creation of 3D surfaces allows comparison of the surfaces for volumes. This lesson 
shows how to verify the job with the 3D view and specify the area to calculate and gen-
erate the volumes. This lesson uses “4D Lesson7.esw”, which is the finished model.

Visual Verification with the  3D View Window

Sitework 4D can display the 3D terrain as it is entered in the Edit window. The 3D View 
Window adds greater flexibility to viewing and verifying the 3D surfaces.

While we were editing, the 3D terrain showed how the program interpreted the data 
lines to form the surfaces. The 3D Window is a much more flexible version of the 3D ter-
rain which allows greater control over the view.

1. Select File>Open and open the “4D Lesson7.esw” file.

2. Click the 3D View button on the tool bar or choose Window>3D View. The 3D win-
dow calculates the cut-fill colors and surfaces before displaying.

Toolbar  Use the Toolbar to change the reference (Ref) and difference (Diff)  
   surface to compare different surfaces in 3D View.

Overlay  The Overlay is the two-dimensional plan view of the job. Clicking  
   on the Overlay moves the view to that position.

Terrain  The Terrain is the three-dimensional representation of the job. Use  
   the Arrow keys to move around the Terrain View.

3D Controls  Use the 3D controls to inspect the terrain for any errors and to see  
   how all of the data we have entered displays on the job. 

Overlay

Terrain

3D Controls
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Driving

Driving the 3D View is the easiest way to double check your work and the surface qual-
ity. It also can display the Subgrade and Stripping surfaces and calculate volumes.

Use the Arrow keys on the keyboard to drive through the site. The Up and Down arrows 
move forward and back. The Right and Left arrows turn. For additional clarity, you may 
want to turn the Overlay off by pressing the O key or by selecting Display>Overlay. 
The speed of the drive is based on the Arrow Rate setting, which is located on the Edit 

menu. Each arrow key press has a distance that the Arrow Rate controls. The speed of 
your computer and video adaptor can also affect screen speed.

Try using the 3D controls to change the views and get a feel for what they do. Also try 
changing the Reference and Difference surfaces to see the different views and compari-
sons.

Drives forward 
and back

Turns the view 
left and right

Increases and 
decreases the 
elevation skew

Changes the 
viewing angle

Increases/
decreases 

the viewing 
distance behind 

the vehicle

Toggles between 
ground and aerial view

Line Label of 
selected point

Northing of 
selected point

Easting of 
selected point

Horizontal 
distance 
between 

selected point 
and current 

location

Slope between 
selected point 

and current 
location

Point Label of 
selected point

Elevation of 
selected point

Vertical 
distance 
between 
selected point 
and current 
location

Launch Help
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Lesson 5 -  Calculating Volumes

Once the model has been verified, and any changes have been made, you can calculate 
volumes and compare surfaces. This lesson uses the file “4D Lesson7.esw”, which is 
the finished model.

1. Select File>Open and open the “4D Lesson7.esw” file.

2. Click the 3D View button on the tool bar or choose Window>3D View. The 3D win-
dow calculates the cut-fill colors and surfaces before displaying.

3. Define the  Volume Area. Click the A button on the Utility Tool Bar to create a bound-
ing box (using the Design Perimeter) around the entire job. This determines the limits 
of the volume calculation. 

4. Specify the Surfaces. Before calculating the volumes, verify that the correct surfaces 
are selected. For our example, set the Reference surface to Subgrade and the Differ-
ence surface to Stripped.

5. Calculate the Volume. The Volume Calculation is started by clicking the Calc Volume 
button on the tool bar or by selecting Utility>Calc Volume.

During the volume calculation the cross sections display at the bottom of the screen 
with blue representing the Reference and Green the Difference. A line displays on the 
overlay showing the corresponding location of the cross section. The calculation can be 
paused by pressing the Spacebar or aborted by pressing Esc. When paused, the I key on 
the keyboard will move across the site incrementally. Pressing the Spacebar again will 
resume the volume calculation.

When the calculation finishes, the Volume Calculation Results are displayed. 

Cross Section 
Display

Be sure the 

finished 

surface (the 

surface you 

are calculating 

to) is on the 

left, and the 

begining 

surface (the 

one you are 

calculating 

from) is on 

the right.

Cross Section 
Location
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These numbers represent uncompacted cut and fill between the two surfaces. The 
Horizontal Area represents plan view areas with no slope adjustment and is broken down 
into Cut, Fill, and On-grade square footage. Slope Area represents a slope adjusted 
square footage. It is the total surface area, excluding vertical surfaces like curb faces. 
Click Done to close the dialog box. These volume numbers can be recalled by clicking 
the Volume Report button on the tool bar.
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The  Volume Report 

Once you click Done in the Volume Calculations Results dialog box, the Volume Report 
displays. You can also access the report after volumes have been calculated by selecting 
Window>Volume Report or by clicking the Volume Report button.

The Volume Report displays area, volume, and depth for stripping and sectional areas. 
The total area, cut/fill, strata, and on grade area for each report region and sectional area 
are displayed, if created. The report also displays the Cut-Fill volumes, compaction ratios 
and their impact on the volumes, import/export data, and volume change per 0.1 foot of 
elevation change, which is useful for balancing the site. The data in the volume report 
should be similar to the illustration below.
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Lesson 6 – Printing Reports

Sitework 4D can print the Overlay and Terrain graphics along with Volumes and Profiles. 
The Print Preview Window allows the user to import graphics and resize, move, and add 
text. The lesson continues to use the file “4D Lesson7.esw”

 Set up the Printer

Before printing, the printer should be configured. Sitework 4D uses the printer specified 
to size the screen and margins.

1. Select File>Print Setup to configure the printer.

2. Verify your printer and its settings and click OK.

Send Graphics to the  Print Page

Selecting File>Send to Print Page sends the current screen view to the Print Page.

1. Click the 3D View button on the tool bar. The job is shown in 3D View mode.

2. Use the keyboard arrows and the 3D Controls to show a Terrain view you want to 
print, then select File>Send to Print Page, or click the Send to Print Page button.

3. If both the Overlay and Terrain are visible, the program asks which you want send. 
Select Send Terrain and click OK.
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The  Print Preview Window

The Print Preview window displays a representation of the page with the Terrain as an 
object on the page. The white area is the printable area on the page. The gray area rep-
resents the printer’s margins.

  Selecting Objects

The Terrain object can be picked by clicking on it. A picked object displays four blocks 
around the object. In case of multiple overlapping objects, Shift+click cycles between 
objects.

  Moving and  Sizing Objects

To move an object, click and hold the object then drag it to the desired location.

To resize an object, click on an item, then click and hold the lower right selection block. 
The arrow changes to a double-headed arrow. By moving the cursor away from, or 
closer to, the object, you can resize it.

• Select the Terrain object, drag it to the left side of the page, and increase the size to 
similar to the illustration below.
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Adding Other Objects

The Print Preview window supports multiple objects. Next we’ll add the Volumes Report 
to the page.

1. Click the Volumes Report button on the tool bar or select Window>Volumes Report. 
The Volumes Report shows the volumes and areas calculated earlier.

2. Select File>Send to Print Page and the report transfers to the Print Preview window.

The Volumes Report can be moved and resized using the same methods as the Terrain 
object. Move and size the report until the page looks similar to the illustration below.

3. To add text to the report, select the Edit menu and select Add Text. Enter the de-
sired text and po
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 Print The Report

1. Click the Plan View button on the tool bar or select Window>Plan View.

2. Send the image to the Print Page and switch back to the Print Page to resize and 
view the results. Your Print Page should look similar to the illustration below.

3. When you are satisfied with the results, click the Print button from the Selection 
Tool Bar or choose File>Print.
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  Earthwork 4D Geo-Referencing Files

To view your job site on Google Earth, or use the file in the field with SmartPlan, you 
must first geo-reference your job file by adding two benchmarks with approximate 
latitude and longitude information in Sitework 4D. You may use Google Earth® to lo-
cate these points.  This procedure is the same for files containing plan sheets only for a 
pre-bid walk-thru, or a complete takeoff to be used for job planning and project manage-
ment.

Enter   Benchmarks and Locate  Lat/Long information

To locate benchmark coordinates, and assign those coordinates in Sitework 4D, it is best 
to have both Sitework 4D and Google Earth® open simultaneously. 

2. Identify some existing features that can be found on the plan sheets.  Existing build-
ings, catch basins, or street intersections are good examples.
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5. Locate the two common features found on Google Earth.

3. Open the job file in Earthwork 4D.

4. Import the plan sheet containing the existing features located on Google Earth. 

6. Minimize Earthwork 4D and return to Google Earth.
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9.  Keep the name Line Measure and click OK.

10. Right click on Line Measure under Temporary Places and select Save Place As. 

7. In Google Earth, select the Show Ruler icon, or select the Tools menu and select 
Ruler.

8.  Draw a line connecting the two points. Click the Save button.

11. Save the file to the same file folder containing the Earthwork 4D job file. 
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12.  In Earthwork 4D, right click and select Import File.

13.  Select the Line Measure.KMZ file and click Import.

14.  The Benchmarks will be inserted, however they will not be in the correct location.

15.  Change the layer to Benchmarks.

16.  Select one of the benchmarks. Position the tip of the arrow on the corresponding      
  location on the plan sheet and press the F7 key to move the benchmark to the new  
  location.

13.  Repeat this process for the second benchmark.

14.  The KMZ file may now be exported. 
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Save   KMZ File

SmartPlan will read a KMZ file containing the plan sheet images, plan view data, color 
cut/fill map and volume reports. To export the KMZ file, select the Plan View mode icon 
on the toolbar.

1. Select File>Export KMZ File. The Save As dialog box displays.

2. Enter a name for the KMZ file and click Save.

3. The KMZ File Export dialog will display.

4. Select the desired layers to be saved to the KMZ file. 

5. Check the desired additional options, such as the Volume Report or Image Export.

6.  Check Optimize for Mobile when exporting the file to be used with SmartPlan.

7. Check Yes to Upload the file to AGTEK Access for use with SmartPlan. Click Export.
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7. The Choose Access Folder dialog will display. 

8. Select the desired Project folder. If no projects exist click New Project. Enter a name 
for the new project and click OK.

9.  The file will be uploaded to AGTEK Access. The KMZ file will open in Google Earth.
It is recommended you view the KMZ file on Google Earth to verify the accuracy of 
the alignment to the job site.

10. If the KMZ file is properly aligned, you are now ready to use SmartPlan in the field on 
the actual job site.
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5. If the file contains no takeoff data the Reference and Difference surfaces will show 
None.

6. Select the desired project folder.  If no project folder exists, create a new project.

7. Check the boxes to Include Images and Upload to Access. Click OK.

8. The file will be uploaded to the project folder for use with SmartPlan.

2. Click the Save as Type pulldown and select AGTEK Mobile Files (*.adf).

3. Enter a name for the ADF file and click Save.

4. The ADF Save Options dialog will display.

Save   ADF File

SmartPlan will read an ADF file containing the plan sheet images. It is recommended to 
use the ADF file when using plan sheets only for a higher resolution of the images.

1. In Sitework 4D, select the File>Save As.  The Save As dialog box displays.
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Field Use Overview

RTK GPS support is an additional feature in Sitework 4D, which must be purchased sep-
arately. In addition to creating takeoffs from grading plans, Sitework 4D can be used to 
capture field data using GPS to manage, update, and correct the 3D model in the office. 

Data Collection Tutorials
Sitework 4D is used for GPS data entry/collection on a job site. The following are the 
tasks and applications for using Sitework 4D in the field.

Instrument Setup

• GPS Base Setup
• Aligning the Site/Rover Setup

Checking Existing Ground

Progress Topoing

Lesson Examples
This part of the tutorial uses lesson files located in the C:\AGTEK\Data directory.
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 Lesson 1 – Instrument Setup

Before you begin collecting GPS data on a job site, you must perform GPS Base Setup to 
localize the Base on the job site. In addition, each time you use Sitework 4D to collect 
GPS data at a job site, you must align to the site using the Rover, or recover the align-
ment.

  GPS Base Setup

Once the Bluetooth connections are established between the computer and the Base, 
you must setup the Base to verify it is receiving GPS data and localize it to the job site. 
Make sure the job site location for the Base has the following:

• A clear view of the horizon

• No nearby obstructions (buildings, trees, etc.)

• A secure and protected location

• Within 1000 feet of benchmark #1

• Within radio range of benchmark #2

• Away from sources of radio interference (cell, microwave towers, etc.)

To setup the Base:

1. Position the Base on the job site location.

2. Double-click the GPS Base Setup Icon on your desktop or select Start>All 

Programs>AGTEK>GPS Base Setup. The AGTEK GPS Base Initialization dialog box 
is displayed.

3. Select the type of GPS receiver you are using (Topcon, Trimble) from the pulldown 
menu.
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 2. Select the model file, and click Open. The job site is opened in Edit Mode.

 3. Switch to 3D View Mode, then select Instrument>GPS>Enable. Your screen should 
appear similar to the following illustration.

4. Click the Port Settings button to verify that the Port is set to the COM port you se-
lected for the Base during Bluetooth setup (typically COM8).

5. Click the SETUP BASE from GPS button. The Base takes shots for 5 minutes to en-
sure an accurate reading.

6. Save the position file for future use on the job site.

7. Click Done to complete Base setup.

  Aligning to the Site/Rover Setup

The Rover is the GPS receiver that moves around the job site. Rovers can be pole, back-
pack, or vehicle mounted. Before you can collect data for the job site, you must align to 
the site using the Rover. 

1. Double-click the Sitework 4D icon or select Start>Programs>AGTEK>

Sitework 4D. The Open dialog box is displays.

Bullseye Button North Arrow Button

To use the 

position file in 

the future, the 

Base must be 

in the same 

location with 

the same 

rod height as 

when the file 

was saved.
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If you have 
already 
aligned to 
the job site, 
you can click 
the Recovery 
button to use 
the previous 
alignment 
data.

4. Select the benchmark on the screen you plan on shooting first, move to the point, 
level the Rover over the point, then click the Bullseye button. Benchmark 1 is shot.

5. Select the benchmark on the screen you plan on shooting second, move to the point, 
level the Rover over the point, then click the North Arrow button. Benchmark 2 is 
shot and the RTK Deviation Confirmation displays the deviation between the theoreti-
cal distance of the Benchmarks and the actual measured distance.

6. Click Accept to complete the alignment, or Retry to reshoot the second benchmark.
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4. Select Simulator from the GPS Type pulldown menu, and click the Change File but-
ton. The Open dialog box is displayed.

5. Select the “sim_checkOG.agt” file, click OK, clear the repeat checkbox, then click 
OK in the GPS Configuration dialog box

 6. Click the Enable GPS button, or select Instrument>GPS>Enable. In the field, once 
you select the Enable command you must align the model to the site with the Rover 
to begin receiving actual GPS data from the Rover. In simulate mode Alignment is 
not necessary.

2. Select the “Stanley Court Demo.esw” file, and click Open.

3. Switch to 3D Mode, then select Instrument>GPS>Configure. The GPS Configura-
tion dialog box is displayed.

Lesson 2 – Checking Job Site Data

Once you have run a GPS Base Setup and aligned to the site, you can use Sitework 4D 
to manage your 3D model with actual job site data, including checking and correcting 
existing ground, progress topoing, and grade checking.

Although Sitework 4D can be used to gather job site data, most of the functions associ-
ated with data capture (topoing, staking, grading, area/stockpile measurement, etc.) are 
performed using a GradePilot RTK unit. Refer to your GradePilot manual for information 
about using the GradePilot RTK unit.

 Checking Existing Ground (Simulation)

In this example the grades on the site begin to deviate substantially from the ground 
model and there appears to be a mound on the surface near the base of the slope. These 
deviations must be shot and recorded in order to update our current surface.

1. Double-click the Sitework 4D icon or select Start>Programs>AGTEK>

Sitework 4D. The Open dialog box is displayed. 
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7. Select “Existing” from the Ref pulldown menu to check actual topo data against the 
data currently in the model. Your screen should look similar to the illustration below.

8. Click the Record Off button so that it reads Record On, then click the Start button 
to begin checking the topo. Notice that the shots detailing the area go out until they 
closely match the Ref surface. This makes sure that survey data ties into the existing 
topo and reflects any volume on the edges.

In the field 
you would 
move the 
Rover to an 
area outside 
the deviations 
before clicking 
the Record 
Off button 
instead 
of using 
simulated 
shots.
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 Notice that the 3D Controls window reports the cut/fill value between the actual 
(survey) and theoretical (reference) as shots are being taken. The Elev box displays 
the elevation or the Reference (Ref) surface at the Rover position. The Northing and 
Easting boxes show the Northing and Easting coordinates for the location using GPS 
data. Also notice that the survey elevation is displayed as the “Z” value at the bottom 
of the screen.

9. After all of the shots are taken, click the Stop button. When the simulation stops, the 
check is complete and we can view and quantify the difference between the shots 
and the existing topo. Your screen should look similar to the following illustration.
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 Correcting the Topo

Once you’ve collected the new survey data, you can use it to update the model so it 
contains accurate data based on job site data.

1. Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.

2. Select Stage, then click OK. The Current Layers Background dialog box is displayed.

3. Select Existing, and click OK to create the Current Surface with the survey data 
staged into the Existing Surface. The survey data is shown on the screen.
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4. Right-click, then select Survey Boundary to draw a boundary around the survey data.

 The Current Surface is displayed with the existing ground and survey data and the 
Apply Survey Data dialog box is displayed.

5. Click the Stage Data button. The Current surface now contains the Existing surface 
data plus the new survey data.
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Calculating the  Survey Volume

Once you’ve created the Current surface, you can compare it to the Existing surface to 
calculate the survey volume difference.

1. Click the Survey Volume Calc button. The survey data is shown on the screen. 

2. Right-click, then select Finished to use the existing survey boundary. After calcula-
tion, the Volume Calculation Results dialog box is displayed. 

3. Click the Done button and the Survey Volume Report is displayed.
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2.  Select the “Stanley Court Demo.esw” file, and click Open.

3. Select File>Save As. The Save As dialog box displays. Add today’s date to the file 
name (i.e. “Stanley Court DemoJune062010.esw”), and click the Save button. 

4. Switch to 3D Mode, then select Instrument>GPS>Configure. The GPS Configura-
tion Dialog box is displayed.

5. Select Simulator from the GPS Type pulldown menu, and click the Change File but-
ton. The Open dialog box is displayed.

6. Select the “sim_progtopo.agt” file, click OK, clear the repeat box, then click OK in 
the GPS Configuration dialog box.

 7. Click the Enable GPS button or select Instrument>GPS>Enable. In the field, once 
you select the Enable command you must align the model to the site with the Rover 
to begin receiving actual GPS data from the Rover. In simulate mode Alignment is 
not necessary.

Typically you would save the file at this point. Since this is a sample file that will be 
used in other examples, do not save the file.

  Progress Topoing

In this example, the street and top two pads will be surveyed to check the work prog-
ress in those areas.

1. Double-click the Sitework 4D icon or select Start>Programs>AGTEK>

Sitework 4D. The Open dialog box is displayed.
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8. Select Existing from the Ref pulldown menu to check actual topo data against the 
data currently in the model. Your screen should look similar to the illustration below.

9. Click the Record Off buttons so that it reads Record On, then click the Start button 
to begin the progress check. Notice that the cut/fill differences are small at the edge 
of the work area and get larger as the simulation reaches the street and the pads.

10. After all of the shots are taken, click the Stop button. When the simulation stops, 
the check is complete and we can view and quantify the difference between the 
survey and the existing topo. Your screen should look similar to the following illustra-
tion.

In the field 
you would 
move the 
Rover to the 
area to topo 
before clicking 
the Record 
Off button.
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 Saving the Progress Topo Data

Once you’ve collected the new survey data, you can save it for comparison to the mas-
ter file for the job site.

Because this is an irregular shaped survey and you want to get an accurate volume cal-
culation, you need to snap a boundary around data rather than using the Survey Bound-
ary command.

1.  Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.

2. Select Stage, then click OK. The Current Layers background dialog box is displayed.

3. Select Existing, and click OK to create the Current Surface with the Existing Surface 
as the background and the survey data staged into it. The survey data is shown on 
the screen.

4. Make sure Snap is enabled (press the S key to turn snap on if it is not already), then 
zoom in, and double-click the first point of the survey near the street on the left side 
of the job.

5. Move to the right end of the survey data, and click the point at the top of the curve. 
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6. Double-click the end point of the next curve above. Your screen should look similar 
to the illustration below.

7. Click on the corner point at the top left of the street.
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8. Continue clicking and double-clicking until the outside edge of the survey has been 
selected. Your screen should look similar to the illustration below.

9. Right-click, and select Finished. The survey data is shown with the Apply Survey 
Data dialog box.

10. Click the Stage Data button. The Current surface now contains the Existing surface 
data plus the new survey data. Click the Home button to see the entire job site.
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Calculating the  Survey Volume

Once you’ve created the Current surface, you can compare it to the Existing surface to 
calculate the survey volume difference.

 1. Click the Survey Volume Calc button. The survey data is shown on the screen.

3. Click the Done button and the Survey Volume Report is displays.

4. Save the file.

2. Right-click, then select Finished to use the existing survey boundary. After calcula-
tion, the Volume Calculation Results dialog box displays.
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  Lesson 3 – Field Supervision

If you use Sitework 4D in the field to collect data, you can export it from the field file, 
then import the survey data in to the master file.

Collect the Data

1. Open the job file that contains the reference surface or start a new file.

2. Switch to 3D View mode and collect data in the field.

3. Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.

4. Select Replace (Copy) and click OK. The Current surface is created with the survey 
data.

5. Select File>Save As, and save the file as an AGT file.

6. (Optional) Save the file as an ESW file for reference. Make sure to change the name 
of the file so the original file is not overwritten.

Apply the Survey Data

1. Open the master file in Sitework 4D.

2. Select File>Import. The Import dialog box is displayed.

3. Select the AGT file that was created with the survey data in it, and click Open. The 
Survey data is opened in CAD Transfer mode.

4. Select the survey data, select “Current” from the Surface pulldown, “Survey Data” 
from the Layer pulldown, then click the Send To button. The data is transferred to 
the Current surface.

5. Switch to 3D Mode and select Edit>Apply Survey. The Survey Into Current dialog 
box is displayed

6. Select Stage (Edit), then click OK. The Current Layers Background dialog box is dis-
played.

7. Select Existing and click OK to create the Current Surface with the Existing Surface 
as the ground and the survey data staged into it. The survey data is shown on the 
screen.

8. Enter a survey boundary around the updated topo data. Right-click at the start of the 
boundary, then select Finished to complete the boundary.

9. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer 
now contains the Existing layer data plus the new topo data.

10. Select Current from the Ref pulldown and Existing from the Diff pulldown. This com-
pares the Existing surface with the Current surface to calculate the volume differ-
ence between the two surface.

 11. Click the Survey Volume Calc button. After calculation, the Volume Calculation Re-
sults dialog box is displayed.

12. Click the Done button, and the Volume Report displays.

If the topo 
data is 
symmetrical, 
right-click and 
select Survey 

Boundary to 
auto-create 
the boundary, 
then right-
click and 
select 
Finished.



Sitework 4D Field Use Tutorial

5-18

 Applying Survey Data Collected in GradePilot RTK

If you use a GradePilot RTK unit in the field to collect data, you can import the survey 
data directly from the unit to the master file.

Apply the Survey Data

1. Open the master file in Sitework 4D.

2. Connect the GradePilot to the computer via a USB port, then select File>PlanPilot 

Import. The Open dialog box is displayed.

3. Select the file that was used to collect the data, and click Open. The Survey data is 
opened in CAD Transfer mode.

4. Click the Send To button. The data is transferred to the Current surface.

5. Switch to 3D Mode, and select Utility>Apply Survey. The Survey Into Current dialog 
box is displayed

6. Select Stage (Edit), then click OK. The Current Layers Background dialog box is dis-
played.

7. Select Existing, and click OK to create the Current Surface with the Existing Surface 
as the ground and the survey data staged into it. The survey data is shown on the 
screen.

8. Enter a survey boundary around the updated topo data. Right-click at the start of the 
boundary, then select Finished to complete the boundary.

9. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer 
now contains the Existing layer data plus the new topo data.

10. Select Current from the Ref pulldown and Existing from the Diff pulldown. This com-
pares the Current surface with the Existing surface to calculate the volume differ-
ence between the two surfaces.

 11. Click the Survey Volume Calc button. After calculation, the Volume Calculation  
Results dialog box is displayed.

12. Click the Done button, and the Volume Report is displayed.

 If the topo 
data is 
symmetrical, 
right-click and 
select Survey 

Boundary to 
auto-create 
the boundary, 
then right-
click and 
select 
Finished.
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  Stake Checking

Make sure you have setup Bluetooth connections and run GPS Base Setup before stake 
checking. Refer to “GPS Base Setup” in “Lesson 1 - Instrument Setup” on page 6-2 for 
information.

1. Open the model file that contains the stake data to check.

2. Align to the site using the Rover. Refer to “Aligning to the Site/Rover Setup” on page 
6-3 for information.

3. Select a stake point to check in the job file.

4. Move the Rover to the point on the site and level the Rover. The Offset tab of the 3D 
Controls window displays the horizontal and vertical difference and the slope from the 
picked point to the Rover

5. Verify the information displayed in Sitework 4D matches the cut/fill and elevation 
data on the stake at the job site.
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Digitizer Support Setup

Digitizer support is an additional feature in Sitework 4D, which must be purchased 
separately. This tutorial demonstrates how to install the tablet drivers and set up your 
tablet for use with Sitework 4D, as well as using the tablet enter a takeoff using a paper 
plansheet. Be sure to install the Sitework 4D software before installing tablet drivers. For 
information regarding Sitework 4D installation please refer to the “Installation” section of 
this manual, beginning on page 1-1.

Lesson 1 -  TabletWorks Driver  Installation

TabletWorks is the software driver used to control the digitizer. This program can be 
downloaded from the GTCO website at http://www.gtco.com/supportgtcocalcompsoft-
ware.htm.

1. Open you internet browser and go to http://www.gtco.com/supportgtcocalcompsoft-
ware.htm.

2. Click on the link to download the Tabletworks version 10.09 software and save it 
somewhere easy to find.

3. Double-click the saved installation file.

4. Click Next in the GTCO CalComp TabletWorks Install Wizard dialog box.
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5. Click yes to accept the license agreement.

6. Select Complete, and click Next.

7. Click Next in the Welcome to Found New Hardware Wizard dialog box.

8. Click Finish to continue.

Lesson 2 AGTEK  16-button Cursor Configuration

After Tabletworks has been installed, you must configure the AGTEK 16-button cursor.

1. Select Start>All Programs>Tablet Works>Tablet Works.

2. Click the 16 Btn tab. The button configuration dialog box is displayed.

3. Select Relative in Mouse Mode, and make sure the Enable Mapping box is checked.

4. Click on the buttons on the cursor image to set their function. The buttons on the 
screen correspond to the actual buttons on your cursor (the top right button is the 
“7” button). Set the buttons to the following:

 7 - None  8  - None  9  - None  Enter - Left Click

 4 - None  5  - None  6  - None  Period - Right Click

 1 - None  2  - None  3  - None  SP - None

 0 - None  Backspace  - None Blank  - Right Click Minus - None

5. Click OK to apply the changes.
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 Plansheet Takeoff Overview

Sitework 4D can be used for dirt takeoff purposes when there is no electronic data avail-
able using a traditional paper plansheet. In these situations Sitework 4D relies on digi-
tized input using a digitizer, and AGTEK 16-button Cursor.

The   Cursor

The AGTEK-formatted 16-button cursor is used to enter digitized data from plan sheets. 
Below is an example of the cursor and a brief explanation of the buttons.

     The   Enter key is used for selecting and entering   
     data. Holding down the Enter key allows tracing of   
     data lines with AGTEK’s intelligent stream mode.

     The  SP key is used to “snap” a point to the nearest   
    data point. Pressing the SP key twice on the same   
    point selects the entire line, and allows the user to   
    determine the distance desired with a third SP entry. 

     The  Period key is used to display the Right-Mouse   
    menu, for entering daylight points, and as a decimal   
    point. 

     The   Blank or End key is used to end a line or stop   
    data entry. It is also used to display the Right-Mouse   
    Menu when not in data entry mode.

     The   Backspace key is used to delete the last point   
    entered while digitizing.

     The Number keys are used to type in values in   
    designated text boxes.0 9to

Tablet Entry Guide

In the Guide menu, Sitework 4D contains guide for PDF, CAD, Tablet, and Haul Plan 
entry. This tutorial focuses on Tablet entry. The Tablet Entry Guide can be accessed 
by selecting Guide>Tablet, and later by pressing the G key. The Guide display a check 
mark in the corresponding box when an operation has been completed.
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   Scaling

Before any data can be digitized, the plan sheet must be scaled. Scaling aligns the plan 
sheet with the digitizer, creates a coordinate system for the job, and establishes the 
scale of the plan sheet. There are three methods of scaling and the one you choose 
should reflect the needs of the job.

 Right Angle

The simplest method is to draw a right angle on the plan. Place the right angle near the 
center of the plan sheet. Measure out about 10” along each axis with the appropriate 
plan scale (20’ = 1” in this case) and mark the coordinates based upon these measure-
ments (see the example below). You can use this method if you don’t need to align the 
takeoff to a CAD file, survey, or a matching sheet. It also does not adjust for any plan 
shrinkage from duplication.

 Known Distance

Another method is to find some known distances on the plan both horizontally and verti-
cally and use those to create the coordinate system. Property Line measurements and 
road stationing often provide known distances. The chief advantage of this method over 
the former is the adjustment for any plan shrinkage. 

 Northings and Eastings

The best method is to use Northings and Eastings marked on the plan sheet. There are 
two advantages to this method. First, alignment to CAD files, surveys, and other sheets 
is greatly simplified. Second, this method adjusts for plan shrinkage. 
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Data Entry Sequence

Below is the suggested data entry sequences for plansheet takeoff.

Enter Existing Ground

• Start a new Job
• Scale Drawing
• Enter Existing Perimeter
• Enter Existing Data Lines
• Enter Stripping Area

Enter Proposed Design

• Enter Design Data Lines
• Enter the Design Perimeter
• Enter Report/Sectional Areas

Calculate Volumes

• Visual Verification with the 3D Window
• Calculate Volumes

Print Reports



Sitework 4D Digitizer Support Tutorial

6-6

Lesson 1 – Enter Existing Data Lines

Prior to beginning, tape the Pine Street grading plan to your digitizer. Be sure you have 
access to a right angle and an engineers scale. The following lesson demonstrates how 
to enter the existing ground.

 Start a  New Job (Job Setup)

1. Double-click on the Sitework 4D shortcut or select Start>Programs>AGTEK> 
Sitework 4D. The Open dialog box displays.

2. Click New to start a new job. The Job Information dialog box displays.

3. Enter a Job Name, Builder, Bid Date, and Operator. Select the units of measure (feet 
for this job) and click OK. Sitework 4D opens in Entry Mode with a blank screen 
ready for data entry.
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Enter the  Plan Scale

To scale the tablet to the Pine Street plan sheet, use the Northings and Eastings marked 
on the eastern property corners and on a monument in the center of Gregory Lane.

1. Select Guide>Tablet, then click Enable Tablet in the Tablet Entry Guide dialog box. 
The Tablet Scaling dialog box is displayed.

2. Type the monument coordinates for the first point, the southeastern property corner 
for the second point, and the northeastern property corner for the third point. Make 
sure the North Always Up box is checked, and click OK to accept these values. A 
dialog box prompts you to digitize the first point.

3. Place the 16-button cursor over the first point, and press the Enter button. Move to 
the second and third scaling points and press the Enter button over each point. A 
confirmation window displays the vertical and horizontal scales.

4. The scale for this job should be about a 1:20. Click OK to accept, or Rescale to re-
enter the scaling coordinates again. After you have accepted the scale, the program 
switches to Entry Mode, and defaults to the Existing Surface and Perimeter Layer.
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Enter the  Existing Perimeter

Once the job has been scaled to the plans, you can begin entering jobsite data, including 
the site boundary, original topo information, and stripping areas. 

A site boundary is supplied on the Pine Street plan sheet (the dashed box with one side 
running down the center of Gregory Lane).

1. Switch to the Entry mode and select Existing from the surface pulldown and Perim-
eters from the Layer pulldown, or select Guide>Tablet, and select Enter Existing 

Perimeter from the Tablet Entry Guide.

2. Place the 16-button cursor over one corner of the marked site boundary and press 
the Enter button. The crosshair is connected to the first point by “rubber band“ line.

3. Move the cursor to the next corner and press the Enter button. Continue entering the 
other corners of the perimeter. If you make a mistake, press the Backspace key to 
remove the last point entered. 

4. Press the Blank key to finish boundary entry.

The Existing 

Perimeter 

is used to 

define the 

limits of 3D 

calculations 

and speed 

3D rendering. 

Make sure 

necessary 

data is 

included in 

the Existing 

Perimeter.
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4. Click the Home button, or press the Home key on the keyboard to zoom out and 
view the boundary.

   Enter Existing Data

With the site boundary entered, the next step is enter the existing ground information. 
All of the topo information is entered into the Data Lines layer. This section demon-
strates how to enter a contour, spot elevation, closed areas, ridge, and swale lines, but 
does not cover entering all data from the plan sheet.

Enter Contours

Contours can be entered in any order but we’ll use the 253 contour in the upper middle 
part of the plan sheet. 

1. Select Existing from the Surface pulldown, and Data Lines from the Layer pulldown, 
or press the G key, and select Enter Existing Datalines from the Tablet Entry Guide.
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2. Type in “253” on the 16-button cursor then move the cursor crosshairs over the 
beginning of the contour, and press the Enter button. The status bar at the bottom of 
the screen displays the entered elevation and coordinates. The program creates the 
first point and connects the cursor to the point by a rubber band line. 

3. Move the cursor along the contour, and press the Enter button at the end of each 
straight section.

4 Press the Enter button several times while moving the cursor around the radius of 
curves.

5. Press the Blank button to end the line at the end of the contour. Your screen should 
look similar to the illustration below.

The more 

points you 

enter while 

digitzing a 

curve, the 

smoother and 

more accurate 

the data will 

be.
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Enter  Closed Contours

Closed contours are entered differently than typical contours. We’ll use the 254 closed 
area inside the contour just digitized in this example.

1. Type in “254” on the 16-button cursor, and then move the crosshairs over the con-
tour and press the Enter button.

2. Digitize the contour, pressing the Enter button at the end of each straight section, 
and pressing the Enter button several times while moving the cursor around the ra-
dius of curves. Your screen should look similar to the illustration below.

3. Move the crosshair close to the starting point, and press the SP button to snap to 
that point and close the contour. 

4. Press the Blank button to end the line.

Auto Increment Elevation Entry

The auto increment function assists in entering elevations. As sequential elevations are 
entered, Sitework 4D anticipates the next elevation and fills it in automatically. As often 
as possible you should enter the contours sequentially by elevation to take advantage of 
this feature.

• Enter the 255 closed contour inside the 254 elevation using the auto increment func-
tion, and steps 2 through 4 above.
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Enter  Spot Elevations

There are several spot elevations in the existing ground. We’ll use one inside the 255 
contour just digitized in this example.

 1. Type in “255.48” on the cursor then move the cursor crosshairs over the elevation 
inside the contour and press the Enter button.

2. Press the Blank button to end the spot elevation entry. Your screen should look simi-
lar to the illustration below.

Enter Remaining Elevations

Use the previous techniques to enter the remaining existing elevations from the Pine 
Street plan sheet.
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   Enter Ridges and Swales

Ridges and swales can be entered to increase the accuracy of the ground model. This 
grading plan includes an existing street (Gregory Lane) represented as contours on the 
left side of the plan sheet. The chevron pattern of the contours do not model the curb 
line very well and leaves out the sharp edge of curb and crown slope. To optimize the 
3D model we should snap elevation lines at the crown and sides of the existing street. 
This improves the model of the original ground.

1. Switch to Entry mode, and place the 16-button cursor near the center crown tip of 
the 247 street contour, then press the SP button to snap to this point.

2. Move the crosshairs to the 248 street contour crown, and press the SP button again.

3. Continue up the street snapping to the other center-line points on the contours.

4. Press the Blank button to close the line.

5. Snap a few other lines along the curb on either side of the existing street. This 
should give it more definition for a better ground model.

6. Press the Blank button to display the Right Mouse menu, and select Edit Mode to 
end line entry. Your screen should look similar to the illustration below.
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Edit  Existing Ground

After you’ve entered the existing ground, you should take some time to edit the data to 
ensure it is as accurate as possible. Essentially, all of the existing ground is made up of 
lines or points. This section shows how to edit lines and points. Editing is typically done 
in Edit mode with the mouse instead of the 16-button cursor.

 Undo

If at any time you make a mistake, Sitework 4D has the added feature of Undo. To ac-
cess this command, press Ctrl+Z or select Edit>Undo. Up to the last 8 commands can 
be reversed. Undo works in both Edit and Entry mode.

 Editing a Line

The Line Editor is used to make changes that affect every point on the line. The Line Edi-
tor allows you to change the Elevation, Point Labels, and the Line Label for the selected 
line. A description of the fields is below.

• To open the Line Editor, double-click on a line, or select a line, right-click to display 
the Right-Mouse menu, and select Line Editor.

Elevation  Changes all points on the selected line to one constant elevation.

Point Label  Assigns all the points on the selected line the same point label.

Line   Assigns a label to the line. This label is independent of any point  
    labels already assigned.

Affect Adjacent  This causes any line attached to the currently selected line   
Points  to also be modified at the point where they connect.

     Deleting a Line

To delete a line, select it then select Edit>Delete or press the Delete key. Multiple lines 
can be deleted by selecting each line using Shift+click before deleting them.
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Breaking a Line

Sometimes only part of a line needs to be edited. To do this you first have to break the 
line, then edit the new line as needed. To break a line:

•  Click on a point on a line and press Ctrl+X or select Edit>Break Line.

or

• Place the cursor over the point at which you want to break the line and press the F5 

key. The line breaks at the location of the cursor and a point is inserted at the break 
points on each line segment.

 Editing a Point

Individual points are edited using the Point Editor. The Point Editor allows you to change 
the North, East, and Elevation of the point as well as the Point Label and Line Label for 
the selected point. Sitework 4D has five point types, color-coded by type. The point 
types are:

•  Interpolated points (light blue) derive their elevation from the slope between the 
Entered elevations that surround them. If the elevation of the points that are used for 
interpolation are edited, the interpolated point elevation is recalculated as well.

•  Daylight points (green) are assigned elevation from the Existing surface. 

•  Entered points (white) are points with user-assigned elevations, through editing or 
entry. These points do not change elevation unless the user specifically changes 
them.

•  Snapped points (red) are created when a point on a data line is snapped (F6 or F8) 
to another existing data line. These become Entered points after the job is saved and 
reopened.

•  Annotation points (brown) are not used by the program to create the 3D surface. 
The presence of an Annotation point on a line changes all points on the line to An-
notation. Lines transferred through the CAD transfer with an elevation of zero are 
automatically assigned as Annotation.

�
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To open the Point Editor:

• Select a point, then right-click and select Point Editor from the Right Mouse Menu. 

 North  The northing coordinate for the point.

 East  The Easting coordinate for the point.

 Elevation  Changes the selected point’s elevation.

 Point Label Assigns the point label to the selected point.

 Line  Assigns a label to the line the point is part of. This label is indepen- 
   dent of any point labels already assigned.

 Affect Adjacent This causes any line attached to the currently selected point to also  
Points   be modified at the point where they connect. 
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2D Overlay

3D Terrain

 Inspect the Existing Ground

Now that all the existing ground data has been digitized and edited, you can visually 
inspect the site in 3D. To view the existing ground in 3D:

• Press the V key, or click the 3D View button on the tool bar. If the 3D view does not 
appear, press T key to toggle the display of the terrain.

Cut or Fill  amount at 
the current location

Resets all settings to
the program defaults

Launches HELP

Point  label of 
selected point

Line label of 
selected point Elevation of 

selected point

Northing of 
selected point

Easting of 
selected point

Horizontal distance 
between selected 
point and current 

location

Slope between
selected point and 

current location

Vertical distance 
between selected point 
and current location

Drives forward 
and back

Turns the view 
left and right

Increases and
decreases the
elevation skew

Changes the
viewing angle

Increases/decreases
the viewing distance

 behind the vehicle

Toggles between ground 
and aerial views
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 Enter  Stripping Areas

 Stripping areas are used to remove a constant depth from the existing ground to reflect 
vegetation and topsoil removal. Stripping areas are entered in the Existing surface in 
the Stripping Areas layer. On this site we’ll strip .5 feet from the back of the existing 
sidewalk over the remainder of the site. Stripping areas are not cumulative, so putting a 
stripping area within an existing stripping area does not add the depths together. 

1.  Switch to Entry mode and select Existing from the Surface pulldown and Stripping 
Areas from the Layer pulldown, or Select Guide>Tablet and choose Enter Stripping 

Areas, and the Stripping Areas dialog box displays.

Fix Bad Elevations

Use the Arrow keys or the 3D Controls on the right side of the window to move the ve-
hicle around the site while looking for bad elevations. A bad elevation usually appears as 
a spike up or down on the 3D terrain. To fix a bad elevation:

1. Select the bad elevation in the 2D Overlay or move the vehicle to the location.

2. Switch to Edit Mode, and press the T key to turn on the terrain to see the bad eleva-
tion in 3D.

3. Select the bad elevation (if not selected). The elevation is highlighted in the Elevation 
list on the right side of the window.

4. Double-click the elevation in the list to open the Point Editor, and make necessary 
modifications. 

5. Switch back to 3D View mode to find and fix other bad elevations.

2. Enter “Stripping 1” for the Area Name and “.5” for the stripping depth. Click OK. 

3. Move you cursor to where the sidewalk for Gregory Lane intersects with the prop-
erty line behind Lot 1.

4. Move the cursor up to where the sidewalk for Gregory Lane intersects with the prop-
erty line behind Lot 4 and push the Enter button.

Having the 
terrain vis-
ible allows 
you to see 
how any 
changes 
affect the 
3D model 
instantly.
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5. Continue to the right and push the Enter button at the point labeled with a Northing 
and Easting at the top-right of the job.

6. Continue down to the next point labeled with a Northing and Easting, and push the 
Enter button.

6. Press the Blank key to end the entry and snap the Stripping Area closed.

 Editing  Stripping Areas
Editing the stripping area is just like editing any line or point on a line. To edit the entire 
area, use the Line Editor. To edit points on the stripping area, including moving the point 
to modify the shape of the area, use the Point Editor. See “Edit Existing Ground” on page 
7-14 and “Editing a Point” on page 7-15 for more information.
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Lesson 2 –  Enter The  Proposed Design

The next step is to enter the proposed design lines. All proposed design lines are entered 
in the Design surface. Like the previous sections, this section demonstrates how to enter 
lots, streets, retaining walls, and curbs, but does not cover entering all data from the 
plan sheet.

 Enter  Lots

There are four lots on Pine Street, but we’ll enter lot on the bottom left as a demonstra-
tion.

1. Switch to Entry Mode and select Design from the Surface pulldown and Data Lines 
from the Layer pulldown, or press the G key and select Enter Design Data Lines from 
the Tablet Entry Guide.

2. Type in “251.0” on the 16-button cursor, then move the crosshairs over the lower 
left corner of lot 1 and press the Enter button. The status bar at the bottom of the 
screen displays the entered elevation and coordinates. The program creates the first 
point and connects the cursor to the point by a rubber band line.

3. Move the cursor along the lot and press the Enter button at the end of each straight 
section.

4. Press the Enter button several times while moving the cursor around the radius of 
curves.

5. Press the SP button to snap to the first point and close the lot. Press the Blank but-
ton to end the line.

6. Enter the remaining lots to practice the technique.
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 Enter the Street

The street will be built to subgrade, and the street, curb/gutter, and sidewalk will be built 
using offset lines. To do that, we must digitize a reference line with elevations to use for 
offset line creation. The reference line we will use is the top of curb line.

1. Type in “246.9” on the 16 button cursor, then move the crosshairs to the left of Lot 
1 where the proposed street meets Gregory Lane, and press the Enter button.

2. Press the Enter button several times while moving the cursor around the radius of 
the curve until you reach the next assigned elevation. 

3. Type in “247.9” on the cursor then press the Enter button to enter that point.

4. Continue typing in elevations and pressing the Enter button along the length of the 
curb to enter points.

5. Press the Blank button to end the line.

6. Type in “247.8” on the cursor, then move the cursor crosshairs to the other side of 
the street at Gregory Lane, and press the Enter button.

7. Continue typing in elevations, and pressing the Enter button along the length of the 
curb to enter points.



Sitework 4D Digitizer Support Tutorial

6-22

 Create the Sidewalk using  Offset Lines

The sidewalk needs to be entered. The top of curb line will be used as the reference for 
creating this line using the Offset Line Editor.

 Offset Line Editor

The Offset Line Editor is a powerful tool for creating lines based on numeric distances 
from a reference line. The following page has explanations of the features of the Offset 
Line Editor.

8. Press the Blank button to end the line. Your screen should look similar to the illustra-
tion below.
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Line Controls

Offset The Offset button toggles the direction of the offset line compared to  
   the selected reference line. The point order on the line determines right  
   and left. An arrow displays on the overlay showing the offset direction.

Points Every This is a two part control. When the Points Every box is checked, the  
   program creates extra points on the offset line at the distance specified in  
   the text box. When the box is unchecked the program matches the points  
   on the reference line and only adds points to correctly model corners. 

Connectors This option creates lines between the reference point and its corre-  
   sponding offset point. It is most often used when sloping to Daylight.

Daylight The Daylight check box allows creation of lines at a specified slope to  
   daylight. Checking this option adds Cut and Fill slope text boxes to the  
   Start and End of line areas.  

Start/End of Line

The Start/End of Line text boxes control the placement of the offset line. Specifying any 
two values for the Start or End calculates the other value and displays it in red. Varying 
the Start and End values allows creation of offset lines not parallel to the reference line.

Offset   The distance from the reference line to the offset line.
Distance

Elevation   The change in elevation between the reference and offset lines.   
Difference     

Slope  The slope from the reference line to the offset line specified as a
   percentage.

Confirmation Controls

Apply  Creates an offset line based upon the specifications in the Offset   
   Editor. 

View  Displays changes made in the Offset Editor settings without actually   
   creating the line. 

Close  Closes the Offset Editor. 

Determining  Line Direction

The line direction is indicated by a diamond at the end of the line indicating the first 
point when the line was drawn. Imagine yourself standing on the first point of the line 
looking down the line. An offset line to the left and right would be the same as your left 
and right.

Other Offset Features

The Offset Editor can offset multiple selected lines. This relies on the line direction being 
constant between the lines. The  Utility>Swap Ends command changes line direction.
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Because we started the lines at Gregory Lane when we digitized the top of curb lines, 
both start on the left side of the job. For this example, we need to change the direction 
of one of the lines so that we can enter the offsets for both lines simultaneously.

1. Switch to Edit mode, and click on the top of curb reference line nearest Lot 4.

2. Click the Swap Ends button to change the direction of the line. The diamond should 
now be at the opposite end of the line.

3. Shift+click on the other top of curb reference line so that both lines are selected.

4. Press the T key to toggle on the terrain display. Your screen should look similar to 
the illustration below.
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5. Click the Offset Line button or select Utility>Offset Line to open the Offset Line Edi-
tor.

6. Set the offset to Right, type “5.5” as the Offset Distance and “2” as the Slope, then 
click the View button to see the line displayed. If it looks to be in the right place, 
click Apply to add the line. After applied, your screen should look like the illustration 
below.

7. Click the Close button to close the Offset Line Editor.
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3. Switch to Entry Mode.

4. Place the 16-button cursor over the 252 design contour behind Lot 2 where it con-
nects to the existing contour, and press the F6 key. This inserts a point on the exist-
ing contour, and snaps to that location. Move to the 253 existing contour and press 
F6 to insert a point, and snap to that contour.

5. Continue digitizing the contour, pressing the F6 key only to snap to a place on a line 
where there is no point. If there is a point on the line available, use the F8 key to 
snap to the existing point.

6. Enter the remaining design contours behind Lots 2 and 3 using the method above. 
When complete, your job site should look similar to the illustration on the next page.

Adding the  Design Contours and a Retaining Wall

The only proposed ground left to enter is the retaining wall and the design contours at the 
back of lots 2 and 3. Most of the contours tie into the existing ground so it is helpful to 
see the existing ground during design entry. 

1. Click the Layer Selection button. The Layer Selection window is displayed. In this 
case, we want to make the existing contour lines visible so we can tie the design con-
tours into them. 

2. Select the Existing box, and click OK. The existing contour lines now display with the 
design lines. 
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7. Zoom in to the location of the retaining wall. Type in “253.5” for the top of the wall, 
and enter points along the wall’s length. Make sure you zoom in far enough that you 
don’t overlap the retaining wall line with the design line for Lot 2.

 Editing Design Data Lines

Editing design lines is the same as editing the existing ground. See “Editing Existing 
Ground” on page 7-14 for additional information.

 For this example, we do not put in the bottom of the retaining wall, because the bot-
tom of the retaining wall is at the same elevation as the building pad. It is not neces-
sary to enter the bottom of the wall in this example. For future retaining walls, use an 
offset line set at 0.1 to the down-sloping side of the wall.

8. Press the Blank button to end data entry.
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 Enter the  Design Perimeter

The Design Perimeter controls the limits of excavation. Any data outside of the Design 
Perimeter area is not calculated and is not included as part of the total volume. Any area 
that does not have a Report Region assigned to it will be a part of the Perimeter Pro-
posed on the volumes report. The Design Perimeter is entered in the Design Perimeter 
layer.

The Design Perimeter has no elevation when entered but calculates the elevation of the 
Existing Ground along its length. The Design Perimeter conforms to the Existing Ground 
and adds a data line, known as a Drape Line, to the Proposed Design at daylight.

 Drape Lines

For most situations the Design Perimeter should be entered with a Drape Line. A Drape 
Line ties the edges of the job to daylight at the perimeter of the job. For example, you 
may not want a drape line if you are doing a takeoff from multiple sheets with perimeters 
around each sheet to calculate volumes but not needed to slope to daylight.

In the illustration above, you can see how the design data slopes differently when there 
is a drape line. With a drape line, the design slopes to daylight at the design perimeter. 
When there is no drape line, the design continues its current slope until it reaches the 
perimeter and then slopes straight to daylight.

Enter the Design Perimeter

1. Switch to Entry Mode and select Design from the Surface pulldown and Perimeters 
from the Layer pulldown, or press the G key and select Enter Design Perimeter from 
the Tablet Entry guide.

2. Place the 16-button cursor at the lower right corner of the plan sheet and press 
the SP button twice to snap to the Stripping Area that should be displayed on the 
screen. If it is not displayed, select View>Show All and make sure that Stripping 
Areas is checked in the Layer Selection dialog box.

3. Snap to the remaining corners of the Stripping Area. You may want to extend the 
perimeter beyond the street so that the associated daylight line does not cause the 
street to slope to daylight.

Design Surface

Existing Surface

Perimeter

Drape Line

Straight SlopeSloping to Daylight
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4. Press the Blank button to close the region. Press the Blank button again to end data 
entry. The Apply Drape Line dialog box is displayed.

5. Click Yes to apply a drape line.

 Entering a  Hole in the Design Perimeter

A hole in the Design Perimeter is entered as a perimeter within the Design Perimeter and 
is excluded from volume calculation. A hole in the design perimeter also places holes in 
the stripping areas, report regions and sectional areas. The opposite is true for a perim-
eter entered outside the Design Perimeter. This acts as an island and becomes a part of 
the volume calculation of the Design Perimeter. The undisturbed area behind Lot 2 will 
be entered as a hole in the Design Perimeter.

1. Make sure that the Design Surface and Perimeters Layer are selected from the 
pulldown menus, and zoom into the area behind Lot 2.

2. Press the Enter button at each of the corners of the hole to create the hole.

3. Press the Blank button twice to close the area, and end data entry. The Apply Drape 
Line dialog box is displayed.

4. Click Yes to apply a drape line. Your screen should look like the illustration below.
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1. Switch to Entry Mode.

2. Click the Add Report Regions button, or press the G key and select Enter Report/Sec-

tional Areas from the Tablet Entry Guide. The Report Regions dialog box is displayed.

3. Type “Lot 1” in the Region Name. Check the Report Region box and uncheck the 
Sectional Area box. Type “.5” as the Sectional Depth. Click OK.

4. Place the cursor over the top left corner of Lot 1, and press the F8 key twice then 
the Blank key to snap a report region around Lot 1.

5. Repeat step 4 for lots 2-4 to digitize a region around each lot.

Sitework 

4D auto-

increments 

Report Region 

names when 

the name is 

followed by a 

space and a 

number, i.e., 

“Lot 1”.

Create  Report Regions/Deduct  Sectional Areas

Sitework 4D uses Report Regions to break up areas for individual calculation on the 
volume report. These are created by entering a Report Region around the area. Sectional 
areas are regions that subtract their depth from the design grade elevations, as well as 
being broken up for individual calculation on the volume report.
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Entering the Street  Sectional Area

To drop the street to subgrade, we need to create a sectional depth.

1. Switch to Entry Mode.

2. Click the Add Report Regions button, or press the G key, and select Enter Report 

Regions/Sectional Areas from  the Tablet Entry Guide. The Report Regions dialog box 
is displayed.

3. Type “Street” in the Region Name. Check the Report Region box and the Sectional 
Area box. Enter “1.15” in the Fill Factor box and “1.33” in the Sectional Depth box. 
Click OK.

6. Press the Blank button again to end Report Region entry.
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4. Place the cursor over the beginning of the top of curb line near Lot 4.

5. Using the F8 key and line snap, digitize a region around the street. Use the other top 
of curb line for the other side of the street and connect the lines at the openings.

6. Press the Blank button to end the entry and close the Sectional.
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Entering the Sidewalk Sectional Areas

To drop the sidewalks to subgrade, we need to create a sectional similar to he street 
section created previously.

1. Click the Add Report Regions button, or press the G key, and select Enter Report 

Regions/Sectional Areas from the Tablet Entry Guide. The Report Regions dialog box 
is displayed

2. Type “Sidewalk 1” in the Region Name box. Check the Report Region box and the 
Sectional Area box. Enter “1.15” in the fill factor box and “0.330” in the Section 
Depth box.

3. Place the cursor over the beginning of the top back or walk line near Lot 4.

4. Using the F8 key and line snap, digitize a region around the left sidewalk between 
the back of walk line and the top of curb line.

5. Press the Blank button to end the entry and close the sectional.

6. Repeat the above process for the sidewalk on the other side of the street, using 
“Sidewalk 2” for the name.
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 Lesson 3 – Calculating Volumes

The creation of 3D surfaces allows comparison of the surfaces for volumes. This les-
son shows how to verify the job with the 3D view and specify the area to calculate and 
generate the volumes.

Visual Verification with the 3D View Window

Sitework 4D can display the 3D terrain as it is entered in the Edit window. The 3D View 
Window adds greater flexibility to viewing and verifying the 3D surfaces.

While we were editing, the 3D Terrain showed how the program interpreted the data 
lines to form the surfaces. The 3D Window is a much more flexible version of the 3D 
Terrain which allows greater control over the view.

Press the 3D View icon on the tool bar or choose Window>3D View. The 3D window 
calculates the cut/fill colors and surfaces before displaying.

Use the 3D controls to inspect the terrain for any errors and to see how the data we 
have entered displays on the job. Refer to “Inspect the Existing Ground” on page 7-17 
for a description of this window and the 3D Controls. Note that the Ref and Diff surfaces 
can be changed to compare different surfaces on the 3D View.

Driving

Driving the 3D View is the easiest way to double check your work and the surface qual-
ity. It also can display the Subgrade and Stripping surfaces and calculate volumes.

Be sure the 

finished 

surface (the 

surface you 

are calculating 

to) is on the 

left, and the 

begining 

surface (the 

one you are 

calculating 

from) is on 

the right.
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Use the Arrow keys on the keyboard to drive through the site. The Up and Down arrows 
move forward and back. The Right and Left arrows turn. For additional clarity you may 
want to turn the Overlay off by pressing the O key or by selecting Display>Overlay. The 
speed of the drive is based on the Arrow Rate setting which is located on the Edit menu. 
Each arrow key press has a distance that the Arrow Rate controls. The speed of your 
computer and video adaptor can also affect screen speed.

Try using the 3D controls to change the views and get a feel for what they do. Also try 
changing the Reference and Difference surfaces to see the different views and compari-
sons.
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 Calculate Volumes

1. Define the  Volume Area. Click the A button on the Utility Tool Bar to create a bound-
ing box around the entire job. This determines the limits of the volume calculation. 

2. Specify the Surfaces. Before calculating the volumes verify that the correct surfaces 
are selected. For our example, set the Reference surface to Design and the Differ-
ence surface to Stripped.

3. Calculate the Volume. The Volume Calculation is started by clicking the Calc Volume 
button on the tool bar or by selecting Utility>Calc Volume.

During the volume calculation the cross sections display at the bottom of the screen 
with blue representing the Reference and Green the Difference. A line displays on the 
overlay showing the corresponding location of the cross section. The calculation can be 
paused by pressing the Spacebar or aborted by pressing Esc. When paused, the I key on 
the keyboard will move across the site incrementally. Pressing the Spacebar again will 
resume the volume calculation.

Cross Section 
display

Cross Section 
location
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When the calculation finishes, the Volume Calculation Results are displayed. 

These numbers represent uncompacted cut and fill between the two surfaces. The 
Horizontal Area represents plan view areas with no slope adjustment and is broken down 
into Cut, Fill, and On-grade square footage. Slope Area represents a slope adjusted 
square footage. It is the total surface area, excluding vertical surfaces like the curb face. 
Press Done to close the dialog box. These volume numbers can be recalled by clicking 
the Volume Report button on the tool bar.



Sitework 4D Digitizer Support Tutorial

6-38

Job: Pine Street PDF Tutorial
Units: Ft-CY

Mon Mar 07, 2011 09:16:47 Page 1

Volume Report
      Subgrade vs. Stripped      

               Area         Volume     Comp/Ratio  Compact  Export  Change   
                                              Total            Cut             Fill     OnGrade              Cut      Fill          Cut        Fill          Cut        Fill    -Import  Per .1 Ft   
Landscape   29,881     9,511     17,821  2,549     319  672     1.00   1.00   319  672  -353  111   

   

Lot 1   7,358     0     7,358  0     0  498     1.00   1.00   0  498  -498  27   

Lot 2   11,666     7,864     2,955  847     290  50     1.00   1.00   290  50  240  43   

Lot 3   8,645     7,103     1,120  422     251  17     1.00   1.00   251  17  234  32   

Lot 4   7,580     2,654     4,703  223     143  274     1.00   1.00   143  274  -131  28   

   
                                                                                                                                                                                                    

Lot Sub:  35,249     17,621     16,136  1,492     684  839           684  839  -155  130  
   

Sidewalk 1   2,038     1,946     0  92     105  0     1.00   1.00   105  0  105  8   

Sidewalk 2   1,441     1,391     0  50     47  0     1.00   1.00   47  0  47  5   

   
                                                                                                                                                                                                    

Sidewalk Sub:  3,479     3,337     0  142     152  0           152  0  152  13  
   

Street   14,113     14,113     0  0     1,254  0     1.00   1.00   1,254  0  1,254  52   
                                                                                                                                                                                                                                               

Regions Total   82,722     44,582     33,957  4,183     2,409  1,511           2,409  1,511  898  306  
   

   

   Plane     Slope  
Stripping Qtys                     Area          Area         Depth       Volume  
Stripping   81,992     82,195     0.500  1,522  

   

   

   Plane     Slope  
Sectional Qtys                    Area          Area         Depth       Volume  
Landscape   29,881     30,572     0.000  0  

   

Lot 1   7,358     7,388     0.500  137  

Lot 2   11,666     11,698     0.500  217  

Lot 3   8,645     8,674     0.500  161  

Lot 4   7,580     7,605     0.500  141  

   
                                                                      

Lot Sub:  35,249     35,365        656  
   

Sidewalk 1   2,038     2,057     0.330  25  

Sidewalk 2   1,441     1,455     0.330  18  

   
                                                                      

Sidewalk Sub:  3,479     3,512        43  
   

Street   14,113     14,118     1.330  695  

   
                                                                      

Sectional Total  82,722     83,567        1,394  

The  Volume Report

Select Window>Volume Report or click on the Volume Report button to switch to the 
Volume Report.

The Volume Report displays area, volume, and depth for stripping and sectional areas. The 
total area, cut/fill, strata, and on grade volume for each report region and sectional area 
are displayed, if created. The report also displays the Cut-Fill volumes, compaction ratios 
and their impact on the volumes, import/export data, and volume change per 0.1 foot of 
elevation change, which is useful for balancing the site. The data in the volume report 
should be similar to the illustration below.
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 Vector PDF Entry Overview

This tutorial illustrates how to digitize a job using the information found in a vector PDF. 
A vector PDF is one that contains line data from a CAD, or similar, file. A vector PDF can 
be identified by the color of the border when the image is imported into Sitework 4D; a 
green outline represents a vector PDF, while a red outline represents a standard raster 
PDF. Remember: green for go, red for no.
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Data Entry Sequence

The following is the suggested data entry sequence when entering a takeoff using a PDF 
file.

Import and Scale PDF File

• Start a New Job
• Import the PDF
• Scale the Image
• Verify the Scale

Vectorizing and Transferring Data

• Vectorize PDF
• Transfer Existing Lines
• Transfer Design Lines

Assigning Elevations

• Line Editor
• Increment Snap
• Elevation Snap
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Lesson 1 - Importing and Scaling

This lesson covers the importing and scaling of a vector PDF. Training videos discussing 
vector PDFs can be found at http://www.agtek.com/trainingvideos.html. It is recom-
mended to watch the training videos before beginning the tutorial.

Start a New Job.

1. Double click the Sitework 4D shortcut on the desktop. The open dialog displays.

2. Select the “Montessori School Site.pdf” file and click Open.

3. The PDF is imported into the Data Transfer Mode with a green outline, signifying 
a vector PDF. A vector PDF contains the information necessary for the program to 
vectorize the data, and create line work similar to a CAD file. The information is 
divided into layers based on line color and thickness. A red outline signifies a raster 
PDF which can not be vectorized and must be entered manually.
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4. Rotate the image pressing the L key twice to rotate the image counter-clockwise into 
the proper alignment. The R key will rotate the image clock-wise. Your screen should 
appear similar to the illustration below.

Scaling the PDF

1. Zoom in to the lower-right section of the PDF and locate the scale bar. In this exam-
ple the scale is 1:20 feet.

2. Select Data Transfer>Image Scale and the Edit Image Scale dialog box is displayed.

3. Enter “20” for the scale and click OK.

4. A dialog box is displayed advising you to verify the scale of a drawing by measuring 
a known distance. Click Yes to verify the scale.
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Lesson 2 - Vectorizing and Transferring Data

When you  vectorize a file using AGTEK software, annotation lines are created and sepa-
rated into layers depending line weight and color of the original file i.e.; red, black, and 
blue lines would all be in different layers (Layer 1, Layer 2, etc...). 

1. Since this is a vector PDF, which has line data from a CAD file, we can vectorize the 
data by selecting Data Transfer>Vectorize.

2. When complete, vecotrized lines are laid over the image. To turn off the background 
image, select Display>Bitmap, or by pressing the T key. Your screen should appear 
similar to the illustration below.

Some files 
vectorize 
better than 
others. You 
may want 
to transfer 
data that 
vectorizes 
well, and 
trace the data 
that doesn’t 
manually.

5. Zoom into the scalebar at the bottom right side of the drawing and enter two points 
at each ond of the toolbar. Confirm the measured distance is correct. Click OK. 

If the measure 
distance is 
incorrect, 
enter the 
correct 
distance in 
the Actual 

field and click 
OK..
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4. Right-click and select Send to Existing. Since there are no elevations assigned, all 
lines are sent to the annotation layer.

5. Select a Design line. Right-click and select Send to Design. Continue sending data to 
the Design layer until all useful information is transferred.

This screen 
shot has been 
zoomed into 
the upper-left 
side of the 
job.

3. Zoom into the drawing and select one of the gray Existing contour lines.

Existing Contour Line

When existing 
contours 
are dashed, 
and can be 
separated 
into their 
own layer 
(same weight, 
color, etc...) 
Sitework 
4D will 
automatically 
join them, 
eliminating 
the gaps.

This screen 
shot has been 
zoomed into 
the upper-left 
side of the 
job.
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3. Select the 505 contour and enter “505” using the keyboard and the Line Editor dia-
log will display. Click OK.

4. Press the ESC key to clear all selections.

5. Position your arrow over the “500” contour, BUT DO NOT CLICK. Press the F8 key. 

6. Position your arrow over the “505” contour, BUT DO NOT CLICK. Press the F8 key.  
This will enable Increment Snap. The current interval can be seen at the bottom left 
of the program window.

Vectorized 
design lines 
are sometimes 
segmented. 
They can 
be joined 
to create a 
single line. For 
information on 
joining lines, 
see page 3-
13.

 Lesson 3 -  Assigning Elevations

1. Turn off the PDF by pressing the T key. This will make the annotation lines easier to 
read.

2. Zoom into the top-left portion of the job and select the 500 contour line. Enter “500” 
using the keyboard and the Line Editor dialog will display. Click OK.

 Increment 
snap 
increases/
decreases the 
elevation of 
the last line 
and assigns 
that elevation 
to the current 
line. It will 
continue until 
you press 
ESC or select 
something by 
clicking the 
mouse.
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9. Continue using the same technique to assign the rest of the Design contour lines. 
The Existing contour lines can also be entered using the same techniques.

It is not uncommon for jobs to be spread across multiple PDFs. In this case, you will 
need to align PDFs to data that has already been entered. For information on aligning 
multiple PDFs please see page A-70 in the appendix.

For more information on completing the job; adding Sectional Areas/Report Regions, Pe-
rimeters, Stripping, etc., please see the CAD Tutorial beginning on page 3-1. There area 
also training videos available at http://www.agtek.com/trainingvideos.asp. It is advised 
that you watch the corresponding training videos before completing the tutorials.

7. Continue using the Increment Snap to assign the rest of the elevations at the top of 
the slope. The increment, in this case 5 feet, and direction, up or down - this case 
up, is determined by the first two lines selected. In the case the first two lines se-
lected were 500 and 505, so following lines will be assigned ascending elevations in 
5 foot increments. 

8. When complete, select annotated portion of the 550 contour line on the right side 
of the job. Position your arrow over the blue portion of the “550” contour line (data 
line) BUT DO NOT CLICK. Press the F9 key. The elevation from the selected 550 
data line will be assigned to the indicated annotation line.
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Document Conventions

This document uses standard software documentation conventions to explain how the 
software works. These conventions are described below.

Click/click on - Press the left mouse button (assuming the buttons are set to the default 
settings). 

Double-click - Press the left mouse button twice in rapid succession.

Right-click - Press the right mouse button.

Click and hold - Press and hold down the left mouse button.

Shift/Ctrl+click - Press and hold down the Shift/Ctrl key then press the left mouse button.

Click and drag - Press and hold the left mouse button, then move the mouse.

Ctrl+(Key) - Press the Ctrl key then press the keyboard key noted in the step.

Press - Push a specified key on the keyboard.

Select - Use the mouse to pick an item on the screen or menu command.

Menu Commands - When documenting a menu command, the command is described us-
ing the following format: Menu>Command. If there is more than one level to the menu, it 
appears as a Submenu. For example, Options>Sound Preference>Sound Card.

Data Entry/File Names - If a file is specified in a procedure, or if specific text needs to be 
entered into a field as part of a procedure, it will appear inside double quote marks.

 User Interface

Earthwork 4D relies on the keyboard for alphanumeric entry and keyboard shortcut, and 
the mouse for non-digitized editing and entry.

  The Keyboard

Most tasks are available on menus and the toolbar at the top of the screen, but the tasks 
can also be accessed through keyboard shortcuts shown next to the command in the 
menus.
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  The Mouse

Earthwork 4D makes extensive use of the mouse throughout the program. A wheel-style 
center button mouse is highly recommended. The mouse is used for data entry and edit-
ing.

The Left button is used to select objects and choose menu items.

The Right button is used to display the Right-Mouse menu. This menu displays quick ac-
cess to specific commands.

The Wheel Button allows the user to zoom in or out over the location of the arrow (or a 
segment if selected) by rolling the wheel Up or Down respectively. Holding the button 
down and moving the mouse allows the user to pan the view on the screen.

Left Button

Wheel Button

Right Button
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 Pull Down  Menus

Menu commands can be selected from pulldown menus by clicking on the menu then 
clicking the command. A submenu is noted by an arrow pointing to the right after the 
command name. Click on the command with the submenu to view the available com-
mands and click on the command in the submenu to select it. Menus and commands 
displayed in gray are not available.

  Buttons

A button is selected by placing the cursor over the button and clicking it.

  Check Boxes and  Radio Buttons

Check Boxes and Radio Buttons are used to display whether an option is enabled or dis-
abled. When filled, the option is on.

  Checks

Checks indicate that a certain command option is enabled. These appear in menus and 
submenus in Earthwork 4D.

  The Arrow

The arrow is used for selecting items only.

  The Crosshair

The crosshair means the program is in Entry Mode. 

 Selecting

Selecting is done by placing the arrow over the object and clicking it. Multiple items can 
be selected by pressing and holding the Shift key while selecting the items.

  Text Boxes

Text Boxes are used to input values. Select the text box to add or modify the data. The 
text cursor can be moved with the TAB key or by selecting a new text box.
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  Screen Modes

Earthwork 4D operates in several modes, each with a different purpose and a different set 
of menus and commands to perform specific tasks associated with that mode. Below is a 
description of each of the modes.

  Import Mode

CAD Transfer Mode is used to transfer the layers of a CAD file into the job file. Differ-
ent layers can be chosen and sent either the Design or Existing Surface. The data can be 
further defined by transferring the lines to a specific layer within each surface.

  Edit Mode

 Edit Mode is used to edit job data and data lines once data has been entered or trans-
ferred.

  Entry Mode

 Entry Mode is used to enter job data and supporting data lines.

  Profile View Mode

 Profile View Mode is used to create two-dimension profile views across the 2D Plan   
View. Profile Lines can also be used to generate stations.

  Plan View Mode

 Plan View Mode is a colorized, two-dimensional cut-fill shaded plan view of the data.   
Plan View labels and the cut-fill shade table can also be displayed in Plan View Mode.

 3D View Mode

 3D View Mode is used to review the job using a three-dimensional model. A virtual drive-  
through can be done to inspect the job and volume quantities can be calculated in 3D   
View Mode. Results of adding additional job data can be seen instantly by the 3D View   
terrain once the data has been added.

  Volume Report Mode

 Volumes Report Mode displays the calculated volumes within the defined report regions.

  Haul Report Mode

Haul Report Mode displays the calculated balance regions.
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 Keyboard Shortcuts

Earthwork 4D contains many commands that can be accessed by both the menus and 
by keyboard shortcuts. Below is a list of these commands, their keyboard shortcut and a 
brief description of the command along with the mode in which the command is used.

 Changing Mode

 Switches to Edit Mode from any other mode. Toggles between Edit and Entry Modes.

 Switches to 3D View Mode from any other mode.

 Switches to Print Preview Mode from any other mode.

 Switches to CAD Transfer Mode from any other mode.

Switches to Plan View Mode from any other mode.

 Switches to Highway Mode. Toggles between Highway Mode and Haul Report Mode.

Switches to Profile View Mode from any other mode.

 CAD Transfer Mode

 Deselects any selected line.

 Zooms out to the extents of the job and restores the default viewing parameter.

 Moves the cursor in the direction of the arrow selected.

 

 Pressing the Shift key selects additional lines without deselecting other line.

Pressing the Ctrl key selects additional lines without deselecting other lines.

Zooms in or out over cursor location.

Rotates displayed PDF right and left respectively in 45 degree increments.

Zoom in and out.

 Deletes the currently selected line(s).

 Sends the currently selected CAD Line(s)/Layer(s) to the selected Surface and Layer

 “Sticky Zoom” toggle, allows zooming to a selected point.

 Toggles on or off the display of Plus Marks on data line.

 Hides the currently selected line(s)

 Displays all hidden data.

 Undo the last edit up to the last eight edits.

 Redo previously undone edits.
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 Print Preview Mode

 Print Preview Mode displays the print page and allows the user to arrange the print page.   
Both 2D views and 3D views can be sent to the print page, along with reports. Titles,   
images and additional text can also be added.

lr -
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  Edit and Entry Modes

Zooms out and centers the 2D Plan View to view the entire file.

When the cursor is placed over the 2D Plan View, the Arrow keys move in the direction 
the Arrow key is pointing. When the cursor is placed over the Elevation List, the Up/Right 
and Down/Left arrows move up and down the list.

In Entry Mode, the Number keys and the Period key are used to enter elevations, which 
appear in the Current Elevation Entry box at the bottom of the screen. In Edit Mode, these 
keys are used only when a line is selected. Typing a number displays the Point Editor dia-
log box, with changes made affecting the value in the Elevation box.

Pressing the Shift key selects additional lines without deselecting other lines.

Zoom in and out.

Deletes currently selected line(s).

Deletes the previously entered point one at a time (Entry Mode only).

Rotates the terrain view right and left respectively in 45 degree increments while in Edit 
mode.

In Entry mode, dipsplays the Edit Point/Line Labels dialog box.

With the terrain displayed, increases and decreases the view angle.

With the terrain displayed, increases and decreases the elevation magnification.

Displays the length and area for a selected line (Edit Mode only).

Toggles the display of the 3D terrain, PDF and a blank background.

Toggles on or off the display of the 2D Plan View (overlay).

Toggles on or off the location and display of the compass.

Displays the most recently selected Guide

Toggles the displayed PDF between low and high contrast.

Toggle on or off the Snap function.

“Sticky Zoom” toggle, allows zooming to a selected point.

With the terrain displayed, toggles between land view and sky view.

With the terrain displayed, moves the view above the vehicle.

With the terrain displayed, moves the view down to ground level.

View from inside vehicle.

View from 50 feet behind vehicle.

View from 50 feet left side of vehicle.

View from 50 feet right side of vehicle.

Breaks a line at a point nearest to the cursor (Edit Mode only).

In Edit Mode, inserts a point on the currently selected line. In Entry mode, snaps the point 
being entered to the nearest line and interpolates the elevation.

Backspace

²

¢£
¥¤

0 9

¨

µ

lr

du
-+

i

t

o

c

s
z

b

u

d

�

�
�

�
�

�

-

(select)

´³ -

-

-

-

g

m

l



Sitework 4D Reference

8-7

In Edit Mode, moves the selected point to the position of the tip of the arrow.

In Edit Mode, assigns ascending or descending elevations to points based on previous 
point selections. In Entry mode, snaps to the nearest point for point entry.

In Edit Mode, assigns the elevation from the nearest point to the selected line(s). In Entry 
Mode, puts the elevation from the nearest point in the Current Elevation box.

With the terrain displayed, rotates the 3D View 180 degrees.

Used to temporarily place the coordinate system into that of the selected line. Press the Q 
key to revert back to the original coordinate system (Entry Mode on).

Selects all data lines in the currently active layer (Edit Mode on).

Displays the Layer Selection window.

Hides the currently selected line.

With the terrain displayed, moves the view angle up.

With the terrain displayed, moves the view angle down.

With the terrain displayed, moves the view to the right.

With the terrain displayed, moves the view to the left.

With the terrain displayed, zooms in over the location of the vehicle.

With the terrain displayed, zooms out over the location of the vehicle.

Sends the currently displayed view to the Print Preview Page.

Displays all hidden data.

Displays only the active layer for editing/entry.

Toggles on or off the display of Hatch regions.

Toggles an elevation point/line to an annotation line and vice versa (Edit Mode on).

Copies the currently selected data to temporary memory (Edit Mode on).

Pastes the currently stored data to the current Surface and Layer.

Joins (Bridge Gap) selected lines at their endpoints if the distance is smaller than the 
bridge gap distance. Closes the line if only one line is selected (Edit Mode on).

Selects all lines with the same label as the currently selected line. If no line is selected, 
displays the Label Selection dialog box to select a label (Edit Mode on).

Displays the Offset Line Editor for the currently selected line(s) (Edit Mode on).

Breaks the currently selected line at the currently selected point (Edit Mode on).

Undo the last edit up to the last eight edits.

Redo previously undone edits (Edit Mode only).
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 3D View Mode

Zooms out and centers the 2D Plan View to view the entire job.

Moves the vehicle on the job site. The Up/Down arrows move the vehicle forward or 
backward. The Left/Right arrows rotate the vehicle left or right.

Cancels in-progress volume calculations.

Rotates the 3D View right and left respectively in 45 degree increments.

Increases and decreases the view angle.

Increases and decreases the elevation magnification.

With the 2D Plan View displayed, increases and decreases the Plan View Scale.

Pauses/resumes the volume calculation.

Displays incremental cross sections during the paused volume calculation.

Toggles on or off the display of the 3D View overlay.

Toggles on or off the display of the 2D Plan View.

Toggles on or off the location and display of the compass.

Displays the most recently selected Guide

Toggles the displayed PDF between low and high contrast.

Toggles between land view and sky view.

Moves the view above the vehicle.

Moves the view down to ground level.

View from inside vehicle.

View from 50 feet behind vehicle.

View from 50 feet left of vehicle.

View from 50 feet right of vehicle.

Rotates the 3D View 180 degrees.

Enters a Volume Area around the entered data.

Calculates the volumes.

Displays the Layer Selection dialog box.

Moves the view angle up.

Moves the view angle down.

Moves the view to the right.

Moves the view to the left.

Zooms in over the location of the vehicle.

Zooms out over the location of the vehicle.

Sends the currently displayed view to the Print Preview Page.
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 Volume Report Mode

Sends the currently displayed view to the Print Page.

 Print Preview Mode

Cycles between items on the page.

Deletes the currently selected item

Increase/decrease the scale of the currently selected item.

Inserts text at the current cursor position.

Moves the currently selected item in the direction indicated.
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 Tool Bars

Earthwork 4D uses the tool bars for quick and easy access to many commands. In addi-
tion to the standard tool bar, there are two other types: Mode Selection and Utility. Click 
on the button to activate the command. Below is a list of the commands on the tool bars. 
Buttons that are gray are not accessible.

New   Starts a new job file. The same command as selecting New from   
    the File menu.

Open   Opens an ESW file. The same command as selecting Open from the   
    File menu.

Save   Saves the current job. The same command as selecting Save from   
    the File menu.

Print   Prints the data that is currently displayed on the screen. The same   
    command as selecting Print from the File menu.

Mode Selection   

The Mode Selection Tool Bar is used for switching between the different Modes.

Import Mode  Switches to Import Mode.

Edit Mode  Switches to the Edit Mode.

Entry Mode  Switches to Entry Mode.

Profile View Mode Switches to Profile View Mode.

Plan View Mode Switches to Plan View Mode.

3D View Mode Switches to 3D View Mode.

Volume Report Mode Displays the Volume Report.

Haul Report Mode Displays the Haul Report.

Print Preview Mode Displays the Print Page.
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  Utility Tool Bar Buttons
The Utility Tool Bar displays different options depending on the Mode.

 Home  Centers the overlay and sizes it to fill the screen.

 Pan    Enables the Pan tool to move the overlay. Click the Pan button,    
     then click and hold to move the overlay. Release to stop moving.

 Area Zoom  Defines the view by dragging a box around the information desired.   
     Click and drag the box to define the zoom area. Click again to zoom   
     in.

 Layer Selection Controls the display of layers. Clicking a layer’s check box toggles   
     on or off the view of that layer. Gray layers cannot be displayed.

 Show Trimesh Displays the Triangular Mesh over the Plan View.

 Water Flow  Displays shaded lines on the overlay indicating the direction water   

     will flow on the surface.

 Send to  Sends the current screen image to the Print Page.
 Print Page

Transfer Auto CAD Data Mode Only

The following command is found only in the Transfer AutoCAD Data Mode Utility Tool 
Bar.

 Blocks  Displays AutoCAD blocks in the CAD file.

Edit Mode Only

The following commands are found only in the Edit Mode Utility Tool Bar.

 Label Selection Selects all lines with the same label as the currently selected line. If   
     no line is selected, displays the Label Selection dialog box to select   
     a label.

 Add Benchmark Adds a benchmark to a selected point or user-defined coordinates.   
     After a point is entered, the Edit Point dialog box is displayed   
     allowing you to adjust the point location or assign a label.

 Add Stake  Adds a stake point to either a selected point, at defined intervals   
 Point   along a selected line, or at user-defined coordinates.

 Apply Template Creates a template which can then be apply to a selected reference   
     line.

 Offset Line  Displays the Offset Line Editor.

 Join (Bridge Gap) Joins selected lines at their endpoints if the distance is smaller than   
     the bridge gap distance. Closes the line if only one line is selected.

 Swap Ends  Switches the start and end points of a selected line. Allows the user   
     to change the direction the line was entered.

 Trim Line  Breaks all lines that cross the selected trim line.

 Fillet Line  Fillets the intersection of line segments and joins them at the   
     selected point.
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 Edit Report Region Edits existing report regions and sectional area.

 Length/Area  Displays the length, plane, and slope area of a selected line, or total   
     length of the selected line(s).

Entry Mode Only

The following commands are found only in the Entry Mode Utility Tool Bar.

 Rectangle Tool Draws a rectangle. Click and drag the box to draw the rectangle.   
     Click again to end. After the rectangle is added, the Add Rectangle   
     dialog box is displayed allowing you to make adjustments to the   
     width and height.

 Circle Tool  Draws a circle. Click to indicate the center of the circle, then drag   
     the circle to draw it. Click again to end. After the circle is added,   
     the Edit Circle Radius window appears allowing you to adjust the   
     radius of the circle.

 Report Regions Creates report regions and sectional areas.

 Balance Regions Enters a balance region using a paint brush effect.

 Stage Over-Ex Displays the Over-Ex Guide menu for staging over-excavation data.

Profile View Mode Only

The following commands are found only in the Profile View Mode Utility Tool Bar.

 Profile Entry  Starts the Profile Entry command allowing the user to enter profile   
     lines across the overlay while viewing the profile in real time at the   
     bottom of the screen.

 Swap Ends  Switches the start and end of the selected profile line.

 Station Offsets Displays the Edit Station/Offset window to enter the station name   
     and the horizontal offset distance.

 Station Generator Displays the Station Generation window to enter the station name,   
     station interval, and left/right offset.

 Attach Profile Assigns elevations to a selected line from profile data entered with   
     a tablet.
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Plan View Mode Only

The following commands are found only in the Plan View Mode Utility Tool bar.

 Balance Regions Enters a balance region using the cursor.

 Volume Area  Creates a report region around all design perimeters (including   
     islands) for total volume calculation. 

 Calc Volume  Begins the volume calculation.

 Calc Balance Areas Begins the volume calculation of the balance regions.

 Apply Haul Plan Analyzes cut and fill areas within a balance region and moves the   
     dirt from highest cut area elevation to lowest fill area elevation.

 Draw Haul Path Draws a typical haul path for the balance region for use in haul   
     planning and calculation.

 Stage Haul Plan Stages the planned haul into the design ground.

3D View Mode Only

The following commands are found only in the 3D View Mode Utility Tool bar.

 Record  Records a driving simulation path.

 Play   Plays the recorded driving simulation path.

 Pause  Toggles the playback of the driving simulation.

 Stop   Stops the driving simulation.

 Volume Area  Creates a report region around all design perimeters (including   
     islands) for total volume calculation. 

 Calc Volume  Begins the volume calculation.

 Enable Autonomous Enables GPS for field data collection.
 GPS

 Reverse Vehicle Rotates the vehicle 180 degrees in the 3D View.
 Direction

 Survey Volume Calculates the volume of survey data in the Current surface.3D View  
     Mode Only
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   Menus

The Menu bar lists the available menus and commands. Many of the menus and com-
mands are common, though some Modes have specific menus and specific commands. 
Below is a description of all of the available commands from each menu. If a menu or 
command is grayed out it is not available in that Mode.

Note: The illustration below shows all Menus, though not all menus will appear on the 
screen, depending on the mode.

 

  File Menu

The File Menu is used to access files, import files, save job files, set up the printer and 
exit the program. The File menu for each Mode is different and specific to tasks in that 
Mode. Below is a list of the commands in the File Menu in all Modes.

  New

Used at the start a new job. When the command is selected, the Job Information dialog 
box is displayed.

 

Enter the Job Name, Builder, Bid Date, Operator and choose the Units of measure, either 
Feet or Meters. This is the only time the units of measure are determined for the job. Click 
OK to start the new job.

  Open

Used to open an existing job. When the command is selected, the Open dialog box is 
displayed.

 

Select the file from the list in the window. The name then displays in the File Name text 
box. Click Open to get the file. The following file types are opened in CAD Transfer Mode: 
.agt .dgn, .dxf, .dwg, and .ln3. AGTEK Highway Files (*.cgo, *.rds, *.rog) are opened in 
Highway Mode.
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   Import

Used to import files for use as a new job file, including CGO, RDS and ROG Highway files. 
When the command is selected, the Import dialog box is displayed.

 

Select the type of file from the Files of type pulldown, and the file from the list in the dia-
log box. The name then displays in the File Name text box. Click Open to get the file. Files 
are opened in CAD Transfer Mode.

  PlanPilot Import

Used to import a GradePilot job file. You must have a PlanPilot connected to your com-
puter for this command to work. When the command is selected, The Open dialog box is 
displayed, showing the files on the PlanPilot.

Select the file from the list in the dialog box and click Open. The file is opened in CAD 
Transfer Mode with Survey Data layer selected as the destination layer.

  Import Recover Data

Used to import benchmarks and alignment data from an existing job file. When the com-
mand is selected, The Import Recover Data dialog box is displayed.

Select the file with the recover data in the dialog box and click Open. The benchmarks 
and alignment data from the selected file are imported in to the open job file.

  Merge

Used to merge all layers from an .esw, .ttm, or .tn3 file into an existing job file. When the 
command is selected, the Merge dialog box is displayed.

 

Select the file from the list in the window. The name then displays in the File Name text 
box. Click Open to merge the files.
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  Save

Saves the job with the current name. If the job has not yet been named, the Save As dia-
log box is displayed when the command is selected (see below).

  Save As

Used to save a file as an AGT, ESW, DXF, DWG, LN3, TN3, or TTM file with an optional 
new file name. When the command is selected, the Save As dialog box is displayed.

 

Type the new name of the file in the text box and choose the appropriate file type from 
the Save as type pulldown, check the Check to Save Surfaces box (see below for infor-
mation) and click Save.

Saving As DXF/DWG

When the DXF or DWG type is chosen, the Export CAD dialog box is displayed. Refer to 
“Export CAD” on page 9-17 for additional information.

  Saving As AGT

When the AGT type is chosen, the surface in the Surface pulldown is saved and a 2-letter 
abbreviation for the surface is appended to the end of the current job name. Refer to “Cre-
ating AGT Files” in the Appendix for additional information.

    Saving as Job File (ESW)

When the ESW type is chosen, the Check to Save Surfaces box is displayed in the Save 
As dialog box. Checking this box saves trimesh surface data in the ESW file. This is nec-
essary if you are using the file with AGTEK Graphic Grade Machine Control or SitePilot to 
save time loading the file. If checked, the Surface Selection dialog box is displayed when 
you click Save.

Select the Reference and Difference surfaces to save and click OK.
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  Export CAD

Used to export a CAD file as either a DXF or DWG format. When the command is select-
ed, the CAD File Export dialog box is displayed.

 

Check the boxes next to the Surface(s), File Type, Data, and Triangular Meshes to in-
clude. Click Export to create the file. The Save As dialog box is displayed prompting the 
user for the location and name of the file to be saved.

Type the new name of the file in the text box and click Save to save the file.

  Export EMF

Used to save the color shaded grid map to an EMF (Enhanced Metafile) file. 

  Export VRML File

Used to save the 3D view as a VRML (Virtual Reality Modeling Language) file. When the 
command is selected, the Save As dialog box is displayed. Type the new name of the file 
in the text box 

Email

Opens your default email program and attaches an .esz (AGTEK zip format) file to the new 
email which contains the file open at the time of selection.
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  Print

Used to print the data that is currently displayed on the screen. When the command is 
selected, the Print dialog box is displayed.

 

Choose the printer, change printer properties and print settings as needed. Click OK to 
print.

  Send To Print Page

Sends the current view to the Print Page. If both the terrain and overlay are displayed, the 
Print Preview Send Options dialog box is displayed. 

Export KMZ

Creates a .kmz (Google Earth zip format) for use in Google Earth. Automatically opens 
Googe Earth, using the resulting .kmz, if Google Earth is installed on the your current 
computer.
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Select either Send Overlay or Send Terrain and click OK . The Print Page opens with the 
chosen view on the screen.

Page Setup

Used to change print options. When selected, the Page Setup dialog box is displayed.

 

The user can change printer properties, such as paper size, orientation, margins, and 
which printer to use.

  Exit

Quits Earthwork 4D. If changes have been made, a dialog box is displayed asking to save 
the file before quitting.

 

Click Yes to save, No to exit without saving or Cancel to abort saving and continue work-
ing on that file in Earthwork 4D.
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  Edit Menu

The Edit Menu is used to undo/redo commands, as well as select and edit data and data 
lines and change job file information and settings. The Edit menu for each Mode is differ-
ent and specific to tasks in that Mode. Below is a list of the commands available from the 
Edit Menu in all Modes.

  Undo

 Cancels the last edit(s) up to eight edits.

 Redo

 Repeats the previously cancelled edit(s) using Undo, up to eight edits.

 Copy

 Copies the currently selected data and stores it in temporary memory.

 Paste

 Inserts the currently stored data from the Copy command into the currently active    
 Surface and Layer.

  Delete

 Removes any selected data. Multiple objects can be deleted by selecting each object   
 using Shift+click before deleting them.

  Strata Names

Used to enter and edit strata for the job. When selected, the Edit Strata Layers dialog box 
is displayed.

 

Enter the Strata Name and the Cut Comp value for the strata layers and click OK. Refer to 
“Strata” in the Appendix for additional information about strata layers.
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Email PDF

Opens your default email program and attaches a PDF of the displayed print page.

Export PDF

Exports a PDF of the displayed print page.
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  Report Region

Used to edit the information of an existing Report Region. When selected, the Report Re-
gions dialog box is displayed.

Note: A Report Region can also be edited by clicking on it in Edit Mode, then clicking the 
Edit Report Region button or by double-clicking on the Report Region.

  

Region Name  Regions with the same name are totaled and regions with ascending   
    names (i.e. Lot 1, Lot 2, etc.) are totaled individually and then   
    subtotaled by the name “Lot”.

Report Region This check box indicates that the region will be included as part of   
    the job totals. Use this option when entering Report Regions.

Sectional Area This check box indicates that the sectional area will be included as   
    part of the job totals. Use this option when entering Sectional Areas.

Fill Factor  Represents the compaction percentage.

Sectional Depth The depth of the sectional taken from the surface of the design.

  Balance Region

Used to edit the information of an existing Balance Region in Plan View Mode. When se-
lected, the Balance Regions dialog box is displayed.

Region Name  Regions with the same name are totaled and regions with ascending  
              names (i.e. Balance 1, Balance 2, etc.) are totaled individually and   
    then subtotaled by the name “Balance”.

Fill Factor  Represents the compaction percentage.
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  Break Line

   Breaks a line at the selected point leaving one-half of the line selected.

  Move Start

Moves the start point of a closed line to the currently selected point on the line. 

  Raise/Lower

Raise or Lower the elevation of selected lines, points, or Vertical COGO (in Highway 
Mode). When selected, the Raise/Lower Dialog box is displayed.

 

Affect Adjacent Causes any line snapped to the affected point(s) to be adjusted.  
Points  This option is not available in Highway Mode.

Raise/Lower  Enter in the amount to raise or lower the line/COGO by typing the 
Elevation  elevation in the appropriate box.

As soon as you start typing in either box, the other box grays out. Click OK to apply the 
elevation change.

  Label Selection
Selects all lines with the same label. If no line is selected, the Label Selection dialog box is 
displayed, allowing the user to select a label from a list of all labels in the current surface. 
An asterisk (“*”) can be used as a wildcard. For example, “curb*” would select all lines 
with a label that starts with curb.

  Find Elevation
Selects data lines less than, equal to, or greater than a specified elevation. When selected, 
the Find Elevation dialog box is displayed.

§x
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Select which value to use and click OK. The Edit Find Elevation dialog box is displayed.

Enter the elevation in the box, check Select All Found to select all instances of the elevation, and 
click OK.

  Area Select

Allows multiple items to be selected by dragging a box around the information desired. 
Click and drag the box to define the area to select. Click again to select the items.

  Select All

Selects all visible data of the currently active surface layer.

  Shade Increment

Adjusts the Cut-Fill Shade Increment in 3D View and Plan View Modes. When selected, 
the Edit Shade Increment dialog box is displayed.

 

Type in a new value or check Automatic. Click OK to apply the changes.

  Vehicle Arrow Rate

Changes the distance the vehicle travels on the screen using the Arrow keys on the 
keyboard or during drive simulation. When selected, the Edit Vehicle Speed dialog box is 
displayed.

 
Change the value in the Vehicle Speed box to change the speed. Click OK to apply the 
scale.
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  Decimal Precision

Used to change the number of decimal places the numbers display for reporting precision. 
When selected, the Edit Report Precision dialog box is displayed.

 
The default value is 0. Enter a value between “0” and “2”. Click OK to apply.

  Apply Survey

Applies collected survey data to the current job file. Refer to “Updating a 3D Model with 
Survey Data” on page 9-81 for additional information about applying survey data.

  Drawing Scale

Used to scale the 2D Plan View and Profiles on the Print Page. First select an item then 
select the command. The Edit Plan Scale dialog box is displayed.

 

If you are scaling a profile, both vertical and horizontal scale appear. Type in the new 
scale in the text box and click OK.

  Cut-Fill Font Size

Used to select the type, style, and size of the fonts that appear as part of the labels on 
the cut-fill shade map. When selected, the Cut-Fill Font dialog box is displayed.

 

Select the font type, style, and size and click OK to apply the changes. The program de-
fault (Arial, Regular, 9) is reset after each session.
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  Cut-Fill Label Style

Used to change the label displayed on the cut-fill shade map. When selected the Cut-Fill 
Label Style dialog box is displayed.

 

No Text Background  Displays black text with no label background over the   
     shade map. 

Solid White Background Displays black text with a transparent background over   
     the shade map.

Transparent Background Displays black text with a white background over the
     shade map.

  Add Text

 Adds text to the screen. When selected, the Enter Text dialog box is displayed.

 

Choose the font type, style, size and color. Type in the text to display on the screen in 
the box at the bottom of the window. Click OK to add the text to the screen.

Tablet Scale

Displays the Tablet Scale box and allows you to rescale the job.

t
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  View Menu

The View Menu is used to adjust the display of visible data on the screen. The View Menu 
is not available in Volume Report or Print Preview Modes. Below is a list of the commands 
available from the View Menu for all other Modes.

  Hide

Hides all selected data from view. Multiple data lines can be hidden by selecting them, 
then selecting the command.

  Hide All But

Hides everything except selected data. Multiple data lines can remain visible by selecting 
them then selecting the command.

  Show All

Displays all hidden data on the screen. 

  Plan View Scale

Used to increase/decrease the size of the displayed overlay. When selected, the Edit 
Planview Scale dialog box is displayed.

 

Type in a value in the text box to change the Plan View Scale. Click OK to apply the 
scale.

  Elevation Scale

Used to increase/decrease the elevation perspective to show increased relief of the   
terrain. When selected, the Edit Elevation Scale dialog box is displayed.

 

Change the value in the text box to change the Elevation Scale. Select the Constrain 
Vehicle check box to keep the Jeep and blade vertical scale unchanged during elevation 
scale magnification. Click OK to apply the scale.
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  Vehicle Scale

Used to change the size of the vehicle in relation to the 3D View. When selected, the Edit 
Vehicle Scale dialog box is displayed.

 

Change the value in the text box to change the Vehicle Scale. Select the Constrain Vehi-
cle check box to keep the Jeep and blade vertical scale unchanged during elevation scale 
magnification. Click OK to apply the scale.

  Layer Selection

Used show/hide layers not normally associated with the current surface. Data not in the   
currently active surface displays in the background and can be snapped to. When
selected, the Layer Selection dialog box is displayed. 

 

Check the boxes next to the layer(s) and click OK.
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R egion Selection

Used to show which areas are contained within another and to show the location in the 
main window. Select an area from the layer, then select the command. The Region Selec-
tion dialog box is displayed.

 

Click on a region to highlight it on the screen. Click the Close button to close the dialog 
box. This command only works for report regions, perimeters, stripping, and sectional 
areas.

  Plus Marks

Toggles on or off the display of plus (+) marks for points along data lines in CAD
Transfer Mode.

  Cut-Fill Values

Toggles on or off the display of the Cut-Fill Labels.

  Cut-Fill Elevations

Toggles on or off the display of the Cut-Fill elevations on the Labels.

  Default Cut-Fill Spacing

Spaces the cut-fill locations optimally on the screen.
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  Fixed Cut-Fill Spacing

Allows the user to define the distance between the cut-fill spacing. When selected, the 
Edit Fixed Cut-Fill dialog box is displayed.

 

Enter a value between “10” and “1000” and click OK.

  User Cut-Fill Locations

Used to enter locations manually for specific cut-fill locations to display in Plan View 
Mode. User locations are entered in Entry Mode in the Cut-Fill Layer. Below is an example 
of a Cut-Fill Label found in Plan View Mode.

Elevation at Reference Surface

Elevation at Difference Surface

Cut-Fill amount between Reference 
and Difference.

Gray Hidden Lines

Any hidden lines are displayed in gray.
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  Display Menu

The Display Menu is used to adjust how screen data is displayed. A check next to the 
command indicates that it is enabled. The Display Menu is not available in Volume Re-
port Mode. Below is a list of the commands available from the Display Menu for all other 
Modes.

  Overlay

 Toggles on or off the display of the 2D plan view overlay.

  Terrain

 Toggles on or off the display of the 3D terrain view.

 Bitmap

 Toggles on or off the display of an imported background image.

  Black Background

Displays the screen background as black in CAD Transfer Mode.

  White Background

Displays the screen background as white in CAD Transfer Mode.

  Color Shades

Used to adjust the cut-fill coloring displayed in 3D View, and Plan View Modes and for 
printing. When selected, the Color Shades dialog box is displayed.

 

Select from a set of predefined color maps by selecting one from the Color Map pulldown 
or create a custom map by clicking on a cut-fill color, selecting a custom color, then click-
ing the Add button and naming the custom Color Map.
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  Shade Table

Toggles on or off the cut-fill shade table.

  Plus Marks

Toggles on or off the display of plus (+) marks for points along all data lines. Plus marks 
automatically toggle off while zooming.

  Grid Display

Toggles on or off the display of a grid over the 3D terra.

  Hatch Regions

Toggles on or off the display of hatch regions (fill patterns) over layers made up of areas.

  Edit Layer Only

Used to display only the selected layer.

  Line Labels

Toggles on or off the display of line labels.

  Material Labels

Toggles on or off the display of point and line labels simultaneously.

  Station Numbers

Displays the station labels in Horizontal and Vertical COGO Modes.

  Point Numbers

Toggles on or off the display of point numbers.

  Point Labels

Toggles on or off the display of point labels.

  Time Stamps

Toggles on or off the display of time stamp labels.

    Elevations/Elevation Labels

Toggles on or off the display of elevation labels.

  Frame

Adds a thick border around the edge of the Print Page.
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  Title Block

Adds a title block across the bottom of the Print Page. A title block can only be added if a 
frame has been added first.

  Add Row

Adds a row of page(s) below the original print page(s) to the Print page.

  Add Column

Adds a column of page(s) to the right of the original page(s) to the Print page.

  Delete Row

Deletes a row of pages from the bottom of the Print page.

  Delete Column

Deletes a row of pages from the right of the Print page.

  Scrollable

Increases the display size of the Print page and allows the user to scroll through multiple 
sheets.
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  Data Transfer Menu

The Data Transfer Menu is used to transfer data from a CAD file to a Earthwork 4D job 
file. Data can be sent to either the Existing or Design surface and a specific layer within 
each surface. The Data Transfer Menu is only available in CAD Data Transfer Mode. Be-
low is a list of the commands available from the Data Transfer Menu.

  Send to Layer

Sends selected data to Surface and Layer displayed in the pulldown menus.

 

  Send To Existing

Sends selected data to the Existing Surface and Layer displayed in the pulldown.

  Send To Design

Sends selected data to the Design Surface and Layer displayed in the pulldown.

  Compression

Compresses the data, removing extra points and detail during data transfer. Refer to 
“Compression Delta” on page 8-46 for information about setting the compression amount.

  Crop Rectangle

Used to delete all the data outside a specified area (Crop Rectangle). When selected, the 
arrow changes to the crosshair. Click and drag the box around the data to keep, then click 
again. A warning dialog displays.

 
Click Yes to remove all data outside of the box.

  Transfer Min/Max

Used to set the minimum and maximum elevations to transfer. Elevations not within the 
minimum/maximum range are transferred as annotation data. When selected, the CAD 
Elevation Threshold dialog box displays.

 

Make any changes to the Minimum and Maximum text boxes. The Disable Min/Max check 
box allows you to turn off the elevation threshold settings. Click OK to apply.
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  CAD Transfer Units

Sets the unit of measure used to create the CAD file for proper scaling. When selected, 
the CAD Transfer Units dialog box is displayed.

 

Select the appropriate unit of measure, enter the Units per Feet if using the User Defined 
option, and click OK. Layers that have been transferred are changed as well.

Image Rotate L/R

Rotates the displayed image clockwise in ninety degree increments.

  Image Scale

Sets the scale for an imported image for proper scaling during vectorization. When select-
ed the Edit Image scale dialog box is displayed.

 

Enter the scale for the imported image and click OK.

  Image Thicken

Makes the lines on an imported image thicker to facilitate viewing and vectorization of 
lines that are not well defined. Images can be thickened multiple times.

  Reset Image

Reverts an imported image to its original state.

  Vectorize

Creates annotation lines from an image and separates the lines into layers based on line 
type and thickness. Once vectorized, lines can be sent to specific Surfaces and Layers like 
any other CAD data.
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  Instrument Menu

The Instrument Menu is used to enable and configure GPS instrument use with Earthwork 
4D, and is only available in 3D View Mode. In addition, the Instrument Menu is only avail-
able if you have purchased GPS functionality. Below is a list of the commands available 
from the Instrument Menu.

  GPS

Enable  Enables GPS for field data collection and displays the rod.

Configure  Displays the GPS Configuration dialog box.

   

 GPS Type Used to select the GPS brand/model.

 Com Port  Specifies to which port the GPS is connected.

 Horiz Dist Displays the horizontal distance from the rover GPS to the base   
    GPS, when the Test/Shoot test button is clicked.

 Elev Diff  Displays the elevation difference between the rover and base GPS,   
    when the Test/Shoot test button is clicked.

 Test/Shoot Test Takes a shot to verify GPS data is being received.

 Settings  Displays the Settings dialog box.

 

 Communications Sets communication settings for the GPS model. Default values are   
    displayed based on the GPS model selected in the GPS Configuration  
    dialog box.

 GPS Ports Specifies the serial port the GPS uses for communication (typically   
    with Trimble units only).
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Network Used to search for and add devices for use in Listen Mode.

 

Client  Adds client devices (devices to listen to) for use in listen mode. To add   
   a device check “Client GPS”, type the name of the device in the    
   Remote Host box, then click Add. 

Server Adds server devices (used to relay data from devices being     
   listened to) for use in Listen Mode.   

  Rod Height

Used to edit the rod height if it has been changed since alignment.

  Create Benchmark

Used to shoot a new benchmark.

  Preferences

Used to set Instrument preferences. When the command is selected, the Instrument Pref-
erences dialog box is displayed showing the GPS Settings tab and the Blade tab.

GPS Settings Tab

 

Benchmark Shot The number of shots taken when doing alignment or when creating a  
Average  benchmark.

Collection   Sets the minimum horizontal and vertical distance (in feet) needed to  
Distance  move before the next shot is taken.
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Blade Tab

 

 Rod Position Position of the rod relative to the Blade.

 Steering Position Position of the driver’s view relative to the rod.

 Blade Width Width of the blade (in feet).

 Rod Point  Offset of the rod (in feet) from the left edge, right edge, or center of   
    the blade.

 Grade Point Offset from the rod (in feet) to set the grading edge.

  Vehicle

Used to select the vehicle type shown in the 3D View. When selected, the Vehicle Type 
dialog box is displayed.

 

Select the type of vehicle and click OK.

  Mode

Cut-Fill  Displays the vehicle/rod rising and falling on a cut-fill bar, which   
    shows the vertical distance from the reference surface.

Stake   Displays the vehicle on the reference surface with no vertical   
    distance indicator.
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  Utility Menu

The Utility Menu is used to change the properties of data and profile lines, determine 
volume calculation areas and calculate those volumes, set the on-grade limits and transfer 
the subgrade to the design surface, and create and edit stations and offsets. The Utility 
Menu is available in Edit, Profile View, Plan View, and 3D View Modes. Below is a list of 
the commands available from the Utility Menu in those Modes.

  Transform Job

Contains several commands used to move job coordinates, align data, and change the job 
scale. Refer to Page 9-75 for more information about using these commands.

  Crop Rectangle

Used to delete all the data outside a specified area (Crop Rectangle). When selected, the 
arrow changes to the crosshair. Click and drag the box around the data to keep, then click 
again. A warning dialog displays.

 
Click Yes to remove all data outside of the box.

  Contour Surface

Used to generate contours along the currently selected surface at a user specified interval. 
The resulting contours are put in the Design Contour layer. When selected, the Edit Con-
tour Interval dialog box is displayed.

 

Enter a contour interval and click OK.

  Auto-Pad

Uses text labels or elevation inside enclosed areas to automatically assign elevations. 
Refer to “Assigning Elevations using Auto-Pad” on page A-13 in the Appendix for more 
information about using Auto-Pad.
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 Offset Line

Used to create an offset line(s) adjacent to the selected line(s). When selected, the   
Offset Line Editor displays.

 

Set the values for distance, elevation and slope. Click the View button to see the lines 
applied in real-time. Click the Apply button to add the line. If you close the Editor before 
clicking Apply, the offset line is not created.

   Bridge Gap (Join)

Used to join multiple line segments. Select the lines then select the command. Only lines  
of the same type may be joined. The lines must also be at a distance that is equal to or 
less than the Bridge Gap distances. Single lines are closed regardless of Bridge Gap dis-
tance when the Join command is selected. 

  Swap Ends

Switches the start and end points of a selected line(s). Allows the user to change the   
direction the line was entered.

  Fillet Line

Used to generate a radius between two line segments. It can also be used to fillet an  
existing angle. For more information, refer to “Adding Arcs/Fillets” on page A-7 in the Ap-
pendix.

§o
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  Trim Line

Used to break all lines that intersect with a selected line or closed area. A trim line can be 
an existing data line, perimeter/region, or an annotation line. Select a line to use as the 
trim line then select the command. All lines crossing the trim line are broken at the trim 
line. If you select a closed line as the trim line, the Region Trim dialog box is displayed.

 

Trim Only  Trims all lines that cross the closed line.

Remove Lines Trims all lines that cross the region and removed all lines inside 
Inside  the closed line.

Remove Lines  Trims all lines that cross the region and removes all lines outside the  
Outside  closed line.

  Length/Area Info

Displays the length, plane and slope area of a line. When selected, the Length and Area 
dialog box is displayed.

The Line Length is displayed in both Feet and Yards. Areas are displayed as square feet 
and acres. Metric jobs displays meters and hectares. Below is a list of display rules for 
various line types.

t§

• Slope Area is automatically displayed for closed lines in the Data Lines Layer.

• The Line Length and Horizontal Area only are displayed for all closed lines that are not 
in the Data Lines Layer.

• If the Calc Slope Area box is checked, the Slope Area of a closed line that is not in the 
Data Lines is calculated.

• Only the Line Length is displayed for open lines.

• Only the total Line Length is displayed for multiple selected lines (open or closed).
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  Compress Selected

Compresses the selected line(s) by removing extra points according to the Compression 
Delta. Refer to “Compression Delta” on page 9-48 for information about setting the com-
pression amount.

  Convert Daylights

Converts Daylight points to entered points on a selected line so the points no longer tie 
into the original surface they were daylighted to. Multiple lines can be selected. Interpo-
lated points are not converted.

  Conform Annotate

Drapes the currently selected annotation line and converts it to a data line.

To Design Lines Converts an annotation line to a data line with elevations based on   
    the data line(s) it crosses.

To Current Surface Converts an annotation line to a data line with elevations based on   
    the trimesh of the current surface.

  Profile Entry

Switches to Profile View Mode and allows you to enter profile lines. Click to begin a line 
and right-click to end. 

  Swap Ends

Swaps the starting point and ending point of the selected line.

  Volume Area

The Volume Area controls the limits of the volume calculation. When selected, the pro-
gram automatically places a report region around the Design Perimeters. If no perimeter is 
present, a region is added surrounding the union of all Report Regions and Design Data.

§a
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Calc Volume

In all other modes it calculates the volume from the area defined using the Volume Area   
command. When complete, a report similar to the illustration below is displayed.

 

The volume and area totals display. Click the Done button to close this window.

  Calc Balance

Calculates the volume of balance regions. When selected, the Haul report is displayed.

  Calc Horiz. Slices

Calculates the volume per lift for user defined lifts. When selected, the Edit Slice Interval 
dialog box is displayed.

 

Enter the elevation interval and click OK. The Horizontal Slice report is displayed, showing 
the cut-fill volumes for each elevation slice.

v§
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  On-Grade Limit

Sets the tolerance for the On-Grade Limit. When selected, the Edit On-Grade Limit dialog 
box is displayed.

 

Enter the On-Grade Limit in the box and click OK to apply the limit. A higher number 
allows for more variation within the tolerance to be considered on grade. A lower limit al-
lows for less tolerance.

  Transfer Subgrade/Design

Stages the subgrade sectional areas into the design or existing surface and deletes the 
sectional areas. All finished grade elevations in the design are changed to subgrade eleva-
tions. When selected, the Transfer Design/Subgrade dialog box is displayed.

 

  Apply Survey

Used to copy data from the Survey layer to the Data Lines layer of the Current surface. 
When selected, the command creates a boundary around the survey data, displays the 
data and stages it. Refer to “Updating a 3D Model with Survey Data” on page 9-92 for 
additional information.

  Cut-Fill Lines

Displays the transition between cut-fill and on-grade as contour lines in Plan View Mode.
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  Lowest Surface

Creates a new surface in the Current layer called Lowest based on the lowest elevations 
of the Existing and Design Surfaces. All regions must be closed prior to selecting the com-
mand. When the command is selected, the Lowest Surface Guide dialog box is displayed.

 

If there are cut-fill lines that are not closed, the Generate Fill Areas is displayed in red and 
you must close them before proceeding.

Click Close. The “Lowest” surface is created with the design lines.

Send to Highway

Sends the currently selected line(s) to Highway as a new highway alignment.
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New Surface

Displays the Create New Surface Dialog box. Entering a name, choosing a surface color, 
and clicking OK creates a new surface with the entered name. You may have no more 
than 8 total surfaces in the file.

Apply Survey

Displays the Survey Into Current dialog box.

Replace Creates a new surface with the survey included and leaves the Design sur  
   face untouched.

Stage  Stages the survey data into the Design ground.

Stage Over-ex

Displays the Over-ex Guide. For more information regarding the Over-ex guide, please see 
page A-15.

Edit Station/Offsets

Allow the Station Name and Horizontal Offset to be edited. When selected, the Edit Sta-
tion/offset dialog box is displayed.
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Station Generator

Allows the generation of stations along a selected profile line. When selected, the Profile 
Generation dialog box is displayed.

Enter or change the Station Name, Station Interval, Left and Right Offsets. Click to apply 
the changes.

Conform Profile Line

Adds points to a selected profile line everywhere it intersects a data line. You can then 
cycle through the points on the selected profile line, which are represented by pointers at 
the top and bottom of the profile view.

Clip Strata

In the Profile View, displays the removal of strata in the selected surface.
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  Options Menu

The Options Menu is used to set certain preferences in Earthwork 4D to change or enable 
the several features like Auto Save and Snap Size. Below is a list of commands available 
from the Options Menu in all Modes.

  Distance Culling

Sets the threshold for the amount of surface to be rendered in 3D View mode to speed up 
viewing the Terrain view on larger files. When selected, the Edit Distance Clipping dialog 
box is displayed.

 

Type in a new distance in the text box and click OK. Checking the Disable box allows the 
terrain for the entire job to be rendered.

  Staged Design

Enables the design to be staged to the Existing Surface for viewing. This allows the user 
to see where and how the design meets the existing ground at the boundary between the 
design data lines and the existing ground data lines.

  AutoSave

Allows the user to enable/disable the Auto Save feature and change the interval between 
saves, which provides a point to resume work on the job file in the event of a program 
failure. When selected, the Auto Save Interval dialog box is displayed.

 

The interval is displayed in minutes between saves. Type in a number to change it. The 
default is 5 minutes. Check the Disable box to turn off this function. When finished, click 
OK to save these changes. When enabled, the file is saved as “Autosave.esw” in the cur-
rent working directory. The file is deleted on normal program exit.
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  Sound Preference

Allows the user to choose sound options. A check next to the option indicates which one 
is active. 

Sound Card  Allow the use of external speakers.

PC Speaker  Uses the internal PC speaker.

No Sound  Disables all sounds

  Strata Tracks OG

Allows the strata layers to follow the slope of the existing ground surface. If not selected, 
the strata layers slope straight from one boring to the next.

  Freeze Strata Layers

Freezes strata to track the current Existing Surface. Future changes to the Existing Sur-
face will not change the Strata Layer.

  Compression Delta

Sets the distance (using specified CAD Transfer Units) used to determine if a point will be 
removed during CAD Transfer to reduce file size. Points farther apart than the Delta will 
not be removed. When the command is selected, the Edit Compression Delta dialog box is 
displayed.

 

Enter the desired Delta distance and click OK.

  Max Undo Levels

Determines how many levels of the Undo command can be performed. When selected, 
the Edit Max Undo Levels dialog box is displayed.

 

Enter in a value between “0” and “8”. A value of 0 turns off the feature. Click OK to save 
and close the window.
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  Snap

Toggles on or off the Snap function.

  Snap Size

Allows the user to change the radius of the snap circle, an invisible perimeter surrounding 
the mouse pointer. Points outside the perimeter can not be snapped to. When selected, 
the Edit Snap Size dialog box is displayed.

 

Type in the a new Snap Size in the text box. Snap sizes can be from “1” to “8”. Click OK 
to apply the changes.

  Bridge Gap Distance

Allows the user to edit the horizontal and vertical distance the Bridge Gap (Join) command 
will span. When selected, the Edit Bridge Gap dialog box is displayed.

 

Type in a new distance for the Horizontal and Vertical distance in the text box and click 
OK.

  Automatic Join

Connects a snapped line to an existing data line and joins them as one line when snapping 
to it.

  Sticky Zoom

Enables the zoom function to zoom on a selected point.

s

z



8-50

Sitework 4D Reference 

  Status Bar Display

Sets the program to one of four status bar display modes. Ctrl+Q cycles between these 
modes. The Q button resets the display to the default Distance/Slope.

Distance/Slope  Displays distance/slope of the line in the lower right of the status   
    bar.

Distance/OG  Displays distance and Original Ground elevation (when Original
Elevation  Ground data exists in the file.)

Discrete  Calculates a discrete distance, which varies with zoom factor, and  
Distance/Slope derives the slope from it, so that when a second elevation is entered   
    in the Elevation entry box and the cursor is moved, the resulting   
    slope is displayed. The distance values are at even stops of 10 when  
    zoomed out, 1 when zoomed in, and 5 in between.

Discrete  Calculates a distance, which varies with zoom factor, and an angle,
Distance/Angle which initially uses single degree increments, then uses 45 degree in 
    crements as data is entered after the second point entry. To 
    orient the coordinate system for this use in Entry Mode, the user
    either presses the F12 key to select which line segment to align to 
    or enters the first two point. The Q key resets the drawing coordi-
    nate system so that zero degrees is up. Snap should be disabled   
    when using this.

  Auto Panning

Allows the cursor to pan the screen when you click on the outer frame drawn on the main 
window.

  Auto Plus Marks

Automatically displays or hides plus marks depending on zoom level. If the Display>Plus 

Marks command is selected Auto Plus Marks is disabled. Select the Auto Plus Marks com-
mand to re-enable the command.

  Rotated Text

Toggles on or of the rotation of text to the same angle as the nearest line.

  Report Title

Toggles the display of the Job Name, Units of Measure and Date at the top of the report 
on or off in the Mass Haul Diagram.

  Report Stripping

Toggles the display of stripping areas on or off in the Mass Haul Diagram.

  Report Sectionals

Toggles the display of sectional areas on or off in the Mass Haul Diagram.

§q
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  Sub-Totals

Toggles the display only on or off of only report region subtotals in the Mass Haul Dia-
gram.

  Title Block Logo

Inserts a logo to display in the Title Block across the bottom of the Print Page. Only files 
with the “.wmf” extension can be inserted in this manner. When the command is select-
ed, the Open dialog box is displayed.

 

Select the logo file to use from the window and click Open to insert the image.

  Label Font Size

Modifies the size of the font used for text labels on the Print page. Check Small, Medium, 
or Large and click OK.
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  Window Menu
The Window Menu is used to switch to a different mode and set some window view pref-
erences. Available Modes are displayed in black text while unavailable ones are in gray. 
Below is a list of commands available from the Window Menu.

  High/Low Contrast

Toggles between windows default colors and high contrast colors for viewing outdoors.

  Hide/Show Dialog

Toggles the display of the Elevation/Station List on the right side of the screen.

  Area Zoom

Displays the crosshair and begins area zoom mode.

  CAD Transfer

Switches to the CAD Transfer Mode.

  Edit Mode

Switches to Edit Mode.

  Entry Mode

Switches to Entry Mode.

  Highway Mode

Switches to Highway Mode.

  Profile View

Switches to Profile View Mode.

  Plan View Mode

Switches to the color-shaded Plan View Mode.

  3D View

Switches to 3D View Mode.

  Volume Report

Switches to the Volume Report Mode.

  Haul Report

Switches to the Mass Haul Report (only available if the job was started in Earthwork 4D).

  Print Preview

Switches to the Print Preview Mode.
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  Help Menu

The Help Menu is used to allow the user to access Earthwork 4D Help, information about 
the version of the software, any recent changes, file name and information regarding 
elevations and coordinates. There is also a link to AGTEK’s Home Page on the internet. 
Below is a description of these commands.

  Earthwork 4D Help

Starts the Help program ,which allows the user to search through various topics about 
Earthwork 4D.

  Hot Key Help

Opens the Help program with links to keyboard shortcuts for the different Modes.

  Job Info

Displays the Job Information dialog box.

 

This is the same window that displays when a new job is started, except the option to 
choose the units of measure is unavailable. Make any changes and click OK.

  File Info

Displays the File Name and Site Min/Max Northing, Easting, Elevation, and Point/Line La-
bels and Counts.
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  OpenGL Info

Displays OpenGL information about you computer.

 

  Visit AGTEK Online

Launches a web browser and opens the AGTEK Development Company Home Page.

  Authorization Manager

Opens the Authorization Manager program, which displays information about current 
AGTEK software programs and is used to update the AGTEK Protection Key.
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  About Earthwork 4D

Displays the Earthwork 4D version, days remaining on Time-out Key and copyright infor-
mation.

  Revision History

Opens a file with the revision history of Earthwork 4D, including the latest changes to the 
software.

Printer Info

Display the name of the currently selected printer.
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 Point Types in Earthwork 4D

Earthwork 4D uses different types of points along lines to generate the 3D terrain. When 
a point is selected in Edit Mode or when a line is being added in Entry Mode, the points 
are listed in the Elevation list on the right side of the screen. Points are color-coded by 
type. Earthwork 4D has five point types, Interpolated, Daylight, Entered, Annotation and 
Snapped. 

  Interpolated

Interpolated points (light blue) derive their elevation from the slope between the entered 
elevations that surround them.

  Daylight

Daylight points (green) are assigned elevation from the Existing surface. Daylight lines 
in the Design Layer automatically update to reflect changes made to the existing ground 
whenever the trimesh is recalculated. The trimesh recalculates any time the terrain view is 
enabled. Entered data points can be changed to daylight using the D button at the top of 
the Elevation list.

  Entered

Entered points (white) are points that the user has assigned an elevation to by editing a 
point or typing in an elevation during Entry Mode.

  Annotation

Annotation points (brown) are not used by the program to create the 3D surface. Lines 
transferred through the CAD transfer with an elevation of zero or with elevations that are 
outside of the Transfer Min/Max range are automatically assigned as Annotation.

  Snapped

Snapped points (red) are created when a point on a data line is snapped (F6 or F8) to ex-
isting data line. A snapped point will automatically adjust its elevation when any adjoining 
point is edited.
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 Elevation List

The Elevation list appears on the right side of the screen in both Edit and Entry modes. 
It displays the elevations of points of the currently selected line, the type of points by a 
color coded system, and allows the user to edit the selected points. If multiple lines are 
selected, no points or elevation are shown in the Elevation list.

  Selecting Multiple Points

To select a range of points, click and drag up or down in the Elevation list.

You can also click on a point, then Shift+click another point. All points between these 
points will be selected.

To select the entire line, click on the line in the main window or right-click over a point in 
the Elevation list, then select Select All.
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   Right-Click Menu

With a line selected, right clicking the mouse provides several commonly used commands 
depending on the current mode.

Entry/Edit Mode

Switch to either Entry or Edit mode.

Send to Existing

Send selected CAD layer to the Existing surface.

Send to Design

Send the selected CAD layer to the Design surface.

Plus Marks

Displays plus mark when checked.

Compression

Compresses the transferred data, removing extra points and detail during data transfer. 
Refer to “Compression Delta” on page 9-49 for information about setting the amount of 
compression.

Hide

Hides the sleeted point or line.

Hide All But

Hides all lines except for the selected points or lines.

Import Mode Edit Mode Entry Mode Point List
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Show All

Displays all points and lines in the job.

Point Editor

Displays the Point Editor dialog box. Allows you to edit the properties of the selected 
point.

Line Editor

Displays the Line Editor dialog box. Allow you to edit the properties of the selected line.

Import File

Imports the PDF associated with the selected outline. If no outline is selected, or the 
selected outlines references a PDF not in the same folder as the file you are using, the 
Import dialog box is displayed.

Align Image

Used to align PDF/TIF files to a current file.  Form more information on aligning PDF’s see 
page 9-76. 

Copy

Copies the selected information.

Paste

Inserts the copied information into the displayed surface.

Display

Any checked layer is displayed, regardless of selected surface.

Snap Enabled

When checked, snap is turned on. Every time you click on the file the program will snap 
to the nearest point.

Undo

Cancels the last edit(s), up to the last eight edits.

Delete Line

Deletes the selected line.

Cancel

Deselects all selected lines and quits and operation in progress.
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Continue

Allows you to proceed entering the most recently ended line.

Station Offset

Displays the Edit Station/Offset dialog box, allowing you to change the station name and 
the horizontal offset of the selected station.

  Select All

Selects all the points of the current line in the Elevation list.

  Clear Selection

Clears all points selected in the Elevation list.

Scale Object

Displays the Edit Scale dialog box, allowing you to change the scale of the selected object 
on the Print Page

Delete Object

Deletes the selected object on the Print Page.

Add Text

Displays the Add Text dialog box, allowing to enter and format text which is then inserted 
into the Print Page.

  Insert Point

Allows a point to be added to the selected line at the highlighted position. By default, 
the point is added as an Entered point using the elevation of the currently selected point. 
The new point is added above the selected point. When Insert Point is selected, the Point 
Editor dialog box displays. Change the North, East and Elevation as needed and assign 
any labels. Checking the Affect Adjacent Point box causes any other lines that share that 
point to be modified as well. Click OK to apply the changes.

Note: When a new point is inserted, it is important that the new point not have the same 
Northing and Easting coordinates as the currently selected point. This can cause problems 
when the volumes are calculated.

  Remove Selected

Deletes the currently selected point(s) and then rejoins the line.

 Edit Selected

Allows the selected point(s) to be edited. When selected, the Point Editor dialog box 
displays. Change the North, East and Elevation as needed and assign any labels. Checking 
the Affect Adjacent Point box causes any other lines which share that point to be modi-
fied as well. Click OK to apply these changes and close the window.
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  Earthwork 4D Surfaces and Layers

A surface is a 3D representation of the ground created by data lines. These data lines can 
be contours, spot elevations or lines with varying elevations. All data entry is done within 
two distinct surfaces, Existing and Design. Four additional surfaces, Stripped, Previous, 
Current, and Subgrade, appear in the 3D View Mode.

Each Surface has several layers associated with it. The different layers are only visible in 
Entry and Edit Mode. The Current Surface and Current Layer are indicated in the tool bar 
at the top of the screen

 

Changing the Current Surface is done by clicking on the pulldown menu and selecting the 
surface. The Current Layer is changed by clicking on the pulldown menu and selecting the 
layer. Below is an explanation of these surfaces and layers.

  Existing Surface

The Existing Surface contains all the data pertaining to the Existing/Original Ground prior 
to any excavation. Existing contour lines, points and labels are contained within this layer. 
This layer also contains any pre-design excavating such as stripping areas.

  Existing Surface Layers

The Existing Surface is composed of several layers. The example below shows the avail-
able Existing Surface Layers. A brief explanation of the layers is found below.

 

  Data Lines

Contains all the contour lines, points, and labels relevant to the existing ground. Data 
contained within this layer is used to generate the Existing 3D surface and are modified by 
any stripping areas and the Existing perimeter.

  Annotation

This is a reference layer not used as part of the 3D surface. Data with no elevation is au-
tomatically moved to this layer during transfer.

  Perimeters

Used to define the bounding edge of the existing ground data.

Current Surface Current Layer
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  Stripping Areas

A modifying layer used to lower the existing surface to reflect stripped material.

  Benchmarks

Special points used to mark control points. These points are often used when scaling to 
CAD file coordinates and preparing files for use in field and Machine Control systems such 
AGTEK’s SitePilot and Graphic Grade Machine Control programs.

  Profile Lines

Lines generated for the Profile View Mode. These lines are used to locate profiles and gen-
erate cross sections from the current surface.

  Contours

Contains contours that are created when using the Contour Surface command.

  Cut-Fill Labels

Used to enter locations for cut-fill labels to appear in Plan View Mode.

  Cut-Fill Lines

Lines generated in Plan View Mode to define the cut to fill transitions.

  Design Surface

The Design Surface contains all the data pertaining to the design. Design lines, points, and 
labels are contained within this surface.

  Design Surface Layers

The Design Surface is composed of several layers. The example below shows the avail-
able Design Surface Layers. A brief explanation of the layers is found below.

 

  Data Lines

Contains all the contour lines, points, and labels relevant to the design. Data contained 
within this layer is used to generate the Design 3D surface, and are modified by any sec-
tional areas and the Design Perimeter.
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  Annotation

This is a reference layer not used as part of the 3D surface. Data with no elevation is au-
tomatically moved to this layer during transfer.

  Perimeters

Creates a bounding limit for grading and defines the bounding edge of the design. When 
Staged Design is enabled, the Design Perimeter determines where the Existing Surface 
ties into the Design Surface. The Design Perimeters define the limits of the volume calclu-
lations. Perimeters entered inside one another creates a hole.  

  Report Regions

Used to define areas for volume calculations that are sub totaled on the Volume Report.

  Sectional Areas

A modifying layer used to lower finish grade to subgrade in areas with a structural sec-
tion.

  Balance Regions

Used to define areas of cut-fill that are normally intended to balanced to plan dirt hauls 
and cost estimation for a job.

  Stake Point List

A list of stake points for use in the field with Graphic Grade 3D.

  Benchmarks

Special points used to mark control points. These points are often used when scaling to 
CAD file coordinates and preparing files for use in field and Machine Control systems such 
AGTEK’s SitePilot and Graphic Grade Machine Control programs.

  Driving Simulation

Allows entry of a path for the vehicle to follow during the driving simulation.

  Profile Lines

Lines generated for the Profile View Mode. These lines are used to locate profiles and gen-
erate cross sections from the current surface.

  Contours

Contains contours created using the Contour Surface command.

  Cut-Fill Labels

Used to enter locations for cut-fill labels to appear in Plan View mode.

  Cut-Fill Lines

Lines generated in Plan View Mode to define the cut to fill transitions.
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Pipe Lines

Pipe Lines may be entered to calculate underground trench excavation.

Documentation

The Documentation layer is used to add notes, 3D views or images to the file for viewing 
on Google Earth or in the field with SmartPlan.  All photos, tracks, notes and measures 

may also be imported from SmartPlan.

     Current/Previous Surfaces

The Current Surface is an additional surface added in Entry Mode. Only two additional sur-
faces can exist at a time. Refer to “Adding a Surface” on page 9-61 for information about 
how to add a surface.

The data that makes up the new surface can come from any source. The data can be 
imported from a file and transferred directly to that surface. The data can also be copied 
from an existing surface layer in the job and pasted to the new surface, staged from sur-
vey data, or digitized into the new surface.

    Current/Previous Surface Layers

Current/Previous Surfaces are composed of several layers. The example below shows the 
available Surface Layers. A brief explanation of the layers is found below.

 

  Data Lines

Contains all the contour lines, points and labels relevant to the surface. Data contained 
within this layer is used to generate the 3D surface.

  Survey Data

Data used to update the surface using Apply Survey and then staging the survey data to 
the Data Lines layer. The Survey Data layer is not available in the Previous Surface Layer 
menu.

  Stage Areas

Data used to update the surface using Stage Over-Ex from the Over-Ex Guide. Once the 
data has been staged, the Stage Areas layer becomes empty.

  Benchmarks

Special points used to mark control points. These points are often used when scaling to 
CAD file coordinates and preparing files for use in field and Machine Control systems such 
AGTEK’s SitePilot and Graphic Grade Machine Control programs.
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  Profile Lines

Lines generated for the Profile View Mode. These lines are used to locate profiles and gen-
erate cross sections from the current surface.

  Contours

Contains contours created from the Current surface using the Contour Surface command.

  Cut-Fill Labels

Used to enter locations for cut-fill labels to appear in Plan View Mode.

  Cut-Fill Lines

Lines generated in Plan View Mode to define the cut to fill transitions.

  Stripped Surface

The Stripped surface is the Existing surface minus any Stripping Areas. The data lines for 
this surface are entered in the Existing Surface and Stripping Area Layer.

  Subgrade Surface

The Subgrade surface is the Design surface minus any Sectional Areas. The data lines for 
this surface are entered in the Design Surface and Sectional Area Layer.

   Adding a Surface

Earthwork 4D allows the creation of two additional surfaces. Each additional surface after 
the second causes the first surface to be copied to the second, called “Previous”, and the 
second surface to be deleted. For example, if you add Surface-1 and Surface-2, then add 
Surface-3, Surface-1 will be removed and Surface-2 and Surface-3 will remain. To add a 
surface:

1. Switch to Edit Mode and select Edit>New Surface. The Create new Surface dialog 
box is displayed. The default name for the surface is “Current” but it can be changed 
by typing a new one.

 

2. Click OK to add the surface or Cancel to abort.
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 Snap Techniques

Snap is a powerful feature in Earthwork 4D. It allows for fast entry with greater precision 
than possible with freehand data entry. When used with CAD files, it allows quick conver-
sion of data from annotation (two-dimensional) to data (three-dimensional) for use in the 
model.

 Snapping in Edit Mode

 Snap

With Snap enabled in Edit Mode, you can enter a point at an existing point/line closest 
to the cursor. Enable Snap Mode by pressing the S key on the keyboard or right-clicking 
and selecting Snap Enabled. The “Snap” indicator at the lower right corner of the window 
displays is black when enabled and gray when disabled.

 Elevation Snap

Earthwork 4D can read elevations, including elevations stored as text (for example in a   
CAD file) and assign it to other points or lines by using Elevation Snap. Select the point   
or line to assign an elevation to, then move the cursor over a point or the plus (+) in   
front of the text with the desired elevation and press F9. 

 Auto-Increment Snap

The Auto-Increment Snap assigns incrementally increasing/decreasing elevations to   
points or lines. Follow the steps below to auto-increment snap:

1. Make sure that nothing is selected by pressing the Esc key.

2. Find two contours that have elevations in the increment you wish to assign. For exam-
ple, to start assigning an auto-increment elevation at 250, going up in one-foot incre-
ments, you need a 248 and a 249 contour.

3. Snap by pressing the F8 key over each contour. The order that the contours are 
snapped determines whether the increment goes up or down.

4. Place the cursor on a contour with no elevation and press F8 to snap an elevation to 
it. Continue snapping to each annotation contour in the order to be assigned. For ex-
ample, if the known contours were 248 and 249 and they were snapped in that order, 
the first elevation assigned to an annotation contour would be 250. Subsequent snaps 
would assign elevation 251, 252, 253, etc.

 Point Snap

Additional points along a line can be entered by placing the arrow over the desired   
location on a line and pressing F6. If the new point is inserted between two points with   
different elevations, the elevation of that point is interpolated along a straight slope.

s

�

�

�
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 Snapping in Entry Mode 

With Snap enabled in Entry Mode, you can connect to the point closest to the cursor for 
data entry. Enable Snap by pressing the S key on the keyboard or right-clicking and select-
ing Snap. The “Snap” indicator at the lower right corner of the window displays is black 
when enabled and gray when disabled.

If an elevation was typed in, the new point assumes that elevation. If no elevation is spec-
ified, the snapped point interpolates the elevation from the point to which it was snapped.

 Line Snap

Line Snap (or double-snap) is a quick way to snap to multiple points on a line. Press the 
F8 key twice or double-click on a line at the point you want to start the new line. The 
entire line should highlight with a small diamond displayed on the first and last points of 
the selected line. The cursor changes to the Line Snap cursor (see example to the left). 
Move the cursor to the point on the highlighted line where you want to end, then press F8 
a third time or click.

A rea Snap

Area Snap is a variation of Line Snap and allows you to snap to multiple points on an 
enclosed line. Press F8 twice or double-click to highlight the entire area, then move the 
cursor to the point on the highlighted line where you want to end and press F8 a third 
time or click.

 Intersection Snap

Intersection Snap enters a point on a existing line at the crosshairs, and interpolates the 
elevation. Press F6 at the point on a line to enter the point.

 Elevation Snap

Earthwork 4D can read elevations, including elevations stored as text (for example in a 
CAD file) and enter it into the elevation window at the bottom of the screen for use in 
data entry. Place the cursor over the point or line with the desired elevation, press F9, 
then enter the data. The points use the elevation selected with F9 as their elevation.

�

�
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 Print Page Basics

 Selecting Objects

Once there are many objects on the Print Page, it can be difficult to select the desired ob-
ject to edit. If you select any object on the page, press the Tab key to cycle through the 
different objects on the page until you select the one you want.

   Moving and Sizing Objects

To move an object, click and hold the object then drag it to the desired location.

To resize an object, click on it, then click and hold the lower right selection block. The 
arrow changes to a double-headed arrow. By moving the cursor toward or away from the 
object, you can resize it.

 Scaling

A drawing object can be scaled by clicking on it then selecting Edit>Drawing Scale. Type 
in the new scale and click OK to apply the new scale.

 Deleting

An unwanted object can be deleted by selecting the object then selecting Edit>Delete or 
pressing the Delete key.

  Adding/Editing Text

Add text by pressing the T key or selecting Edit>Add Text, then typing the text and click-
ing OK.

Edit text by selecting the text, then pressing the T key or selecting Edit>Add Text.

 Changing Cut-Fill Labels

Both the text size and style of the Plan View cut-fill labels can be changed by selecting 
the Edit>Cut-Fill Font Size. The label background is changed selecting Edit>Cut-Fill Label 

Style.
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  Exporting CAD Files

Earthwork 4D can export DXF/DWG files with many options. When File>Export CAD is 
selected, the CAD File export dialog box is displayed

 

The export choices are broken down by Surface, File Type, Data, and Triangular Meshes. 
When exported, each checked option is created in the file as a separate layer.

Surfaces
Surface options are the data lines displayed as the overlay and create the three-dimension-
al views (annotation is an exception). Many of these are self-explanatory.

Design  The design surface data lines.

 Perimeters The proposed perimeter line.

 Annotation Annotation lines present in the design surface.

 Report Regions Report regions present in the design surface.

Subgrade  The design surface data lines lowered by the Sectional Area depth.

 Sectional Areas Sectional areas that were used to create the Subgrade Surface.

Existing  The existing ground surface data lines.

 Perimeter  The existing ground perimeter line.

 Annotation Annotation lines present in the existing surface.

Stripped  The stripped surface data lines.

 Stripping Areas Stripping areas used to create the stripped surface.

Strata  The strata surface data lines.

 Bore Holes Location and depth of strata bore holes.
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File Type

The File Type options allow you to select file format to which the CAD file will be export-
ed.

DXF   Saves the file as a DXF (Data Exchange Format) file.

DWG   Saves the file as a DWG (AutoCAD) file.

Data

The Data options are additional data types you may want to include in the CAD export. 
Each option, when checked is written as a separate layer.

Point Labels  The text labels entered on points.

Line Labels  The text labels entered on lines.

Balance Regions All balance regions entered in the file.

Cut-Fill Lines  All cut-fill lines generated in the file.

Contours  All contours generated in the file.

Benchmark Pts Any Benchmarks in the file.

Survey Data   All survey data in the file.

Stake List Pts All stake list data in the file.

 Triangular Meshes

Triangular Meshes are three-dimensional triangles that Earthwork 4D creates based on the 
data lines of the different surfaces. The Entity Type allows the user to specify the way 
these meshes are written. The user should choose entity types based on what software 
the file is going to be read into and how it will be used.

Design  Design Surface Trimesh.

Subgrade  Subgrade Surface Trimesh.

Current  Current Surface Trimesh.

Previous  Previous Surface Trimesh.

Existing  Existing Surface Trimesh.

Stripped  Stripped Surface Trimesh.

Entity Type

 3D Face  Exports the Trimesh as 3D faces.

 3D Polyline Exports the Trimesh as 3D polylines.



Sitework 4D Reference

8-71

   Adding a Point to a Line

Points can be added to a line using the F6 key or the Insert Point command from the Right 
Mouse menu in the Elevation list.

Using F6

To add a point using the F6 key:

• Select the line, place the cursor over the location for the new point, then press the F6 
key.

The grade at that location is interpolated and an interpolated point is placed on the line.

Using the Elevation List

To add a point using the Right-Mouse menu in the Elevation list:

1. Select the line, then select a point closest to the location of the new point in the El-
evation list.

2. Right-click and select Insert Point. The Point Editor dialog box is displayed.

3. Type in the North and East coordinates and Elevation for the new point and click OK.

�
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 Importing Files

Earthwork 4D can import a variety of file types. Importing a file is typically done to create 
a new job from an existing file. Below is a list of importable file types.

• Earthwork Files   (*.esw, *.dxf, *.dwg)
• AGTEK SiteWork Files  (*.esw)
• AutoCAD Files   (*dxf, *.dwg)
• NEZ Text Files   (*.agt, *.csv, *.txt)
• Topcon LN3 Files  (*.ln3)
• Microstation Files  (*.dgn)
• LandXML Files   (*.xml)
• PDF Files    (*.pdf)
• TIF Files    (*.tif)
• Print Preview Files  (*.aip)
• AGTEK Sitework zip file  (*.esz)

To import, select File>Import for an existing job, or File>Open for a new job. The Import 
dialog box displays

Use the pulldown menu to choose the desired file type, then select the file and Click 
Open.

AutoCAD, NEZ, Topcon LN3, Microstation, LandXML, PDF, and TIF Files

(.dxf, .dwg, .agt, .csv, .txt, .ln3, .dgn, .xml, .pdf, .tif)

AutoCAD, NEZ, Topcon LN3, Microstation, LandXML, PDF, and TIF files all open using 
Import Mode, allowing you to transfer the data to the appropriate surface.

Print Preview Files (.aip)

Importing an AIP file automatically switches the program to Print Preview Mode. Any 
reports or images on the Print Preview Page remain and the imported data is added to the 
page.



Sitework 4D Reference

8-73

 Transforming Jobs

Transforming jobs uses commands in the Utility>Transform Job in Edit Mode. These com-
mands are: Translate North/East, Align Matching Edges, and Stretch Site. Each of these 
commands are described below.

Note: There is no Undo for when using the “Whole Job” option. It is recommended that a 
backup of the job file be made prior to using any of these commands.

  Translate North/East

Used to move data to a different coordinate system. There are three methods to move 
data; all data, selected data, or the whole job. All data and selected data methods move 
only the data in the current Surface and Layer. Whole job moves all data in all Surfaces 
and Layers. For information on aligning multiple PDF files, see the examples starting on 
page A-68.

All Data

1. Press the ESC key to make sure no data is selected.

2. Select Utility>Transform Job>Translate North/East.

3. Pick the first point, indicating what data to move. The Translate North/East dialog box 
displays.

 
4. Either type in the To coordinates or check Use Next Point Entered and click OK. If you 

check Use Next Point Entered, select the second point, indicating where you want to 
move this data to. Once the second point is selected, Translate North/East dialog box 
is displayed again for verification of the second point.

5. Click OK to continue. The Translating Site dialog box is displayed.

 
6. This dialog box displays the distance the data will be moved. Click OK to move the 

data or Cancel to abort the command.
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Selected Data/Whole Job

The procedure for Selected Data and Whole Job are identical, except that you would se-
lect Whole Job if you accidentally had data selected but wanted to move the whole job.

1. Select the data to move.

2. Select Utility>Transform Job>Translate North/East. The Select Area for Transforma-
tion dialog box displays.

 
3. Choose Selected Lines and click OK to continue.

4. Pick the first point, indicating what data to move. The Translate North/East dialog box 
is displayed.

 
5. Either type in the To coordinates or check Use Next Point Entered and click OK. If you 

check Use Next Point Entered, select the second point, indicating where you want to 
move this data. Once the second point is selected, Translate North/East dialog box is 
displayed again for verification of the second point.

6. Click OK to continue. The Translating Site dialog box is displayed.

 
7. This dialog box displays the distance the data will be moved. Click OK to move the 

data or Cancel to abort the command.
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  Align Matching Edges

Used for matching data from separate grading sheets, rotating data into the correct field 
coordinates, moving data on different surfaces into the same coordinate system, or align-
ing digitized data with a PDF. Aligning matching edges requires two common points in 
both sets of data. Property corners or pad corners are often good points.

 Matching Data to a Common Edge

When files are merged, or imported, often they are in different coordinates systems. Se-
lected data, or a PDF, can be moved and edge matched to non-selected data. Point 1 is 
moved to match Point 2, and Point 3 is moved to match Point 4. See the example below.

Entered Data

Selected Data 

or PDF

Point 1

Point 2

Point 3

Point 4

1. Select the data to move.

2. Select Utility>Transform Job>Align Matching Edges. The Select Area for Transfor-
mation dialog box is displayed.

 
3. Choose Selected Lines or Image Only (for PDF) and click OK to continue.

4. Pick the first point (Point 1) indicating what data you want to align. The Alignment: 
Point 1 of 4 dialog box displays the coordinates of the first point. Click OK to con-
tinue.

5. Pick the second point (Point 2) indicating where the first point matches. The Align-
ment: Point 2 of 4 dialog box is displayed. Click OK to continue.

6. Pick the third point (Point 3) indicating what data you want to align. The Alignment: 
Point 3 of 4 dialog box is displayed. Click OK to continue.

7. Pick the fourth point (Point 4) indicating where the third point matches. The Align-
ment: Point 4 of 4 dialog box is displayed. Click OK to continue.

8. A warning dialog box may appear stating that the second pair of points may not 
match. This is common given the degree of error in digitized takeoffs. Alignment does 
not rescale the data. Click OK to continue.
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 Rotating Data

Rotating data is very similar to matching data to a common edge. The only difference is 
that point 1 and point 2 would be the same point when rotating data.

To rotate data, use the procedure for matching data to a common edge and select the 
same points for point 1 and point 2 in steps 4 and 5 in the procedure.

 Moving Data

Layers can be moved in relation to each other to match the coordinate system. For ex-
ample, moving the design layer data to match the existing ground. This is similar to edge 
matching, but the data is being aligned to data points on a different surface or layer. This 
is commonly used to move data imported from a CAD file to align with data from a take-
off and you may need to add benchmarks before moving data. 

1. Press the ESC key to make sure nothing is selected.

2. Select Utility>Transform Job>Align Matching Edges.

3. Press Alt+B to display the Layer Selection window.

4. Select all required surfaces and layers. If moving design to match existing, make sure 
they are both selected.

5. Select all the data in the layer you want to move.
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6. Choose Utility>Transform Job>Align Matching Edges. The Select Area for Transfor-
mation dialog box is displayed.

 
7. Choose Selected Lines and click OK to continue.

8. Pick the first point, indicating what data you want to align. The Alignment: Point 1 of 
4 dialog box displays the coordinates of the first point. Click OK to continue.

9. Pick the second point, indicating where the first point matches. The Alignment: Point 
2 of 4 dialog box is displayed. Click OK to continue.

10. Pick the third point indicating what data you want to align. The Alignment: Point 3 of 
4 dialog box is displayed. Click OK to continue.

11. Pick the fourth point indicating where the third point matches. The Alignment: Point 4 
of 4 dialog box is displayed. Click OK to continue.

12. A warning window may appear stating that the second pair of points may not match 
each other. This is common given the degree of error in digitized takeoffs. Alignment 
does not rescale the data. Click OK to continue.
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  Stretch Site

Adjusts the scale of selected data, or the whole job. The most common use is to correct 
data entered at the wrong scale.

Whole Job

1. Press the ESC key to make sure nothing is selected.

2. Select Utility>Transform Job>Stretch Site.

3. Select an anchor Point, indicating from where you want to stretch the data in the 
lower left corner on the screen. The Stretch: Point 1 of 3 dialog box displays.

 
4. Check the Enter Scale Value Directly box. The Rescale Job dialog box is displays.

 
5. On the Job Scale tab, enter the scale used to digitize the plan sheet in the Old Scale 

box. Enter the new scale for the job (the correct scale) in the New Scale box.

 Note: The Scale Factor tab can be used to adjust the job scale by a factor. For exam-
ple, to scale a plan digitized at a 1:10 to 1:20, enter a scale factor of 2.

6. Click OK. The Stretching Site dialog box displays the vertical and horizontal factor by 
which the job was stretched. 

 
7. Click OK to finish and rescale the job.
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Selected Lines Only

1. Select all the data to stretch on the screen.

2. Select Utility>Transform Job>Stretch Site. The Select Area for Transformation dialog 
box is displayed.

 
3. Check Selected Lines and click OK to continue.

4. Select an anchor Point, indicating from where you want to stretch the data in the 
lower left corner on the screen. The Stretch: Point 1 of 3 dialog box displays.

 
5. Check the Enter Scale Value Directly box. The Rescale Job dialog box displays.

 
6. On the Job Scale tab, enter the scale used to digitize the plan sheet in the Old Scale 

box. Enter the new scale for the job (the correct scale) in the New Scale box.

 Note: The Scale Factor tab can be used to adjust the job scale by a factor. For exam-
ple, to scale a plan digitized at a 1:10 to 1:20, enter a scale factor of 2.

7. Click OK. The Stretching Site dialog box displays the vertical and horizontal factor by 
which the job was stretched.

 
8. Click OK to finish and rescale the job.
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  Stake Checking

RTK GPS support is an additional feature in Sitework 4D, which must be purchased sepa-
rately. Make sure you have setup Bluetooth connections and run GPS Base Setup before 
stake checking. Refer to “Bluetooth Setup” in the Appendix on page  for additional infor-
mation.

1. Open the model file that contains the stake data to check.

2. Align to the site using the Rover. Refer to “Aligning to the Site/Rover Setup” on page 
7-3 for information.

3. Select a stake point to check in the job file.

4. Move the Rover to the point on the site and level the Rover. The Offset tab of the 3D 
Controls window displays the horizontal and vertical difference and the slope from the 
picked point to the Rover.

 
5. Verify the information displayed in Earthwork 4D matches the cut/fill and elevation 

data on the stake at the job site.
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 Checking Existing Ground

When checking existing ground, areas with high grass, brush, or trees should be given ex-
tra attention because errors can be common in those areas on aerial topos. Also look for 
obvious signs of earth-moving that may have occurred after the original topo was done. 
Finally, remember that there is a certain inherent inaccuracy to ground models represented 
by contours and grades within half a contour interval are usually considered within ac-
ceptable margins as long as they are not consistently high or low.

Make sure you have setup Bluetooth connections and run GPS Base Setup before check-
ing existing ground. Refer to “Bluetooth Configuration” in the Appendix A-26 and “Lesson 
1 - Instrument Setup” on page 6-2 for additional information.

1. Open the job file with the data in it to grade check.

2. Align to the site using the Rover. Refer to “Aligning to the Site/Rover Setup” on page 
6-3 for information.

3. Change the Reference surface to Existing to display the existing ground by selecting 
Existing from the Ref pulldown menu.

4. Move the Rover around the area to check. The 3D Controls window reports the cut or 
fill value between the actual (survey) and theoretical (reference). The Elev box shows 
what elevation the program calculated that it should be based on the Reference (Ref) 
surface. The Northing and Easting boxes show the Northing and Easting coordinates 
for the location using GPS data. The survey elevation is displayed as the “Z” value at 
the bottom of the screen.

5. Click the Stop button when finished checking the area.

 Correcting Existing Ground

If the existing ground deviates substantially from the data in the job file, Earthwork 4D 
can use data collected from the Rover to document the difference and correct the original 
topo.

1. Switch to 3D view Mode, then move the Rover to a starting point for the topo area to 
correct. 

2. Click the Record Off button so that it reads Record On and take shots in serpentine 
pattern to cover the topo area.

3. After completing the topo, click the Record On button so that it reads Record Off.

4. Select Utility>Apply Survey. The Survey into Current Dialog box is displayed.

 
5. Select Replace to copy the data into the current layer with no other data or Stage to 

copy the data into data from the model and click OK. If you select Replace, skip step 
6.
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6. In the Current Layer Background dialog box, select the layer to use as the data for the 
Current layer. The cursor changes to a crosshair.

 
7. Enter a survey boundary around the updated topo data. Right-click at the start of the 

boundary, then select Finished to complete the boundary.

 Note: You can also right-click and select Survey Boundary if the topo data is a sym-
metrical shape to auto-create the boundary, then right-click and select Finished to 
complete the boundary.

8. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer 
now contains the new topo data plus the data from the layer you selected as the 
background (if any).
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  Progress Topoing

Progress topoing is a variation of checking existing ground. The difference is that you are 
creating a record of progress by creating multiple job site files with a progression of the 
Existing/Current changes for comparison.

Make sure you have setup Bluetooth connections and run GPS Base Setup before stake 
checking. Refer to “Bluetooth Configuration” in the Appendix page A-26 and “Lesson 1 
- Instrument Setup” on page 6-2 for additional information.

1. Open the model to do progress topo.

2. Select File>Save As to save the job file under a different name.

 Note: Progress topoing might be performed on a daily basis, so using a name such as 
the job file plus the date or the job file plus the phase would be helpful for future com-
parison of the files.

3. Align to the site using the Rover. Refer to “Aligning to the Site/Rover Setup” on page 
6-3 for additional information.

4. Move the Rover to a staring point for the topo area to check. 

5. Click the Record Off button so that it reads Record On and take shots in serpentine 
pattern to cover the topo area.

6. After completing the progress topo, click the Record On button so that it reads Record 
Off and save the job.

7. Select Utility>Apply Survey. The Survey into Current Dialog box is displayed

 
8. Select Replace to copy the data into the current layer with no other data or Stage to 

copy the data in with data from the model (see next step). If you select Replace, skip 
step 9.

9. In the Current Layer Background dialog box, select the layer to use as the data for the 
Current layer. The cursor changes to a crosshair.
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10. Enter a survey boundary around the updated topo data. Right-click at the start of the 
boundary, then select Finished to complete the boundary.

 Note: You can also right-click and select Survey Boundary if the topo data is a sym-
metrical shape to auto-create the boundary, then right-click and select Finished to 
complete the boundary.

11. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer 
now contains the new topo data plus the data from the layer you selected as the 
background (if any).

  12. Click the Survey Volume Calc button. The survey data is shown on the screen.

13. Right-click, then select Finished to use the existing survey boundary. After calculation, 
the Volume Calculation Results dialog box displays.

14. Click the Done button and the Survey Volume Report displays.

 Grade Checking

Earthwork 4D can be used for spot grade checking to determine if data for specific points 
in the model match the job site data.

Make sure you have setup Bluetooth connections and run GPS Base Setup before stake 
checking. Refer to “Bluetooth Configuration” in the Appendix A-26 and “Lesson 1 - Instru-
ment Setup” on page 6-2 for additional information.

1. Open the job file with the data in it to grade check.

2. Align to the site using the Rover. Refer to “Aligning to the Site/Rover Setup” on page 
7-3 for additional information.

3. Change the Reference surface to Existing to display the existing ground by selecting 
Existing from the Ref pulldown menu.

4. Select the point to check in the model, move the Rover to it, then level the Rover on 
the point. The 3D Controls window reports the cut or fill value between the actual 
(survey) and theoretical (reference). The Elev box shows what the elevation should be 
based on data in the Reference (Ref) surface. The Northing and Easting boxes show 
the Northing and Easting coordinates for the location using GPS data.

Cut or Fill amount at 
the current location

Reference elevation 
at Rover location

Northing at 
current location

Easting at 
current location

5. Repeat steps 3-4 for any other points to check.



Sitework 4D Reference

8-85

 Updating a 3D Model with Survey Data

In addition to updating job files in the field, you may have a file in the office that serves as 
the master file that you update with data collected in the field using a different file. This 
data is typically collected in the Survey Data Layer of the Current Surface. Updating a file 
with survey data is also called staging data.

Apply Survey Dialog box

The Apply Survey Data dialog box is displayed during the staging process. Below is a 
description of the dialog box.

Stage Data  Moves the survey data to the data line layer and updates the current   
    surface.

Edit Survey  Switches back to Entry Mode to change the boundary of the survey   
    data.

Toggle Overlay Toggles on or off the display of the 2D Overlay.

Cancel  Aborts the Apply Survey Command.

 Applying Survey Data Collected in Earthwork 4D

If you use Earthwork 4D in the field to collect data, you can export it from the field file, 
then import the survey data in to the master file.

Collect the Data

1. Open the job file that contains the reference surface or start a new file.

2. Switch to 3D View mode and collect data in the field.

3. Select Utility>Apply Survey. The Survey Into Current dialog box is displayed.

4. Select Replace (Copy) and click OK. The Current surface is created with the survey 
data.

5. Select File>Save As, and save the file as an AGT file.

6. (Optional) Save the file as an ESW file for reference. Make sure to change the name of 
the file so the original file is not overwritten if using an existing file.
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  Stage the Data

1. Open the master file to apply the data to in Earthwork 4D.

2. Select File>Import. The Import dialog box is displayed.

3. Select the AGT file that was created with the survey data in it and click Open. The 
Survey data is opened in CAD Transfer mode.

 4. Select the survey data, select “Current” from the Surface pulldown, “Survey Data” 
from the Layer pulldown, then click the Send To button. The data is transferred to the 
Current surface.

5. Switch to 3D Mode and select Utility>Apply Survey. The Survey Into Current dialog 
box is displayed.

 
6. Select Stage, then click OK. The Current Layers Background dialog box is displayed.

 
7. Select Existing and click OK to create the Current Surface with the Existing Surface 

as the ground and the survey data staged into it. The survey data is shown on the 
screen.
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8. Enter a survey boundary around the updated topo data by clicking to add points 
around the data. Right-click at the start of the boundary, then select Finished to com-
plete the boundary.

 Note: If the topo data is symmetrical, you can right-click and select Survey Bound-

ary to auto-create the boundary, then right-click and select Finished to complete the 
boundary.

 
9. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer 

now contains the Existing layer data plus the new topo data.

10. Select Existing from the Ref pulldown and Current from the Diff pulldown. This com-
pares the Existing surface with the Current surface to calculate the volume difference 
between the two surfaces.

11. Click the Survey Volume Calc button. After calculation, the Volume Calculation   
Results dialog box is displayed.

12. Click the Done button and the Volume Report is displayed.

 Applying Survey Data Collected in SitePilot RTK

If you use a SitePilot RTK unit in the field to collect data, you can import the survey data 
directly from the unit in to the master file.

Collect the Data

Refer to the SitePilot chapter of the PlanPilot manual for information about checking exist-
ing ground and starting a new survey using SitePilot RTK.

  Stage the Data

1. Open the master file to apply the data to in Earthwork 4D.

2. Connect the SitePilot to your computer via a USB port, then select File>PlanPilot Im-

port. The Open dialog box is displayed.

3. Select the file that was used to collect the data and click Open. The Survey data is 
opened in CAD Transfer mode.

4. Click the Send To button. The data is transferred to the Current surface.
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5. Switch to 3D Mode and select Utility>Apply Survey. The Survey Into Current dialog 
box displays.

 
6. Select Stage, then click OK. The Current Layers Background dialog box is displayed.

 
7. Select Existing and click OK to create the Current Surface with the Existing Surface 

as the ground and the survey data staged into it. The survey data is shown on the 
screen.

8. Enter a survey boundary around the updated topo data by clicking to add points 
around the data. Right-click at the start of the boundary, then select Finished to com-
plete the boundary.

 Note: If the topo data is symmetrical, you can right-click and select Survey Bound-

ary to auto-create the boundary, then right-click and select Finished to complete the 
boundary.

 
9. Click the Stage Data button in the Apply Survey Data dialog box. The Current layer 

now contains the Existing layer data plus the new topo data.

10. Select Existing from the Ref pulldown and Current from the Diff pulldown. This com-
pares the Existing surface with the Current surface to calculate the volume difference 
between the two surfaces.

11. Click the Survey Volume Calc button. After calculation, the Volume Calculation   
 Results dialog box is displayed.

12. Click the Done button and the Volume Report displays.
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  Calculating Volumes

Earthwork 4D calculates volumes in 3D View Mode by comparing the Reference surface 
with the Difference surface within the Volume Area. Report Regions are used to control 
the extent of the volume calculation. In 3D View Mode, all design perimeters can be se-
lected, and the undefined area included by using the Volume Area button.

  Volume Area

Click the Volume Area button on the tool bar or select Utility>Volume Area. The Volume 
Area controls the limits of the volume calculation. When selected, the program automati-
cally places a report region around the Design Perimeters. If no perimeter is present, a 
region is added surrounding all the entered Report Regions, Design Data, or Existing Data 
accordingly.

Starting the Volume Calculation

Before calculating the volumes verify that the correct surfaces are selected for compari-
son. Click the Calc Volume button on the Utility Tool Bar or select Utility>Calc Volume 
to begin volume calculation. During volume calculation, the cross sections display at the 
bottom of the screen with blue representing the Reference and Green the Difference. A 
line displays on the overlay showing the corresponding location of the cross section. The 
calculation can be paused by pressing the Spacebar. When paused, the I key will move 
across the site incrementally. Pressing the Spacebar again resumes the volume calcula-
tion. Volume calculation can also be aborted by pressing the Esc key. When the calcula-
tion completes, the Volume Calculation Results dialog box displays.

 

Click Done to close this window and view the Volume Report. You can also switch to Vol-
ume Report Mode to view the Volume Report by clicking the Volume Report button.
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  Calculating Survey Volumes

Earthwork 4D can also calculate the volume of survey data in the Current surface if you 
have collected survey data.

Once you have staged survey data, you can click the Survey Volume button. Using the 
Survey boundary, the Volume Calculation Results dialog box displays the survey volume. 
Click OK to display the Survey Volume report.

Islands and Holes

Islands and holes are additions/subtraction to areas in the design.

 Islands

An Island is a separate area outside of the main design perimeter but is part of volume 
calculation. A golf course may be a good example of this. The parent region is the first 
region entered and islands are entered afterwards using the same attributes as the parent. 
Any island that does not have a design perimeter or report region around its perimeter is 
not included in volume calculation.

 Holes

A Hole is an area within another area that is not to be included as part of the parent 
region on the volume report. Entering a hole in the Design Perimeter essentially places 
a hole in all other regions. Entering a hole in other regions has other effects, described 
below.

 Design Perimeter Hole

A hole in the design perimeter is created by entering a design perimeter within the parent 
perimeter. If a hole is placed in the design perimeter, it will also place a hole in the Report 
Region, Sectional Areas, and Stripping Areas. There is no need to enter additional holes in 
area that contain design perimeter holes.

 Report Region Hole

A hole in a Report Region is entered by placing a report region with the name “Hole” 
within the parent region. The area of the hole is added to the Unspecified area and does 
not show up as “Hole” on the volume report. 

 Stripping Area Hole

A hole in a Stripping Area is entered by placing a stripping area within the parent area 
with a depth of “0”. The hole can be any name. Individual stripping areas are totaled, and 
stripping areas with the same name are subtotaled.

 Sectional Area Hole

A hole in a Sectional Area is entered by placing a sectional area with the name “Hole” and 
a depth of “0” within the parent area. Sectional Areas with the name “Hole” do not show 
up on the volume report. However, a sectional area with a different name and depth of 
“0” does show up.
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Templates

Earthwork 4D can be used to create a template using typical cross section information. 
That template can then be applied to a chosen reference line, which can be used to build 
job such as roads, canals and trenches. Templates are entered by clicking on the Apply 

Template button on the toolbar.

When selected, you are prompted to scale the cross section. For instructions on using 
Templates, see page A-37.

Hinge  Adds a hinge point to the left or right side of the template to allow the ends to be   
  sloped to daylight.

Mirror  Creates a symmetrical template by entering default values to match either the Cut and  
   Fill, or the Left and Right, depending on when checkboxes are selected.

Daylight  Selects the surface to be referenced when daylighting the template.

Output  Selects the surface to which the template is applied. Selecting “New Surface” copies   
  the Daylight surface in a new surface, and stages the new template lines into the new  
  surface.

Stage Lines Stages lines produced by the template into the output surface by trimming and   
  deleting any intersecting lines within the template.

Points Every When selected, enters points at the designated interval.

Vertical  Distance, in feet, above or below the reference line.
Offset

Apply  Applies the template to the chosen reference line.

Save  Saves the template for use on future jobs.

Cancel  Cancels the operation.

Width  Segment width.

Height  Segment elevation change.

Slope  Segment slope.
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Offset Line Editor

Offset Lines are a powerful method of creating lines based upon numeric distances and 
elevations from a specified reference line (such as creating the bottom of curb from the 
top of curb line). This tutorial uses the “4D Lesson 4.esw” file, with all of the CAD data 
converted.

The Offset Line Editor is used to create offset lines in Earthwork 4D. This page and the 
following page has explanations of the feature of the Offset Line Editor.

Line Controls

Offset Toggles the direction of the offset line compared to the selected    
   reference line. The point order on the line determines right and left. An   
   arrow displays on the overlay showing the offset direction. 

Points Every This is a two-part control. When the Points Every box is checked, the   
   program creates extra points on the offset line at the distance specified in   
   the text box. When the box is unchecked, the program matches the points   
   on the reference line and only adds points to correctly model corners.

Connectors This option creates lines between the reference point and its corre-   
   sponding offset point. It is most often used when sloping to Daylight.

Daylight The Daylight check box allows creation of lines at a specified slope to a   
   designated daylight surface. The default surface is existing. Selecting this   
   option adds Cut and Fill slope text boxes to the Start and End of lines areas

Line Label Use this box to enter a line label for the offset line that will be created.
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Start/End of Line

The Start/End of Line text boxes control the placement of the offset line. Specifying any 
two values for the Start or End calculates the other value and displays it in red. Varying 
the Start and End values allows creation of offset lines not parallel to the reference line.

Offset The distance from the reference line to the offset line.
Distance

Elevation The change in elevation between the reference and offset lines.   
Difference     

Slope  The slope from the reference line to the offset line shown as a percentage.

Confirmation Controls

Apply  Creates an offset line using the specifications in the Offset Editor.

View  Displays changes made in the Offset Editor settings without actually    
   creating the line. 

Close  Closes the Offset Editor. 

Determining  Line Direction

The line direction is indicated by a diamond at the starting point of the line. Imagine your-
self standing on the first point of the line looking down the line. An offset line to the left 
and right would be the same as your left and right.

Other Offset Features

The Offset Editor can offset multiple selected lines, but requires the line direction for the 
lines be constant. The  Utility>Swap Ends command changes line direction.

Multiple offset lines can also be created from a single reference line. For example, the 
base of curb could be created from the top of curb by clicking the Apply button and then 
a back of walk created by entering the new specifications and clicking Apply.
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 Using Auto Save

The Auto Save feature automatically saves your job to ensure data is not lost during 
an inadvertent termination of Sitework 4D. To edit the properties of this feature, select 
Options>Auto Save. A check next to the command on the menu indicates that it is en-
abled.

Auto Save allows you to set the interval between saves from 1 and 60 minutes. By de-
fault, the programs sets the save interval to 5 minutes. To turn off the Auto Save func-
tion, select Disable checkbox and click OK.

  The Autosave.esw File

If Sitework 4D is not closed down properly, any data in the current job file that was 
entered after the previous Save is automatically saved to a file called “Autosave.esw”. 
The “Autosave.esw” file is located in the current working directory. This file is only cre-
ated when the amount of time passed is greater than both the Auto Save interval and the 
amount of time since the last Save command was executed. If Sitework 4D is closed us-
ing the Exit command from the file menu, the autosave file is deleted.

 Recovering the File

When an “Autosave.esw” file has been created and Sitework 4D has closed improperly, 
the Autosave.esw file is automatically opened the next time Sitework 4D is started. If an 
autosave file is opened, be sure to Save the file and either change the name of the file 
or choose the previous version of that file and overwrite it. Auto Save files that have not 
been recovered are deleted when you exit Sitework 4D.
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  Creating AGT Files

Sitework 4D can create AGT files, which are ASCII line format files used to transfer data 
lines between programs. These files can then be imported into other programs, such as 
AGTEK’s Graphic Grade 3D program. To create an AGT file

 

1. Select the Surface and Layer you want to save as an AGT file.

2. Use the Hide, Hide All But, and Show All commands or use the Layer Selection com-
mand to display the Layer data to be saved. Only the visible data lines of the active 
Surface and Layer are saved in the AGT file

 

3. Select File>Save As. The Save As dialog box is displayed.

4. Change the file type to AGTEK Text Export (*.agt) and click Save.

 Note: A 2-letter abbreviation for the currently active surface is appended to the end of 
the job name to distinguish it from other AGT files created from this job.

  Importing AGT Files

When an AGT file is imported, Sitework 4D automatically switches to CAD Transfer mode 
and allows the file to be sent to a specific surface and layer from that window.

  Exporting Machine Control Files

Sitework 4D saves surface information for use in Machine control units, including AGTEK, 
Topcon, Trimble, Leica units.

  AGTEK Graphic Grade Machine Control

Sitework 4D saves machine control data in the .esw file when it is saved in Sitework 4D. 
To use the data, open the .esw file in Graphic Grade Machine Control. Refer to the AGTEK 
Graphic Grade Machine Control manual for additional information.
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   Topcon Machine Control

Sitework 4D can export TN3 files, which can be opened in Topcon applications to create 
a machine control file for use in Topcon units.

1. Open the file for use as the machine control file in Sitework 4D. 

2. Select File>Save As. The Save As dialog box displays.

3. Select “Topcon TN3 File (*.tn3)” from the Save as type pulldown and click Save.

 

4. Select “Topcon LN3 File (*.ln3)” from the Save as type pulldown and click Save.

5. Open the files in Topcon and save a machine control file. Refer to the Topcon docu-
mentation for information about saving a machine control file.

   Trimble Machine Control

Sitework 4D can export TTM files, which can be opened in Trimble applications to create 
a machine control file for use in Trimble units.

1. Open the file for use as the machine control file in Sitework 4D. 

2. Select File>Save As. The Save As dialog box is displayed.

 

3. Select “Trimble TTM File (*.ttm)” from the Save as type pulldown and click Save.

4. Open the file in Trimble and save a machine control file. Refer to the Trimble docu-
mentation for information about saving a machine control file.
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 Adding Circles

The Circle Tool button is used to add a user-defined circle to a design. Circles are added 
using an existing center point or by creating a circle without a center point reference. 
Circles can only be added in Entry Mode. Follow the steps below to add a circle to your 
job.

1. Click the Circle Tool button from the Utility Tool Bar. The Circle Drawing Mode win-
dow will display. Choose the desired method. 

Leica Machine Control

Sitework 4D can export DWG files which are optimized for use with Leica applications 
and products.

1. Open the file for use as the machine control file in Sitework 4D. 

2. Select File>Save As. The Save As dialog box is displayed.

2. Move the crosshair over the location for the circle or the center point to use and press 
the Enter key. The crosshair snaps to the existing point if snap is turned on.

3. Select “Leica HMC3D (*.dwg, *.dxf)” from the Save as type pulldown and click Save.

4. Open the file in Leica and save a machine control file. Refer to the Leica documenta-
tion for information about saving a machine control file.
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 Adding Rectangles

The Rectangle Tool button is used to add a user defined rectangle, such as a building pad, 
to a design. Rectangles can only be added in Entry Mode. Follow the steps below to add a 

rectangle to your job.

1. Click the Rectangle Tool button from the Utility Tool Bar. The cursor changes to a 
crosshair.

2. Move the crosshair over the location of one of the corners of the rectangle and press 
the Enter key.

3. Move the crosshair away from the starting point to draw the rectangle. 

4. Press the Enter key again to add the rectangle. The Add Rectangle dialog box is dis-
played.

5. Make changes to the Width and Height and click OK to finish entering the rectangle.

5. Make changes to the radius and click OK to finish entering the circle.

3. Move the crosshair away from the center point.

4. Press the Enter key again to add the circle. The Edit Circle Radius dialog box is dis-
played
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Entering Rectangles Parallel to an Existing Line

Often, the roads and pads of a job site do not run exactly North-South and East-West. 
Sitework 4D can enter data by temporarily changing the coordinate system based on a 
line segment that runs parallel to the data to be entered. Any rectangles drawn subse-
quently will follow this new coordinate system. Follow the steps below to add a rectangle 
parallel to an existing line to your job .

1. Move the cursor over a line parallel to the orientation of the proposed rectangle.

2. Press the F12 key . The line displays a yellow diamond at each end. The job is now 
set up to use these coordinates for data entry. 

3. Click the Rectangle Tool button from the Utility Tool Bar. The cursor changes to a 
crosshair.

4. Move the crosshair over the location of one of the corners of the rectangle and press 
the Enter key.

5. Move the crosshair away from the starting point to draw the rectangle.

6. Press the Enter key again to add the rectangle.  The Add Rectangle dialog box dis-
plays.

7. Make changes to the Width and Height and click OK to finish entering the rectangle.

8. Press the X key to return the original job coordinate system.

�

x
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  Adding Arcs/Fillets

The Fillet Line button is used to add an arc where two surfaces meet, forming a rounded 
corner. The fillet is entered with a user-defined radius added between adjoining line seg-
ments. Fillets can be added in Entry and Edit Mode. Follow the steps below to add a Fillet 
to your job.

Adding a Fillet in Edit Mode

In Edit Mode, the Fillet Tool button is used to add a fillet to the corner of two joined line 
segments. The corner must be on a joined or continuous line segment. 

1. Switch to Edit Mode.

2. Click on the corner of the line where the fillet will be added

3. Click the Fillet Tool button from the Utility Tool Bar. The Edit Fillet Radius dialog box 
displays.

 

4. Enter the desired radius and click OK to add the fillet.

Two annotation points are added, “CR1” and “PL1”. “CR1” represents the center of the 
radius that was created and “PL1” is the previous corner location.

Adding a Fillet in Entry Mode

In Entry Mode, the fillet command is accessed using the R key while entering points. The 
radius is applied to the line after the second point is entered.

1. Switch to Entry Mode.

2. Click on the first point.

3. Move the crosshairs to the location of the second point and click on the point

4. Press the R key followed by a radius value and move the crosshair to preview the    
fillet. 

5. Click again to add a point using the specified fillet radius.

 Note: Any subsequent fillet will use the previously used radius value until a different 
R-value is entered using the steps above.

r
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  Adding Benchmarks

The Add Benchmarks button is used to add benchmarks to a job. Once added, Bench-
marks can be used for scaling purposes or for future use in the field. Benchmarks can only 
be added in Edit Mode. There are two methods for adding a Benchmark, using a selected 
point and using user-defined Benchmarks. Follow the steps below to add a Benchmark to 
your job.

Using a Selected Point

An existing point can be used as a benchmark. The point may be alone or part of a data 
line.

1. Click on the point to be used as a benchmark.

2. Click the Add Benchmarks button. The add Point dialog box displays.

3. Add any desired Point or Line Labels and click OK. A benchmark point (displayed as a 
“Y”) is created. 

User-Defined Benchmarks

If no point exists at the Benchmark location, a user-defined Benchmark can be added at 
a specific location. Note that the current job must be scaled to field coordinates to add a 
Benchmark that can be used on the construction site.

1. Make sure nothing is selected by pressing the Esc key

2. Click the Add Benchmarks button. The cursor changes to a crosshair.

3. Move the crosshair to the location of the Benchmark and click. The Add Point dialog 
box is displayed.

4. Enter the coordinates for the Benchmark, add any desired Point or Line Labels and 
click OK. A benchmark point (displayed as a “Y”) is created.
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Enter Benchmarks with Lat/Long Info From Google Earth

To successfully export a .kmz file for use with Google Earth the file must be properly 
aligned using lats and longs. If this information is not available, approximate lat/long coor-
dinates can be obtained using Google Earth. For information on exporting a .kmz file refer 
to page 5-4.

1. Open your file in Sitework 4D and launch Google Earth. If you do not have Google 
Earth installed it can be downloaded at http://earth.google.com/.

2. Using Google Earth, locate your job site.

3. Identify two points which can also be found in you job file.

4. Click the Add Placemark tool identified below. A dialog box displays giving you the 
latitude and longitude of the pushpin.

5. Place the tip of the pushpin on the first of the two points selected.

6. Click and drag over the lat coordinate to highlight it, right-click and select copy.

7. Switch to Sitework 4D.

8. Click the Add Benchmarks button. The cursor becomes to a crosshair.

Add Placemark Tool
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9. Click the point on the job that matches the point located in Google Earth. The Add 
Point box displays.

10. Right-click in the degree box for the latitude coordinate and select paste.

11. Switch to Google Earth and repeat steps 6-10, this time for the longitude coordinate.

12. Repeat the process for the second point.

13. Click the Save button.

14. Your job is now ready to create a .kmz file.
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  Conforming Annotation Lines

Design lines are often imported from CAD files as annotation lines. These annotation lines 
can be converted into three-dimensional data lines by using the Conform Annotate com-
mand. This command can quickly change a large number of annotation lines by interpo-
lating elevations and “conforming” them to current design data lines or to the current 
surface.

Conforming to Design Lines

This example uses a sample file called “Crandell Ave.esw”, available in the C:\AGTEK\

Data directory. This job is a subdivision with street lines that have been imported as an-
notation lines. We’ll convert these lines to design lines using Conform Annotate instead of 
entering elevations individually or re-digitizing the lines.

1. Open the “Crandell Ave.esw” file.

2. Switch to Edit Mode, make sure the Design Surface and Annotation Lines Layer are 
selected, and zoom in to a section of the street.

3. Click the L-EOA line (the inside line defining the street), then click the Label Selection 
button

 

4. Select Utility>Conform Annotate>to Design Lines. The line changes to blue, and 
elevations are interpolated based on elevations near the line.

5. Click the L-SHLDR line (the outside line defining the street), then click the Label Selec-

tion button.

6. Select Utility>Conform Annotate>to Design Lines. Elevations are interpolated based 
on elevations near the line. 
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7. Click the Centerline line then Click the Label Selection button.

8. Select Utility>Conform Annotate to Design Lines. Elevations are interpolated based 
on elevations near the line and the road is now at Finished Grade. 

9. Check the design in 3D view for elevation differences. Your screen should look similar 
to the illustration below
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  Assigning Elevations using Auto-Pad

Sitework 4D can quickly assign elevations to enclosed areas using the Auto-Pad function. 
This is especially useful for assigning elevations to files that have a large number of pads 
that are transferred as annotation lines.

This example uses a sample file called “Auto Pad.esw”, available in the C:\AGTEK\Data 

directory. This is a CAD file that has been transferred with the pads as annotation lines.

1. Open the “Auto Pad.esw” file.

2. Switch to Edit Mode, make sure the Design Surface and Annotation Lines Layer are 
selected.
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4. Select Utility>Auto-Pad to create pad elevations.

 

3. Click on an elevation then Shift+click on all of the remaining elevations in the pads. If 
the pad number is selected, it will be used for the elevation.
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 Over-Excavating

Over-Excavation and backfilling new material is often required on building sites before 
grading to subgrade. Sitework 4D allows the user to calculate the volumes of the over-ex-
cavation by creating a new surface at the over-ex grades and comparing it to the exist-
ing ground. The example below uses the “over-ex.esw” file, which can be found in the 
C:\AGTEK\Data directory.

1. Open the “Over-ex.esw” file.

2. Switch to Entry Mode and click the Over-Ex button on the Utility Tool Bar. The Over-
Ex Guide dialog box is displayed.

3. Select Create New Surface and click OK. The Create New Surface dialog box is dis-
played with Current as the default name.

4. Click OK. The Current Surface is displayed on the screen.



A-16

Sitework 4D Appendix 

5. Click the Over-Ex button on the Utility Tool Bar and select Copy OG into New Surface. 
The Copy From window will display.  Select either Existing or Stripped and click OK.

6. Click the Over-Ex button on the Utility Tool Bar and select Create Over-Ex Surface 
from the guide. The Over-Ex Surface is displayed on the screen with no data.

7. Click the Over-Ex button on the Utility Tool Bar and select Enter Over-Ex Data.

8. Switch to Edit Mode and select the Design Surface and Data Lines Layer.
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9. Click on the pad on the left side of the job and select Edit>Copy. 

10. Select the Over-Ex Surface and select Edit>Paste. The pad is pasted in as a yellow 
line.

11. Click on the pad and the click the Offset Line button. The Offset Line Editor is dis-
played.

12. Run an Offset Line outside the pad with an Offset Distance of “5” and a Slope % of 
“0”. Click View to view the line, Apply to add the line, and Close to close the Offset 
Line Editor.
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13. Press the Delete key to remove the pad from the Over-Ex Surface since we no longer 
need it.

14. Select the offset line just created and select Edit>Raise/Lower from the menu. The 
Raise/Lower Elevation dialog box is displayed.

15. Enter “10” in the Lower Elevation box and click OK. This lowers the offset line from 
the pad to the over-excavation level.

16. With the line selected, click the Offset Line Editor button. The Offset Line Editor dis-
plays.

17. Check the Day Light box, select Existing, and enter “2:1” in the Start of Line Slope % 
box. This creates an offset line to daylight at 2:1 slope. 

18. Click View to view the line, Apply to add the line, and Close to close the Offset Line 
Editor. Your screen should look similar to the illustration on the following page.

19. Switch to Entry Mode, click the Over-Ex button on the Utility Tool Bar and select En-
ter Staging Areas. The Stage Areas Layer is selected.
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20. Press the F8 key twice over the offset line to area snap the stage area to the line. 
Right-click twice to end snap and data entry.

21. Press the Over-Ex button on the Utility Tool Bar and select Stage Over-Ex. The screen 
switches to 3D Edit Mode displaying the staged data in Terrain and Overlay view.

22. Switch to 3D View Mode and select Current as the Ref and Stripped as the Diff.

23. Click the Calc Volume button to calculate the volume of the over-excavation area. To   
view the full report, switch to the Volume Report Mode.
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 Stripped Current Surface vs. Stripped Existing Surface

To compare a stripped current surface to stripped existing surface in 3D View Mode, the 
stripped surface must be used instead of the existing surface in the current layer when 
creating the Over-Ex surface. When creating the current surface on the Over-Ex Guide, 
skip the step: Copy OG into New Surface. Follow the steps below to copy the stripped 
existing ground data into the Current Surface.

1. Switch to 3D View Mode, change the Ref to Stripped.

2. Type Ctrl-C to copy the stripped surface. 

3. Switch back to Edit Mode. Change the Surface to Current and the Layer to Data Lines. 
Type Ctrl-V to paste the data into the Data Lines layer of the Current surface.

Press the Over-Ex button and continue from Create Over-Ex Surface.
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 Profile Views

Profiles are another way to check your work and can be viewed from any position on the 
site. Profiles are entered in the Profile View mode.

 Entering a Profile

1. Switch to Profile View Mode and select Subgrade as the Ref (Reference) layer and 
Stripped as the Diff (Difference) Layer. 

2. Select Utility>Profile Entry and click at the edge of Lot 4.

3. Move the cursor across Lot 3 to the back edge of the design contours and click again. 

4. Right-click to end the line

 

As you drag the cursor over the site, you notice how the profile displays along the bottom 
of the screen showing design, existing ground and the strata layers. To display all layers 
in the file, select the All button on the tool bar.
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5. Move the cursor to the center-line of the street between Lot 1 and Lot 4, then click 
and draw a line down the center of the street passing through Lot 2 and the retaining 
wall to the edge of the site. 

6. Right-click to end the line

 

Notice how the street section displays as well as the retaining wall and hole in the pro-
posed perimeter. Try entering in other profile lines. Profile lines don’t have to be straight 
and may contain multiple line segments. Press the Enter button to add a point and change 
the direction of the line. These Profile lines can also be used to create stations along the 
length of the profile. 



A-23

Sitework 4D Appendix

Zooming In/Out on a Profile

Zooming in on a selected profiles allows for a closer inspection of that profile. You can 
also pan across the profile to continue inspection.

1. Place the cursor over the selected profile in the profile view. Roll the mouse wheel 
up/down to zoom in/out.

2. Push down on the mouse wheel and drag the cursor to pan the view of the selected 
profile.

Enlarging Profile Window

Enlarging the profile window allows you to adjust the amount of screen space dedicated 
to the profile view.

1. Place the cursor over the bar separating the plan view from the profile view.

2. Left-click and drag the bar up or down to adjust the size of the profile view. Your pro-
file view should appear similar to the illustration below.
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  User Cut-Fill Values

The User Cut Fill Values option allows the user to enter locations manually for specific 
cut/fill locations to display. To enter these specific locations.

1. Switch to Entry Mode 

2. Select the Design Surface and Cut/Fill Labels Layer.

3. Click to enter Points where you wish cut-fill labels to display. Right-click to finish.

4. Switch to Plan View Mode.

5. Select View>User Cut Fill Values. The only cut-fill labels that appear should be the 
ones that you entered.

Modifying the View

The Plan View can be modified with the Zoom and Pan functions.

Zooming

Zoom allows you to change the scale of the Plan View and creates a more detailed display 
of cut-fill labels. 

Panning

Panning allows you to move your position on the plan View while zoomed in. There are 
several ways to pan. 
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 Plan View

The Plan View is a view of the overlay showing cut-fill areas by color, with information 
regarding cut-fill, and elevations of the reference and difference layers at predetermined 
locations on the plan.

Switch to Plan View Mode to view your job in Plan View. The label information is ex-
plained below.

Plan View Labels

Below is an example of a Plan View label.

Elevation at Reference Surface

Elevation at Difference Surface

Cut-Fill amount between Reference 
and Difference

The information displayed in the label can be changed by selected the options located 
under the View Menu. Select the desired label option and see the results display on the 
screen.
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Bluetooth Setup

RTK GPS support is an additional feature in Sitework 4D, which must be purchased 
separately.Before you can receive GPS data from the base and rover, you must setup a 
Bluetooth connection between the receivers and your computer. You only need to setup 
the Bluetooth connection once for each GPS receiver. This can be performed prior to arriv-
ing at the job site.

1. Turn on your base and rover GPS units.

2. Click Start>Bluetooth Settings. If no receivers have been setup, the Add New Con-
nection Wizard is displayed. If connections exist, the Bluetooth Settings window 
displays.

 

3. Click the New Connection button to display the Add New Connection Wizard.

 

4. Be sure to select Custom Mode and click Next.
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5. Select the Base GPS from the list and click Next.

 

6. Select Serial Port as the Service and click Next.

7. Uncheck the Use default COM port option. Click OK when the warning dialog box is 
displayed.

 

8. Select COM8 from the pulldown menu and click Next.

9. Click Next on the COM port setting screen and on the Enter a name and select an Icon 
screen.
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10. Click Finished to complete setup. An icon for the Base is displayed in the Bluetooth 
Settings window.

11. Repeat the steps above for the Rover, selecting the Rover GPS in step 4 and COM9 in 
step 7 for the port. The Bluetooth Settings window should look similar to the illustra-
tion below when finished.
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 Strata

Strata are layers of different materials beneath the Existing Ground. Strata layers are 
described by borings as depths below the existing ground or by elevations that cannot 
exceed the existing ground. Only cut areas produce strata volumes. During volume calcu-
lations, each cut area volume is calculated for each strata layer.

 Strata Bores

There are seven borings located on Pine Street. The illustration below shows their loca-
tions on the Pine Street plan sheet.

On the following page is a chart that explains the strata at each bore location. The ex-
isting ground starts at zero and increasing values are depths below the existing ground 
surface.

B1

B2

B3

B4

B5
B6 B7



A-30

Sitework 4D Appendix 

Entering Strata Bores

1. Open the “Pine Street PDF Tutorial.esw” file.

2. Select the annotation outline surrounding the job site. Right-click and select Import 

File. The PDF is displayed. There are seven bore holes visible on the PDF.

B1 B2 B3 B4 B5 B6 B7 LEGEND

2.0

3.0

2.2 2.2

3.0

1.8

2.2

2.8

2.5

3.1

2.2

2.9

EXISTING

RIP

SHOT 

D
e
p
th

 i
n
 F

e
e
t

2.0

2.9

3. Switch to Entry mode, set the surface to Existing and set the layer to Strata Bore 

Holes.
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4. Left-click on bore location B1 at the center of Lot 4. The Edit Strata Layers dialog box 
displays. The Edit Strata Layers dialog box will only display the first time you enter a 
bore hole.

5. In the second row, type “Rip Rock” as the STRATA NAME and “1.30” as the CUT 
COMP value. In the third row, type “Shot Rock” as the STRATA NAME and “1.40” as 
the CUT COMP value. Click OK. The Bore Log Information dialog box is displayed. 

6. Enter a Depth of “2.0” for the Rip Rock and “3.0” for the Shot Rock. These number 
represent the depth below the existing ground and can be found on the Bore Log on 
page A-30. Click OK to add the bore hole to the takeoff.

7. Left-click on bore hole at location B2. The Bore Log Information dialog box is dis-
played.

8. This bore has different strata depths and thickness than the previous bore. Enter a 
Depth “2.2” for the Rip Rock and a Depth of “3.0” for the Shot Rock. Click OK to add 
the bore hole to the takeoff.

9. Continue entering the remaining borings using the same steps. Press the right-click 
end bore hole entry.

If a strata 
layer does 
not exist 
at a given 
location, 
enter the 
same depth 
as the layer 
below the 
nonexistent 
layer.
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 Strata Tracking

The strata borings require a method used to determine how the strata slopes from one 
boring to another.

Strata Tracks OG

The Options>Strata Tracks OG command allows the program to use the existing ground 
and slope the strata layers following the sloping information from the existing ground 
topo. When there is a check next to this option, it is turned on and tracks the existing 
ground, or OG (Original Ground).

When this option is unchecked, the program uses the break lines to slope from one boring 
to the next.

Freeze Strata Layers

The Options>Freeze Strata Layers command freezes any entered strata data to the cur-
rent Existing Surface. Any future changes to the Existing Surface will not change the 
Strata Layer. 

When this option is unchecked, any changes to the Existing Surface will also affect the 
Strata data in the job file.

  Editing Borings and Break Lines

Editing borings and break lines is similar to editing any other point or line. Switch to Edit 
mode and select the Existing Surface and either the Strata Bore Holes or Strata Break 
Lines Layer.

If the break lines were entered as one continuous line, then use the Edit>Break Line com-
mand to break the lines as selected points. The lines can then be deleted.

Editing break lines is slightly different. To edit the strata elevations, select a boring, then 
double click the point in the Elevation list. The Point Editor is displayed with a Depth box 
showing the depth of the first layer, instead of an Elevation box. Make any desired chang-
es and click OK.
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Reviewing Strata Information

1. Switch to the Planview Mode.

2. Set the Reference surface to Subgrade and the Difference surface to Rip Rock. You 
can now see the cut area where you will encounter Rip Rock.

3. Change the Difference layer to Shot Rock and you can see the cut areas where you 
will see the areas that will require blasting.
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Calculating Volumes

1. Change the Difference Layer to Stripped.

2. Click the V button to calculate volumes and the Volume Calculation Results dialog box 
displays.

3. Click done and the Volume Report displays. The volume of the entered strata layers 
are displayed in red. 
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Entering Profile Reference Line

In this example we enter an annotation line to be used as a reference line for both the 
existing and design data.

1. Switch to the Entry Mode, and set the Layer to Annotation Lines.

2. Using the keyboard, enter “0” as the elevation, and trace the centerline of the road, 
left-clicking as you go to enter points. Begin tracing where the matchline intersects 
station 25+00 and stop tracing at the 39+00 station.

3. Right-click to end the entry, and right-click again to get your arrow back.

 PDF Profile Entry

Sitework 4D can be used to enter elevations that are defined by a profile view. This is 
common on jobs such as county roads, streets or canals. Profiles may be attached to data 
lines, annotation line or profile lines. The following example uses a job which already has 
the existing plan view information entered.

Open Sample Files

1. Select File>Open and browse to C:\AGTEK\data. Select “Profile Entry1.esw” and 
click Open.

2. Select the brown annotation line surrounding the job site. Right-click and select Import 

File.
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4. Right-click and select “Edit Mode”. Your screen should appears similar to the illustra-
tion below.

Centerline

Scaling the Profile

When scaling the profile, it is important to use the elevations listed on the grid for vertical 
elevations and station numbers, or distance between stations, for horizontal distance.

1. Click on the annotation line you just entered to select it.

2. Click the Attache Profile button and the Profile Scaling dialog box displays.

3. Enter “4015” for the vertical of point 1, “3970” for the vertical of point 2, “1400” for 
the horizontal of point 3, and click OK.
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4. On the profile grid at the bottom of the PDF, position the crosshair at the intersection 
of station 25+00 and elevation 4015. Left-click to enter point 1.

5. Position the crosshair over the intersection of station 25+00 and elevation 3970. 
Left-click to enter point 2.

6. Position the crosshair over the intersection of station 39+00 and elevation 3970. 
Left-click to enter point 3. You are prompted by the status bar to enter the existing 
ground.

Point 1

Point 2

Status Bar

Point 3

Entering Existing and Design Data

1. Beginning at station 25+00, trace the existing profile line, left-clicking to enter points 
as you go. Right-click to end the entry at the 39+00 station.

2. Beginning at station 25+00, trace the Design profile line, left-clicking to enter points 
as you go. Right-click to end the entry at the 39+00 station.

3. The elevations will be assigned to the selected profile line, which is displayed in the 
profile view at the bottom of the screen. The street can then be built using Template.

If there is no 

existing data 

to enter here, 

right-click to 

skip to the 

design entry
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 Templates

Jobs such as roads, canals and trenches are often based on structural details or typical 
cross sections. Sitework 4D can be used to create a template based a typical cross sec-
tion and apply that template to a chosen reference line.

 Basic Template Entry

1. Select File>Open and browse to C:\AGTEK\data. Select “Template Entry 1.esw” and 
click Open. Set the Surface to Design.

2. Select the brown annotation line surrounding the job site. Right-click and select Import 

File. The existing contours and design profile information have already been entered in 
this file.

Import Typical Information

This section imports the PDF containing the information for the typical cross section. It is 
possible to skip the following steps and enter the typical cross section segments as dem-
onstrated in the “Enter Template Information” section without importing the PDF in which 
they are contained, using the blank space outside of your job.

1. Press the Esc key to deselect the brown annotation border. Select File>Import, 
choose “Typicals.pdf” and click Open. The PDF opens in the CAD Transfer window.

2. Switch to the Edit Mode. The PDF imports larger than the previous one.
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3. Zoom in to the typical section labeled “2. Proposed Typical Bypass Roadway Section”. 
Take note of the following information: 12’ travelway with a -2% slope, 6’ shoulder 
with a -2% slope, 5’ taper at a 4:1 slope, and a 4:1 slope to existing ground. Notice 
the typical cross section is symmetrical.

Enter Template Information

1. Zoom out and select the design center line.

2. Click the Apply Template button on the toolbar and the Open dialog box displays. 

3. Click New and the Template Scaling dialog box displays. The typical section is not to 
scale, which is common, so we will use the default values provided.

4. Click OK and zoom in to the typical section labeled “2. Proposed Typical Bypass Road-
way Section” and click on the top-left, bottom-left and bottom-right extremes of the 
typical section shown below to scale in. Remember, the scale is arbitrary.

5. Trace the typical cross section, entering points between each segment. Add a seg-
ment on each side to allow for a slope to daylight. There are eight segments in this 
example.

Point 1

Point 2 Point 3

Segment 1 Segment 8
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6. Right-click to end the entry and the Template Editor dialog box displays. The refer-
ence point is marked with a yellow diamond on the cross section at the bottom of the 
screen.

7. Select both the Cut to Fill and the Left to Right check boxes.

8. For segment 5, enter “12” for the width and “-2” for the slope. For segment 6, enter 
“6” for the width and “-2” for the slope. For segment 7, enter “5” for the width and 
“-4:1” for the slope. Notice segments 2 through 4, and all values for fill, change to 
match entered values.

9. Select segment 2 and select the Left Hinge checkbox, the width changes to Variable 
and the height changes to Daylight.

10. Select segment 7 and select the Right Hinge checkbox, the width changes to Variable 
and the height changes to Daylight.

11. Enter “4:1” in the Slope column for segment 1.

12. Set the Daylight surface to Existing and the Output surface to Design.

13. Select the Points Every check box and enter “20” for the value. 

14. Click Apply and you are prompted to save the changes to the template. Click Yes and 
the Save As dialog box displays.

For more information on Reference Points (RP) and Hinge Points (HL and HR) see page    
8-87.

Typical 

information 

can also 

be entered 

freehand, 

without 

the PDF 

displayed. 

Be sure to 

include the 

appropriate 

number of 

segments.
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15. Name the template “Bypass” and click Save. The template then sweeps down the 
reference line using the template information to create lines at the designated distance 
and slope from the chosen reference line.

16. Switch to 3D Mode to view the changes made to the design surface by the applied 
template.
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 Templates - Building Trenches

For this example, we will import lines representing the pipe work on the job in the form of 
an .agt file. This .agt file was created using Materials 4D. The pipe data can be entered 
using the invert elevations.

1. Select File>Open, select “Airway 4D Trench.esw” from the C:/AGTEK/Data directory 
and click Open.

2. Select File>Import and choose “Pipe.agt” from the C:/AGTEK/Data directory and click 
Open. The .agt file opens in the Import mode.
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3. Select one of the lines in the CAD Transfer mode, set the Surface to Design and the 
Layer to Pipe Lines. Click the Send To button.

Applying Templates

1. Be sure no lines are selected and click the Label Select button. The Label Selection 
dialog box is displayed.

2. Select the Line Label option and enter “ss*” and click OK. All sanitary sewer lines are 
highlighted.

3. Click the Apply Template button and the Open dialog box displays. Select “3ftTrench.
typ” from the C:/AGTEK/Data directory and click Open. The Template Editor dialog 
box is displayed. The 3ftTrench.typ is a saved template from a previous job.

The asterick 

is used a wild 

card. In this 

case all lines 

beginning 

with “ss” will 

be hilighted, 

regardless 

of the text 

following the 

“ss”.
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4. Set the Daylight Surface to Subgrade and the Output surface to New Surface. Stage 
Lines is selected by default. Select the Points Every box and enter “10”. Click Apply. 
The template sweeps down the selected lines.

5. When the template application is complete, the Create New Surface dialog box dis-
plays. Enter “Sewer” for the surface name. Click OK and your screen should appear 
similar to the illustration below.

6. Change the Surface to Design and click the Label Select button. The Label Selection 
dialog box is displayed.

7. Select the Line Label option and enter “sd*” and click OK. All storm pipes should be 
highlighted.
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8. Click the Apply Template button and the Open dialog box displays. Select “3ftTrench.
typ” from the C:/AGTEK/Data directory and click Open. The Template Editor dialog 
box is displayed.

9. Set the Output surface to New Surface. Leave the rest of the information unchanged 
and click Apply. The template sweeps down the selected lines.

10. When the template application is complete, the Create New Surface dialog box dis-
plays. Enter “Storm” for the surface name and click OK. Two new surfaces should 
now be visible in the Surface pulldown: Sewer and Storm.
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Calculating Volumes

1. Click the 3D View button. Set the Ref surface to Storm and the Dif surface to 
Subgrade. The 3D view can be inspected using the 3D controls discussed on page2-
23.

2. Click the V button to begin volume calculation. The Volume Calculations Results dia-
log box is displayed. Click Done to view the report. The process can be repeated for 
the Sewer surface as well.
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 Applying Templates to Subgrade

Templates can be used to create subgrade by running multiple offset lines simultaneously. 
In this example we will be using the top of curb lines to build the subgrade of the street.

1. Select File>Open, select “Pine Street Template Subgrade.esw” from the C:/AGTEK/
Data directory and click Open.

2.  Select the annotated outline around the design data. Right-click and select Import File. 
You screen should appear similar to the illustration below.

3. Select the two top of curb lines using Ctrl+Click. To apply templates to multiple lines, 
the lines must be entered in the same direction. In this case, the lines are entered in a 
clockwise direction, as seen by the location of the diamond shaped start points.



A-48

Sitework 4D Appendix 

Enter Template Information

1. Zoom in to the drawing of the street typical on the right side of the PDF.

2. Click the Apply Template button and the Open dialog box displays. Click New.

3. The Template Scaling dialog box displays. Click OK. The typical section is not to 
scale, so the scale point values are arbitrary.

4. Click on the three scaling points on the outside extremes of the typical as illustrated 
below. 

Point 1

Point 2

Point 3

5. Trace the subgrade on the left side of the typical section. The resulting line should ap-
pear similar to the example below.

6.  Right-click to finish and the Template Editor dialog box is displayed.
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7. Click and drag the Reference Point (RP) up one position, between segment 2 and seg-
ment 3.

8. Select the Cut to Fill check box in the Mirror section of the Template Editor.

9. For segment 1, enter “0” for the Width and “0.330” for the Height. The Slope de-
faults to “Vertical”.

10. For segment 2, enter “5” for the Width and “2” for the Slope. The Height defaults to 
“1.100”.

11. For segment 3, enter “0” for the Width and “-0.670” for the Height. The Slope de-
faults to “Vertical”.

12. For segment 4, enter “2” for the Width and “2” for the Slope. The Height defaults to 
“0.040”.

13. For segment 5, enter “0” for the Width and “-0.330” for the Height. The Slope de-
faults to “Vertical”.

14. For segment 6, enter “18.500” for the Width and “2” for the Slope. The Height de-
faults to “0.370”

15. Select the Points Every check box and enter “20”

16. Enter “-.33” in the Vertical Offset box. When complete the Template Editor dialog box 
should appear similar to the illustration below.

17. Click Apply and the you are prompted to save the changes to the Template. Click Yes 
and the Save As dialog box is displayed. 

18. Enter “C&G” for the name and click Save. The Template will now sweep down both 
lines in the direction they were entered.

The reference 

point is 

displayed as 

diamond on 

the template 

cross section 

at the bottom 

of the screen.
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19. When the Template is applied, the street section is completed and can be seen in the 
terrain by press the T key twice.
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 Applying Templates to Over Excavation

Templates can be used to create over excavation surfaces for structures such as base-
ments and holding tanks. In the first example, the over excavation lines for the two tanks 
do not overlap and can entered at the same time.

Over Excavation - Example 1

1. Select File>Open, select “Template OverExcavation 1.esw” from the C:/AGTEK/Data 
directory and click Open.

2. Check to make sure both lines are entered in the same direction. Select one of the 
inner lines of the holding tanks. Select a point in the point list on the right side of the 
screen. Press the down arrow on your keyboard to scroll through the points. Note that 
the flashing box representing the selected point is moving conter-clockwise.

3. Repeat the process for the second holding tank.
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Enter Template Information

1. Zoom into the pair of holding tanks as see below.

2. Select one of the bottom of tank lines (inner data lines). Shift+click the second bot-
tom of tank line to select both lines. 

3. Click the Apply Template button on the toolbar and the Open dialog box displays. 
Click New and the Template Scaling dialog box displays.

4. Since we will be entering the Template free hand the scale is arbitrary. Keep the de-
fault values and click OK.

5. Zoom out and enter three scaling points outside of the data. Enter the points at a 90˚ 
angle, in the shape of a letter “L”, similar to the illustration below.

6. Enter three points to roughly define the five foot horizontal segment and a 1:1 slope 
to daylight. Use the illustration below as a guide. The template does not have to be 
perfect since we will adjust it in the Template Editor.
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7. When complete, right-click to end and the Template Editor dialog box is displayed.

8. Click and drag the reference point (RP) to segment 1, making the reference point the 
first entry on the list.

9. Select the Cut to Fill checkbox in the Mirror section.

10. For segment 1, enter “5.000” for the Width and “0” for the Slope. The height defaults 
to “0”.

11.  Select segment 1 and the select the Right checkbox in the Hinge section. For seg-
ment 2, the width defaults to “Variable” and the Height defaults to “Daylight”. Enter 
“1:1” for the Slope.

12. Select Subgrade for the Daylight surface and New Surface for the Output surface. The 
Stages Lines check box is selected by default.

13. Select the Points Every check box and enter “10”.

14. Click Apply and you are prompted to save the changes made to the Template. Click 
Yes. Enter “5ftOverex” for the name, click Save and the Template is applied.

The reference 

point is 

displayed as 

diamond on 

the template 

cross section 

at the bottom 

of the screen.
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15. When the Template is complete the Create New Surface dialog box is displayed. Enter 
“Tank Overex” for the Surface name and click OK.

16. The resulting surface can be viewed by pressing “T” key turn on the terrain. Press the 
“T” key again to turn off the terrain.

Calculating Volumes

1. Click the 3D View button. Set the Reference Surface to Tank Overex and the Differ-
ence Surface to Existing. The 3D view can be inspected using the 3D controls dis-
cussed on page 2-23.
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2. Click the V button to begin volume calculation. The Volume Calculations Results dia-
log box is displayed. Click Done to view the report. This volumes represents the total 
excavation for the entire site.

3. Click the 3D View button. Set the Reference Surface to Subgrade and the Differ 
ence Surface to Tank Overex. The 3D view can be inspected using the 3D controls 
discussed on page2-23 

4. Click the V button to begin volume calculation. The Volume Calculations Results 
dialog box is displayed. Click Done to view the report. This volumes represents the 
backfill required.

Over Excavation - Example 2

In the case, when the Template is applied to both lines, the areas overlap. The Template 
will need to be applied to one line at a time and then edited to clean up the model. Begin 
with the tank on the left.

1. Select File>Open, select “Template OverExcavation2.esw” from the C:/AGTEK/Data 
directory and click Open.

2. Select the bottom of tank line (inner data line) of the left holding tank.

3. Click the Apply Template button on the toolbar and the Open dialog box is displayed.



A-56

Sitework 4D Appendix 

4. Select “5ftOverex.typ” and click Open. The Template Editor dialog box is displayed.

5. Set the Daylight surface to Subgrade and set the Output surface to New Surface, and 
click Apply. The Template sweeps around the first tank.

6. When complete the Create New Surface dialog box displays. Enter “Tank Overex” and 
click OK.

7. Select the bottom of tank line (inner data line) of the right holding tank.

8. Click the Apply Template button on the toolbar and the Open dialog box displays.

9. Select “5ftOverex.typ” and click Open. The Template Editor dialog box displays.

10. Set the Daylight surface to Tank Overex, set the Output surface to Tank Overex and 
select the Stage Lines checkbox. The Template sweeps around the second tank.
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11. The resulting surface can be viewed by pressing “T” key turn on the terrain. Press the 
“T” key again to turn off the terrain.

12. The resulting over excavation surface may also be view as a profile. Click the Profile 

View button on the toolbar.

13. Click the Profile Entry button, and enter a profile line across both tanks, similar to the 
illustration below. Right-click to end the entry.

14. The profile of the two tanks is displayed at the bottom of the screen. Be sure the All 
button is selected to view all surfaces.

15. Volumes can be calculated as in the previous example.
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 Cleaning up CAD Files

The following lesson demonstrates the use of the Join, Compress Selected, and Join func-
tions to clean up CAD files before they are used for your Sitework 4D takeoff. The sample 
file used in the lesson below assumes that a CAD file has been imported, and the informa-
tion has been transferred to Sitework 4D.

Open Sample Files

1. Select File>Open and browse to C:\AGTEK\data. Select “Earthwork 4D File Cleanup.
esw”, and click Open.

2. Set the Surface to Existing and the Layer to Data Lines, and press the Home key to 
zoom out and center the job.
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Checking File Info

Checking the file info gives you and idea of just how large the file is. If there seems to 
be an excessive number of points or lines, the amount of information in the file may be 
reduced by joining and compressing the file data, and/or deleting unused data.

1. Select Help>File Info and the File Information window is displayed. 

2. Scroll to the bottom of the window. Notice that there are half as many lines as there 
are points, which means that each line only contains two points. This is a good indica-
tion that the lines in the file need to be joined.

3. Click OK to close the File Information window.

Joining Lines.

1. Select any contour. Notice that all contours are in small sections.

2. Select Edit>Select All to select all data lines.

3. Click the Join Lines button and the Edit Bridge Gap dialog box displays. 

Depending of 

the file size, 

the process 

can take a 

long time. You 

may need to 

join the lines 

in sections by 

selecting and 

joining smaller 

areas. 4. If not already set, enter “0.1” for the Horizontal and “0” for the vertical. Click OK and 
the Joining Line Process begins. 
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5. Select Help>File info and you can see the original Polyline and Point counts have 
been greatly reduced. Click OK to close the File Information window.

Compressing File Information

Compressing files removes points based on the Compression Delta. The higher the com-
pression Delta, the more points that are removed. If the Compression Delta is to high, the 
resulting data lines will be too coarse.

1. Select Edit>Select All and all data lines are selected.

2. Select Utility>Compress Selected and the Edit Compression Delete Dialog box dis-
plays.

3. Enter “0.1” for the Delta, click OK, and the lines are compressed.
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4. When complete, select Help>File Info and the File Information window is displayed. 
You can see that the Point Count in the file is reduced even further.

Trimming Lines

In some cases, the existing data may extend beyond the limits of excavation. This ex-
tra data can be removed, with the aid of the Trim Lines function, to further reduce the 
amount data in the file.

1. Click the Layer Selection button and the Layer Selection dialog box displays.
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2. Select the Design checkbox and the Annotation checkbox directly below Design. The 
design data lines, and the design annotation lines are now visible. Click OK.

3. Click the Entry Mode button to switch to Entry Mode.

4. Change the Layer to Annotation.

5. Type “0” on the keyboard to enter a 0 elevation.

6. Draw a line around the design data in the job, similar to the illustration below. Be sure 
to snap the line closed using the F8 key. Right-click to end the entry.
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7. Right-click again to return to an arrow and click the Edit Mode button to switch to Edit 
Mode.

8. Select the annotation line you just entered, click the Trim Line button and the Trim 
Region dialog box displays.

9. Select Remove Lines Outside and click OK. All data outside of the selected trim line is 
removed.
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10. Select Help>File Info and the File Info dialog box is displayed. You can see the 
Polyline and Point counts are even further reduced. 



A-65

Sitework 4D Appendix

 Finding Elevations

Finding elevations is a useful tool to diagnose problems seen in the 3D View, such as 
spikes. The Find Elevation tool allows you to isolate elevations in a specific range. In the 
sample file used below, there a several elevation spikes, which simulate elevation spikes 
which are sometimes seen when you transfer CAD data to Sitework 4D. Training videos 
on this subject can be found by going to AGTEK’s website at www.agtek.com.

Open Sample Files

1. Select File>Open and browse to C:\AGTEK\data. Select “Pine Street Spike.esw”, and 
click Open.

2. Click the 3D View button to switch to 3D View. Set the Ref surface to Design and 
the Dif surface to Stripped. You should be able to see the elevation spikes on the job, 
similar to the illustration below.

Correcting Elevation Spikes

In this example we know that we should have no elevation above 300ft, or below 200ft.

1. Switch to the Edit Mode and set the Surface to Design and the Layer to Data Lines.
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2. Select Display>Edit Layer Only to hide everything but the data lines.

3. Press the Esc key to be sure that no points are selected, and your screen should ap-
pear similar to the illustration below.

4. Select Edit>Find Elevation and the Find Elevation dialog box is displayed.

5. Select the Greater Than button and click OK. The Edit Find Elevation dialog box is 
displayed.

6. Enter “300” for the elevation and select the “Select All Found” check box. 

7. Click OK and all data with and elevation of 300 or above is selected. The lines can be 
deleted, or you can click on the A button on the IDEA bar to change the data to an-
notation.
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8. Select Edit>Find Elevation and the Find Elevation dialog box is displayed.

9. Select the Less Than button and click OK. The Edit Find Elevation dialog box is dis-
played.

10. Enter “200” for the elevation and select the “Select All Found” check box.

11. Click OK and all data with and elevation of 200 or less is selected. The lines can be 
deleted, or you can click on the A button on the IDEA bar to change the data to an-
notation.

12. Switch the 3D View and you can see that the spikes have been corrected.
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 Aligning PDFs

This section discusses skills which are useful when working with PDF files. We will cover 
correcting a PDF scale, aligning PDFs, and working with vector PDFs. All sample files 
used can be found in the C:\AGTEK\Data directory. Training videos on this subject can be 
found by going to AGTEK’s website at www.agtek.com.

Adjusting an incorrect PDF Scale

Depending on how the PDF file was created, it may have scale which does not match the 
scale printed on the drawings. When working with a PDF, it is always advisable to check 
the scale of the plansheet using a known distance.

Opening the Sample File

1. Double-click the Sitework 4D icon on the desktop to launch the program.

2. Select File>New and the Job Information dialog box is displayed. Enter “Pine Street 
1” for the Job Name and click OK. The rest of the information is optional.

3. Select File>Import and select “Pine Street 11x17.pdf” from the C:\AGTEK\Data direc-
tory and click Open.

Checking the Scale

1. Press the “L” twice to rotate the PDF image. Locate and zoom in on the scale bar on 
the lower-right portion of the drawing. According the scale bar, the scale of the draw-
ing should be 1 inch equals 20 feet.
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2 Select Data Transfer>Image Scale and the Edit Image Scale dialog box displays.

3. Enter “20” for the scale and click OK.

4 You are prompted to check a known distance on the plansheet. Click Yes to check the 
scale.

5. Zoom in to the scale bar.

6. Enter two points at each end of the scale bar.  The Measured Distance will display.

7. Enter the correct distance in the Actual field and click OK. The scale is now correct.
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Aligning Multiple PDFs

Most jobs will be drawn on multiple sheets. In this case, it is necessary to align multiple 
PDF sheets to complete your job. 

Example 1 - Open Sample Files

Benchmarks have been added to illustrate the points we will use to align the second PDF 
sheet. Benchmarks are not required.

1. Select File>Open and select “Sample PDF 1.esw” from the C:\ AGTEK\Data directory.

2. Set the Surface to Design and the Layer to Data Lines.

3. Select the annotation line surrounding the job. Right-click, select Import File and the 
PDF is displayed behind the data.
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Align PDF to Entered Data

1. Press the Esc key to make sure no lines are selected. Select File>Import and select 
“Sample PDF 2.pdf” and click Open. The file opens in the Data Transfer mode.

2. Press the “R” key on your keyboard twice to rotate the image.

3. Select Data Transfer>Image Scale and the Edit Image Scale dialog box displays.

4. Enter “30” for the Image Scale and click OK. You will be prompted to check the scale 
using a known distance. Click OK.

5. Switch to the Edit Mode.

6. The image will be inserted but it will not be in the correct location. We will need to 
move the new image to match the data from the first sheet. Right-click on the job and 
select Align Image.
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7. Select the first point (Point 1) on the PDF sheet to be moved.

8. Select the benchmark that corresponds with the point selected in step 7 (Point 2). The 
image will be moved to the second point.

9. The points from sheet one should line up with the points from the entered data. Since 
both sheets are in the same rotation, the second alignment point is not needed. Right-
click and select Cancel. The data on the second sheet can now be entered.
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Example 2 - Opening Sample Files

The following example assumes the second PDF sheet has already been imported and 
scaled. This job also has benchmarks entered to aid in alignment. The benchmarks are not 
necessary.

1. Select File>Open and select “Sample PDF 3.esw” from the C:\ AGTEK\Data directory.

2. Set the Surface to Design and the Layer to Data Lines.

3. Select the annotation line surrounding the job. Right-click and select Import File.

Align PDF to Entered Data

1. Right click and select Import File. Select the Sample PDF 4.pdf and click Import. The 
image will be inserted, however it will not be in the correct location.
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5. Select the spot elevation (3998.0) to the upper-right of the matchline (Point 3). 

6. Select the spot elevation entered from the previous sheet (Point 4). 

2. Right-click on the job and select Align Image.

3. Select the intersection of the match line with the center line on the new sheet (Point 
1).

4. Select the end of the data line from the previous sheet (Point 2). 
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7. The Aligning Site dialog box displays providing information about the alignment. Click 
OK. The sheet should now be aligned and ready to continue entering information. 
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Aligning PDFs With CAD Files

On some jobs you may find it beneficial to align CAD data with a PDF image, such as 
when there is required information on the PDF which is not included in the CAD file. This 
example assumes that the existing and design data lines have already been transferred 
from the CAD file.

Opening Sample Files

1. Double-click the Sitework 4D icon on the desktop to launch the program.

2. Select File>Import and select “4D Lesson6.esw” from the C:\AGTEK\Data directory 
and click Open.
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Aligning PDF image

1. Select File>Import. Select “Paving Plan.pdf” from the C:\AGTEK\Data directory and 
click Open. The file will open in the Data Transfer Mode.

2. Press the “L” key twice to rotate the image.

3. Select Data Transfer>Image Scale and the edit Image Scale dialog box is displayed.

4. Enter “30” for the Scale and click OK. 

5. Switch to the Edit Mode.
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6. Right-click on the job and select Align Image.

7. Select the corner of the curb line in the upper-left portion of the job site on the PDF 
image (Point 1).

8. Select the corresponding corner in the upper-left portion of the design data (Point 2). 
The PDF image will change position, but will not be aligned properly.
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9. Select the corner in the lower-right portion of the job site on the PDF image (Point 3) 
and the Alignment Point dialog box displays. Click OK.

Point 3

Point 4

10. Select the corner in the lower-right portion of the design data (Point 4) and the Align-
ment Point dialog box displays. Click OK and the Aligning Site dialog box will display. 
Click OK. The PDF image will should be aligned with the design data.

11. The PDF image can now be used to enter information not found in the CAD file, such 
as Sectional Areas.
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 Vector PDFs

There are two types of PDF files: raster and vector. Raster files are images or scans of 
drawings. Vector files contain the information necessary for Sitework 4D to create lines 
and arcs in different layers. You can then transfer that information from the Data Transfer 
Mode and edit as though you were working with a CAD file.

Opening Sample Files

1. Double-click the Sitework 4D shortcut on your desktop and the Open dialog box is 
displayed.

2. Select “Montessori School Site.pdf” from the C:\AGTEK\Data directory and click 
Open. The PDF will be displayed in the Data Transfer Mode.

Scaling the Drawing

1. Press the “L” key twice to rotate the PDF.

2. To find the scale of the drawing, zoom into scalebar at the lower-right side of the 
drawing. You can see the scale is 1:20.

3. Select Data Transfer>Image Scale and the Edit Image Scale dialog box is displayed.  
Enter 20 for the scale and click OK.

In the Data 

Transfer 

Mode: if 

the PDF is 

outlined in red 

it can not be 

vectorized, if 

it is outlined 

in green it can 

be vectorized.
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4. You are prompted to check the resulting scale of the drawing, click Yes to check the 
scale.

5. Enter two points at each end of the scale bar. The Measured distance will display. 

Verify the distance is correct and click OK.

Vectorize and Transfer Data

1. Select Data Transfer>Vectorize and lines are overlaid on the image.

2. To turn off the image, select Display>Bitmap (or press the “T” key on the keyboard).

3. Zoom into the drawing and select an existing contour line. The entire layer will be 
selected.
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4. Right-click and select Send to Existing.

5. Select a design contour, the right-click and select Send to Design.

6. Continue sending data until all useful data has been transferred.

7. Switch to the Edit Mode and you can see the data that you have transferred.

8. Press the “T” key on the keyboard to turn the PDF image on.
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Assigning Elevations

1. Change the surface to Existing.  Select an Annotation with a text elevation shown on 
the plan.  Enter the elevation from the keyboard and the Line Editor will display.  Click 
OK. 

2. Enter an elevation from the keyboard for the next contour in sequence and click OK.

3. Press the Escape key to clear the point review list.  Position the cursor over the first 
contour entered (Do not pick the line) and press the F8 key on the keyboard. Move 
the cursor over the next contour in sequence and press the F8 key again.  This will 
start the Sequence Snap.  Move the cursor to the next contour and press the F8 key. 
Continue this process until you reach the top or bottom of the slope.
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4. To assign elevations to an Annotation that has an data line with the correct elevation 
assigned, you may select the Annotation line and position the arrow over the elevated 
data line and press the F9 key to assign the elevation to the Annotation. Continue as-
signing elevations using the desired method.
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