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AGTEK Software License Agreement
PLEASE READ CAREFULLY. BY USING THIS PRODUCT, YOU ARE CONSENTING TO BE
BOUND BY THIS AGREEMENT.
Copyright

The AGTEK software package, on CD or in electronic form, together with associated
documentation, is protected under copyright. The buyer may make copies for the buyer’s
internal use only. The buyer agrees not to reverse engineer or otherwise seek to discover
the source code, or to modify or create derivative works from this software.

Single License

AGTEK grants to the buyer a non-exclusive, single license to load and use the AGTEK
software on one or more computers operated by the buyer, provided that use by the
buyer shall not be on more than one computer at a time. The buyer agree not to rent,
loan or otherwise temporarily transfer this software for use on computers not operated by
the buyer.

Access Key

Access key. The AGTEK software is enabled by means of an access key that must be
present on the computer when the software is running. The access key may be a key
code checked-out from the Internet or a physical device that plugs into a computer port.

Export

AGTEK software includes cryptography that is not user-accessible, specifically designed
to allow execution of copy-protected software. Accordingly, this software is controlled
under ECCN EAR99 of the Export Administration Regulations (NLR, no export license
required). The buyer agrees to comply with all applicable regulations and prohibitions with
regard to export or re-export to sanctioned countries or individuals.

Limitations of
Warranty and
Liability

Limitations of warranty and liability. AGTEK software is licensed “as is” and with all
faults. AGTEK Development Company, Inc. and its Representatives make no warranties,
either expressed or implied, with respect to AGTEK software, its quality, performance,
merchantability, or fitness for any particular use. In no event will AGTEK Development
Company, Inc. or its Representatives be liable for direct, indirect, incidental or consequential damages resulting from any defect in AGTEK software, even if AGTEK Development
Company, Inc. has been advised of the possibilities of such damages.
Copyright© 2011 AGTEK Development Company, Inc.

Trademark
Credits

Windows XP® , Windows Vista® and Windows® 7 are registered trademarks of
Microsoft Corp. Google Earth™ is a trademark of Google. AutoCAD®, CAiCE™, DWG™,
DXF™ are trademarks of Autodesk, Inc. GEOPAK, MicroStation, GPK and DGN are trademarks of Bentley Systems, Inc, Leica™
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SmartDirt Installation

Welcome to SmartDirt
Instructions for Installing the AGTEK SmartDirt app on your Android phone or tablet.
1. To install SmartDirt on your Android phone
or tablet, visit our website at www.agtek.com.
On the Home Page, tap the Menu bar and tap
Support.

2. Tap Downloads.
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3. Scroll down to SmartDirt. Tap SmartDirt
and enter your technical support login and
password, You may need to get this information from your support contact.

1-2

4. Tap Download to start the download
process.

SmartDirt Installation

5. When the download is complete, tap Open
at the bottom of the screen. Depending on
your browser settings, you may need to swipe
down from the top to view the download.

6. Tap Install to begin the installation.
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7. When the installation is complete, tap
Done to exit or Open to start SmartDirt.

9. To Restart SmartDirt, tap the SmartDirt
icon on your home screen.

9. To launch SmartDirt for future sessions,
tap the SmartDirt icon in your Apps folder.
You may move the icon to your main screen.
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8. Enter you Login and Password. Check
Remember Password and tap Login.
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SmartDirt Geo-Referencing Files

Earthwork 4D Geo-Referencing Files
Before you can use your earthwork takeoff in the field with SmartDirt, you must first
enter two benchmarks with approximate latitude and longitude information. There are
a couple ways to enter the benchmarks. If the takeoff was done from a PDF file, the
benchmarks would need to be entered using Google Earth to establish the latitude and
longitude. If the takeoff was done from a CAD file that is in state plane coordinates, you
may use the Map Projection Settings utility.

Enter Benchmarks using Google Earth
If the takeoff was completed using PDF plan sheets, we may use Google Earth to establish the benchmarks with approximated latitude and longitude.
1. Locate your job site on Google Earth.

2. Identify some existing features that can be found on the plan sheets. Existing curb
corners, catch basins, or street intersections are good examples.
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3. Open the job file in Earthwork 4D.
4. Import the plan sheet containing the existing features located on Google Earth.

5. Locate the two common features found on Google Earth.

6. Minimize Earthwork 4D and return to Google Earth.
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7. In Google Earth, select the Show Ruler icon, or select the Tools menu and select
Ruler.
8. Draw a line connecting the two points. Click the Save button.

9. Keep the name Line Measure and click OK.
10. Right click on Line Measure under Temporary Places and select Save Place As.

11. Save the file to the same file folder containing the Earthwork 4D job file.
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12. In Earthwork 4D, right click and select Import File.
13. Select the Line Measure.KMZ file and click Import.

14. The Benchmarks will be inserted, however they will not be in the correct location.
15. Change the layer to Benchmarks.
16. Select one of the benchmarks. Position the tip of the arrow on the corresponding
location on the plan sheet and press the F7 key to move the benchmark to the new
location.

13. Repeat this process for the second benchmark.
14. The ADF file may now be exported.
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Enter Benchmarks using Map Projection Settings
If the takeoff was completed using CAD file that is in state plane coordinates, we may
use the Map Projection Settings utility to establish the benchmarks with accurate latitude
and longitude.
1. Before adding the benchmarks using Map Projection Settings, check the north and
east coordinates to see if they are in state plane or a local coordinate system determined by the engineer. Typically if the coordinates are large values (millions and
hundred thousands) they are state plane coordinates.

2. Select the Utility menu and select Transform Job > Map Projection Settings.
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3. Select the desired State Plane Coordinate Zone. Check the proper Unit and click Set.

4. Two Benchmarks will be added at the extents of the job with the correct latitude and
longitude. Again, the file must be in state plane coordinates for this utility to work
properly.

5. The ADF file may now be exported.
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Save KMZ File
Before we save the ADF file for use with SmartDirt, we recommend exporting a KMZ file
that may be viewed on Google Earth to verify the alignment of the project data is accurate. To export the KMZ file, select the Plan View mode icon on the toolbar.
1. Select File>Export KMZ File. The Save As dialog box displays.

2. Enter a name for the KMZ file and click Save.
3. The KMZ File Export dialog will display.

4. Select the desired layers to be saved to the KMZ file. Since we are only viewing this
on Google Earth to verify the alignment, it is recommended to output the plan sheets
and existing data lines. Check Existing under Layers and check All under Image Export. Click Export.
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5. The KMZ file will open in Google Earth. It is recommended you view the KMZ file on
Google Earth to verify the accuracy of the alignment to the job site.

6. The Cut/Fill Map will display by default. To view the plan sheets, check Plan Sheets
on the left under Temporary Places.

7. To verify the alignment is correct, you may change the transparency of the images.
Select Plan Sheets under Temporary Places. Click the blue Zoom button and slide
the bar to the left to see through the images. If the alignment is correct, we are
ready to export the ADF file.
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Save ADF File
After the alignment has been verified, we may now export the ADF file for use with
SmartDirt.
1. In Sitework 4D, select the File>Save As. The Save As dialog box displays.

2. Click the Save as Type pulldown and select AGTEK Mobile Files (*.adf).
3. Enter a name for the ADF file and click Save.
4. The ADF Save Options dialog will display.

5. Select the desired Reference and Difference surfaces. Check Ref and Diff Surfaces
Only to limit the size of the file.
6. Select the desired project folder. If no project folder exists, create a new project.
7. Check the boxes to Include Images and Upload to Access. Click OK.
8. The file will be uploaded to the project folder for use with SmartDirt.

2-9

REFERENCE

Section 3

Basics

2-1

REFERENCE

2-2

SmartDirt Basics

SmartDirt - Basics
SmartDirt geo-references your plan sheets, cut/fill maps, and takeoff quantities using the
GPS positioning capability built into your IPhone or IPad. Geo-reference the file using the
procedure described in the previous section.
1. Before launching SmartDirt, make sure the GPS feature is enabled on your phone.
This procedure will vary with different phone versions.
2. To launch SmartDirt, locate the SmartDirt icon in your Apps. You may move the icon
to your Home screen if desired.

3. Enter your Login and Password information. Check the box to Remember password
and select Login.
4. Select any available SmartDirt Key.
5. If the file has not been saved locally to the phone, select AGTEK Access.
6. Locate the project folder and select the desired ADF file. The file will open and you
will automatically be geo-referenced to the job site. The cut/fill color map will display.
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3D View

Measure
Menu
Toggle
Distance/
Slope

Record
Tracks

Add Photos
Add Notes

Tap to
disengage
GPS to
pan data
onscreen

Reference
and
Difference
surfaces

Depth of Cut/Fill
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SmartDirt - Layer Controls
When using an ADF file, all data saved in the file is stored in separate layers. You may
turn layers on and off by using the layer controls.
1. To change the displayed data, tap the menu and select View.

Layers

Visibility

2. All data saved in the file will be listed at the bottom of the screen. Visibility is controlled by a check box. Check or uncheck the box to toggle the display of the layer.
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3. To display the plan sheets, tap the Menu and select Show Plan Sheets Plan Sheets.

Toggle
between
Plan Sheets
and Cut/Fill
Map

4. You will now be walking on the plan sheets. If plan sheets overlap, tap and hold on
the sheet and select the desired sheet.
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SmartDirt - Measure Mode
Measurements may be made using either the plan sheets or the job data.
1. To enter Measure mode, tap the Tape Measure button.
2. Tap the screen to enter the points. The cut/fill volumes, length and area will be displayed at the bottom of the screen. The length is the accumulated length up to the
last entered point. The area is the shaded area. To get the total length of the perimeter, you must enter a point back on the starting point. If you make a mistake, tap
the Backspace button.

Snap

Length
and
Area
of the
selected
measure
area

New Measure

Cut/Fill
Volume of
the selected
measure area

Backspace

Tap to toggle
through
multiple
measure areas
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SmartDirt - 3D View
Tap the 3D button to view the 3 dimensional view of the reference surface.
1. Use the pinch to zoom to zoom in and out on the view. Rotation is controlled by the
compass in the phone or tablet.

2. Tap the 3D button again to exit the 3D view.
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3. To upload all photos, notes, tracks and measure areas tap the menu and select Save.

4. Enter a name or keep the default time stamped filename and tap Save.

5. All user added data will be uploaded to AGTEK Access to be downloaded in the office.
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SmartDirt - Download Photos, Tracks, Notes and Measures
If photos, tracks, notes or measure areas were uploaded during the job site session, they
may be downloaded to the office computer using AGTEK Access. AGTEK Access is a
web based application.
1. From your web browser, visit Apps.agtek.com. Enter your login and password. It is
recommended you bookmark this site for future sessions.
2. Open the Projects folder and locate the desired project.
3. Open the desired project folder.
4. Open the User Tracks folder to locate the KMZ file containing the tracks and photos.
The individual photos will also be stored in the Photos folder.

5. Select the desired file and click Download.
6. Select the destination folder and click Save. Depending on your browser the file may
automatically download to your Downloads folder.
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7. The KMZ file may be opened in Google Earth to view the recorded photos,tracks,
notes and measures.
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