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Sitework 4D CAD Tutorial

3D Modeling Overview
Sitework 4D can be used to convert CAD files into takeoffs and accurate 3D models.
This tutorial covers the steps to perform the conversion and creating the model.

CAD Entry Guide
In the Guide menu, Sitework 4D contains guides for PDF, CAD, Tablet and Haul Plan
entry. These guides aid the entry of a complete job. This tutorial focuses on CAD entry.
The CAD Entry Guide can be accessed by selecting Guide>CAD or by pressing the G
key. When a procedure is selected from the Guide, Sitework 4D will change to the proper mode, surface, and layer necessary for that procedure. The Guide displays a check
mark in the corresponding box when an operation has been completed.
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Data Entry Sequence
Sitework 4D is used for data entry and editing to create 3D models from CAD data. Below is the suggested data entry sequence for the 3D modeling.

CAD Data Transfer
•
•

Start a New Job
Transfer CAD Data

Existing Ground Data
•
•
•

Enter Existing Perimeter
Edit Existing Ground
Enter Stripping Areas

Design Ground
•
•
•

Edit Design Data Lines
Enter Design Perimeter
Enter Sectional Areas

Calculate Volumes
•
•
•
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Visual Verification with the 3D Window
Calculate Volumes
Print Reports
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Lesson 1 - CAD Data Transfer
Sitework 4D is a tool for creating takeoffs from PDF files, digitized plan sheets, and CAD
files. Both DWG and DXF files are read and can be quickly transformed into a precise 3D
model suitable for use in the field.When a DXF or DWG file is selected, the data from
that file is opened in CAD Transfer Mode displaying all layers in the file including frozen,
or locked, layers. Training videos discussing CAD modeling are available at http://www.
agtek.com/trainingvideos.asp. It recomended that you watch the training videos first.

Start a New Job (Job Setup)
This Open
dialog box
defaults to
display three
file types:
ESW, DXF,
and DWG.
ESW is
the native
file type of
Sitework 4D.

1. Double-click on the Sitework 4D shortcut, or select Start>Programs>AGTEK>
Sitework 4D. The Open Dialog box is displays.

2. Select the “4D Lesson1.dwg” file, and click Open.

3. Select Data Transfer>Crop Rectangle to remove unnecessary data.
4. Click and draw a box around the relevant data, then click again to end.
5. Click Yes when asked to remove everything outside the rectangle.
6. Select Data Transfer>Import Transfer Units, and make sure Feet is selected as the
units of measure, then click OK.
Import Transfer Units: The Import Transfer Units designate what unit of measurement
the job is created in. It must be set to the same units as the CAD file being transfered:
feet, metric, or architectural. User defined is used when the CAD file is created using a
unique unit of measurement.

Transfer Existing Ground Data
When a line is selected in CAD Transfer Mode, all lines in the same CAD layer are highlighted. The tool bar shows the name of selected layer along with the controls used to
send that layer to a Sitework 4D surface. Transfer mode can also be found by pressing
the G key, and choosing Transfer Data.
Current Sitework 4D
target surface

Sitework 4D target layer

Send To button transfers
selected CAD layer to target
surface

Selected CAD Layer list
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1. Change to the Existing Surface and Data Line Layer, then click the “CONT-MNR”
layer, or use the toolbar to select it in the CAD pulldown, then click the Send To button to transfer the layer to the Existing surface.

2. Select the “CONT-MJR” layer with the mouse or by using the layer pulldown menu
and send it to the Existing Surface and Data Lines Layer.
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3. Change to the Design Surface and Data Line Layer, then select the “P-BLD” (building
pad) layer and click the Send To button.

Other CAD Transfer Methods
In addition to the previous example, there are other methods of transferring CAD data.
Right-Click
Right-clicking a layer displays the Right-Mouse menu, which allows you to select the
target surface.
•

Select the “DSN-CNTR” layer, right-click, then select Send to Design to transfer the
layer.

Transferring Multiple Layers
CAD Transfer also supports the transfer of multiple layers simultaneously.
1. Click on the top of curb “Des-TC” near the upper-left corner of the site.
2. Ctrl+click on the storm drain detail “1-SD”.
3. Ctrl+click on the grade text “TXT”.
4. Ctrl+click on the retaining wall “1-WALL”.
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5. Right-click, then select Send to Design to move the layers to the Design surface.

Complete CAD Data Transfer
A few layers are left to transfer at this point. Use any of the transfer techniques to send
the layers listed below to the Design surface.

Selecting
File>Save will
give you the
opportunity
to save a
copy of
your current
file using
a different
name,
leaving the
original file
unchanged.

•

“Walk”

•

“TEXT-GRADES”

•

“1-DES-CURB”

When finished, click the Edit Mode button on the toolbar to leave CAD Transfer Mode.
6. Select File>Save, or click the Save button.

Other CAD Transfer Features
The CAD Transfer window has additional features that are not needed in this tutorial but
are useful for future files.
Hide, Show All, and Delete
In some CAD files the amount of data displayed makes it difficult to identify the desired
layers. The Hide command removes the selected data from the screen. It can be activated from the right-click menu, the Edit menu, or by pressing Alt+H.
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The reverse of Hide is the Show All command. Show All is selected from the right-click
menu or the View menu.
The Delete command removes the selected data from the screen permanently. Delete
is activated by pressing the Delete key or through the Edit menu. It does not affect the
original CAD file.
Undo and Redo
Sitework 4D supports up to eight levels of undo for those occasional mistakes that
you wish you could start over. The Undo command is activated by pressing CTRL-Z or
through the Edit menu. The Redo command is usually used when Undo was used one
too many times. It also supports eight levels and is activated by pressing CTRL-Y or
through the Edit menu.

Lesson 2 - Existing Ground
The Existing Ground represents the current conditions of the job site. In addition to the
existing conditions, we add the Existing Perimeter and Stripping Areas so the existing
surface can be used in volume calculations.

Enter the Existing Perimeter
The Existing Perimeter defines the job limits of your existing ground and is used to speed
3D rendering by ignoring information outside of the boundary. Use the following steps to
enter the Existing Perimeter.
1. Select File>Open and open “4D Lesson2.esw”.
2. Switch to Entry mode, then select Existing from the Surface pulldown and Perimeter
from the Layer pulldown, or press the G key, and choose Enter Existing Perimeter
from the CAD Entry Guide.
3. Using the mouse, draw a perimeter around your site boundary. Right-click to close
and end the site boundary entry. Right-click again to get your arrow back.
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Edit Existing Data Lines
The 3D surface is created by converting the two-dimensional CAD data into a threedimensional surface. Much of this work consists of cleaning up the data that has been
transferred, including assigning elevations to points and contours, and joining lines.
In this example all existing lines transfer with elevations already assigned to them. All
techniques used to edit design data lines found in Lesson 3 of this tutorial can be used
to edit existing data lines as well. To see what information is assigned to an individual
existing data line:
1. Switch to the Edit mode by clicking the Edit Mode button and select Data Lines in
the Layer drop down, or press the G key, and select Edit Existing Data Lines from the
CAD Entry Guide.
2. Click on an existing data line to select it.
3. Right-click and choose Line Editor from the right-click menu. The Line Editor box is
displays.

4. Click Cancel to close the Line Editor box.

Enter Stripping Areas
The depth specified for Stripping Areas is deducted from the Existing surface to create
a Stripped surface. Stripping Areas are not additive, you may exclude areas from being
stripped by entering a stripping area with a depth of “0”.
In this sample we also display the design data lines and design annotation behind the
existing data lines. This aids in the Stripping Area entry.
1. Switch to Entry mode, and select Existing from the Surface pulldown and Stripping
Areas from the Layer pulldown, or press the G key and select Enter Stripping Area
from the CAD Entry Guide.
2. If the Stripping Areas box is not displayed, click the Add Regions button.
3. Enter “Stripping 1” for the Area Name, “0.5” for the Stripping Depth, and click OK.
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4. Right-click on the existing ground and select Display>Design Layer.
5. Right-click on the existing ground and select Display>Design Annotation.
6. Using your mouse, enter the Stripping Area around the area you plan to strip.
7. Right-click to close the Stripping area and end the entry. Be sure to keep the Stripping Area within the Existing Perimeter.
8. Right-click twice on the existing ground and select Display>Design Layer to turn the
layer off.
9. Right-click on the existing ground and select Display>Design Annotation to turn the
layer off.

10. Select File>Save, or click the Save button.
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Lesson 3 - Design Data
The Design Ground contains the design information for your job. In this lesson we will
clean up the data transferred from a CAD file by joining lines, and assigning elevations,
as well as creating offset lines, entering the Design Perimeter, grade breaks, Sectional
Areas and control points.

Edit Design Lines
While editing Design lines we will clean up the transferred data by assigning elevations
and joining lines. We will further refine the data by adding Sectional Areas, benchmarks,
grade breaks, and a Design Perimeter.

The Edit Window
The initial view of the design data after transfer looks similar to the illustration below.
Some lines transferred from the CAD file may have an elevation assigned to them already, while others may not. Lines with elevations are displayed in light blue. Lines without elevation are sent to the Annotation layer and are displayed in Brown.
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Elevation List
The Elevation List shows information on the selected line (see the illustration below).
Points listed in the elevation window are color-coded by type. Sitework 4D has five point
types: Interpolated, Daylight, Entered, Snapped and Annotation.
•

Interpolated points (light blue) derive their elevation from the slope between the
Entered elevations that surround them. If the elevation of the points that are used for
interpolation change, the interpolated point elevation is recalculated as well.

•

Daylight points (green) are assigned elevation from the Existing surface.

•

Entered points (white) are points where the user has assigned an elevation to by
editing or entry. These points do not change elevation unless the user specifically
changes them.

•

Snapped points (red) are created when a point on a data line is snapped (F6 or F8)
to another existing data line. These become Entered points after the job is saved and
reopened.

•

Annotation points (brown) are not used by the program to create the 3D surface.
The presence of an Annotation point on a line changes all points on the line to Annotation. Lines transferred through the CAD transfer with an elevation of zero are
automatically assigned as Annotation.

Point type buttons
(Interpolated, Daylight, Entered, Annotation)
List of elevations for points
on the selected line

The selected point

Point Label of the
selected point
Line label

Northing and Easting of
the selected point
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Assign Elevations
Annotation lines are lines with no elevation. Assigning elevations to annotation lines essentially converts them to data lines. Elevations can be assigned to these lines by using
the Snap techniques described in this tutorial. We’ll go over several different snap techniques in the exercises that follow.
Before you begin, switch to the Design Surface in Edit mode. Notice how the contour
lines on the upper right side on the screen are blue, while the ones on the left are brown.
The blue contours have elevations assigned. We need to assign the remaining elevations
to the brown (annotation) contours.
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Join Lines/Assign Spot Elevations using Elevation Snap
CAD file lines are often “broken” and should be joined to ease elevation assignment.
Before you can join lines, you should make sure to set your Bridge Gap Distance to the
appropriate amount.
The Bridge Gap Distance indicates how far apart lines can be and still be joined. The
space between the endpoints must be less than the Bridge Gap Distance for the lines to
be joined.

Joining Lines
1. Select File>Open and open “4D Lesson3.esw”. Make the Surface is set to Design
and the Layer is set to Data Lines, or select Guide>CAD and select Edit Design Data
Lines from the CAD Entry Guide
2. Select one of the pad lines at the base of the slope.
3. Click the Label Select button. All the pad lines are selected.

4. Select Options>Bridge Gap Distance, and enter the desired distance in the Edit
Bridge Gap Distance dialog box. The distance is measured in feet. For this example,
use the default distance of “0.1”.
5. Click Join button to join the lines. After the line is joined, it is selected.
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Assign Elevations using Elevation Snap
Once the lines for the pad are joined, you can use Elevation Snap to assign an elevation
to the line from a label.
1. Select the pad again and verify that it is now a single line.
2. Move the cursor over the text in the center (FF=103.5) and press F9 to assign that
elevation to the pad.

3. Continue using this technique to assign elevations to the remaining pads.
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All of the snap
techniques
shown can
be used
for existing
ground data
as well as
design data.

Elevation Snap (F9) grabs the elevation data from a label, or data line, and assigns it to a
selected line.
4. Select File>Open and open “4D Lesson3.esw”.
5. Zoom in to the contours at the top of the screen, and click on the first brown (annotation) contour on the left. Notice the elevation is 0.000 in the Elevation list.

3. Place the cursor over the light blue line to the right, and press the F9 key. The elevation assigned to the line is displayed in the Elevation list.

4. Repeat this process for the next contour to practice the technique. Use the Elevation
list to verify that an elevation has been assigned.
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Assigning Elevation Using Increment Snap
Increment Snap creates an elevation increment and direction, then applies it to lines.
1. Press the Esc key to deselect any selected lines.
2. Place the cursor over the light blue contour with an elevation of 131, and press F8.
3. Move to the next contour below (130), and press F8 again. The triple-beep indicates
that the program is now in Increment Snap Mode.

4. Move to the next brown contour below, and press F8 again. It automatically assigns
the next incremental elevation, 127, to the line.

5. Repeat this process for three more contours to practice the technique.
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Assigning Varied Elevations to a Line
Up to this point we have snapped a single elevation to entire lines. However, you can
also snap multiple elevations to a line.
1. Click on the top of curb line on the top, right side of the job. Notice that the first
point on the line is marked with a diamond.
2. Click on the diamond or select the first point in the Elevation list to Select the first
point.

3. Move the cursor to the 103.8TC label, and press F9 to assign that elevation to the
curb.
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4. Move the cursor to the intersection of the 103.4 leader line, and press F6 to add a
point on the curb line. The new point is automatically selected.

5. Move the cursor over the 103.4TC label, and press F9 to assign that elevation to the
point.
6. Select the next point (corner point) on the line, and use F9 to snap to the 103.4TC
elevation label.
7. Continue down the line using F6 key to add a point, and the contour label (103) for
the elevation where the 103 contour meets the curb. Then use the F9 key to assign
the 103 elevation to the new point.
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8. Bypass the first points on the corner until you reach the center of the arc and assign
that point using the 102.7TC elevation label. Notice that the bypassed points on the
corner are automatically interpolated between the entered elevations.

9. Continue down the line assigning grades as needed. You can use F9 to snap elevations from some of the contours, and use the point editor to enter grades where the
annotation contours intersect the curb (the 102 through 98).

Assigning Elevations Using the Line Editor
The Line Editor can also be used to assign elevations to annotation lines or change existing elevations. To use the Line Editor:
1. Click on a data line, then right-click to display the Right-Mouse menu and select Line
Editor. The Line Editor dialog box is displayed.
2. Type in an elevation or label and click OK. The changes are displayed in the Elevation
list.

For extra practice, you can continue to the assign elevations to the remaining annotation
lines using the techniques previously discussed.
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Offset Line Editor
Offset Lines are a powerful method of creating lines based upon numeric distances and
elevations from a specified reference line (such as creating the bottom of curb from the
top of curb line). This tutorial uses the “4D Lesson 4.esw” file, with all of the CAD data
converted. For more information regarding offset lines, see page 8-92.

Creating Offset Lines
The job now has all of the top of curb, pad, and contour elevations assigned. To refine it
further we need to create the bottom of curb lines.
In this example, to reach light duty pavement subgrade the new line needs to be offset
down 1.25 feet (.5 for curb height, .75 paving materials). We’ll use an offset distance of
.1 because you should never create two lines exactly on top of each other with differing
elevations.
1. Select File>Open and open the “4D Lesson4.esw” file.
2. Switch to Edit Mode, then select Design from the Surface pulldown and Data Lines
from the Layer pulldown, or select Guide>CAD, and select Edit Design Data Lines
from the CAD Entry Guide.

3-20

Sitework 4D CAD Tutorial

3. Press the T key to turn on the Terrain View.
4. Click on the top of curb line to which elevations were first assigned in the previous
lesson (below the 103.5 pad), then select Utility>Offset Line. The Offset Line Editor
is displayed.

5. Enter “CURB SUB” in the Label box. AGTEK recommends that you label lines whenever possible. Labels are helpful for making changes to the model later if needed;
such as raising the elevation of all lines with a common label.
6. Type “.1” in the Start of Line Offset Distance box, and “-1.25” in the Elevation Difference box. The Slope calculates automatically. Make sure the Offset button shows
“Left” (click the button to change it if necessary).
Click Apply and notice that the bottom of curb line is showing and the curb face has
been created using the two lines. Click Close.
At this point you can select and offset the remaining top of curb lines on the job. The
Offset Line Editor remembers the last settings used so the only changes you should need
to make is changing the direction of the offset using the Offset button.
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Add Grade Breaks
Grade breaks are another method to refine the model for accurate takeoffs and volume
calculations. This section uses the “4D Lesson5.esw” file, which has all of the bottom of
curb (BC) lines offset.
The parking areas include grade breaks and rim elevations for drainage. To refine it
further we’ll enter the grade breaks including the drains for the parking lot on the right
(between the 103 pads).
1. Select File>Open and open the “4D Lesson5.esw” file.
2. Switch to Entry Mode, select Design from the Surface pulldown and Data Lines from
the Layer pulldown, then zoom in to the parking lot on the right side of the job.
3. Move the cursor to the bottom left curb at grade break and press F8. The first point
is entered at the curb and a tether line connects it to the cursor.
4. Move the cursor near the drain point in the center of the lot (101.4RIM), type
“100.65”, and press F8. If the drain was at subgrade we could use F9 to grab the
elevation from the label, but we need to subtract an additional .75 from this grade.

5. Continue diagonally to opposite corner, and press F8 to snap to the bottom of curb.
6. Right-click to end the line, and move the crosshair across to the opposite corner.
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7. Press F8 to snap the top left corner, snap again to the point you previously entered
near the drain rim, and finish the line in the opposite corner.

8. Enter the remaining grade breaks on the job.
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Enter Sectional Areas
Sectional Areas are closed areas that modify the Design Surface by their specified depth.
When we used the Offset Editor to create the bottom of the curb, we subtracted both
the curb height and the light duty pavement section. This means that the only area needing a section is the heavy duty paving and the pads. The first sectional we’ll enter is the
heavy duty paving area. This section starts with all data lines entered and uses “4D Lesson6.esw”.
1. Select File>Open and open the “4D Lesson6.esw” file.
2. Switch to Entry Mode, select Design from the Surface pulldown and Sectional Areas
from the Layer pulldown, or Press the G key and select Report/Sectional Areas.
Then, zoom to the driveway in the lower-left of the design.

Once a
Sectional
Area has been
entered, it
can also be
used as a
report region
by selecting
the area in
Edit Mode,
selecting
Edit>Report
Region, and
naming the
region.

On a metric
job the same
“.42” would
represent
.42m , or
420mm.
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3. If the Report Regions box is not displayed, click the Report Regions button. Enter
“HD Paving” as the Region Name, “.42” (42/100 of a foot) as the Sectional Depth
(this is the difference between the heavy duty and light duty section). Clear the Report Region checkbox and click Enter.
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4. Move the cross hair down to the lower-left edge of the driveway, and press F8 to
snap to the bottom of the curb line.
5. Move the crosshair to the next point up the driveway and press F8 twice (Line
Snap). The entire line is selected and changes the cursor to the line snap cursor.
6. Press the Spacebar to display the entire job. The selected line goes all the way to the
retaining wall at the top of the parking lot. We want to follow only the portion of the
line that borders the heavy duty paving area.

7. Move the cursor to the top of the driveway where the parking stalls start and press
the Spacebar again to toggle back to the zoomed view, then press F8 to limit the
amount of line entered to just that section.
8. Move the cursor across the end of parking stalls, and press F8 twice to snap to the
end of the peninsula and then line snap around the tip.
9. Continue down the end of the parking stalls to the retaining wall using snap and line
snap as necessary.
10. Trace around the outer edges of the parking while avoiding the light duty areas until
you reach the starting point (see the illustration below).

3-25

Sitework 4D CAD Tutorial

11. At the starting point (marked with a diamond) right-click to end and close the area.

Sectional Areas within Sectional Areas
The sectional area entered would drop the entire area within it by .42 feet. Since we
want this to affect the heavy duty parking lot only, new sectional areas need to be entered within the first to represent different depths. Sectional Areas within other sections
are not additive. We can specify a 0 depth and remove the portions from the surrounding
section.
1. Switch to Entry Mode, select Design from the Surface pulldown and Sectional Areas
from the Layer pulldown.
2. Type “0” to set the new depth to no sectional.
3. Move the crosshair to the center pad and surrounding curb (shown in the illustration
below).
4. Use the F8 key to snap and line snap around the CURB SUB line, and light parking
areas (see the illustration below).

5. Right-click to finish and close the area.
The pad in the center of the 0 section has a .67 section. We need to add another sectional area to represent this.
1. Type “.67” for the section and move the crosshair over one of the pad corners, then
press F8 twice to change to line snap mode. The entire pad line highlights.
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2. Right-click to snap to the entire area. This is a variation of Line Snap, called Area
Snap, which assigns the elevation to the entire enclosed area.

3. Continue the process to enter the rest of the sectional areas.
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Enter Design Perimeter
Design Perimeters define where the Design stops and the Existing surface begins. They
are also useful as a ready-made boundary when defining the volume calculation area.
Our goal with the perimeter is to trace around the edges of the design where it meets
the existing ground. The Design Perimeter does not need any elevations to be entered
because it automatically daylights to the Existing surface after exiting Entry mode.
1. Switch to Entry Mode and select Design from the Surface pulldown and Perimeters
from the Layer pulldown, or select Guide>PDF and then select Enter Design Perimeter from the CAD Entry Guide.
2. Right-click, select Display>Stripping Areas.

3. Position the cursor over the Stripping Areas line and press the F8 twice to line snap
to the Stripping Areas line.
4. Right-click to end then entry. Right-click again and the Apply Drape Line dialog box
displays. Click Yes.
5. Right-click to return to an arrow. Return to Edit Mode.
The program calculates the daylight elevations of the perimeter and creates a data line
in the Design surface. If the 3D Terrain is turned on and the Options>Staged Design is
checked, you’ll see the Existing Ground shown outside of the Perimeter.
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Lesson 4 – Verify the 3D Model
The creation of 3D surfaces allows comparison of the surfaces for volumes. This lesson
shows how to verify the job with the 3D view and specify the area to calculate and generate the volumes. This lesson uses “4D Lesson7.esw”, which is the finished model.

Visual Verification with the 3D View Window
Sitework 4D can display the 3D terrain as it is entered in the Edit window. The 3D View
Window adds greater flexibility to viewing and verifying the 3D surfaces.
While we were editing, the 3D terrain showed how the program interpreted the data
lines to form the surfaces. The 3D Window is a much more flexible version of the 3D terrain which allows greater control over the view.
1. Select File>Open and open the “4D Lesson7.esw” file.
2. Click the 3D View button on the tool bar or choose Window>3D View. The 3D window calculates the cut-fill colors and surfaces before displaying.
Toolbar

Overlay

3D Controls

Terrain

Toolbar

Use the Toolbar to change the reference (Ref) and difference (Diff)
surface to compare different surfaces in 3D View.

Overlay

The Overlay is the two-dimensional plan view of the job. Clicking
on the Overlay moves the view to that position.

Terrain

The Terrain is the three-dimensional representation of the job. Use
the Arrow keys to move around the Terrain View.

3D Controls

Use the 3D controls to inspect the terrain for any errors and to see
how all of the data we have entered displays on the job.
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Driving
Driving the 3D View is the easiest way to double check your work and the surface quality. It also can display the Subgrade and Stripping surfaces and calculate volumes.
Use the Arrow keys on the keyboard to drive through the site. The Up and Down arrows
move forward and back. The Right and Left arrows turn. For additional clarity, you may
want to turn the Overlay off by pressing the O key or by selecting Display>Overlay.
The speed of the drive is based on the Arrow Rate setting, which is located on the Edit
menu. Each arrow key press has a distance that the Arrow Rate controls. The speed of
your computer and video adaptor can also affect screen speed.
Try using the 3D controls to change the views and get a feel for what they do. Also try
changing the Reference and Difference surfaces to see the different views and comparisons.
Cut or Fill amount at
the current location

Point Label of
selected point
Line Label of
selected point

Northing of
selected point

Elevation of
selected point
Drives forward
and back
Changes the
viewing angle
Turns the view
left and right

Easting of
selected point
Increases/decreases
the viewing distance
behind the vehicle
Horizontal distance
between selected point
and current location

Slope between
selected point and
current location

Vertical distance
between selected
point and current
location

Launches Help
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Increases and
decreases the
elevation skew

Toggles between
ground and aerial view
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Lesson 5 - Calculating Volumes
Once the model has been verified, and any changes have been made, you can calculate
volumes and compare surfaces. This lesson uses the file “4D Lesson7.esw”, which is
the finished model.
1. Select File>Open and open the “4D Lesson7.esw” file.
2. Click the 3D View button on the tool bar or choose Window>3D View. The 3D window calculates the cut-fill colors and surfaces before displaying.
3. Define the Volume Area. Click the A button on the Utility Tool Bar to create a bounding box (using the Design Perimeter) around the entire job. This determines the limits
of the volume calculation.
4. Specify the Surfaces. Before calculating the volumes, verify that the correct surfaces
are selected. For our example, set the Reference surface to Subgrade and the Difference surface to Stripped.
5. Calculate the Volume. The Volume Calculation is started by clicking the Calc Volume
button on the tool bar or by selecting Utility>Calc Volume.
During the volume calculation the cross sections display at the bottom of the screen
with blue representing the Reference and Green the Difference. A line displays on the
overlay showing the corresponding location of the cross section. The calculation can be
paused by pressing the Spacebar or aborted by pressing Esc. When paused, the I key on
the keyboard will move across the site incrementally. Pressing the Spacebar again will
resume the volume calculation.
When the calculation finishes, the Volume Calculation Results are displayed.

Be sure the
finished
surface (the
surface you
are calculating
to) is on the
left, and the
begining
surface (the
one you are
calculating
from) is on
the right.

Cross Section
Location

Cross Section
Display
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These numbers represent uncompacted cut and fill between the two surfaces. The
Horizontal Area represents plan view areas with no slope adjustment and is broken down
into Cut, Fill, and On-grade square footage. Slope Area represents a slope adjusted
square footage. It is the total surface area, excluding vertical surfaces like curb faces.
Click Done to close the dialog box. These volume numbers can be recalled by clicking
the Volume Report button on the tool bar.
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The Volume Report
Once you click Done in the Volume Calculations Results dialog box, the Volume Report
displays. You can also access the report after volumes have been calculated by selecting
Window>Volume Report or by clicking the Volume Report button.
The Volume Report displays area, volume, and depth for stripping and sectional areas.
The total area, cut/fill, strata, and on grade area for each report region and sectional area
are displayed, if created. The report also displays the Cut-Fill volumes, compaction ratios
and their impact on the volumes, import/export data, and volume change per 0.1 foot of
elevation change, which is useful for balancing the site. The data in the volume report
should be similar to the illustration below.
Job: Lesson5
Units: Ft-CY
Thu Mar 03, 2011 11:21:01 Page 1
Volume Report
Subgrade vs. Stripped

Job Site

Total
129,957

Cut
59,884

Area
Fill
67,984

OnGrade
2,089

Stripping Qtys
Stripping 1

Plane
Area
129,971

Slope
Area
131,704

Depth
0.500

Volume
2,439

Sectional Qtys
HD Paving

Plane
Area
39,699

Slope
Area
39,810

Depth
0.420

Volume
619

509
108
108
5,804

511
109
108
6,186

0.000
0.000
0.000
0.000

0
0
0
0

6,529

6,914

5,833
1,292
7,809
3,887
12,370

5,868
1,296
7,845
3,905
12,376

Pad Sub:

31,191

31,290

777

Sectional Total

77,419

78,014

1,396

Landscape
Landscape
Landscape
Landscape
Landscape Sub:
Pad
Pad
Pad
Pad
Pad

Volume
Cut
Fill
17,876 8,071

Comp/Ratio
Cut
Fill
1.00
1.00

Compact
Export Change
Cut
Fill -Import Per .1 Ft
17,876 8,071
9,805
481

0
0.670
0.670
0.670
0.670
0.670

146
32
195
97
307
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Lesson 6 – Printing Reports
Sitework 4D can print the Overlay and Terrain graphics along with Volumes and Profiles.
The Print Preview Window allows the user to import graphics and resize, move, and add
text. The lesson continues to use the file “4D Lesson7.esw”

Set up the Printer
Before printing, the printer should be configured. Sitework 4D uses the printer specified
to size the screen and margins.
1. Select File>Print Setup to configure the printer.

2. Verify your printer and its settings and click OK.

Send Graphics to the Print Page
Selecting File>Send to Print Page sends the current screen view to the Print Page.
1. Click the 3D View button on the tool bar. The job is shown in 3D View mode.
2. Use the keyboard arrows and the 3D Controls to show a Terrain view you want to
print, then select File>Send to Print Page, or click the Send to Print Page button.
3. If both the Overlay and Terrain are visible, the program asks which you want send.
Select Send Terrain and click OK.
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The Print Preview Window
The Print Preview window displays a representation of the page with the Terrain as an
object on the page. The white area is the printable area on the page. The gray area represents the printer’s margins.

Selecting Objects
The Terrain object can be picked by clicking on it. A picked object displays four blocks
around the object. In case of multiple overlapping objects, Shift+click cycles between
objects.

Moving and Sizing Objects
To move an object, click and hold the object then drag it to the desired location.
To resize an object, click on an item, then click and hold the lower right selection block.
The arrow changes to a double-headed arrow. By moving the cursor away from, or
closer to, the object, you can resize it.
•

Select the Terrain object, drag it to the left side of the page, and increase the size to
similar to the illustration below.
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Adding Other Objects
The Print Preview window supports multiple objects. Next we’ll add the Volumes Report
to the page.
1. Click the Volumes Report button on the tool bar or select Window>Volumes Report.
The Volumes Report shows the volumes and areas calculated earlier.
2. Select File>Send to Print Page and the report transfers to the Print Preview window.
The Volumes Report can be moved and resized using the same methods as the Terrain
object. Move and size the report until the page looks similar to the illustration below.
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Print The Report
1. Click the Plan View button on the tool bar or select Window>Plan View.
2. Send the image to the Print Page and switch back to the Print Page to resize and
view the results. Your Print Page should look similar to the illustration below.
3. When you are satisfied with the results, click the Print button from the Selection
Tool Bar or choose File>Print.
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